
1111project

Rocket Ship Artwork
Your client is the owner and founder 
of a delivery service named Rocket 
Overnight Delivery, which specializes 
in quick, overnight package handling 
between local and regional businesses. 
Th e company is growing rapidly, and 
they plan to further expand their 
revenues by using an email marketing 
campaign that promotes special Web 
site off ers. 

Th is project incorporates the following skills:

o Defi ning a movie fi le with appropriate settings for the job you’re 
building

o Importing a scanned image provided by the creative director

o Using Flash drawing tools to develop a digital version of a rough 
sketch

o Adding depth to a line-art rocket ship using various shading and 
blending techniques

o Placing a background image that simulates deep space, so the 
client can see the artwork in position as it might appear on a Web 
banner, poster, or postcard
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Project Meeting
We hired your agency to develop our site and 
corresponding mailers. Th e fi rst thing we need 
is the primary graphic — the rocket ship — 
that will be used for banners, mailers, and 
eventually animated on the site. 

We want the main rocket artwork to refl ect a 
“retro” design, looking like something from a 
1950s science fi ction movie. Th e art should not 
be overly sophisticated or perfectly rendered. 
We want to develop a visual “look and feel” 
that will help local businesses immediately 
recognize us, so we’re going to use this basic 
rocket artwork as a visual branding asset. 

Since Flash produces vector artwork, we can 
use the artwork for just about anything once 
it’s done. 

We already received approval for the sketch, so 
the fi rst thing to do is import that sketch to use 
as a guide. Start by tracing the drawing using 
a bright color that you can see against the gray 
lines in the sketch. 

Once you fi nish the line art, you can add color. 
I want you to start out with fl at colors because 
I might want to show that to the client — it 
gives a good “retro” feel. Th en I want a version 
using gradients, so the client can see how the 
artwork looks with more depth.

Also, make sure you build the artwork using 
logical layers — such as a body layer, separate 
layers for each set of fi ns, etc. Th at way, if we 
need to make changes later, or if we need to 
animate the rocket ship, the document will be 
structured properly.

To complete this project, you will:

o Set up the workspace to match the 
requirements of the project

o Import the scan of the sketched rocket ship

o Create a set of logical layers to hold the 
various components you’ll create

o Understand the diff erence between 
standard- and object-drawing modes

o Use the primitive shape and line tools to 
develop the components of the drawing

o Draw precise Bézier curves with the Pen 
tool

o Use the Pencil tool to draw freehand shapes

o Apply color with the Paint Bucket, Ink 
Bottle, Eyedropper, and Brush tools

o Use object groups to combine and protect 
drawing objects

o Apply and edit color gradients
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Stage 1	 Setting up the Workspace
The first step of any new project is to set up the Stage. Once you set up a new file for this project, 
you use the Import command to bring the rough sketch (which we already scanned for you) into the 
document so you can get right to work.

Create a New Document

	 1.	 On your desktop, copy the Rocket folder from the WIP folder on your 
Resource CD to the WIP folder where you’re saving your work.

You should save all files for this project in your WIP>Rocket folder.

	 2.	 In Flash, choose Essentials in the Workspace switcher. If Essentials already 
shows in the Workspace switcher, choose Reset ‘Essentials’ to revert to the 
default interface options as defined by the software.

Although you won’t use all the panels included in the Essentials workspace, this 
workspace provides a good starting point. This step allows you to work from the same 
interface you see in our screen shots.

	 3.	 Choose File>New.

The New Document dialog box presents a list of document types you can use as the 
basis for your new file.

Click the Templates tab 
to access pre-defined 
templates in many 
different styles.

This list provides ten 
types of files on which 
you can base a new 
document.

	 4.	 Make sure the first option — Flash File (ActionScript 3.0) — is selected in 
the list, and then click OK.

	 5.	 Choose File>Save As.

	 6.	 In the resulting dialog box, navigate to your WIP>Rocket folder as the 
target location. 

Although there are slight 
differences in appearance 
between the Macintosh 
and Windows (shown 
here) dialog boxes, the 
options are all the same.

Note:



18 Project 1: Rocket Ship Artwork

	 7.	 Change the file name to rocket_working.fla. Make sure Flash CS4 
Document is selected in the Format/Save As Type menu and click Save.

By default, the extension is included in the Save As/File Name field. You don’t need to 
type it again if you don’t delete the default extension from the field.

If necessary, you can use 
this menu to save a file to 
be compatible with the 
previous version of Flash.

Flash files — that is, “live” files in the program’s native format — use the “.fla” 
extension. When distributing movies and animations for viewing by other people or for 
use on a Web site, you use a stand-alone format that does not require the actual Flash 
application. These files are called “player” files (because they require the Flash Player to 
view) and use the “.swf” extension.

Import Objects from Other Programs

As we discussed during the production meeting for this assignment, you will base your 
work on a hand-drawn sketch of a rocket ship. We already scanned the sketch for you, 
so you don’t need to worry about that step. (In an actual on-the-job project, however, 
you would need to scan the sketch as the first step in the design process.) Flash can 
import a wide variety of file formats, including native Illustrator and Photoshop files, 
as well as JPG, GIF, TIF, and EPS. The first three formats are bitmaps; the fourth — 
EPS, or Encapsulated PostScript — is a common vector format.

	 1.	 With the rocket_working.fla file open, choose File>Import>Import to Stage.

Four options are available when you choose the Import command: 

•	 Import to Stage simply brings an external image onto the current Stage. 
(The image is also added to the file Library panel.)

•	 Import to Library automatically places graphics into the Flash Library panel.
•	 Open External Library is commonly used to incorporate graphics from one 

project into another project.
•	 Import Video allows you to bring digital video into a Flash file. 

	 2.	 Navigate to the RF_Flash>Rocket folder and double-click the rocket.jpg file.

It’s good practice to 
include the “.fla” 
extension in the file 
name. Doing so will help 
you distinguish Flash 
files from Flash player 
files (with the “.swf” 
extension) when you start 
exporting files for digital 
distribution. 

Note:

The key command for 
importing objects to 
the Stage is Command/
Control-R.

Note:
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	 3.	 Look at the Properties panel on the right side of your workspace. 

The Properties panel 
shows that the selected 
object is a bitmap file.

	 4.	 Save the file and continue to the next exercise.

There are two kinds of computer images. The first, known 
as a bitmap, is composed of simple pixels. Each pixel has a 
specific value, and that value determines the color, intensity, 
and brightness of that pixel. The number of pixels that 
make up a bitmap image is fixed at the time of the scan 
or photograph. If you blow up (enlarge) a bitmap image, it 
becomes grainy and loses quality; in fact, 
you can see the individual pixels in an 
enlarged bitmap image. 

Flash is a vector-based program. Vector 
art is not based on pixels; instead, it is 
based on mathematical values. Vector art 
is essentially a tiny program that tells the 
printer or monitor to “draw a line from 
point a to point b, and that the line needs 
to bend x degrees coming out of point 
a and enter point b from an angle of z.” 
Although this might sound confusing, 
you don’t have to write any complicated 
code to make vectors work properly; you 
can simply draw with the Flash tools and 
the vectors are created for you.

An example of the difference between a bitmap image and 
vector art is shown below. At 100% size, both the image (a 
bitmap) and the type (composed of vector objects) are crisp. 
If you zoom in close enough, however, the individual pixels 
in the photograph start to show, and the image breaks 
down — while the type remains perfectly crisp and clear. 
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Bitmap Images vs. Vector Art

At actual size, both the type 
in this image and the 
photograph appear 
perfectly crisp and clear.

The type object, which is a 
vector object, remains clear 
even when enlarged

The detail on the tree 
breaks down if you look 
closely enough.



20 Project 1: Rocket Ship Artwork

Change Document Properties 
There are many reasons why you might need to change the size and other properties 
of a document; for example, when it’s complete, the artwork you’re creating in this 
project will be placed horizontally along the top of a Web page. Knowing this, you 
need to make the document wider than it is high so it appears visually correct in its 
final application. It is important to note that changing the document size does not 
change the size of the objects contained in the document; you have to do that yourself 
on an object-by-object basis.

Objects on the Stage are controlled through the Properties panel. Document 
properties, on the other hand, change the size of the Stage only; the settings in the 
Document Properties dialog box have no effect on existing objects on the Stage.

	 1.	 With rocket_working.fla open, choose the Selection tool at the top of the 
Tools panel.

	 2.	 Click away from the imported bitmap image to deselect it.

	 3.	 In the Properties panel, click the Edit button to the right of the document size.

This command opens the Document Properties dialog box. Changes made here affect 
the Stage (including all scenes contained within the movie). These changes do not, 
however, affect the objects contained in the movie; changing the size of the Stage doesn’t 
alter the size of objects you’ve already drawn. 

	 4.	 Change the Width field to 800 pixels, and click OK to apply the change.

Frame rates or “fps” 
(frames per second) 
are controlled here.

Use these fields to define 
or change the width and 

height of the Stage. 

Use this swatch to 
change the background 

color of the Stage.

Most Flash projects are measured 
in pixels, but you can change this 
menu if you need to work with a 
different unit of measurement. 

	 5.	 Save the file and continue to the next exercise.

Align Objects

At times you might want to align a set of objects, such as a column of buzzing bees 
or a row of spectators in the bleachers at a sporting event. At other times, however, 
you’ll need to align objects relative to the Stage. One example, which you see next, is 
positioning an object in the exact center of the Stage, equidistant from both the top 
and bottom edges, as well as from the two sides.

You can use the Align panel to control alignment and/or space-distribution 
options. You can align the sides, tops, bottoms, or centers of any and all selected 
objects, along either their horizontal or vertical axes.

	 1.	 With rocket_working.fla open, choose Window>Align to open the Align panel.

Remember: all Flash panels are accessed in the Window menu. Beginning in Project 2, 
we will only tell you which panel you need to use; we will not repeat the instruction to 
open the panel from the Window menu.

You can also choose 
Modify>Document to 
open the Document 
Properties dialog box.

Note:

Press Command/
Control-K to show or 
hide the Align panel.

Note:
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	 2.	 Click the To Stage button until the button is active.

The buttons in the Align panel are arranged in specific categories: Align, Distribute, 
Match Size, and Space. The Align panel remembers the last-used state of the To Stage 
button, so this option might already be active. 

On Windows, 
the To Stage button is 
light grey when active...

On Macintosh,
the To Stage button is 

dark gray when active...

...and not highlighted 
at all when inactive.

...and light gray 
when inactive.

	 3.	 Click the sketch on the Stage to select it, and then click the Align 
Horizontal Center and Align Vertical Center buttons.

The scan of the rocket ship snaps into the center of the Stage, along both axes.

Align Horizontal Center

Align Vertical Center

Activating the [Align] To Stage 
button causes selected objects 
to align to the Stage instead 
of to each other.

	 4.	 Save the file and continue to the next stage of the project.

Besides being able to align an object to the Stage, you 
can also align two or more selected objects to each other. 
The images shown here are basic examples of how you 
can use the Align panel to align objects on the Stage.

You can also use the distribution buttons to equalize 
the amount of space between multiple objects, or use 
the Match Size buttons to match the sizes of different 
objects. 
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Aligning Objects to Each Other

Original object placement

Align Left Edge

Align Horizontal Center

Align Right Edge

Align Top Edge

Align Vertical Center

Align Bottom Edge
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Stage 2	 Using Layers to Develop Artwork
If you’ve used other professional drawing or imaging programs, you might already know about layers 
and how they work. If not, the following exercises will introduce you to these important concepts.

Think of layers as individual sheets of transparent material on which you can draw. For example, 
let’s say you drew a red circle on one sheet of the material and a blue square on another sheet. If the 
sheet containing the square were on top of the sheet containing the circle, the portion of the square 
laying directly over the circle would hide that portion of the circle. If you were to move the sheet 
containing the circle to be on top of the sheet containing the square, the opposite would occur: the 
circle would obscure the square.

These are layers. As their names 
suggest, one layer holds the circle 
and another layer holds the square.

Rearranging layers 
determines which objects 

cover other objects.

Create Layers for Organizing Artwork

To facilitate work on complex objects — both from a drawing perspective as well as 
from the standpoint of being able to animate complex objects — Flash provides a 
simple way to create, rearrange, and otherwise manage layers (the imaginary “sheets” 
we discussed above). Some Flash objects, especially complex animations, require many 
layers to create the desired result. 

Clicking the Outline icon 
displays objects on the 
layer as outlines only.

This is the 
layer’s name.

The Pencil icon 
indicates the 

currently active layer.

Clicking the dot in 
the Visibility column 

hides that layer.

Clicking the dot in the Lock 
column locks the layer, 
protecting objects on that 
layer from being changed.

	 1.	 With rocket_working.fla open (from your WIP>Rocket folder), look at 
the layers portion of the Timeline.

There is only one layer, named Layer 1. By reviewing the icons to the right of the  
layer’s name, you know Layer 1 is active, visible, unlocked, and displaying regular —  
not outlined — objects.

Delete

New Folder

New Layer

Layers are stacked on the 
left side of the Timeline. 
The order in which the 
layers are stacked (from 
top to bottom) is referred 
to as the stacking order. 

Note:
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	 2.	 Double-click the name of the layer to highlight the name. Type Sketch to 
rename the layer, and then press Return/Enter to apply the change.

Layers are stacked on the Timeline. Objects on the lowest layer are covered by objects 
on all layers above it in the Timeline. When developing a drawing with many layers, you 
often change the layer stacking order.  

Double-click the layer 
name to change it.

	 3.	 Below the list of layers, click the New Layer button to add another layer on 
top of the first layer.

	 4.	 Rename the new layer Body and press Return/Enter to apply the change.

Each layer is assigned a 
unique color, making it easy 
to determine which objects 
are on which layers.

The new layer appears 
on top of the previously 

selected layer. 

	 5.	 Lock the Sketch layer by clicking the small dot below the Lock icon.

The Pencil icon shows 
the currently active layer.

This Lock icon indicates 
that the Sketch layer is 
locked and protected 
from change.

	 6.	 Save the file and continue to the next exercise. 

Organize Layers into Folders

A Flash project can contain dozens of layers representing the various components of 
the animation or movie. To organize all these layers into logical groups or categories, 
you can use layer folders. You can rename layer folders in the same way you rename 
layers, and you can reorder layer folders (and their contents) by dragging the folders 
into new positions in the layer stack.

	 1.	 With rocket_working.fla open, click the New Folder button at the bottom 
of the Timeline panel (below the list of layers).

	 2.	 Double-click the layer folder name and type Fins to rename the folder.

You change the name of a layer folder the same way you change the name of a layer; 
simply double-click the folder name and type in the new name.

This is a 
layer folder.

If a layer is selected 
but locked, the pencil 
is covered with a slash, 
indicating that you can’t 
change objects on the 
layer or add objects to the 
layer.

Note:
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	 3.	 Create four new layers named Top Fins, Side Fins, Bottom Fins, and Tail Fins.

	 4.	 Shift-click the four new layers and drag them onto the Fins layer folder.

The dragged layers now reside inside the Fins layer folder. The layers will stay together as 
long as they all remain inside the folder. 

	 5.	 Rearrange the layers within the Fins folder to match the following top-to-
bottom stacking order:

Tail Fins

Bottom Fins

Side Fins

Top Fins

	 6.	 Click the Sketch layer name to select it, and then create another new layer 
folder and name it Body Parts. 

New layers and layer folders are created in the same nesting level as the currently selected 
layer. If you click the New Folder button with the nested layers selected, the new layer 
folder will be created inside the Fins folder instead of at the same level as the Fins folder.

	 7.	 Create new layers named Nose Cone, Windows, and Exhaust Vent. 
Drag these layers — along with the existing Body layer — into the new 
Body Parts layer folder.

	 8.	 Arrange the layers in the Body Parts folder in the following top-to-bottom 
stacking order:

Body

Nose Cone

Exhaust Vent

Windows

To rearrange layers, simply click 
the layer and drag it into a new 
position in the list of layers.

Each folder contains separate 
layers, which will contain individual 
components of the artwork.

Press Shift to select 
contiguous layers — that 
is, layers directly on top 
of or below one another. 
To select layers that aren’t 
next to each other, press 
the Command/Control 
key while clicking 
the individual (non-
contiguous) layers.

Note:

When you work with complex images that contain many 
layers, it’s often helpful to expand the vertical size of the 
Timeline; the Timeline’s default height wouldn’t allow you 
to see all the layers the document contains. To increase the 
vertical size of the Timeline, simply grab the small bar that 
separates the Timeline from the Stage and drag it up. To 
decrease the vertical size of the Timeline, drag the bar down.
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Expanding and Reducing the Timeline
Drag this bar up or down 
to change the height of 
the Timeline.

Layers and layer 
folders can assist you 
in organizing complex 
drawings and animations 
into logical, easy-to-
recognize component 
categories — and at the 
same time, allow you to 
keep all the components 
separate.

Note:



25Project 1: Rocket Ship Artwork

	 9.	 Click the Arrow icon to the immediate left of the Body Parts layer folder to 
collapse the folder.

Once collapsed, you see only the layer folder; you do not see the individual layers it 
contains. (Layers in collapsed folders are still visible on the Stage, but not in the list of 
layers.) Collapsing folders makes it much easier to organize complex Flash documents. 

Click this arrow to 
collapse or expand 

a layer folder.

	10.	 Save the file and continue to the next stage of the project.

Stage 3	 Drawing in Flash 
A primitive shape is a simple object such as a square, circle, oval, rectangle, or polygon. 
(A polygon is any shape with at least three sides and angles; this definition naturally 
includes triangles.) Other shapes include freeform shapes, and recognizable objects such as 
balloons, stars, twirls, cones with rounded bottoms, spirals, and a host of others.

A shape displays two primary attributes: a fill and a stroke. The fill is the color 
contained within a shape, and the stroke is the line that defines the outside border of a 
shape. To change the fill and stroke of an object, use the pop-up Color Swatch panel that 
appears when you click and hold the Stroke or Fill button at the bottom of the Tools panel.

Click this swatch to 
choose the stroke color.

Click this swatch to 
choose the fill color.

Click here to swap the 
fill and stroke colors.

Click here to reset stroke and fill 
to black and white (respectively).

Click this button to toggle 
between object-drawing and 
standard-drawing modes. 	

Clicking a swatch 
opens the pop-up 
color palette.

There are two modes for drawing in Flash: standard drawing and object drawing. When 
you draw with the primitive shapes tools, or with the Pen, Line, Pencil, or Brush tool, a 
toggle near the bottom of the Tools panel determines which type of drawing you will create.

When created in standard-drawing mode, the fill and stroke are treated as separate 
entities. You can individually select each part with the Selection (solid arrow) tool, and you 
can move or modify each part without affecting the other. 

Oval drawn in 
standard-drawing 
mode. It has a blue fill 
and a green stroke.

The fill was selected with the 
Selection tool and dragged 
away from the stroke; the tiny 
cross-hatch pattern indicates 
the selected area.



26 Project 1: Rocket Ship Artwork

Standard-drawing mode has some advantages over object-drawing mode; specifically, 
you can select a part of a shape by dragging a marquee with the Selection tool.

Drag a selection 
marquee to select 
part of a shape.

The selected area can be 
deleted without affecting 
the rest of the shape.

You can prevent this type of editing by grouping the components of the object. Simply 
drag a selection around the entire object and choose Modify>Group. When a standard 
object is grouped, you see only the group bounding box (the blue border) when you select 
the object on the Stage.

After grouping the fill and stroke, 
you can’t select the individual 
components. The bounding box 
indicates the boundary of the group.

Bounding box 

Even when standard objects are grouped, you can access the individual pixel components 
by double-clicking them on the Stage. This opens a secondary Stage — called Edit mode — 
where you can access and edit the individual components. The Edit bar above the 
Stage shows that you are no longer on the main Stage, but editing a group. 

Double-clicking a group enters 
Edit mode for that group, where 
you can access the individual 
components of the group.

Edit bar

Of course, standard-drawing objects have their drawbacks as well; you could 
easily move or change an object that you don’t want to change — such as dragging 
a fill away from its stroke and not realizing it until 15 steps later when it’s too late to 
easily undo the error.

When you double-click 
an object or group, you 
are editing the object 
in place (this is often 
referred to as “entering 
into” the object or 
group). Other objects on 
the Stage remain visible 
but shaded back; you can 
see those objects, but you 
can’t access them. 

Note:

When you drag one standard object onto another standard object 
on the same layer, the topmost object removes whatever portion 
of the lower shape it covers. In the second image to the right, we 
placed the orange circle from the first image on top of the blue 
circle. In the third image, you see the result of deselecting the 
orange circle, and then reselecting it and pulling it away from the 
blue circle. (This type of destructive interaction does not occur 
until you deselect the topmost object. This gives you a chance to 
“finalize” the edit. As long as you still see the crosshatch pattern 
on the object you’re dragging, the underlying objects have not yet 
been changed.) 

This type of interaction does not occur with objects created in object-drawing mode or when you’re working with grouped 
objects. If you select something with the Selection tool and see a bounding box instead of the crosshatch pattern, underlying 
objects will not be affected. Only you can tell when an object needs to be protected from destructive interaction with other 
objects or, conversely, when you want one object to interact another object.
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Destructive vs. Non-Destructive Editing
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To solve this problem, you can draw in object-drawing mode by toggling on the switch 
at the bottom of the Tools panel. When you create a shape or line in object-drawing mode, 
it automatically displays the bounding box as soon as you create it, and you can’t select the 
fill and stroke independently — at least not on the main Stage.

A circle drawn in standard-
drawing mode; when selected 
with the Selection tool, the fill 

and stroke are treated as 
distinct elements that can be 

moved or edited independently.

A circle drawn in object-
drawing mode; when selected 
with the Selection tool, you see 
the outer bounding box instead 
of the highlighted area.

If you want to access the individual components of an object in object-drawing 
mode, simply double-click the object. Like modifying a group, double-clicking 
activates Edit mode; the Edit bar shows that you are “inside” (editing) a drawing 
object that exists in Scene 1.

In Edit mode, you can access 
the individual drawing 
objects that compose an 
object created in object-
drawing mode.

Use the Oval Tool to Create Shapes

Many otherwise complex objects are, in fact, simply a collection of primitive shapes 
combined, overlaid, and mixed together. Actually, with a little vision, you can see that 
most artwork is a combination of various primitive shapes.

	 1.	 With rocket_working.fla open, select the Side Fins layer inside the Fins 
layer folder.

	 2.	 Zoom in to the front of the side fin.

As a general rule, we don’t tell you the specific view percentage to use because every 
user’s monitor and personal preference determine a comfortable working environment. 
We do, however, tell you where to focus your attention.

	 3.	 Choose the Oval tool (nested under the Rectangle tool) in the Tools panel. 

	 4.	 Make sure the Object Drawing option is toggled off at the bottom of the 
Tools panel.

The Object Drawing toggle is 
not highlighted when inactive. 

The Object Drawing toggle 
is dark gray when active. 

	 5.	 In the Properties panel, click the Stroke swatch and choose a bright color 
that will stand out against the gray and black lines in the sketch. 

We used orange, but feel free to use whichever color you prefer.

You can also convert an 
object-drawing object 
to a standard-drawing 
object by selecting it 
on the main Stage and 
choosing Modify>Break 
Apart.

Note:
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	 6.	 Click the Fill swatch and choose the None option in the top-right corner of 
the pop-up palette. 

Click here to change 
the fill to None.

	 7.	 Set the stroke weight (thickness) to 1 pt and choose Solid in the Style menu.

When you select a drawing tool, the Properties panel provides controls for fill color, 
stroke color and weight, the type of stroke (now set to Solid), access to custom strokes, 
end cap styles (round, square, etc.), and whether strokes meet in sharp or blunt corners.

Change the fill 
color to None.

Change the stroke 
color to something 
that will stand out 
against the black 

and gray sketch lines.

Use this slider/field 
to change the 
stroke weight.

Oval tool

Object-drawing mode 
should be toggled off.

	 8.	 On the Stage, click at the upper corner of the curve, and then drag down and 
right to create an oval that closely matches the shape of the front of the fin.

If you don’t get it right the first time, press Command/Control-Z to undo and try again. 

After releasing the 
mouse button, the 
orange oval appears.

Click here and 
drag down and 

to the right. 

A small icon shows 
the current location 

of the cursor. 

	 9.	 Choose the Selection tool (the solid arrow) in the Tools panel. 

	10.	 Click away from the circle to deselect it, and then move the cursor near the 
top-right edge of the circle until you see a curved line in the cursor icon. 

Press the Shift key while 
drawing to constrain the 
shape to a perfect circle. 
The same method works 
with the other primitive 
shape tools as well.

Note:
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	11.	 Click and push the top-right edge of the circle toward the center of the circle.

One unique aspect of drawing with Flash is using the Selection tool to pull and push a 
shape until it exactly fits what you’re tracing. When you release the mouse button, the 
circle is reshaped. Although it takes a bit of getting used to, you will find this method 
quite effective once you’ve mastered it.

When the Selection tool 
cursor includes a curved line 

in the icon, you can click and 
drag to “push” the line into 

a different shape.
  

	12.	 Use the Selection tool to draw a rectangle marquee that covers the upper-
right side of the object you reshaped in Step 11. 

When you release the mouse button, the area you surrounded with the rectangle (called 
a selection marquee) displays a hatch pattern, indicating that the area is now selected.

Because you drew this object in standard mode, you don’t have to “enter into” the object 
to edit the components. 

The hash pattern 
shows the selected 
part of the drawing. 

A selection marquee 
can be used to select 

certain parts of a 
drawing object. 

	13.	 Press the Delete/Backspace key to remove the selected portion of the shape.

The selected area is removed from the Stage. You can select any portion of an object in 
this manner, and then change its stroke and fill values independently of the rest of the 
drawing — or, as is the case here, remove it from the Stage completely.

	14.	 Use the same method to remove the bottom-right side of the shape.

	15.	 Use the Selection tool to refine the shape until the curves fit the sketch.

If you position the Selection tool at the very end of a stroke, you can pull the end of the 
stroke to a new position. The lines connected to the end point will reshape as necessary 
to match the new position of the end point.

	16.	 Save the file and continue to the next exercise.

This type of “bending” 
works for objects created 
in standard-drawing or 
object-drawing mode.

Note:
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Work with the Line Tool

The Line tool draws lines, which are simply strokes with no fills. You can combine 
lines with other shapes to develop custom objects, such as the fin you’re working on 
now. In this exercise, you draw several lines to complete the shape of the side fin.

	 1.	 With rocket_working.fla open, select the Line tool in the Tools panel and 
make sure the object-drawing option is turned off.

You’re adding to the standard-drawing mode object you created in the previous exercise, 
so you should continue working in standard mode.

	 2.	 Click the upper-right end of the half-oval shape, then drag down and to the 
right before releasing the mouse button.

Since you’re clicking the end of an existing line, Flash assumes you’re continuing the 
same shape and automatically connects the lines with a corner point. The line doesn’t 
have to be a specific length; it should stop somewhere above the center of the empty 
space to the right of the partial oval shape. 

Line tool

Click here to 
start drawing 

the line…

…and drag to 
here before you 

release the 
mouse button.

	 3.	 Drag another line from the bottom edge of the half-oval to somewhere 
below the endpoint of the line you drew in Step 2.

At this point, you should have two lines that come off the top and bottom of the curve 
and hang in the middle of the fin shape. 

…and drag to here 
before you release the 
mouse button.Click here to start 

drawing the line…
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	 4.	 Using the Subselection tool (the hollow arrow), click the end of the top line 
to select that point, and then pull it out until it sits at the rear of the fin.

The Selection tool selects entire paths, but the Subselection tool selects individual anchor 
points. You use the Subselection tool to edit, add, or delete anchor points, or adjust 
curves using the handles that radiate from anchor points. 

Use the Subselection 
tool to select the point 
at the end of the line 
and pull it to the end 
of the shape.

	 5.	 Pull the end of the bottom line until it touches the end of the top line.

If Snap To Objects is active (View>Snapping>Snap To Objects), the point you drag will 
“snap” to the other point as soon as it gets close. 

Using the Subselection 
tool, pull the end of the 
line until it touches the 
end of the top line.

	 6.	 Use the Selection tool to bend the top and bottom lines so they more closely 
match the curve of the original sketch.

	 7.	 Hide the Sketch layer.

By hiding the Sketch layer, you can better see how your side fin shape is coming along. 
With the background hidden, it’s easier to check the lines, curves, and overall integrity 
of the shapes you’re developing.

The sketch bitmap, 
on the hidden 

Sketch layer, is not 
visible on the Stage.

Hidden layers 
show an X in the 
Visibility column.

	 8.	 Show the Sketch layer, lock the Side Fins layer, save the file, and continue to 
the next exercise.

Locking the layer protects the object while you work on other components of the 
drawing. If the layer remains unlocked, you might accidentally delete or otherwise 
modify the shape. (The sketch is the basis for developing the actual drawing, so the 
Sketch layer should remain locked.)

Anchor points are more 
fully explained in the 
next exercise.

Note:
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Draw with the Pen Tool

The Pen tool draws curved lines, also known as Bézier curves. A Bézier curve is a 
curved line defined by specific points called anchor points. These anchor points define 
the direction and shape of the curves that make up a line or shape. In this exercise, you 
use the Pen tool to create the top fin of the rocket ship. 

	 1.	 With rocket_working.fla open, select the Top Fins layer.

	 2.	 Select the Pen tool in the Tools panel.

The Properties panel shows different settings that affect how and what you draw with the 
Pen tool. Make sure the stroke color is set to the same orange you used earlier, the stroke 
weight is set to 1 point, and the stroke style is set to Solid. It’s likely these settings are 
already in place; but if someone used your computer or you changed the settings since 
the previous exercise, you might have to return the settings to the ones you used earlier. 

Pen tool

Pen tool 
cursor

You are 
drawing on the 

Top Fins layer.

	 3.	 Click the Pen tool at the left side of the top fin where it meets the body. 
Without releasing the mouse button, pull up and to the right.

The point you first click becomes an anchor point, which is a point at which the curve is 
attached to the drawing. As you pull, handles appear. Handles control the size and shape 
of the lines connected to the point; longer handles make a steeper curve. 

As you drag away 
from the point, 

handles appear. 

Clicking here 
creates the first 

anchor point. 
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	 4.	 Now click at the upper-right corner of the top fin to place another anchor 
point. Without releasing the mouse button, pull down and to the right to 
create handles for the point, dragging carefully to fit the curve to the sketch.

Clicking the upper-right corner of the fin shape creates a second anchor point, and 
pulling handles out from that anchor point creates the shape of the curve between the 
two points. 

Click here… 

…and drag to here.

Dragging the handle 
changes the shape of 
this connecting path.

	 5.	 Click the right anchor point with the Pen tool.

There are two kinds of anchor points: curve and corner. In this case, you have to create a 
sharp corner. 

While you’re drawing a shape with the Pen tool, single-clicking the anchor point allows 
you to change direction, leaving a sharp corner instead of a smooth curve. 

Clicking an existing 
point with the Pen 
tool changes the point 
to a corner point.

After clicking the 
point, the right handle 
of the point is gone.

	 6.	 Using the Pen tool, click at the point where the rear side of the top fin 
touches the ship body. Drag handles for this point until the shape of the 
curve matches the shape of the fin’s back edge.

Click here…

…and drag to shape 
the connecting curve.

	 7.	 Click the third point with the Pen tool to convert the point to a corner.

Placing the Pen tool 
cursor over an existing 
point shows a small 
arrow in the tool icon. 

Note:
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	 8.	 Hover the Pen tool cursor over the first anchor point you created until you 
see a small hollow-circle icon next to the cursor.

The hollow circle in 
the tool cursor 

indicates that clicking 
will close the shape.

	 9.	 Click to close the shape with a straight line.

The straight line will be covered by the ship body, so it doesn’t need to be adjusted.

	10.	 Deselect all objects on the Stage, and then hide the Sketch layer. 

Your fin should be graceful, not choppy. If you aren’t satisfied with the result, delete your 
fin and try again.

	11.	 Display the Sketch layer again and lock the Top Fins layer.

	12.	 Save the file and continue to the next exercise.

While drawing with a 
basic shape tool, press 
Command/Control to 
temporarily access the 
Selection tool; when you 
release the modifier key, 
you return to the last-
selected tool.

The easiest way to deselect 
everything is to press 
Command/Control, and 
then click away from any 
object on the stage. 

Note:
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Pen Tool Basics

Converting curves to corner points. 
If you need to convert a curve to a corner point, 
place the Pen tool over the curve point, press 
the Option/Alt key, and click to change the 
point to a sharp corner. (Alternatively, use the 
Convert Anchor Point tool.)

Deleting anchor points. To delete an anchor 
point, first select the path with the Subselection 
tool. Using the Pen tool, place the cursor near 
an existing point until you see a minus sign (-) 
in the tool cursor. (Alternatively, use the Delete 
Anchor Point tool.)

Adding anchor points. To add an anchor 
point, first select the path with the Subselection 
tool. Using the Pen tool, place the cursor near 
the path but not over an existing anchor point 
until you see a plus sign (+) in the tool cursor. 
Click the path to add a new point to the line. 
(Alternatively, use the Add Anchor Point tool.)

Converting corner points to curves. To change a 
corner point into a smooth curve, first select the point you 
want to convert with the Subselection tool. Then press the 
Option/Alt key and drag the point; handles appear, and the 
corner becomes a curve. You can then adjust the shape of 
the curve by adjusting the handles.

Reshaping a curve using its handles. 
To reshape a curve, first select it with the Subselection 
tool, and then drag the related handles. (Handles will 
appear from each smooth anchor point that is connected 
to the curve.)

Moving points. To move an anchor point, select the 
point with the Subselection tool and move it to the 
desired location. You can also nudge (move it a little bit 
at a time) a point by selecting it and then pressing the 
Up/Down and Left/Right Arrow keys on your keyboard.

Selecting entire objects or single points. 
As you move the Subselection tool near a 
stroke, a small, solid black square appears at 
the bottom right of the icon. If you move the 
Subselection tool directly over a single anchor 
point, a hollow square in the icon indicates 
that clicking selects only that point.

Using the Subselection tool. When you click 
a line with the Subselection tool, you can see 
the object’s anchor points. In the image to the 
right, both objects were selected by surrounding 
them with a selection rectangle; you can see all 
the objects’ points and curves.
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Work with Anchor Points and Curves

At times, you will need to create lines that follow multiple curves. You can use several 
different methods to accomplish this task, but all of them require you to manage 
multiple anchor points with curves of varying shapes and angles. To do this, you need 
to know how to add, delete, and modify anchor points and their curves and handles. 

	 1.	 With rocket_working.fla open, select the Tail Fins layer. Use the Line tool 
in standard-drawing mode to draw a triangle that touches all three corners 
of the top portion of the fin.

When you hover the cursor over the original starting point to close the shape, the cursor 
shows a small, hollow circle in the icon; this icon indicates that you can close the shape.

You are drawing on 
the Tail Fins layer.

	 2.	 Use the Selection tool to pull the three lines into shape.

Reshape the portion of the fin that intersects the body so it extends into the area where 
the body will be positioned. When you arrange the layers and put the body layer on top 
of the fins layers, the body will hide that portion of each fin. Make sure no gaps show 
between the fins and the ship.

This portion of the fin will 
eventually be hidden by 

objects on layers higher in 
the stacking order.

	 3.	 Starting on the top-right corner of the bottom tail fin, use the Pen tool to 
create a curve that curves away and down from the fin shape.

If you look closely, you’ll see that the top portion of the sketched fin curves twice. You 
need to add an anchor point on the curve you just drew, which is actually a two-step 
process: first, you need to select the line, and then you need to add the anchor point.

Click here and drag down 
to set the first anchor 
point (with its handles)…

…then click here and 
drag to the right to form 
the connecting curve.
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	 4.	 With the Pen tool active, press the Command/Control key and click away 
from the line to deselect it. Do not release the Command/Control key.

Pressing Command/Control while using the Pen tool temporarily switches to the 
Subselection tool. 

	 5.	 Still holding the Command/Control key, move the cursor near the line you 
deselected in Step 4. When you see a black square in the cursor icon, click 
the line to re-select it. 

This is a quirk of the software. For the following steps to work properly, you have to first 
deselect and then reselect the line.

When you hold down the 
Command/Control key, the Pen 
tool temporarily becomes the 
Subselection tool.

	 6.	 Release the Command/Control key to return to the Pen tool. 

You could also simply choose the Add Anchor Point tool, but the method outlined in 
these steps allows you to add points to a path without switching tools.

	 7.	 Move the Pen tool toward the line until a plus sign (+) appears in the tool’s 
icon. Click the line to add an anchor point at that location.

When you see a plus sign 
in the tool cursor, you can 

click to add an anchor 
point to the selected line.

   

	 8.	 Choose the Subselection tool in the Tools panel and click the new anchor point. 

Clicking with the 
Subselection tool selects 
the point. Selected points 
are solid.

	 9.	 Drag the anchor point and place it on top of the sketched line.

As you move the anchor point away from its current position, the handles that control 
the curve become apparent. In the next step, you use these handles to change the shape 
and direction of the curve where you added the new anchor point.

	10.	 Using the Subselection tool, pull the handles of the three anchor points to 
adjust the shape of the line. 

The Subselection tool 
selects individual anchor 
points and line segments. 
Use this tool when you 
want to add or delete an 
anchor point, reposition 
an anchor point, or 
adjust a curve using the 
handles that radiate from 
an anchor point.

Note:
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	11.	 Deselect everything, then hide the Sketch layer and review your curve.

Remember, curves should be smooth with no apparent flat spots or unnatural bumps or 
ridges (unless, of course, the artwork calls for a bump or ridge; this piece does not).

	12.	 Make the Sketch layer visible again, and then complete the rest of the tail 
fin using the methods you just learned. When you’re satisfied with your fin 
shape, lock the Tail Fins layer.

As you draw, you can show 
and hide the Sketch layer 
as necessary so you can 
review your progress.

	13.	 Select the Bottom Fins layer to make it active, and then use any techniques 
you’ve learned so far to complete the two bottom fins. 

	14.	 Using the Selection tool, bend the inner edges of each fin (where the fins 
meet the body) into the body area so the body area will overlap the fins and 
prevent any gaps.

	15.	 Hide the Sketch layer and review your drawing.

	16.	 Show the Sketch layer, save the file, and continue to the next exercise.
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Use Groups to Control the Interaction between Objects

All your fins should be complete and neatly organized inside their layer folder. In this 
exercise, you collapse the Fins folder, hide it, and then start working on the body of the 
ship — and working with object groups. A group is a collection of shapes combined 
into a single object. You can ungroup a grouped object, returning it to the original 
collection of discrete components. 

As you complete this exercise, you also learn how Flash objects residing on a single 
layer interact with each other, and how grouping and ungrouping objects offers control 
over that interaction.

	 1.	 With rocket_working.fla open, collapse the Fins layer folder. Hide all the 
fins by clicking the Visibility column of the Fins layer folder. 

	 2.	 Expand the Body Parts layer folder so you can see the layers in the folder.

	 3.	 Make sure the Sketch layer is visible, and then click the Exhaust Vent layer 
to make it active.

	 4.	 Use the Rectangle tool in object-drawing mode to draw a shape for the four 
sides of the vent.

The object-drawing 
toggle should be 
highlighted (active). 

Hide all the fins layers 
by hiding the layer folder.

Rectangle tool 

You are drawing on 
the Exhaust Vent layer.

	 5.	 Deselect everything, then use the Selection tool to move the corners and 
bend the sides of the rectangle until they fit the sketch.

	 6.	 Using the Line tool in object-drawing mode, draw two lines that extend from 
the left edge of the exhaust vent to the point at the end of the spear shape.

When you use layer 
folders, you can lock and 
hide all the contents in 
the folder by locking 
and hiding the entire 
folder. As we mentioned 
earlier, many of your 
projects will be quite 
complex, requiring 
dozens of layers. Without 
layer folders, it would 
become very difficult to 
structure and manage 
your drawings and 
animations. 	

Note:
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	 7.	 Using the Selection tool, bend the two horizontal lines into shape to match 
the spear-shaped part of the exhaust vent.

     

	 8.	 Select all three shapes on the Stage.

Because you created these objects in object-drawing mode, you can see a bounding box 
surrounding each shape. To prevent moving one of these components independently, 
you can group them into a single unit.

You can see the bounding 
boxes for each object.

	 9.	 Choose Modify>Group.

When you group objects, the bounding box displays around the entire group. Using 
the bounding box, you can resize, move, and otherwise modify a group as you would 
a single object. Grouped objects are isolated from other elements on the same layer, so 
you can place grouped objects on top of one another with no worries of damaging the 
underlying objects. 

A single bounding box 
now appears around 
all three objects.

	10.	 Double-click the group to enter into it (view the group in Edit mode).

Even though the objects are grouped on the main Stage, you can access the individual 
components in Edit mode.

Because you drew these shapes in object-drawing mode, you can’t access the pixels of 
the lines. You can’t select and delete parts of the lines with the Selection tool, which you 
need to do.

The Edit bar shows that 
you’re editing the group.

The individual bounding boxes 
are visible in Edit mode.

You can also group 
objects by pressing 
Command/Control-G.

To ungroup objects, select 
the group and choose 
Modify>Ungroup or 
press Command/Control-
Shift-G.

Note:
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	11.	 With all three objects in the group selected, choose Modify>Break Apart.

This command converts objects in object-drawing mode to standard mode so you can 
use the destructive editing capabilities of the Selection tool.

You are still working 
within the group, not 
on the main Stage.

	12.	 Deselect all objects. Use the Selection tool to click the line in the middle of 
the spear shape to select it, and then press Delete/Backspace.

Remember from the earlier discussion on destructive editing that when you’re editing a 
drawing object, Flash recognizes and separates overlapping elements. (If you selected the 
shape with the Subselection tool, you would see that Flash added anchor points where 
the lines meet.)

Delete the line 
that was here.

	13.	 Click Scene 1 in the Edit bar to return to the main Stage.

Because these objects started as a group, and you made all the edits inside the group, the 
selection on the main Stage is still treated a single unit; the bounding box surrounds the 
outer edge of all the objects in the group.

The Edit bar shows 
that you are back on 
the main Stage.

On the main Stage, the 
objects are still a group.

	14.	 Use the Oval tool in object-drawing mode to draw the circle at the top of 
the vent.
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	15.	 With the Selection tool active, press the Option/Alt key and drag the shape 
to the second circle on the sketch.

Pressing Option/Alt while dragging clones (makes a copy of ) the object you drag.

	16.	 Using the same cloning method, make additional copies for the two round 
objects on the lower half of the vent.

	17.	 Lock the Exhaust Vent layer, save the file, and continue to the next exercise.

Use the Pencil Tool

The Pencil tool provides another way to develop curved artwork. Drawing with the 
Pencil tool is easy; simply drag a line or shape, and the stroke — in whatever color is 
currently set in the Tools panel — follows the cursor.  

With the proper equipment — notably a pressure-sensitive drawing tablet —  
the Pencil tool might very well be the most important tool Flash offers. This notion 
is particularly true for artists skilled at sketching or drawing with natural media such 
as pen and ink, pencils, and pastel chalks. Other people find the Pencil tool difficult 
to use, preferring the Pen tool, Bézier curves, primitive shapes, freeform shapes, and 
combinations thereof. 

	 1.	 With rocket_working.fla open, select the Nose Cone layer to make it active. 
Position the sketch so the nose cone area is prominent on the Stage.

	 2.	 Select the Pencil tool in the Tools panel.

In the Properties panel, options for the Pencil tool are very similar to those you used 
with the Pen tool.

Pencil tool
Pencil tool 

cursor

You are drawing 
on the Nose 

Cone layer.

Be careful while making 
copies of any object. Do 
not release the Option/
Alt key before releasing 
the mouse. Doing so will 
move the original object 
instead of making a copy.

Note:
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	 3.	 In the lower portion of the Tools panel, click the Pencil Mode button and 
choose Ink from the pop-up menu. 

These three modes affect the behavior of the Pencil tool. Specifically, the modes 
determine whether the lines you create with the tool are automatically smoothed, 
automatically straightened, or left alone (Ink mode).

Click here to access the 
Pencil tool options.

	 4.	 Make sure the object-drawing option is turned off, and then try drawing the 
tip of the nose cone. Hide the Sketch layer and inspect the results. 

Hiding the Sketch layer between processes can dramatically improve the quality of your 
finished drawings. You should develop the habit of hiding and displaying sketched templates 
often, which will ensure that your drawings look good without the template showing.

	 5.	 Using the Selection tool, select the shape you drew in Step 4 and delete it, 
and then redisplay the Sketch layer.

	 6.	 Select the Pencil tool, choose Smooth mode for the tool, and try drawing the tip 
of the nose cone section again. Hide the Sketch layer to review your shape.

	 7.	 Delete the object you drew in Step 6, and then show the Sketch layer again.

	 8.	 Use the Pencil tool in Straighten mode to draw the tip of the cone again.

	 9.	 Use whichever drawing method you prefer to create a final version. 

We found Straighten mode worked best, but you might prefer one of the other options. 

	10.	 Choose Smooth mode, and then try drawing the top and bottom lines that 
compose the cone.

You’ll find that working at close range to your artwork is almost always the most 
effective method. There will be times, however — especially when you use the Pencil 
tool — that being a bit farther away from the artwork yields better results. When you’re 
zoomed out, the lines you draw are shorter and require less mouse (or tablet stylus) 
movement, resulting in less jagged lines.

	11.	 Use the Subselection tool to adjust the lines until you’re satisfied with the result.

Remember, lines behave one way when you use the Selection tool to edit them and a 
completely different way when you use the Subselection tool (which you use to fine-tune 
the anchor points that compose each stroke). 

Interestingly, more 
often than not, using 
Straighten mode works 
best for drawing circles 
with the Pencil tool. 
Using Smooth mode 
results in bumpy, 
less-than-perfect circles 
because this option is 
more sensitive to slight 
mouse movements 
(although not nearly as 
sensitive as Ink mode).

Note:
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	12.	 Using any combination of tools, complete the nose cone section. 

Pay particular attention to the integrity and shape of the back section of the nose cone. 
You will use this line in the next exercise when you draw the body section. The two 
sections will share a common curve: the rear side of the nose cone will be copied and 
pasted for use as the front end of the body component.

As we mentioned 
previously, feel free to 
toggle the Sketch 
layer visibility to 
review your progress.

	13.	 Save the file and keep it open for the next exercise.

You can control a number of drawing options using the 
Drawing pane of the Preferences dialog box. (On Macintosh, 
Preferences are accessed in the Flash menu; on Windows, 
Preferences are accessed in the Edit menu.)

Each time you click with the Pen tool, you add an anchor 
point; successive anchor points are connected by lines. If 
the Show Pen Preview option is checked, a preview line 
follows the cursor to show the line that will be created 
when you add a new anchor point.

When the Show Solid Points check box is active, selecting 
an anchor point with the Subselection tool shows the 
selected point as solid instead of hollow.

You can change the Pen tool cursor ( ) to a precise 
crosshair ( ) by activating the Show Precise Cursors 
check box.

The Connect Lines options (Must Be Close, Normal, and 
Can Be Distant) determine how close lines or points must be 
before Flash automatically connects them. 

The Smooth Curves options (Off, Rough, Normal, and 
Smooth) determine how many points will be used to create 
a line when you’re drawing with the Pencil tool with the 
Smooth or Straighten options turned on. The Rough option 
results in more points and a jagged line; the Smooth option 
results in fewer points and a smoother line.

The Recognize Lines options (Off, Strict, Normal, and 
Tolerant) determine how close to straight a line drawn with 
the Pencil tool must be before Flash recognizes it as straight.

The Recognize Shapes options (Off, Strict, Normal, and 
Tolerant) determine how close to the shape an oval or 
square drawn with the Pencil tool must be before Flash 
recognizes it as the actual shape and makes the necessary 
adjustment.

The Click Accuracy options (Strict, Normal, and Tolerant) 
determine how close to an object you must place the cursor 
to select the object.
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Drawing Preferences
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Cut, Copy, Paste, and Paste in Place

Four important techniques that you might have used before are cutting, copying, 
pasting, and pasting in place. Cutting, as you probably know, is the act of removing 
a selected item from the Stage and placing it onto the Clipboard. The Clipboard is a 
reserved area of memory that allows you to temporarily hold objects — text, images, 
artwork, or Flash objects — until you need to use them again somewhere else. For 
example, you might cut an object from one layer and hold it on the Clipboard until 
you need it again later. Copying is similar to cutting, except when you copy an object, 
the original selected item remains on the Stage.

Pasting takes the content on the Clipboard and drops it onto the Stage, normally 
in the middle of the visible area. Pasting in place is virtually the same as pasting, except 
the object you paste is positioned exactly on top of the original, regardless of whether 
you cut the object or copied it.

	 1.	 In the open rocket_working.fla file, use the Selection tool to select the 
stroke on the right side of the cone shape. 

Depending on how you created this line, you might need to Shift-click to select multiple 
segments of the path.

…Shift-click to select 
all segments that make 
up the line.

If the entire line 
is not selected… 

	 2.	 Choose Edit>Copy to copy the stroke to the Clipboard.

Use the Selection 
tool to select the 
right side of the nose 
cone shape.

	 3.	 Lock and hide the Nose Cone layer, and then select the Body layer. 

To copy an object, select 
the object and press 
Command/Control-C. 

To cut an object, select 
the object and press 
Command/Control-X. 

To paste an object, select 
the object and press 
Command/Control-V. 

To paste an object in 
place, select the object 
and press Command/
Control-Shift-V.

Note:
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	 4.	 Choose Edit>Paste in Place to paste the copied object in place on the Body layer.

The copied stroke appears in the exact location as the original, but on the Body layer. 
After you’ve completed the body section, these two strokes will occupy the same location 
on the Stage, which ensures that the intersection of the two objects is absolutely perfect.

You are pasting the 
line in the same 

position, but on the 
Body layer.

	 5.	 Unlock the Exhaust Vent layer.

	 6.	 Double-click one of the edge lines to enter into the group on the Exhaust 
Vent layer.

For the same reasons we outlined in Step 4, you are going to use the front of the exhaust 
structure as the back of the body shape. To access those lines, however, you have to first 
enter into the group.

	 7.	 Using the Selection tool, Shift-click all three pieces of the left edge.

Remember, Flash adds anchor points where lines intersect, so you have to manually 
select all three pieces of the left edge.

You have to enter into 
the group to select 
the individual lines.

Use the Selection tool 
to select all three lines 
on the left edge of 
this shape.

You have to unlock 
the Exhaust Vent layer 
to access these lines.

	 8.	 Press Command/Control-C to copy the strokes to the Clipboard.
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	 9.	 Click Scene 1 to return to the main Stage.

	10.	 Hide and lock the Exhaust Vent layer, and then select the Body layer. Press 
Command/Control-Shift-V to paste the rear stroke for the body in place.

You are pasting the 
selected lines in the 
same place, but on 

the Body layer.

	11.	 Use the Line tool with the object-drawing toggle turned off to connect the 
top and bottom points of the curves. Use the Selection tool to bend the top 
and bottom lines into shape.

	12.	 Show and lock all layers, save the file, and continue to the next exercise.
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Use Strokes to Create Complete Objects

In this exercise, you work with lines — specifically, you experiment with ways to 
incorporate stroke width (also called stroke weight) into your objects.

	 1.	 In the open rocket_working.fla file, hide all but the Windows and Sketch 
layers. Unlock the Windows layer and select it to make it active. 

	 2.	 Select the Line tool in the Tools panel and make sure object-drawing mode 
is turned on.

	 3.	 Using the Properties panel, define a stroke weight of 15 and choose the 
Round option in the Cap menu of the Properties panel.

This Cap menu defines the end treatment of the line. None means nothing special will 
happen at the ends of the line. Round means rounded ends will extend beyond the 
endpoints of the actual line. Square means square ends will extend beyond the endpoints 
of the actual line.

	 4.	 Draw a straight line between the left and right sides of the long, rounded 
window at the top of the ship.

Don’t extend the line all the way to the edges of the shape; keep the ends of the lines 
within the rounded sections, as shown in the following image.

You are drawing on 
the Windows layer.

	 5.	 Deselect the line, and then use the Selection tool to bend the line into shape 
to fit the curve of the long window.

The stroke almost perfectly matches the sketched shape — and you accomplished the 
task with a single process. There was no need to draw a circle or use the Pen tool to 
carefully position anchor points. 

If the now-curved line isn’t on top of the window area of the sketch, move or adjust the 
line as necessary to make your line match the sketch.

The bounding box 
corner shows the 
actual ends of the line.

Select a line with the 
Subselection tool to see 
the actual line instead of 
the bounding box.

Note:
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	 6.	 Use the Line tool to draw the remaining three top windows. Use the 
Selection or Subselection tool to adjust and position the lines as necessary.

	 7.	 Move to the three round portholes at the lower part of the ship, and then draw 
a line from the middle of the left circle to the middle of the right circle.

Don’t worry that the line covers all three windows; you fix that in the next step.

	 8.	 With the line selected, use the Properties panel to change the stroke weight 
to 17 and the Style to Dotted. 

Depending on where you started and ended your line, you probably have four or five 
dots instead of three. Don’t worry; you fix that in the next exercise.

	 9.	 Save the file and continue to the next exercise.

Flash provides three important visual features that can dramatically 
improve accuracy and reduce development time. All three — rulers, 
guides, and grids — can be found under the View menu.

Rulers (View>Rulers) are measurement tools located along the left 
side and top of the Stage. You can drag a guide from either of these 
two areas to assist in visual alignment. Rulers normally measure in 
pixels, but you can use the General Preferences dialog box to change 
this setting to any measurement system you prefer.

You can choose View>Guides>Edit Guides to modify guide lines. 
The Show Guides option toggles guides on or off. Snap To Guides 
causes guidelines to act like magnets when objects are dragged near a 
guide. Lock Guides prevents existing guides from being moved.

The grid (View>Grid>Show Grid) is a pattern of horizontal and 
vertical lines that also aid in the development/alignment process. 
You can edit the current grid and modify how the grid interacts with 
objects on the Stage by choosing View>Grid>Edit Grid. You can make 
gridlines “magnetic” using the Snap To Grid feature. When turned 
on, this feature causes objects close to a gridline to snap into place, 
avoiding minor placement errors during the drawing process.
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The Properties panel includes a 
number of options for editing lines 
in a Flash file.

The W, H, X, and Y fields control the 
dimensions and position of the line’s 
bounding box.

You can use the stroke swatch to 
change the color of a line. (A line 
technically has no fill, so the fill 
color swatch has no effect on a 
selected line.)

You can type a specific stroke weight in the Stroke Weight field, or you can drag the associated slider for a live preview 
of the size you drag to (between 0.25 and 200 points). The Hinting check box allows you to draw smooth and sharp lines. 
This feature is most helpful when you draw a rectangle 
with curves. When you draw a curved rectangle or square, 
the lines and the curves can be very blurred. Curves might 
actually seem to be different entities that are not joined 
with the connecting line. After you select the Stroke Hinting 
option, you will see that the lines are smooth and the blur 
effect is invisible. You can apply a predefined style from the 
Stroke Style menu or create your own style by clicking the 
Custom button.

The three options in the Cap menu (None, Round, 
and Square) define the appearance of a stroke 
beyond the endpoint of the line.

The three options in the Join menu (Miter, Round, 
and Bevel) define the appearance of corners where 
two lines meet. When Miter is selected, you can 
define a miter limit in the Miter field. A miter limit controls when 
the corner switches from a pointed joint to a beveled joint, as a 
factor of the stroke weight. If you define a miter limit of 2 for a 
2-point line, the corner is beveled if the pointed corner extends 
beyond 4 points (2 1 2).

The Scale menu defines how strokes are affected by scaling a 
symbol in which the line exists. (This option only affects strokes 
on graphics that are part of a symbol.) Normal means the stroke 
will be scaled proportionally. Horizontal means a stroke will be 
scaled based only on the horizontal scale of the symbol. Vertical 
means the stroke will be scaled based only on the vertical scale 
of the symbol. None means the stroke will not be scaled.
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Use these fields to change 
the dimensions and position 

of the selected object.

Stroke color
Fill color

Stroke weight
Stroke Style menu

Click to edit the line style
Scale Behavior menu

End Cap style

Join style
Miter limit

Activate stroke hinting

None of the curves are 
smooth, and they look as if 
the lines were drawn twice.

Now you can see that the 
curves are smooth and 
appear as a single image. 

Miter join results 
in pointed corners.

Rounded join 
applies a circular 

edge to the corners.

Beveled join cuts 
off the points of 

the corners.

None end cap style

Round end cap style

Square end cap style
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Convert Strokes to Fills

To change these windows so they contain a different fill and stroke, you have to change 
the stroke to a fill, which would essentially change the stroke-only object to a regular 
filled object. The resultant shape would be the same as if you had used regular filled 
shapes to construct all the windows.

	 1.	 In the open rocket_working.fla file, choose the Selection tool, and then 
choose Edit>Select All.

The Edit>Select All command selects all the strokes on the Windows layer. (All but the 
Windows and Sketch layers are hidden and locked, and the Sketch layer is locked.)

	 2.	 Choose Modify>Shape>Convert Lines to Fills.

All the lines are converted into regular fills; they do not yet have defined stroke 
attributes. You change the stroke for these shapes in a later exercise.

The bounding boxes 
indicate that each of 
these former lines is 
now a filled shape.

The dotted line style 
results in a group 
made up of the 
individual circles.

	 3.	 If you have more than three circles in the bottom row of windows, deselect 
everything, and then select the bottom row of windows with the Selection 
tool. Choose Modify>Ungroup, deselect all the circles, select and delete the 
extras (more than three), and then drag the remaining three circles into the 
appropriate positions based on the sketch.

	 4.	 Lock the Windows layer.

	 5.	 Save the file and continue to the next stage of the project.

Press Command/
Control-A to select all 
objects.

Note:
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Stage 4	 Painting and Coloring
You now have the necessary parts to build a fairly respectable rocket ship. All your ship needs is a good 
paint job and plenty of open space. In this section, you color the individual components and launch 
the craft into space. You also add the shadowed areas you see in the original sketch.

You can use a wide variety of methods to paint the ship. For example, the Paint Bucket tool fills 
shapes with a specified color. The Ink Bottle tool changes the color of existing strokes, or adds a stroke 
to a fill that doesn’t have one (such as the windows you converted to fills in the previous exercise).

Fill Artwork with the Paint Bucket Tool

Sometimes, the best way to color an object is to simply tip a can of paint into the 
shape and let it fill up with color — which is exactly what you do with the Paint 
Bucket tool in this set of exercises.

	 1.	 With rocket_working.fla open, hide the Sketch layer. Show and unlock the 
Body, Nose Cone, and Exhaust Vent layers (in the Body Parts layer folder).

	 2.	 Choose the Paint Bucket tool from the Tools panel.

	 3.	 Set the stroke color to None, and set the fill color to a light gray (#999999).

Remember, you can change the stroke and fill colors by clicking the buttons in the Tools 
panel and choosing the color you want from the pop-up Color Swatch panel.

	 4.	 With the Paint Bucket tool selected, click inside the nose cone.

As soon as you click, the nose cone fills with the gray fill color.

Paint Bucket 
tool

Paint Bucket
tool cursor

The Paint Bucket tool only fills closed shapes. If you have difficulty filling a particular 
object with the Paint Bucket tool, you probably didn’t correctly connect the endpoints 
of the different lines that make up that shape. Select the problem endpoints with the 
Subselection tool, zoom into the corners, and make sure the endpoints of different lines 
meet one another.

If you find open endpoints, 
use the Direct Selection 
tool to move open 
endpoints to overlap.

Zoom into corners and 
look for gaps or other 

open endpoints.
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	 5.	 Click the Paint Bucket tool cursor inside the body to fill it with the same 
gray color.

Because the Windows layer is below the Body layer — and thus, below the now-filled 
body shape — you can’t see the windows.

	 6.	 In the layers section of the Timeline, drag the Windows layer above the 
Body layer.

Moving the Windows 
layer above the Body 

layer makes the 
windows visible again.

	 7.	 Double-click the exhaust vent with the Selection tool to enter into the group. 

	 8. 	Fill the three shapes with the same gray you used on the rest of the ship’s body.

You have to enter into 
the group to change 

the color of the 
exhaust vent shapes.

	 9.	 Click Scene 1 to return to the main Stage.

	10.	 Change the fill color to white and fill the four circles on the vent.

Change the fill color to 
white, and then fill the 
four circles in the 
exhaust vent. 

	11.	  Save the file and continue to the next exercise.
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Change Stroke Colors with the Ink Bottle Tool

Most, but not all, of the objects you’ve drawn so far should display a 1-point colored 
stroke. In this exercise, you use the Ink Bottle tool to add strokes to the windows 
(which currently have strokes of None) and change the colors of other strokes as well. 

	 1.	 With rocket_working.fla open, select the exhaust vent shape with the 
Selection tool and choose Modify>Ungroup.

By ungrouping these shapes, you no longer have to enter into the group to edit the fills 
and strokes.

	 2.	 Make sure nothing is selected in the file. 

	 3.	 Select the Ink Bottle tool (nested under the Paint Bucket tool) in the Tools 
panel. In the Properties panel, pick a dark blue color as the stroke color. 
Change the stroke weight to 1 and the style to Solid.

Once you select the Ink Bottle tool, you can use the Properties panel to predetermine 
the weight, color, stroke style, and other features before you use the tool. The current 
settings in the Properties panel will be applied to any shape you click with the Ink Bottle 
tool. These settings will remain in effect for the Ink Bottle tool until you change them.

	 4.	 Click the Ink Bottle tool cursor in the nose cone, the body, the three shapes 
of the exhaust vent, and the four circles on the exhaust vent. 

The strokes instantly change to the new color; it doesn’t matter if you select the layer or 
not. Since the objects are on unlocked layers, the Ink Bottle tool “knows” which objects 
it’s touching.

	 5.	 Unlock the Windows layer, and then add strokes to the windows by clicking 
them with the Ink Bottle tool cursor.

Remember that these shapes started as thick strokes with no fills applied. When you 
converted them to shapes, you set the stage for adding strokes to these shapes.
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	 6.	 Make sure nothing is selected, and then use the Properties panel to change 
the stroke style to Hatched.

Combining styles, colors, and shapes, as well as using strokes in combination with the 
Convert Line to Fill command, can not only save you a great deal of time, but it can also 
result in some very interesting artwork.

	 7.	 Change the strokes of the bottom windows by clicking them with the Ink 
Bottle tool. 

You must click exactly on the object strokes to change them to the hatched pattern.

	 8.	 Save the file and continue to the next exercise.

Use the Eyedropper Tool

The Eyedropper tool is used to “pick up” colors from one object and apply the 
colors to other objects in a drawing. In this exercise, you use the Eyedropper tool to 
automatically change the stroke color for all the fins at the same time, and then fill the 
individual fins with the same color you applied to the ship.

	 1.	 With rocket_working.fla open, collapse and hide the Body Parts layer folder.

	 2.	 Expand, show, and unlock the Fins layer folder.

	 3.	 Make sure the Body Parts layer folder is above the Fins layer folder in the 
stacking order.

If the Body Parts layer folder is under the Fins layer folder, drag the Body Parts layer 
folder above the Fins layer folder in the Timeline.

	 4.	 Using the Ink Bottle tool, apply a solid 1-pt blue stroke to all the fins.

To change the strokes, you have to click the lines that compose the fin shapes. 

The fins have no fill, so you 
have to click the actual 

lines you want to change.

You don’t need to select 
the objects before clicking 
with the Ink Bottle tool 
to change the stroke color.

Note:
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	 5.	 Show the Body Parts layer folder. 

	 6.	 If any of the fin corners are not hidden by the body of the ship, use the 
Selection or Subselection tool to reposition the fin corners.

We adjusted 
these corners.

	 7.	 Click the nose cone with the Eyedropper tool.

The Eyedropper tool copies fill and stroke attributes from one object and immediately 
applies them to another object. 

When you click a stroke with the Eyedropper tool, the cursor automatically changes to 
the Ink Bottle tool. When you click a filled area, the tool automatically changes to the 
Paint Bucket tool with the Lock Fill modifier turned on. You can then click another 
object to apply the copied attributes.

Paint Bucket tool 
cursor with Locked 
Fill indicator Eyedropper tool 

cursor
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	 8.	 One at a time, click the Paint Bucket cursor on each fin shape.

To fill the fins, you have to click the lines that compose the fin shapes. (The fins 
currently have no fill, so you have to click the outside edge of the shape you want to fill.) 

	 9.	 Hide the Body Parts layer folder, and then click the side fin outline to fill 
the shape with the same gray color.

	10.	 Show the Body Parts layer folder. 

When the Body Parts layer folder is visible, it hides the side fin (which is in the Fins 
layer folder, lower in the stacking order).

The Lock Fill option 
controls the appearance of 
gradient and bitmap fills. 
If this modifier is active, 
the gradient or bitmap 
fills the entire Stage; 
objects filled with the 
gradient or bitmap show 
the underlying area of 
that gradient or bitmap.

Note:
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	11.	 Expand the Body Parts layer folder, and then drag the Side Fins layer into 
the Body Parts layer folder. Position the Side Fins layer at the top of the 
Body Parts layer folder. 

The Side Fins layer is now part of the Body Parts layer folder. It appears in the proper 
position, as long as it remains above the Body layer within the Body Parts layer folder.

The Side Fins layer has 
to be at the top of the 

stacking order in the 
Body Parts layer folder.

	12.	 Save the file and continue to the next exercise.

Outline viewing mode is one 
of the choices available in the 
layers area of the Timeline. As 
is the case with the Visibility 
and Lock icons, you can 
turn on Outline mode for a 
single layer or a layer folder 
(which affects all layers in the 
folder). 
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Use the Brush Tool 
The Brush tool acts exactly as you might expect: it simulates a paint brush, and you 
use it to color objects, draw shapes, and add color to existing objects. You can exert 
considerable control over how the Brush tool behaves. You can use it to paint inside 
a specific object, paint behind an object, paint outside an object, or — as it normally 
behaves — paint directly over an existing object. 

	 1.	 With rocket_working.fla open, lock all layers except the Side Fins layer. 
Display all but the Side Fins and Sketch layers in Outline mode. 

You need to see the sketch as you develop the shadows, but keeping the Sketch layer 
locked ensures that you don’t accidentally move the sketch. Since the sketch is a bitmap 
image, selecting Outline view for the layer makes the sketch disappear.

Click here to toggle a 
layer between Outline 

mode and Normal mode.

	 2.	 Select the Side Fins layer to make it active, and then click the Selection tool 
anywhere on the Stage to deselect the object on the layer.

	 3.	 Select the Brush tool in the Tools panel, and set its fill to light gray (#CCCCCC).

	 4.	 In the Options menu at the bottom of the Tools panel, choose Paint Behind.

This option causes the 
Brush tool to paint 
behind the objects on 
the selected layer.
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	 5.	 Paint the shadow that appears on the sketch.

While you’re painting the shadow, it appears to be on top of (and obscuring) the fin 
shape; but when you release the mouse button, the shadow assumes its proper place 
behind the fin shape.

While you’re painting, 
the brush strokes appear 
to be on top of the 
existing shape.

Brush tool 
cursor 

Using the Paint Behind 
option, the overlapping 
paint disappears when you 
release the mouse button.

	 6.	 Unlock the Bottom Fins layer and view it normally (turn off Outline mode). 

	 7.	 Using the Selection tool, click the fill of the bottom-front fin to select it.

	 8.	 Choose the Brush tool in the Tools panel, and switch to Paint Selection mode.

	 9.	 Paint a shadow on the bottom-front fin, using the following image as a guide.

Brush Tool cursor

Selected fill

Using Paint Selection 
mode, you don’t have 
to stay inside the lines.

Don’t worry about filling 
the upper part of the fin; 
this area will be hidden 

by the body shape.

When you release the 
mouse button, only 

areas within the 
selected fill are painted.

	10.	 Using the same method, paint the shadow on the bottom-rear fin.

Remember, you have to select the fin’s fill before you can successfully use the Paint 
Selection option.

	11.	 Repeat the process to add a shadow to the bottom tail fin on the 
Tail Fins layer.

For this procedure to work correctly, you must show the layer in regular mode (not 
Outline mode) and select the fin’s fill. Use the Undo command (Command/Control-Z) 
to step backward if you need to repeat the previous few steps.
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	12.	 Hide the Sketch layer, show all the drawing layers in regular mode, and 
review your work.

	13.	 Save the file and continue to the next exercise.

When you’re using the 
Brush tool, four options are 
available in the bottom of 
the Tools panel.

The Lock Fill option applies 
when you paint with a gradient, allowing you to lock the 
gradient fill to the Stage instead of the object. If you turn 
on this option, the first spot you paint is considered the 
starting point of the gradient (whether linear or radial). 
Any additional areas you paint with the same gradient are 
considered extensions of the gradient. 

Without Lock Fill active, each 
stroke starts the gradient again.

With Lock Fill active, the gradient 
extends across the entire Stage. 

Painting essentially “reveals” the 
gradient in those places.

The Brush tool has five modes:

•	 Paint Normal is exactly that: it 
paints directly on top of anything 
already on the Stage. 

•	 Using the Paint Fills mode, you 
paint over the background and any object fills, but you 
leave object strokes unaffected. 

•	 Paint Behind allows you to paint only the background; 
any area with a fill remains unaffected by the brush 
stroke. 

•	 Paint Selection applies your brush strokes to currently 
selected fill areas only. 

•	 Paint Inside applies the brush stroke within the 
boundaries of the fill where you first click. 

You can also change the brush 
shape and brush size using the 
bottom two menus.
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Add Backgrounds 
You have two choices when it comes to using backgrounds on your projects. The first 
choice is to simply change the color of the Stage. Since all layers reside on the Stage, 
the background color appears behind all objects you create. The second option is to 
include a digital image, similar to the sketch you used in this project. 

	 1.	 With rocket_working.fla open, show and unlock the Sketch layer. 

	 2.	 Using the Selection tool, select the sketch on the Stage and delete it. 

	 3.	 With nothing selected on the Stage, click the Stage swatch in the Properties 
panel. Choose a dark blue from the pop-up color palette.

Click this swatch 
to change the 
color of the Stage.

   

	 4.	 Choose File>Save As. Save the file as rocket_flat.fla in your WIP>Rocket 
folder, and then close the file. 

	 5.	 Rename the Sketch layer Space. 

	 6.	 With the Space layer selected, choose File>Import>Import to Stage, and 
then double-click the space.jpg image in the RF_Flash>Rocket folder.

	 7.	 Choose File>Save As. Save another version of the same file as 
rocket_space.fla in your WIP>Rocket folder.

	 8.	 Continue to the next exercise. 

Artwork that contains 
only solid fills is referred 
to as flat art. 

Note:
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Stage 5	 Using Gradients
In its current state, your rocket ship drawing is an example of flat art. In most cases, 
however, you’ll find flat art is too restrictive, especially when you want to apply 
shading to your objects. Most shading is accomplished using blends of two or more 
colors, usually referred to as gradients or blends. 

Blends add depth (sometimes called dimension) to otherwise flat artwork. Blends 
come in several types, the two most common being linear blends and radial blends. 

Apply a Standard Gradient to Selected Objects

Flash includes several gradients (both linear and radial) in the Swatches panel. You can 
apply a gradient to a selected object by choosing from the available options in the fill 
color Swatches panel.

You can also apply a gradient fill by selecting the Paint Bucket tool, choosing a 
gradient swatch as the fill color, and then clicking the objects you want to fill. Finally, 
you can select an object on the Stage and choose Linear or Radial from the Type menu 
of the Color panel; the object fills with a gradient of the last-used colors.

Built-in gradient 
swatches

With the object selected, click 
the Fill button in the Tools 
panel and choose one of the 
gradient swatches from the 
pop-up Color Swatch panel.

   

Choose Linear or Radial 
in the Type menu to 
apply a gradient fill to a 
selected object.

Shadows and fills often work better when they’re soft. In many cases, 
you might want to use the built-in Modify>Shape>Soften Fill Edges 
feature to automatically soften the edges of a fill. For example, the 
shape in the following images started out as a 12-point stroke, and 
was then converted to a fill. Once converted, the shape was selected 
with the Selection tool.

The Soften Fill Edges command opens a dialog box where you can 
determine whether the shape should soften inward (Inset), which 
keeps the soft edge within the current boundaries of the fill, or 
outward (Expand), which makes the fill larger by the pixel value you 
enter into the Distance field. The Number of Steps field determines 
how smooth the blend appears. If you look closely, you’ll see that 
the softening effect is accomplished by gradually changing the pixel 
density from the color of the original object to white (or the current color of the Stage).
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The terms “gradient” 
and “blend” are used 
interchangeably. Flash 
documentation uses both 
gradient and blend; both 
terms mean a smooth 
transition from one color 
to another.

Note:
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	 1.	 With rocket_space.fla open, unlock all the layers except the Space layer.

Make sure you open the correct file; you don’t want to modify the flat-art version you 
saved in the previous exercise.

	 2.	 Click the Tail Fins layer name to select the layer and all objects on that layer.

	 3.	 Click the Fill button in the Tools panel and choose the white-to-black linear 
gradient swatch.

When you select a layer (as you did in Step 2), the objects on that layer are automatically 
selected — which means that when you choose a new fill color, the selected objects 
automatically reflect the color change.

Click the Fill button 
on the Tools panel to 
open the pop-up 
color palette.

Select the
white-to-black linear 

gradient swatch.

Selected objects fill 
with the selected 
gradient swatch.

	 4.	 Repeat the process with the bottom fins: select the Bottom Fins layer, and 
then select the white-to-black swatch in the fill color Swatches panel. 

	 5.	 Use the same method to apply gradients to the top fin, nose cone, and body 
of the ship.

Leave the side fin alone for now. You will use a different kind of gradient to add 
dimensionality to that shape.

	 6.	 Save the file as rocket_depth.fla in your WIP>Rocket folder, and continue 
to the next exercise.
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Change the Direction of a Gradient

In your drawing, all the shapes containing gradients follow the same flow of colors: 
from light (white) to dark (black). However, real shadows follow real light sources. This 
fact requires you to exercise some degree of control over the direction of the gradients 
in your drawing. 

You can accomplish this task using the Gradient Transform tool. When you select 
the tool and click a gradient, a bounding box appears. You can use the handles on the 
bounding box to enlarge, reduce, rotate, or otherwise transform a gradient applied to a 
Flash object. 

	 1.	 With rocket_depth.fla open, hide the Space layer.

	 2.	 Select the Gradient Transform tool (nested under the Free Transform tool) 
in the Tools panel.

You can edit the colors in a gradient using 
the gradient ramp in the Color panel 
(Window>Color). This option allows you to 
create custom gradients that blend across 
multiple colors (up to 15) at different 
locations along the ramp.

When you use the Paint Bucket tool to apply 
a gradient, the bottom of the Tools panel 
offers an option to lock the fill to the Stage. 
When this option is toggled on, the gradient 
is applied relative to the overall Stage; when 
you fill individual objects with the Lock Fill 
modifier, those objects show the associated 
portion of the underlying gradient. 
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Gradient ramp

Gradient stop

Click below the gradient ramp 
to add another gradient stop.

Drag gradient stops across the 
ramp to move the location of 
that color along the gradient.

Click a gradient stop to change 
the color of the specific stop.

The gradient in the object 
matches the added and adjusted 

stops in the gradient ramp.

Without the Lock Fill modifier, the 
gradient was applied to the top 
row of squares. The gradient is 

applied individually to each square.

Using the Lock Fill modifier, the 
same gradient was applied to the 
bottom row of squares. The fill is 

treated as a single gradient 
across all seven squares.

Lock Fill 
modifier
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	 3.	 Click the top-rear fin with the Gradient Transform tool to show the 
gradient handles.

Gradient 
Transform tool 

Gradient rotation handle

Gradient center point

Gradient width handle

The Gradient Transform tool (nested under the Free Transform tool) enables you to adjust the size, direction, and center point 
of a gradient fill. When you click an object filled with a gradient, a special bounding box shows the gradient-editing handles.

Width handle

For a radial gradient, 
dragging the width 
handle changes the 
width of the gradient to 
create a skewed effect.

Center point handle

Size handle

Rotation handle

Center point handle

Width handle

Rotation handle

Dragging the center 
point handle moves the 
center of the gradient to 
a new location. 

Dragging the width 
handle makes the 
gradient larger or smaller 
relative to the object 
that you are modifying. 

Dragging the rotation 
handle rotates the gradient 
around its center point. 
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Transforming Gradients
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	 4.	 Click the gradient rotation handle and drag left until the white part of the 
gradient roughly aligns to the point where the fin meets the body.

Click here and drag to 
rotate the gradient.

	 5.	 Click the gradient width handle and drag left to make the gradient narrower 
(about half the width of the original gradient).

Click here and drag to 
make the gradient 
narrower or wider.

	 6.	 Click the gradient center point and drag left until the center point touches 
the body edge.

Click here and drag to 
move the gradient’s 
center point.
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	 7.	 Using the same techniques, transform the gradients that fill the other 
components of the ship. Try to create the effect of a consistent light source.

When you get to the main body, rotate the gradient so the black part is on the left, 
meeting the black portion of the gradient that fills the nose cone.

	 8.	 Save the file and continue to the next exercise.

Use Radial and Custom Gradients

So far you’ve used linear gradients that move from one end of a shape to the other, 
changing color along the way. You can also use radial gradients, which start in the 
center of a shape and radiate outward toward the edges. Radial gradients are very well 
suited for making round objects appear three-dimensional. Fortunately, you have 
several perfect candidates in your drawing for radial gradients: the round portholes at 
the lower rear of the ship. 

	 1.	 With rocket_depth.fla open, use the Selection tool to select all three 
window shapes in the bottom row of windows.

	 2.	 Select the Paint Bucket tool and display the Color panel (Window>Color).

	 3.	 In the Color panel, choose Radial from the Type menu.

A number of choices are available in the Type menu: None, which represents no fill; 
Solid (or flat) colors; Linear; Radial; and Bitmap, which affects imported bitmap images, 
allowing you to adjust color tones.

The selected objects are automatically filled with a radial gradient of the last-used 
gradient stop colors.

Change the 
gradient to Radial 
in this menu.

You can use the rotation 
handle to reverse a 
gradient. Simply drag all 
the way around (180°) 
until the gradient colors 
are reversed.

Note:
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	 4.	 Select the top windows and change the fill type to Linear in the Colors panel. 

Because the windows are already selected, they automatically fill with the white-to-black 
linear gradient. (White-to-black is the last gradient setting you used, so it remains in the 
gradient ramp until you choose or create a new gradient.)

	 5.	 In the Color panel, drag the left gradient stop to the midpoint of the 
gradient ramp.

	 6.	 Click under the left end of the ramp to add another gradient stop.

	 7.	 While the new gradient stop is selected, change the RGB color values to 
R:0, G:0, B:0 (the equivalent of black).

Click a stop and drag to move 
that color to a different 
position along the gradient.

Click below the ramp to 
add a stop to the gradient.

	 8.	 Select the side fin shape. Choose the Linear option in the Color panel to 
apply the black-to-white-to-black linear gradient to the shape’s fill. 
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	 9.	 Select the Paint Bucket tool and turn off the Lock Fill modifier at the 
bottom of the Tools panel. 

Paint Bucket tool

The Lock Fill option 
should be toggled off.

	10.	 Click near the top of the side fin and drag down past the lower edge to 
define the direction of the gradient fill.

When you release the mouse button, the gradient fill is redirected based on the length of 
the line you drew with the Paint Bucket tool. We dragged past the lower edge about the 
same distance as the fin’s height; the center point of the gradient is near the bottom edge 
of the middle of the fin.

	11.	 Show the Space layer.

	12.	 Adjust any fill colors or gradients until you are satisfied with the overall result.

	13.	 Save the file and close it.
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Project 1: Rocket Ship Artwork

Project Review

 1. Briefl y explain how anchor points and handles control the lines in a vector shape.

 2. Briefl y explain the difference between the Selection tool and the Subselection tool.

 3. Briefl y explain what is meant by “destructive editing.”

 1. The _______________ can be used to change 
the size of the Stage.

 2. _______________ in the Timeline can be used 
to manage the top-to-bottom order of objects 
on the Stage.

 3. When created in _______________, the fi ll 
and stroke are treated as separate entities; you 
can individually select each part, and move or 
modify each part without affecting the other. 

 4. When you create a shape in _______________, 
it automatically displays the bounding box as 
soon as you create it; you can’t select the fi ll 
and stroke independently on the main Stage.

 5. A(n) _______________ allows multiple objects 
to be treated as a single entity on the Stage.

 6. The _______________ tool can be used to 
select areas of a standard drawing object, or to 
bend lines created in either drawing mode.

 7. The _______________ tool can be used to 
select individual anchor points and handles that 
make up a shape.

 8. The _______________ tool is used to create 
precise Bézier curves.

 9. The _______________ tool is used to change 
the fi ll color of closed shapes.

 10. The _______________ tool is used to change 
the stroke color of any object.
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Use what you learned in this project to complete the following freeform exercise. 
Carefully read the art director and client comments, then create your own design to meet the needs of the project.
Use the space below to sketch ideas; when fi nished, write a brief explanation of your reasoning behind your fi nal design.

Portfolio Builder Project

We need a series of icons we can use on our Web 
site. Th ese icons will eventually be turned into 
buttons that will link to various areas of the site: 
basic shipping information, cargo and freight 
shipping information, packing services, tracking 
services, and customer service.

We really like the ‘retro’ look of the rocket ship 
you drew. If possible, can you incorporate that style 
into the icons? 

Use any colors you want except brown/yellow and 
blue/orange. Th ose schemes are already taken by 
our primary competitors, and we don’t want to be 
accused of infringing on any trademarks.

We don’t have the images for these icons. Can you 
fi nd something on the Internet to use as a guide? 
We are talking about icons, which need to be easily 
recognizable in any language. Each illustration 
should very clearly convey what each one is for.

Can you have the project fi nished within the next 
two weeks?

Your client is happy with the rocket ship 
artwork, and asked you to create a second set 
of illustrations required for the new Web site.

To complete this project, you should:

o Search the Internet or any other source for 
graphic ideas relating to the client’s fi ve 
icons. If necessary, use images as templates 
when you draw the icons.

o Create the fi ve icons, each in its own 
Flash fi le.

o Carefully consider the best approach for 
each icon and use whichever tool (or tools) 
are most appropriate to create the icon 
artwork.
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Although Flash is known as an animation program, you can see from this project that the application 
off ers a considerable array of drawing and painting tools. You learned how to import a sketch, control 
the size of the Flash Stage, and align objects to the Stage. Th ese skills set the groundwork for any type 
of assignment. 

You also developed an understanding of layers and how they positively aff ect the construction of 
complex drawings and artwork. You now know how to create, rename, lock, and hide layers. You know 
that artwork contained on one layer resides either above or below other layers in the document, and 
that the top-to-bottom order of layers in the Layers panel is called the stacking order. You also found 
that you can change the stacking order at any time to hide or reveal specifi c sections of your artwork.

You learned about the two Flash drawing modes, and discovered the strengths of both modes. You 
created shapes using several diff erent methods, including the primitive drawing tools, the Line tool for 
simple lines, and the Pen and Pencil tools for more complex curves. You also learned how to control 
shape attributes such as the fi ll and stroke colors, as well as how to apply stroke styles and gradients to 
create unique artistic eff ects.

Control object fill 
and stroke attributes

Work in both standard- 
and object-drawing modes

Use stroke 
styles to create 
artistic effects

Convert lines to 
filled shapes

Place a bitmap 
image as a 
background

Create and edit 
basic shapes

Use the Pencil 
tool to create 

custom shapes

Use the Pen 
tool to create 
precise curves

Use destructive pixel 
editing to remove 
drawing elements

Paint shapes 
using various 
brush modes

Create depth 
with gradients




