
Rocket Ship Artwork
Your client is the owner and founder 
of a delivery service named Rocket 
Overnight Delivery, which specializes 
in quick, overnight package handling 
between local and regional businesses. 
Th e company is growing rapidly, and 
they plan to further expand their 
revenues by using an email marketing 
campaign connected to special Web 
site off ers. 

Th is project incorporates the following skills:

o Defi ning a movie fi le with settings that are appropriate for the 
job you’re building

o Importing a scanned image provided by the creative director

o Using Flash drawing tools to develop a digital version of the 
rough sketch

o Adding depth to the line-art rocket ship using various shading 
and blending techniques

o Placing a background image that simulates deep space, so the 
client can see the artwork in position as it might be on a Web 
banner, poster, or postcard

1Project
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We’re hiring your agency to develop our site 
and corresponding mailers. The first thing  
we need is the primary graphic — the rocket 
ship — that will be used for banners, mailers, 
and eventually animated on the site. 

We want the main rocket artwork to reflect a 
“retro” design, looking like something from a 
1950s science fiction movie — the art should 
not be overly sophisticated or perfectly ren
dered. We want to develop a visual “look and 
feel” that will help local businesses immediately 
recognize us, so we’re going to use this basic 
rocket artwork as a visual branding asset. 

Since Flash produces vector artwork, we can 
use the artwork for just about anything once 
it’s done. I want the finished product to be 
1024 pixels wide by 400 pixels high; the 1024 
width constraint is to make sure it works for a 
Web site header (which is the first thing I want 
to do with it).

We’ve already gotten approval for the sketch. 
The first thing to do is import that sketch 
to use as a guide. Start by tracing the line 
art using a bright color so I can see how it’s 
coming before you add color. 

Once you finish the line art, you can add color. 
I want you to start out with flat colors because 
I might want to show that to the client — it 
gives a good “retro” feel. Then I want a version 
using gradients, so the client can see how the 
artwork looks with more depth.

Also, make sure you build the artwork using 
logical layers — such as a body layer, separate 
layers for each set of fins, etc. That way, if we 
need to make changes later, or if we need to 
animate the rocket ship, the document will be 
properly structured.

To complete this project, you will:

o	 Set up the workspace to match the 
requirements of the project

o	 Import the scan of the sketched rocket ship

o	 Create a set of logical layers to hold the 
various components you’ll create

o	 Understand the difference between 
standard- and object-drawing mode

o	 Use the primitive shape and line tools to 
develop various components of the drawing

o	 Draw precise Bezier curves with the  
Pen tool

o	 Use the Pencil tool to draw freehand shapes

o	 Apply color with the Paint Bucket, Ink 
Bottle, Eyedropper, and Brush tools

o	 Use object groups to combine and protect 
drawing objects

o	 Apply and edit color gradients
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Stage 1	 Setting Up the Workspace
The first step of any new project is to set up the Stage. Once you set up a new file for this project,  
you will use the Import command to bring the rough sketch (which we already scanned for you)  
into the document so you can get to work.

Create a New Document

	 1.	 Launch Flash.

	 2.	 Choose File>New.

The New Document dialog box presents a list of different document types you can use 
as the basis for your new file.

	 3.	 Make sure the first option — Flash File (ActionScript 3.0) — is selected in 
the list, and then click OK.

	 4.	 Choose File>Save As.

	 5.	 In the resulting dialog box, navigate to your WIP>Rocket folder as the 
target location. 

	 6.	 Change the file name to “rocket_working.fla”. Make sure Flash CS3 
Document is selected in the Format/Save As Type menu and click Save.

The “.fla” extension should automatically be added to the file name. If you delete it, 
you should add it back into the file name. This is good practice, and it will help you 
distinguish Flash files from Flash player files (with the “.swf” extension) when you start 
exporting files for digital distribution. 

Flash files — that is, “live” files in the program’s native format — use the “.fla” 
extension. When distributing your movies and animations for viewing by other people 
or for use on a Web site, you use a stand-alone format that does not require the actual 
Flash application. These files are called “player” files (because they require the Flash 
player to view) and use the “.swf” extension.

Before completing this 
project, copy the Rocket 
folder from the WIP 
folder on your Resource 
CD to your WIP folder 
wherever you are saving 
your work. When you 
save files for this project, 
you will save them in 
your WIP>Rocket folder.

Note:

We encourage the use 
of three-letter suffixes 
such as “.fla” and 
“.swf.” Using the correct 
extension will allow you 
to quickly identify a file’s 
type and origin when 
you look at the file on 
your desktop or within a 
folder (when viewing the 
contents as icons). This is 
true for all programs, not 
only Flash.

Note:
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Import Objects from Other Programs

As we discussed during the production meeting for this assignment, your work for 
this project is going to be based on a hand-drawn sketch of a rocket ship. We already 
scanned the sketch for you, so you don’t need to worry about that step. (In an actual 
on-the-job project, however, you would need to scan the sketch as the first step in 
the process.) Flash can import a wide variety of file formats, including JPG, GIF, TIF, 
and EPS. The first three formats are bitmaps; the fourth — EPS, or Encapsulated 
PostScript — is a common vector format.

	 1.	 With the rocket_working.fla file open, choose File>Import>Import to Stage.

Four options are available when you choose the Import command: 

•	 Import to Stage simply brings an external image onto the current Stage.  
(The image is also added to the file Library.)

•	 Import to Library automatically places imported graphics into the Flash  
Library panel.

•	 Open External Library is commonly used to incorporate graphics from one 
project into another project.

•	 Import Video allows you to bring in digital video or analog video that has 
already been digitized. 

	 2.	 Navigate to the RF_Flash>Rocket folder and double-click the rocket.jpg file.

	 3.	 Look at the Properties Inspector at the bottom of your screen; it shows that 
the imported image is a bitmap. 

If you can’t see the Properties Inspector, choose Window>Properties>Properties. 

	 4.	 Save the file and continue to the next exercise.

The key command for 
importing objects to 
the Stage is Command/
Control-R.

Key Command:
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Change Document Properties 
There are many reasons why you might need to change the size and other properties 
of a document. When complete, this artwork is going to be placed horizontally along 
the top of a Web page. Knowing this, you need to make the document wider than it 
is high so it appears visually correct in its final application. It is important to note that 
changing the document size does not change the size of the objects contained in the 
document; you have to do that yourself on an object-by-object basis.

Objects on the Stage are controlled through the Properties Inspector. Document 
properties, on the other hand, change the size of the Stage only; the settings in the 
Document Properties dialog box don’t affect existing objects on the Stage.

	 1.	 In the open file, choose Modify>Document.

This command opens the Document Properties dialog box. Changes made here affect 
the Stage (including all scenes contained within the movie). These changes do not, 
however, affect the objects contained in that movie; changing the size of the Stage 
doesn’t alter the size of objects you’ve already drawn. 

There are two kinds of computer images. The first, known as a bitmap, is comprised of simple pixels. Each pixel has a 
specific value, and that value determines the color, intensity, and brightness of that pixel. The number of pixels that make up 
a bitmap image is fixed at the time of the scan or photograph. If you blow up (enlarge) a bitmap image, it becomes grainy 
and loses quality; in fact, you can see the individual pixels in an enlarged bitmap image. 

Flash is a vector-based program. Vector art is not based on pixels; instead, it is based on mathematical values. Vector art 
is essentially a tiny program that tells the printer or monitor to “draw a line from point a to point b, and that the line needs 
to bend x degrees coming out of point a and enter point b from an angle of z.” Although this might sound confusing, you 
don’t have to write any complicated code 
to make vectors work properly; you can 
simply draw lines with the Flash Pen tool 
and the vectors are created for you.

An example of the difference between a 
bitmap image and vector art is shown to 
the right. At 100% size, both the image 
(a bitmap) and the type (comprised of 
vector objects) are crisp. If you zoom in 
close enough, however, the individual 
pixels in the photograph start to show 
and the image breaks down — while the 
type remains perfectly crisp and clear. 
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Bitmap Images and Vector Art

Press Command/
Control-J to open the 
Document Properties 
dialog box.

Key Command:
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	 2.	 Change the Width field to 1024 pixels, and click OK to apply the change.

	 3.	 Save the file and continue to the next exercise.

Align Objects

At times you might want to align a set of objects, such as a column of buzzing bees 
or a row of spectators in the bleachers at a sporting event. At other times, however, 
you’ll need to align objects relative to the Stage. One example, which you see next, is 
positioning an object in the exact center of the Stage, equidistant from both the top 
and bottom edges, as well as from the two sides.

You can use the Align panel to control alignment and/or space-distribution 
option. You can align the sides, tops, bottoms, or centers of any and all selected 
objects, along either their horizontal or vertical axes.

	 1.	 Choose Window>Align to open the Align panel.

	 2.	 Click the To Stage button until the button is active.

The Align panel remembers the last-used state of the To Stage button, so this option 
might be already active depending on what you or someone else did before now. 

The buttons in the Align panel are arranged in specific categories: Align, Distribute,  
Match Size, and (Match) Space. 

	 3.	 Click the Align Horizontal Center and Align Vertical Center buttons.

The scan of the rocket ship snaps into the center of the Stage, along both axes.

Press Command/
Control-K to show or 
hide the Align panel.

Key Command:

On Macintosh, the To 
Stage toggle is dark gray 
when active and light 
gray when inactive.

On Windows, the To 
Stage toggle is outlined 
when active and not 
outlined when inactive.

Note:
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	 4.	 Try some of the other alignment options. For example, try aligning the 
rocket to the lower-left side of the Stage.

	 5.	 When you’re done experimenting, place the rocket in the center of the Stage, 
using the same method you applied in Step 3.

	 6.	 Save the file and continue to the next stage of the project.

Besides being able to align an object to the 
Stage — as you are doing with the scanned 
rocket sketch — you can also align two or 
more selected objects to each other. The images 
to the right are basic examples of how you can 
use the Align panel to align, distribute, and 
resize objects on the Stage.

Another option on the Align panel is space 
distribution. You can use the distribution 
buttons in the Align panel to equalize the 
amount of space between multiple objects. 
As is the case with alignment, the objects you 
want to distribute need to be selected before 
you click a button to invoke a distribution 
command.

You can also use the Match Size icons to 
match the sizes of different objects. Take some 
time to experiment with various options. 
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Aligning Objects to Each Other

Original object placement

Align Left Edge

Align Horizontal Center

Align Right Edge

Align Top Edge

Align Vertical Center

Align Bottom Edge
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Stage 2	 Using Layers to Develop Artwork
If you’ve used any professional drawing or imaging program, you might already know about layers and 
how they work. If not, the following exercises will introduce you to these important concepts.

Think of layers as individual sheets of transparent material on which you can draw. For example, 
let’s say you drew a red circle on one sheet of the material and a blue square on another sheet. If the 
sheet containing the circle was on top of the sheet containing the square, the portion of the circle 
laying directly over the square would hide that portion of the square.

If, however, you move the sheet containing the square to be on top of the sheet containing the 
circle, the opposite would occur: the square would obscure the circle.

Create Layers for Organizing Artwork

To facilitate work on complex objects — both from a drawing perspective as well as 
from the standpoint of being able to animate complex objects — Flash provides a 
simple way to create, re-arrange, and otherwise manage these imaginary “sheets.” In 
Flash, the “sheets” are called layers. Some Flash objects, especially complex animations, 
require many different layers to create the desired result. 

Layers are stacked on the left side of the Timeline. The order in which the layers 
are stacked (from top to bottom) is referred to as the stacking order. 
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	 1.	 With rocket_working.fla open (from your WIP>Rocket folder), look at the 
layers portion of the Timeline.

There is only one layer named Layer 1. By reviewing the icons to the right of the layer’s 
name, you know Layer 1 is active, visible, unlocked, and displaying regular — not 
outlined — objects.

	 2.	 Double-click the name of the layer to highlight the name. Type “Rocket 
Sketch” to rename the layer, then press Return/Enter to apply the change.

	 3.	 Below the list of layers, click the Insert Layer button to add another layer on 
top of the first layer.

	 4.	 Rename the new layer “Body” and press Return/Enter to apply the change.

	 5.	 Lock the Rocket Sketch layer by clicking the small dot below the Lock icon.

	 6.	 Save the file and continue to the next exercise. 

Layers are stacked on the 
Timeline. Objects on the 
lowest layer are covered 
by objects on all layers 
above it in the Timeline. 
When you’re developing 
a drawing with many 
layers, you’ll often need to 
change the layer stacking 
order. 

Note:

If the layer is locked, the 
pencil is covered with a 
slash, indicating that you 
can’t change objects on 
the layer or add objects to 
the layer.

Note:
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Organize Layers into Folders

In some cases, a Flash project will contain dozens of layers representing the various 
components of an animation or movie. You can use layer folders to organize layers into 
logical groups or categories. You can rename layer folders in the same way you rename 
layers, and you can reorder layer folders (and their contents) by dragging the folders 
into new positions in the stack of layers.

	 1.	 With rocket_working.fla open, click the Insert Layer Folder button at the 
bottom of the panel (below the list of layers).

	 2.	 Double-click the layer folder name and type “Fins” to rename the folder.

Changing the name of a layer folder is the same as changing the name of a layer; simply 
double-click the folder name and type in the new name.

	 3.	 Create four new layers named “Top Fins”, “Side Fins”, “Bottom Fins”,  
and “Tail Fins”.

	 4.	 Shift-click the four new layers and drag them onto the Fins layer folder.

The dragged layers now reside inside the Fins layer folder. The layers will stay together as 
long as they all remain inside the folder. 

	 5.	 Click the Rocket Sketch layer name to select it (deselecting the layers in the  
Fins layer), and then create another new layer folder and name it “Body Parts”. 

New layers and layer folders are created in the same nesting level as the currently selected 
layer. If you click the Insert Layer Folder button with the nested layers still selected, the new 
layer folder will be created inside the Fins folder instead of at the same level as the Fins folder.

Press Shift to select 
contiguous layers — that 
is, layers directly on top 
of or below each other. 
To select layers that aren’t 
next to each other, press 
the Command/Control 
key while clicking the 
individual layers.

Note:

When you work with complex images that contain many layers, it’s often helpful to expand the vertical size of the Timeline; 
the Timeline’s default height wouldn’t allow you to see all the layers the document contains. To increase the vertical size 
of the Timeline, simply grab the small bar that separates the Timeline from the Stage and drag it down toward the bottom 
of your monitor. To 
decrease the vertical  
size of the Timeline, drag 
the bar up toward the 
top of your monitor.
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	 6.	 Create new layers named “Nose Cone”, “Windows”, and “Exhaust Vent”. 
Drag these layers — along with the existing Body layer — into the new 
Body Parts layer folder.

	 7.	 Click the Arrow icon to the immediate left of the Body Parts layer folder to 
collapse the folder.

Once collapsed, you see only the layer folder; you do not see the individual layers it 
contains. (Layers in collapsed folders are still visible on the stage, but not in the list of 
layers.) Collapsing folders makes it much easier to organize complex Flash documents. 

	 8.	 Save the file and continue to the next stage of the project.

Stage 3	 Drawing in Flash
A primitive shape is a simple object such as a square, circle, oval, rectangle, or polygon. 
(A polygon is any shape with least three sides and angles; this definition naturally includes 
triangles.) Other shapes include freeform shapes (similar to polygons, but without straight 
sides) and recognizable objects such as balloons, stars, twirls, cones with rounded bottoms, 
spirals, and a host of others.

A shape displays two primary attributes: a fill and a stroke. The fill is the color contained 
within a shape, and the stroke is the line that defines the outside border. To change the fill 
and stroke of an object, use the pop-up Color Swatch panel that appears when you click and 
hold the Stroke or Fill button at the bottom of the Tools panel.

You see how layers 
and layer folders can 
assist you in organizing 
complex drawings 
and animations into 
logical, easy-to-recognize 
component categories, 
and at the same time, 
allow you to keep all the 
components separate.

Note:
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There are two modes for drawing in Flash: standard drawing and object drawing.  
When you select one of the primitive shape tools, the Pencil tool, the Line tool, or the  
Pen tool, a toggle in the bottom section of the Tools panel determines which type of  
drawing you will create.

When created in standard-drawing mode, the fill and stroke are treated as separate 
entities. You can individually select either piece with the Selection (solid arrow) tool and 
move or modify it without affecting the other piece. 

Standard-drawing mode has some advantages; specifically, you can select only a piece  
of a shape by dragging a marquee with the Selection tool.

You can prevent this type of editing by grouping the two pieces of the object. Simply 
drag a selection around the entire object and choose Modify>Group. When a standard object 
is grouped, you see only the group bounding box (the blue border) when you select the 
object on the Stage.
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Even when standard objects are grouped, you can access the individual pixel components 
by double-clicking them on the Stage. This opens a secondary Stage — called Edit mode — 
where you can access and edit the individual components. The Edit bar above the Stage 
shows that you are no longer on the main Stage, but editing a group. 

Of course, standard-drawing objects have their drawbacks as well; you could easily 
move or change an object that you don’t want to change — such as dragging a fill away 
from its stroke and not realizing it until 15 steps later when it’s too late to easily undo.

To solve this problem, you can also draw in object-drawing mode by toggling on 
the switch at the bottom of the Tools panel. When you create a shape or line in object-
drawing mode, it automatically displays the bounding box as soon as you create it, and  
you can’t select the fill and stroke independently — at least not on the main Stage.

If you want to access the individual components of an object in object-drawing 
mode, simply double-click the object. Like modifying a group, double-clicking activates 
the Edit mode; the Edit bar shows that you are “inside” (editing) a drawing object that 
exists in Scene 1.

When you double-click 
an object or group, you 
are editing it in place 
(this is often referred to as 
“entering into” the object 
or group). Other objects 
on the Stage will remain 
visible but shaded back; 
you can see those objects 
but you can’t access them. 

Note:

You can also convert an 
object-drawing object 
to a standard-drawing 
object by selecting it 
on the main Stage and 
choosing Modify>Break 
Apart.

Note:

When you drag one standard object onto another standard 
object on the same layer, the topmost object removes 
whatever portion of the lower shape it covers. In the second 
image to the right, we placed the square from the first image 
on top of the circle. In the third image, you see the result of 
deselecting the square, and then reselecting it and pulling 
the square away from the circle. (This type of destructive 
interaction does not occur until you deselect the topmost 
object. This gives you a chance to “finalize” the edit; as long 
as you still see the crosshatch pattern on the object you’re 
dragging, the underlying objects have not yet been changed.) 

This type of interaction does not occur with objects created in object-drawing mode or when you’re working with grouped 
objects. If you select something with the Selection tool and see a bounding box instead of the crosshatch pattern, underlying 
objects will not be affected. Only you can tell when an object needs to be protected from destructive interaction with other 
objects or, conversely, when you want one object to interact another object. 
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Use the Oval Tool to Create Shapes

Many otherwise complex objects are, in fact, simply a collection of primitive shapes 
combined, overlaid, and mixed together. Actually, with a little vision, you can see that 
all artwork is a combination of various primitive shapes.

	 1.	 With rocket_working.fla open, select the Side Fins layer inside the Fins  
layer folder.

	 2.	 Click the Fill button in the Tools panel, and then click the None button to 
turn off the fill color.

This is a critical step when tracing an object: if shapes were automatically filled,  
they would hide the underlying image you’re tracing.

	 3.	 Select the Zoom tool from the Tools panel, and then drag a marquee around 
the front of the side fin.

Drawing a marquee with the Zoom tool enlarges and positions the specific area you’re 
working on.

	 4.	 Click the Rectangle tool in the Tools panel and hold down the mouse 
button to access the tools nested beneath it. 

	 5.	 From the pop-up menu, select the Oval tool.

	 6.	 Make sure the Object Drawing option is toggled off at the bottom of the 
Tools panel.

On Macintosh, the Object Drawing toggle is dark gray when active and light gray when 
inactive. On Windows, the Object Drawing toggle is outlined when active and not 
outlined when inactive.

Press Command/Control-
Plus (+) to zoom in or 
Command/Control-
Minus (-) to zoom out 
without selecting the 
Zoom tool. 

Key Command:

Press and hold the 
Spacebar to turn the 
cursor into a hand, 
which allows you to 
“push” the document 
around on the Stage. 

Key Command:
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	 7.	 In the Properties Inspector, change the weight (thickness) of the stroke to 
0.5, change the color of the stroke to bright orange, and choose Solid in the 
Style menu.

When you select a drawing tool, the Properties Inspector provides controls for fill color, 
stroke color and weight, the type of stroke (now set to Solid), access to custom strokes, 
end cap styles (round, square, etc.), and whether strokes meet in sharp or blunt corners.

Reducing the stroke weight results in a finer line than the 1-point default. Changing the 
color to orange allows you to better see your drawing against the black strokes of the 
scanned sketch. 

	 8.	 On the Stage, click at the upper corner of the curve, press Shift, and then 
drag down and right to create a circle that closely matches the shape of the 
front of the fin.

If you don’t get it right the first time, press Command/Control-Z to undo the step and 
try again. 

	 9.	 Choose the Selection tool (the solid arrow) in the Tools panel. 

	10.	 Click away from the circle to deselect it, and then move the cursor near the 
top-right edge of the circle until you see a curved line in the cursor icon. 

	11.	 Click and push the top-right edge of the circle toward the center of the circle.

One unique aspect of drawing with Flash is using the Selection tool to pull and push 
on a shape until it exactly fits what you’re tracing. When you release the mouse button, 
the circle will be reshaped. Although it takes a bit of getting used to, you will find this 
method quite effective once you’ve mastered it.

Press the Shift key while 
drawing to constrain the 
shape to a perfect circle. 
The same method works 
with the other primitive 
shape tools as well.

Key Command:

This type of editing — 
bending a shape — 
works for objects created 
in either standard-
drawing or object-
drawing mode.

Note:
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	12.	 Use the Selection tool to draw a rectangle marquee that covers the upper-
right side of the object you just reshaped. 

When you release the mouse button, the area you surrounded with the rectangle (called 
a selection marquee) displays a hatch pattern, indicating that the area is now selected.

Because you drew this object in standard mode, you don’t have to “enter into” the object 
to edit the components. 

	13.	 Press the Delete/Backspace key to remove the selected portion of the shape.

The selected area is removed from the Stage. You can select any portion of an object in 
this manner, and then change its stroke and fill values independently of the rest of the 
drawing — or, as is the case here, remove it from the Stage completely.

	14.	 Use the same method to remove the bottom-right side of the shape.

	15.	 Use the Selection tool to refine the shape so the curves fit the sketch.

If you position the Selection tool at the very end of a stroke, you can pull the end of the 
stroke to a new position; the lines connected to the end point will reshape as necessary 
to match the new position of the end point.

	16.	 Save the file and continue to the next exercise.
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Work with the Line Tool

The Line tool draws lines, which are simply strokes with no fills. You can combine 
lines with other shapes to develop custom objects, such as the fin you’re working on 
now. In this exercise, you draw several lines to complete the shape of the side fin.

	 1.	 With rocket_working.fla open, select the Line tool in the Tools panel and 
make sure the object-drawing option is turned off.

You’re adding to the standard-drawing mode object that you created in the previous 
exercise, so you should continue working in standard mode.

	 2.	 Click the upper-right side of the half-oval shape, then drag down and to the 
right before releasing the mouse button.

Since you’re clicking the end of an existing line, Flash assumes you’re continuing the 
same shape and automatically connects the lines with a corner point. The line doesn’t 
have to be a specific length; it should stop somewhere above the center of the empty 
space to the right of the partial oval shape. 

	 3.	 Drag another line from the bottom edge of the half-oval to somewhere 
below the endpoint of the line you drew in Step 2.

At this point, you should have two lines that come off the top and bottom of the curve 
and hang in the middle of the fin shape. 
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	 4.	 Using the Subselection tool, click the end of the top line to select that  
point, and then pull it out until it sits at the rear of the fin.

The Selection tool selects entire paths, but the Subselection tool (the hollow arrow) 
selects individual anchor points. You use the Subselection tool to add or delete anchor 
points, reposition anchor points, or adjust curves using the handles that radiate from 
anchor points. 

	 5.	 Pull the end of the bottom line until it touches the end of the top line.

Now all you have to do is fine-tune the curve of the two lines, and you’ll have a 
completed side fin.

	 6.	 Use the Selection tool to bend the top and bottom lines so that they more 
closely match the curve of the original sketch.

	 7.	 Hide the Rocket Sketch layer.

By hiding the Rocket Sketch layer, you can better see how your side fin shape is coming 
along. With the background hidden, it’s easier to check the lines, curves, and overall 
integrity of the shapes you’re developing.

If Snap To Objects is 
active (View>Snapping> 
Snap To Objects), the 
point you drag will 
“snap” to the other point 
as soon as it gets close. 

Note:

The terms stroke and line 
are used interchangeably 
both by Adobe and in 
this book.

Note:
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	 8.	 Lock the Side Fins layer.

Locking the layer protects the object while you work on other components of the 
drawing. If the layer remains unlocked, you might accidentally delete or otherwise 
modify the shape.

	 9.	 Display the Rocket Sketch layer, save the file, and continue to the next exercise.

Remember: the rocket ship sketch is only meant to serve as the basis for developing the 
actual drawing. It should remain locked.

Draw with the Pen Tool

The Pen tool draws curved lines, also known as Bezier curves. A Bezier curve is a 
curved line defined by specific points called anchor points. These anchor points define 
the direction and shape of the curves that make up a line or shape. In this exercise, you 
use the Pen tool to create the top fin of the rocket ship. 

	 1.	 With rocket_working.fla open, select the Top Fins layer.

	 2.	 Select the Pen tool from the Tools panel and display the Properties Inspector 
(if it’s not already visible).

Make sure the stroke color is set to the same orange you used earlier, the stroke weight 
is set to 0.5 point, and the stroke style is set to Solid. It’s likely that these settings are 
already in place; but if someone used your computer or you changed the settings since 
the previous exercise, you might have to return the settings to the ones you used earlier. 
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	 3.	 Click the Pen tool at the left side of the top fin where it meets the body. 
Without releasing the mouse button, pull up and to the right.

The point you first click becomes an anchor point, which is a point at which the curve 
is attached to the drawing. As you pull, handles appear. Handles control the size and 
shape of the lines that are connected to the point; longer handles make a steeper curve. 

	 4.	 Now click at the upper-right corner of the top fin to place another anchor 
point. Without releasing the mouse button, pull down and to the right to 
create handles for the point, dragging carefully to fit the curve to the sketch.

Clicking the upper-right corner of the fin shape creates a second anchor point, and 
pulling handles out from that anchor point creates the shape of the curve between the 
two points. 

	 5.	 Click the right anchor point with the Pen tool.

There are two kinds of anchor points: curve and corner. In this case, you have to create a 
sharp corner. 

While you’re drawing a shape with the Pen tool, single-clicking the anchor point allows 
you to change direction, leaving a sharp corner instead of a smooth curve. 
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	 6.	 Still using the Pen tool, click at the point where the rear side of the top fin 
touches the ship body. Drag handles for this point until the shape of the 
curve matches the shape of the fin’s back edge.

	 7.	 Click the third point with the Pen tool to convert the point to a corner.

	 8.	 Hover the cursor over the first anchor point you created until you see a small 
hollow-circle icon next to the cursor.

	 9.	 Click to close the shape with a straight line.

The straight line will be covered by the ship body, so it doesn’t need to be adjusted.

	10.	 Deselect everything, then zoom out and hide the Rocket Sketch layer. 

Your fins should be graceful, not choppy. If you aren’t satisfied with the result, delete the 
fin and try again.

	11.	 Display the Rocket Sketch layer again and lock the Top Fins layer.

	12.	 Save the file and continue to the next exercise.
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Pen Tool Basics

Converting curves to corner points.  
If you need to convert a curve to a corner point, 
place the Pen tool over the curve point, press 
the Option/Alt key, and click to change the 
point to a sharp corner. (Alternatively, use the 
Convert Anchor Point tool.)

Deleting anchor points. To delete an anchor 
point, first select the path with the Subselection 
tool. Using the Pen tool, place the cursor near 
an existing corner point until you see a minus 
sign (-) in the tool cursor. (Alternatively, use the 
Delete Anchor Point tool.)

Adding anchor points. To add an anchor 
point, first select the path with the Subselection 
tool. Using the Pen tool, place the cursor near 
the path but not over an existing anchor point 
until you see a plus sign (+) in the tool cursor. 
Click the path to add a new point to the line. 
(Alternatively, use the Add Anchor Point tool.)

Converting corner points to curves. To change a 
corner point into a smooth curve, first select the point you 
want to convert with the Subselection tool. Then press the 
Option/Alt key and drag the point; handles appear, and the 
corner becomes a curve. You can then adjust the shape of 
the curve by adjusting the handles.

Reshaping a curve using its handles.  
To reshape a curve, first select it with the Subselection 
tool, and then drag the related handles. (Handles will 
appear from each smooth anchor point that is connected 
to the curve.)

Moving points. To move an anchor point, select the 
point with the Subselection tool and move it to the 
desired location. You can also nudge (move it a little bit 
at a time) a point by selecting it and then pressing the 
Up/Down and Left/Right Arrow keys on your keyboard.

Selecting entire objects or single points. 
As you move the Subselection tool near a 
stroke, a small, solid black square appears at 
the bottom right of the icon. If you move the 
Subselection tool directly over a single anchor 
point, a hollow square in the icon indicates 
that clicking selects only that point.

Using the Subselection tool. When you click 
a line with the Subselection tool, you can see 
the object’s anchor points. In the image to the 
right, both objects were selected by surrounding 
them with a selection rectangle; you can see all 
the objects’ points and curves.
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Work with Anchor Points and Curves

There will be times when you need to create lines that follow multiple curves. There are 
several different ways to accomplish this task, but all of them require you to manage 
multiple anchor points with curves of varying shapes and angles. To do this, you need 
to know how to add, delete, and modify anchor points and their curves and handles. 

	 1.	 In the open file, select the Tail Fins layer. Use the Line tool in standard-drawing 
mode to draw a triangle that touches all three corners of the top portion of the fin.

When you hover the cursor over the original starting point to close the shape, the cursor 
shows a small, hollow circle in the icon; this indicates that you can close the shape.

	 2.	 Use the Selection tool to pull the three lines into shape.

Reshape the portion of the fin that intersects the body so it extends into the area where 
the body is going to be. When you arrange the layers and put the body layer on top 
of the fins layers, the body will hide that portion of each fin. Make sure no gaps show 
between the fins and the ship itself.

	 3.	 Starting on the top-right corner of the bottom tail fin, use the Pen tool to 
create a curve that curves away and down from the fin shape.

If you look closely, you’ll see that the top portion of the sketched fin curves twice. You 
need to add an anchor point on the curve you just drew, which is actually a two-step 
process: first, you need to select the line, and then you need to add the anchor point.
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	 4.	 With the Pen tool still selected, press the Command/Control key and click 
away from the line to deselect it.

Pressing Command/Control while using the Pen tool temporarily switches to the 
Subselection tool. 

	 5.	 Still holding the Command/Control key, move the cursor near the line you 
just deselected. When you see a black square in the cursor icon, click the 
line to re-select it. 

This is a quirk of the software. For the following steps to work properly, you have to first 
deselect and then reselect the line.

	 6.	 Release the Command/Control key to return to the Pen tool. 

	 7.	 Move the Pen tool toward the line until a plus sign (+) appears in the tool’s 
icon. Click the line to add an anchor point at that location.

	 8.	 Choose the Subselection tool in the Tools panel and click the new anchor point. 

	 9.	 Drag the anchor point to be on top of the sketched line.

As you move the anchor point away from its current position, the handles that control 
the curve become apparent. In the next step, you use these handles to change the shape 
and direction of the curve at the point of the new anchor point.

The Subselection tool 
selects individual anchor 
points and line segments. 
Use this tool when you 
want to add or delete an 
anchor point, reposition 
an anchor point, or 
adjust a curve using the 
handles that radiate from 
an anchor point. 

Note:
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	10.	 Using the Subselection tool, pull down the handle of the first anchor point 
(on the left end of the line). 

The curve begins to change shape and more closely match the sketch.

	11.	 Using the Subselection tool, edit the handle of the third anchor point to 
move the lower half of the curve into place.

	12.	 Deselect everything, then hide the Rocket Sketch layer and review your curve.

Remember, curves should be smooth, with no apparent flat spots or unnatural bumps or 
ridges (unless, of course, the artwork calls for a bump or ridge; this piece does not).

	13.	 Make the Rocket Sketch layer visible again, then complete the rest of the 
tail fin using the methods you just learned. When you’re satisfied with the 
results, lock the Tail Fins layer.

	14.	 Select the Bottom Fins layer to make it active, and then use any techniques 
you’ve learned so far to complete the two bottom fins. 

	15.	 Using the Selection tool, bend the inner edges of each fin (where the fins 
meet the body) into the body area so that the body area will overlap the fins 
and prevent any gaps.

	16.	 Save the file and continue to the next exercise.
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Use Groups to Control the Interaction Between Flash Objects

You should now have all the fins completed and neatly organized inside their layer 
folder. In this exercise, you collapse the Fins folder, hide it, and then start working 
on the body of the ship. In doing so, you work with groups. A group is a collection 
of shapes combined into a single object. You can later ungroup a grouped object, 
returning it to the original collection of discrete components. You also learn how 
Flash objects residing on a single layer interact with each other, and how grouping and 
ungrouping objects offers control over that interaction.

	 1.	 With rocket_working.fla open, collapse the Fins layer folder by clicking the 
Collapse/Expand arrow to the left of the Folder icon. 

	 2.	 Hide all the fins by clicking the Visibility column of the Fins layer folder.

	 3.	 Lock all the fins by clicking the Lock column of the Fins layers folder.

	 4.	 Expand the view of the Body Parts layer folder.

	 5.	 Make sure the Rocket Sketch layer is visible, and then click the Exhaust Vent 
layer to make it active.

	 6.	 Use the Rectangle tool in object-drawing mode to draw a shape that will 
make up the four sides of the vent.

	 7.	 Deselect everything, then use the Selection tool to move the corners and 
bend the sides of the rectangle until they fit the sketch.

When you use layer 
folders, you can lock and 
hide all the contents in 
the folder by locking 
and hiding the entire 
folder. As we mentioned 
earlier, many of your 
projects will be quite 
complex, requiring 
dozens of layers. Without 
layer folders, it would 
become very difficult to 
structure and manage 
your drawings and 
animations. 	

Note:
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	 8.	 Using the Line tool in object-drawing mode, draw two lines that extend from the 
left edge of the exhaust vent to the point at the end of the spear shape.

	 9.	 Using the Selection tool, bend the two horizontal lines into shape to match 
the spear-shaped part of the exhaust vent.

	10.	 Select all three shapes on the stage.

Because you created these objects in object-drawing mode, you can see a bounding box 
surrounding each shape. To prevent moving one of these components independently, 
you can group them into a single unit.

	11.	 Choose Modify>Group.

When you group objects, the bounding box displays around the group. Using the bounding 
box, you can resize, move, and otherwise modify a group as you would a single object. 
Grouped objects are isolated from other elements on the same layer, so you can place 
grouped objects on top of one another with no worries of damaging the underlying objects. 

You can also group 
objects by pressing 
Command/Control-G.

Ungroup objects 
by selecting the 
group and choosing 
Modify>Ungroup or 
pressing Command/
Control-Shift-G.

Key Command:
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	12.	 Double-click the group to enter into it (view it in Edit mode).

Even though the objects are grouped on the main Stage, you can access the individual 
pieces in Edit mode.

Because you drew these shapes in object-drawing mode, you can’t access the pixels of 
the lines. You can’t select and delete parts of the lines with the Selection tool, which you 
need to do.

	13.	 With all three objects in the group selected, choose Modify>Break Apart.

This command converts objects in object-drawing mode to standard mode so you can 
use the destructive editing capabilities of the Selection tool.

	14.	 Deselect all objects, then use the Selection tool to click the line in the 
middle of the spear shape to select it, and then press Delete/Backspace.

Remember from the earlier discussion on destructive editing: When you’re editing a 
drawing object, Flash recognizes and separates overlapping elements. (If you selected the 
shape with the Subselection tool, you would see that Flash added anchor points where 
the lines meet.)
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	15.	 Click Scene 1 in the Edit bar to return to the main stage.

Because these objects started as a group, and you made all of the edits inside the group, 
the selection on the main Stage is still treated a single unit; the bounding box surrounds 
the outer edge of all the objects in the group.

	16.	 Use the Oval tool in object-drawing mode to draw the circle at the top of 
the vent.

	17.	 With the Selection tool active, press the Option/Alt key and drag the shape 
to the second circle on the sketch.

Pressing Option/Alt while dragging clones (makes a copy of ) the object you drag.

	18.	 Using the same cloning method, make additional copies for the other round 
objects on the lower half of the vent.

	19.	 Lock the Exhaust Vent layer, save the file, and continue to the next exercise.

Use the Pencil Tool

The Pencil tool provides another way to develop curved artwork. Drawing with the 
Pencil tool is easy; simply drag a line or shape, and the stroke — in whatever color is 
currently set in the Tools panel — follows the cursor.  

With the proper equipment — most notably a pressure-sensitive drawing tablet — 
the Pencil tool might very well be the most important tool Flash offers. This notion is 
particularly true for artists skilled at sketching or drawing with natural media, such as 
pen and ink, pencils, and pastel chalks. Other people find the Pencil tool difficult to 
use, preferring the Pen tool, Bezier curves, primitives, freeform shapes, and 
combinations thereof. Some artists enjoy using both.

	 1.	 With rocket_working.fla open, select the Nose Cone layer to make it active. 

	 2.	 Position the sketch so the nose cone area is prominent on the stage.

Be careful while making 
copies of any object. Do 
not release the Option/
Alt keys before releasing 
the mouse. Doing so will 
move the original object 
instead of making a copy.

Note:



36 Project 1: Rocket Ship Artwork

	 3.	 Select the Pencil tool in the Tools panel and display the Properties Inspector 
(if it’s not already visible).

The Properties Inspector settings for the Pencil tool are very similar to those you used 
with the Pen tool.

	 4.	 In the lower portion of the Tools panel, click the Options button and choose 
Ink from the pop-up menu. 

These three options affect the behavior of the Pencil tool. Specifically, the options 
determine whether the lines you create with the tool are automatically smoothed, 
automatically straightened, or left alone (the Ink option).

	 5.	 Make sure the object-drawing option is turned off, and then try drawing the 
tip of the nose cone. Hide the Rocket Sketch layer and inspect the results. 

Hiding the Rocket Sketch layer in between processes can dramatically improve the 
quality of your finished drawings. You should develop the habit of hiding and displaying 
sketched templates often, which will ensure that your drawings look good without the 
template showing.

	 6.	 Press Command/Control-Z to undo your drawing.

If you drew the shape in more than one pass, you might have to apply the Undo 
command (Command/Control-Z) more than once.

	 7.	 Re-display the Rocket Sketch layer, select the Smooth option for the Pencil 
tool, and try drawing the tip of the nose cone section again. 

	 8.	 Use the Undo command to remove the object.
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	 9.	 Finally, try the Straighten option and draw the tip of the cone. Inspect the results.

	10.	 Use whichever drawing method you prefer to create a final version. 

We found the Smooth option worked best, but you might prefer one of the other options. 

	11.	 Choose the Smooth option, and then try drawing the top and bottom lines 
that make up the cone.

You’ll find that working at close range to your artwork is almost always the most 
effective method. There will be times, however — especially when you use the Pencil 
tool — that being a bit farther away from the artwork yields better results. When you’re 
zoomed out, the lines you draw are shorter and require less mouse (or tablet stylus) 
movement, resulting in less jigs and jags.

	12.	 Use the Subselection tool to adjust the lines until you’re satisfied.

Remember, lines behave one way when you use the Selection tool to edit them and a 
completely different way when you use the Subselection tool (which you use to fine-tune 
the anchor points that make up each stroke). 

You can control a number of drawing options using the Drawing 
pane of the Preferences dialog box. (On Macintosh, Preferences are 
accessed in the Flash menu; on Windows, Preferences are accessed  
in the Edit menu.)

Each time you click with the Pen tool, you add an anchor point; 
successive anchor points are connected by lines. If the Show Pen 
Preview option is checked, a preview line follows the cursor to show 
the line that will be created when you add a new anchor point.

When the Show Solid Points check box is active, selecting an anchor point with the Subselection tool shows the selected 
point as solid instead of hollow.

You can change the Pen tool ( ) to a precise crosshair cursor ( ) by activating the Show Precise Cursors check box.

The Connect Lines options (Must Be Close, Normal, and Can Be Distant) determine how close lines or points must be 
before Flash automatically connects them. 

The Smooth Curves options (Off, Rough, Normal, and Smooth) determine how many points will be used to create a line 
when you’re drawing with the Pencil tool with the Smooth or Straighten options turned on. The Rough option results in more 
points and a jagged line; the Smooth option results in fewer points and a smoother line.

The Recognize Lines options (Off, Strict, Normal, and Tolerant) determine how close to straight a line drawn with the 
Pencil tool must be before Flash recognizes it as straight.

The Recognize Shapes options (Off, Strict, Normal, and Tolerant) determine how close to the shape an oval or square 
drawn with the Pencil tool must be before Flash recognizes it as the actual shape and makes the necessary adjustment.

The Click Accuracy options (Strict, Normal, and Tolerant) determine how close to an object you must place the cursor to 
select the object.
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Drawing Preferences

Interestingly, more 
often than not, using 
the Straighten option 
works best for drawing 
circles with the Pencil 
tool. Using the Smooth 
option results in bumpy, 
less-than-perfect circles 
because this option is 
more sensitive to slight 
mouse movements 
(although not nearly 
as sensitive as the Ink 
option). 

Note:
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	13.	 Using any combinations of tools, complete the nose cone section. 

Pay particular attention to the integrity and shape of the back section of the nose cone. 
You will use this line in the next exercise when you draw the body section. The two 
sections will share a common curve: the rear side of the nose cone will be copied and 
pasted for use as the front end of the body component.

	14.	 Save the file and keep it open for the next exercise.

Cut, Copy, Paste, and Paste in Place

Four important techniques that you might have used before are cutting, copying, 
pasting, and pasting in place. Cutting, as you probably know, is the act of removing 
a selected item from the Stage and placing it onto the Clipboard. The Clipboard is a 
reserved area of memory that allows you to temporarily hold objects — text, images, 
artwork, or a Flash object — until you need to use them again somewhere else. For 
example, you might cut an object from one layer and hold it on the Clipboard until 
you need it again later. Copying is similar to cutting, except when you copy an object, 
the original selected item remains on the Stage.

Pasting takes the content on the Clipboard and drops it on the Stage, normally in 
the middle of the visible area. Pasting in place is virtually the same as pasting, except 
that the object you paste is positioned exactly on top of the original, regardless of 
whether you cut the object or copied it.

	 1.	 In the open rocket_working.fla file, use the Selection tool to select the 
stroke on the right side of the cone shape. 

To copy an object, select 
the object and press 
Command/Control-C. 

To cut an object, select 
the object and press 
Command/Control-X. 

To paste an object, select 
the object and press 
Command/Control-V. 

To paste an object in 
place, select the object 
and press Command/
Control-Shift-V.

Key Command:
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	 2.	 Choose Edit>Copy to copy the stroke to the Clipboard.

	 3.	 Lock and hide the Nose Cone layer, and then select the Body layer. 

	 4.	 Choose Edit>Paste in Place to paste the copied object in place on the Body layer.

The copied stroke appears in the exact location as the original, but on the Body layer. 
After you’ve completed the body section, these two strokes will occupy the same location 
on the Stage, which ensures that the intersection of the two objects is absolutely perfect.

	 5.	 Unlock the Exhaust Vent layer.

	 6.	 Double-click one of the edge lines to enter into the group on the Exhaust 
Vent layer.

For the same reasons we outlined in Step 4, you are going to use the front of the exhaust 
structure as the back of the body shape. To access those lines, however, you have to first 
enter into the group.

	 7.	 Using the Selection tool, Shift-click all three pieces of the left edge.

Remember, Flash adds anchor points where lines intersect, so you have to manually 
select all three pieces of the left edge.

	 8.	 Press Command/Control-C to copy the strokes to the Clipboard.

	 9.	 Click Scene 1 to return to the main Stage, then hide the Rocket Sketch layer.
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	10.	 Hide and lock the Exhaust Vent layer, and then select the Body layer.

	11.	 Press Command/Control-Shift-V to paste the rear stroke for the body in place.

	12.	 Use the Line tool with the object-drawing toggle turned off to connect the 
top and bottom points of the curves.

	13.	 Display the Rocket Sketch layer, and then use the Selection tool to bend the 
top and bottom lines into shape.

	14.	 Show all layers, save the file, and continue to the next exercise.
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Use Strokes to Create Complete Objects

In this exercise, you work with lines — specifically, you experiment with ways to 
incorporate stroke width (also called stroke weight) into your objects.

	 1.	 In the open file, hide all but the Windows and Rocket Sketch layers, then 
lock the Rocket Sketch layer.

	 2.	 Select the Windows layer.

	 3.	 Use the Line tool in object-drawing mode to draw a straight line between 
the left and right sides of the long, rounded window at the top of the ship.

Don’t extend the line all the way to the edges of the shape; keep the ends of the lines 
within the rounded sections, as shown in the following image.

	 4.	 Use the Selection tool to bend the line into shape to fit the curve of the  
long window.

	 5.	 With the stroke selected, use the Properties Inspector to change the stroke 
weight to 10 pt.

Remember, before you 
can “bend” the line, you 
must first deselect it and 
then reselect it with the 
Selection tool.

Note:
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	 6.	 With the line still selected, click the Cap menu in the Properties Inspector 
and make sure the Round option is selected.

This menu defines the end treatment of the line. None means nothing special will 
happen at the ends of the line. Round means rounded ends will extend beyond 
the endpoints of the actual line. Square means square ends will extend beyond the 
endpoints of the actual line.

The stroke almost perfectly matches the sketched shape — and you accomplished the 
task with a single process. There was no need to draw a circle or use the Pen tool to 
carefully position anchor points. 

	 7.	 Use the Properties Inspector to change the stroke weight to 12 points. 

	 8.	 Use the Line tool to draw the remaining three top windows. Use the 
Selection or Subselection tool to adjust and position the lines as necessary.

	 9.	 Move to the three round portholes at the lower part of the ship, and then draw a 
line from the middle of the left circle to the middle of the right circle.

Don’t worry that the line covers all three windows; you’ll fix that in the next step.

Select a line with the 
Subselection tool to see 
the actual line instead of 
the bounding box.

Note:
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As you can see in the Properties Inspector, you have a 
number of options for editing lines in a Flash file.

The W, H, X, and Y fields control the dimensions and position 
of the line’s bounding box.

You can use the stroke swatch to change the stroke color of a 
line. (A line technically has no fill, so the fill color swatch has 
no effect on a selected line.)

You can type a specific stroke weight in the Stroke Weight 
field, or drag the associated slider for a live preview of the 
size you drag to (between 0.25 and 200 points).

The Stroke Hinting check box allows you to draw smooth and sharp lines. This feature is most helpful when you draw a 
rectangle with curves. When you draw a curved rectangle or square, the lines and the curves can be very blurred. Curves 
might actually seem to be different entities that are not 
joined with the connecting line. After you select the Stroke 
Hinting option, you will see that the lines are smooth and 
the blur effect is invisible.

You can apply a predefined style from the Stroke Style 
menu or create your own style by clicking the Custom button.

The three options in the End Cap Style menu (None, Round, and Square) define the appearance of a stroke beyond the 
endpoint of the line.

The three options in the Join Style menu (Miter, Round, and Bevel) define the appearance of corners where two lines meet. 

When Miter is selected, you can define a miter limit in the Miter field. A miter limit controls when the corner switches 
from a pointed joint to a beveled joint, as a factor of the stroke weight. If you define a miter limit of 2 for a 2-point line, the 
corner will be beveled if the pointed corner would extend beyond 4 points (2 1 2).

The Scale menu defines how strokes are affected by scaling a symbol in which the line exists (this option only affects strokes 
on graphics that are part of a symbol). Normal scales strokes proportionally. Horizontal means that a stroke will be scaled 
based only on the horizontal scale of the symbol. Vertical means the stroke will be scaled based only on the vertical scale of 
the symbol. None means the stroke will not be scaled.
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	10.	 With the line selected, choose the dotted line style (fourth from the top) in 
the Stroke Style menu of the Properties Inspector.

	11.	 Use the Properties Inspector to change the stroke weight to 16 points, and 
then deselect the stroke.

Depending on where you started and ended your line, you will probably have four or 
five dots instead of three. Don’t worry; you’ll fix that in the next exercise.

	12.	 Save the file and continue to the next exercise.

Press Command/
Control-A to select all  
of the objects on the 
current layer.

Key Command:

Flash provides three important visual features that can dramatically improve accuracy and reduce development time.  
All three — rulers, guides, and grids — can be found under the View menu.

Rulers (View>Rulers) are vertical and horizontal measurement 
tools located along the left and top side of the Stage. You can 
drag a guide from either of these two rulers to assist in visual 
alignment. Rulers normally measure in pixels, but you can use 
the General Preferences dialog box to change this setting to 
any measurement system you prefer.

You can choose View>Guides>Edit Guides to modify guide 
lines. The Show Guides option reflects the current visibility  
of guides on the Stage; you can use this option to toggle 
guides on or off. Snap To Guides causes guidelines to act  
like magnets when objects are dragged near a guide. Lock 
Guides prevents existing guides from being moved.

The grid (View>Grid>Show Grid) is a pattern of horizontal 
and vertical lines that also aid in the development/alignment 
process. You can edit the current grid and modify how 
the grid interacts with objects on the Stage by choosing 
View>Grid>Edit Grid. Like the Snap To Guides feature, you can 
make gridlines “magnetic” using the Snap To Grid feature. 
When turned on, this feature causes objects close to a gridline 
to snap into place, avoiding minor placement errors during the 
drawing process.
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Using Rulers, Guides, and Grids
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Convert Strokes to Fills

What if you decide to change one of these windows so it contains a different fill and 
displays a stroke as well? You would have to change the stroke to a fill, which would 
essentially change the stroke-only object to a regular filled object. The resultant shape 
would be the same as if you had used the Pen tool and anchor points to construct all 
the windows.

	 1.	 In the open rocket_working.fla file, make sure all but the Windows layer  
is locked.

	 2.	 Choose the Selection tool, and then choose Edit>Select All.

The Edit>Select All command selects all the strokes on the Windows layer. (Remember, 
all but the Windows and Rocket Sketch layers are hidden and locked, and the Rocket 
Sketch layer is locked.)

	 3.	 Choose Modify>Shape>Convert Lines to Fills.

All the lines are converted into regular fills, but they do not yet have defined stroke 
attributes. You will change the strok for these shapes in a later exercise.

	 4.	 If you have more than three circles in the bottom row of windows, deselect 
everything, and then select the bottom row of windows with the Selection 
tool. Choose Modify>Ungroup, deselect all of the circles, select and delete 
the extras (more than three), and then drag the remaining three circles into 
the appropriate positions based on the sketch.

	 5.	 Save the file and continue to the next stage of the project.
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Stage 4	 Painting and Coloring
You now have the necessary parts to build a fairly respectable rocket ship. All your ship needs is a good 
paint job and plenty of open space. In this section, you color the individual components and launch 
the craft into space. You also add the shadowed areas that you can see in the original sketch.

There is a wide variety of methods that you can use to paint the ship. The Paint Bucket tool fills 
shapes with a specified color. The Ink Bottle tool changes the color of any existing stroke, and adds 
a stroke to a fill that doesn’t have one (such as the windows you created and converted to fills in the 
previous exercise).

Fill Artwork with the Paint Bucket Tool

Sometimes, the best way to color an object is to simply tip a can of paint into the 
shape and let it fill up with color — which is exactly what you do with the Paint 
Bucket tool in this set of exercises.

	 1.	 With rocket_working.fla open, hide and lock the Fins layer folder and the Rocket 
Sketch layer. Show and unlock all layers in the Body Parts layer folder, and then 
hide the Windows layer.

	 2.	 Choose the Paint Bucket tool from the Tools panel.

	 3.	 Set the stroke color to None and set the fill color to a light gray (#999999).

Remember, you can change the stroke and fill colors by clicking the buttons in the Tools 
panel and choosing the color you want from the pop-up Color Swatch panel.

	 4.	 With the Paint Bucket tool selected, click inside the nose cone.

As soon as you click, the nose cone fills with the gray fill color.

	 5.	 Click the Paint Bucket cursor inside the body to fill it with the same gray color.

	 6.	 Show the Windows layer.

Because the Windows layer is below the Body layer — and thus, below the now-filled 
body shape — you can’t see the windows.
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	 7.	 In the layers section of the Timeline, drag the Windows layer above the 
Body layer.

	 8.	 Double-click the exhaust vent with the Selection tool to enter into the group. 

	 9. 	Fill the three shapes with the same gray you used on the rest of the ship’s body.

	10.	 Click Scene 1 to return to the main stage.

	11.	 Change the fill color to white and fill the four circles on the vent with white.

	12.	  Save the file and continue to the next exercise.

Change Stroke Colors with the Ink Bottle Tool

Most, but not all, of the objects you’ve drawn so far should display a 0.5-point colored 
stroke. In this exercise, you use the Ink Bottle tool to add strokes to the windows 
(which currently have strokes of None) and change the colors of other strokes as well. 

	 1.	 With rocket_working.fla open, make sure the Fins layer folder and the 
Rocket Sketch layers are hidden and locked, and all layers in the Body Parts 
layer folder are visible and unlocked.

	 2.	 Select the exhaust vent shape with the Selection tool and choose 
Modify>Ungroup.

By ungrouping these shapes, you no longer have to enter into the group to edit the fills 
and strokes.

	 3.	 Make sure nothing is selected in the file. 
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	 4.	 Select the Ink Bottle tool in the Tools panel. In the Properties Inspector, 
pick a dark blue color as the stroke color. Change the stroke weight to 0.5 
and the style to Solid.

Once you select the Ink Bottle tool, you can use the Properties Inspector to pre-
determine the weight, color, stroke style, and other features before you use the tool. The 
current settings in the Properties Inspector will be applied to any shape you click with 
the Ink Bottle tool. These settings will remain in effect for the Ink Bottle tool until you 
change them.

	 5.	 Click the Ink Bottle tool cursor in the nose cone, the body, the three shapes 
of the exhaust vent, and the four circles on the exhaust vent. 

The strokes instantly change to the new color; it doesn’t matter if you select the layer or 
not. Since the objects are on unlocked layers, the Ink Bottle tool “knows” which object 
it’s touching.

	 6.	 Add strokes to the top windows by clicking them with the Ink Bottle tool.

Remember that these shapes started as thick strokes with no fills applied. When you 
converted them to shapes, you set the stage for adding strokes to these shapes.

	 7.	 Make sure nothing is selected, then use the Properties Inspector to change 
the stroke style to vertical dashed lines (the last style in the list).

Combining styles, colors, and shapes, as well as using strokes in combination with the 
Convert Line to Fill command, can not only save you a great deal of time, but it can also 
result in some very interesting artwork.
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	 8.	 Change the strokes of the bottom windows by clicking them with the Ink 
Bottle tool. 

	 9.	 Save the file and continue to the next exercise.

Use the Eyedropper Tool

The Eyedropper tool is used to “pick up” colors from one object so you can apply the 
colors to other objects in a drawing. In this exercise, you use the Eyedropper tool to 
automatically change the stroke color for all the fins at the same time, and then to fill 
the individual fins with the same color you applied to the ship.

	 1.	 With rocket_working.fla open, make sure the Body Parts layer folder is 
above the Fins layer folder in the stacking order.

If the Body Parts layer folder is currently under the Fins layer folder, drag the Body Parts 
folder above the Fins folder in the layers area of the Timeline.

	 2.	 Hide the Body Parts layer folder and the Rocket Sketch layer, then display 
and unlock all the fins layers.

	 3.	 Select the Ink Bottle tool and use the Properties Inspector to change the line 
style to a solid blue line with a weight of 0.5.

	 4.	 Using the Ink Bottle tool, apply the solid blue stroke to all of the fins.

To change the strokes, you have to click the lines that make up the fin shapes. (The fins 
have no fill, so you have to click the actual lines that you want to change.) 
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	 5.	 Show the Body Parts layer folder. 

	 6.	 Click the nose cone with the Eyedropper tool.

The Eyedropper tool copies fill and stroke attributes from one object so you can 
immediately apply them to another object. 

When you click a stroke with the Eyedropper tool, the cursor automatically changes to 
the Ink Bottle tool. When you click a filled area, the tool automatically changes to the 
Paint Bucket tool with the Lock Fill modifier turned on. You can then click another 
object to apply the copied attributes.

	 7.	 One at a time, click the Paint Bucket cursor on each of the fin shapes.

To fill the fins, you have to click the lines that make up the fin shapes. (The fins currently 
have no fill, so you have to click the outside edge of the shape that you want to fill.) 

	 8.	 Hide the Body Parts layer folder, and click the Side Fin outline to fill the 
shape with the same gray color.

The Lock Fill option 
controls the appearance of 
gradient and bitmap fills. 
If this modifier is active, 
the gradient or bitmap 
will fill the entire stage; 
objects filled with the 
gradient or bitmap show 
the underlying area of 
that gradient or bitmap.

Note:
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	 9.	 Re-show the Body Parts layer folder. 

When the Body Parts layer folder is visible, it hides the side fin (which is in the Fins 
layer folder, lower in the stacking order).

	10.	 Drag the Side Fins layer into the Body Parts layer folder, above both the 
Body and the Nose Cone layers. 

The Side Fins layer is now part of the Body Parts layer folder, and appears in the proper 
position — as long as it remains above the Body layer within the Body Parts layer folder.

	11.	 Show all layers and review your work. If the fins leave gaps near the body 
edges, use the Selection tool to fix those areas.

	12.	 Save the file and continue to the next exercise.
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Use the Brush Tool 
The Brush tool acts exactly as you might expect: it simulates a paint brush, and you 
use it to color objects, draw shapes, and add color to existing objects. You can exert 
considerable control over how the Brush tool behaves: You can use it to paint inside 
a specific object, paint behind an object, paint outside an object, or — as it normally 
behaves — paint directly over an existing object. 

	 1.	 With rocket_working.fla open, lock all layers except the Side Fins layer.

	 2.	 Display all but the Side Fins and Rocket Sketch layers in Outline mode. 

You need to see the sketch as you develop the shadows, but keeping the Rocket Sketch 
layer locked ensures that you don’t accidentally move the sketch. Since the sketch is a 
bitmap image, selecting Outline view for the layer makes the sketch disappear.

Outline mode is one of the choices available in the layers area of the Timeline. As is the case with the Visibility and Lock 
icons, you can turn on Outline mode for a single layer or for a layer folder (which affects all layers in the folder). 
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	 3.	 Select the Side Fins layer, and then click the Selection tool anywhere on the 
Stage to deselect the objects on the layer.

	 4.	 Select the Brush tool in the Tools panel and set its fill to light gray 
(#CCCCCC).

	 5.	 Using the Options pop-up menu at the bottom of the Tools panel, choose 
Paint Behind as the Brush tool’s option.

	 6.	 Paint the shadow that appears on the sketch.

While you’re painting the shadow, it appears to be on top of (and obscuring) the fin 
shape; but when you release the mouse button, the shadow assumes its proper place 
behind the fin shape.

	 7.	 Unlock the Bottom Fins layer and view it normally (turn off Outline mode). 

	 8.	 Using the Selection tool, click the bottom-front fin’s fill to select it.

	 9.	 Choose the Brush tool in the Tools panel and switch to the Paint Selection mode.
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	10.	 Paint a shadow on the bottom front fin, using the following image as a guide.

	11.	 Using the same method, paint the shadow on the bottom-rear fin.

Remember, you have to select the fin’s fill before you can successfully use the Paint 
Selection option.

When you’re using the Brush tool, four options are available in the bottom of the Tools panel.

The Lock Fill option applies when you paint with a gradient, allowing you to lock the gradient 
fill to the Stage instead of the object. If you turn on this option, the first spot you paint will be 
considered the starting point of the gradient (whether linear or radial). Any additional areas 
you paint with the same gradient will be considered extensions of the gradient. 

The Brush tool has five different modes. 

•	 Paint Normal is exactly that: it paints directly on top of anything already  
on the Stage. 

•	 Using the Paint Fills mode, you paint over the background and any  
object fills, but leave object strokes unaffected. 

•	 Paint Behind allows you to paint only the background; any area with a  
fill is unaffected by the brush stroke. 

•	 Paint Selection applies your brush strokes only to currently selected fill areas. 

•	 Paint Inside applies the brush stroke within the boundaries of the fill where you first click. 

You can also change the brush shape and brush size using the bottom two menus.
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	12.	 Repeat the process to add a shadow to the bottom tail fin on the Tail Fins layer.

You have to show the layer in regular mode (not Outline mode) and select the fin’s fill 
for this procedure to work. Use the Undo command (Command/Control-Z) to step 
backward if you need to repeat the previous few steps.

	13.	 When you’re done, show all the layers in regular mode and review the result.

	14.	 Save the file and continue to the next exercise.

Add Backgrounds 
You have two choices when it comes to using backgrounds on your projects. The first 
choice is to simply change the color of the Stage. Since all layers reside on the Stage, 
the background color appears behind all objects you create. The second option is to 
use a digital image, similar to the sketch you used in this project. 

	 1.	 With rocket_working.fla open, hide the Rocket Sketch layer.

Since you’ve already drawn all the components of the rocket ship, you don’t really need 
the sketch anymore. 

	 2.	 Choose Modify>Document. In the Document Properties dialog box, click the 
Background Color button and change the Stage color from white to a dark blue.

Artwork that contains 
only solid fills is referred 
to as flat art. In the 
final section of this 
project, you learn how 
to make objects appear 
much more interesting 
by applying gradients, 
which are smooth 
transitions between two 
or more colors.

Note:
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	 3.	 Click OK to close the Document Properties dialog box. 

	 4.	 Show and unlock the Rocket Sketch layer, rename it “Deep Space”, and then 
use the Selection tool to delete the sketch.

	 5.	 With the Deep Space layer selected, choose File>Import>Import to Stage, and 
then double-click the deep_space.jpg image in the RF_Flash>Rocket folder.

	 6.	 Using the Align panel, align the placed bitmap to the horizontal and vertical 
centers of the stage.

	 7.	 Save the file.

	 8.	 Choose File>Save As. Save another version of the same file as  
“rocket_flat.fla” in the WIP>Rocket folder, and then close the file. 

Shadows and fills often work better when they’re soft. In many cases, you might want to use a built-in feature that 
automatically softens the edges of a fill. You can soften any selected fill by choosing Modify>Shape>Soften Fill Edges. 

For example: The two checkmark shapes in the following images started out as 12-point strokes, and were then converted to 
fills. Once converted, the checkmark on the right was selected with the Selection tool.

The Soften Fill Edges command provides a dialog box 
where you can determine whether the shape should 
soften inward (called the Inset), which keeps the 
soft edge within the current boundaries of the fill, or 
outward (Expand), which makes the fill larger by the 
pixel value you enter into the Distance field. 

The Number of Steps field determines how 
smooth the blend appears. If you look 
closely, you’ll see that the softening effect is 
accomplished by gradually changing the pixel 
density from the color of the original object 
to white (or the current color of the Stage).
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Stage 5	 Using Gradients
The drawing you created so far is an example of flat art. In many cases, however, you 
need far more latitude when coloring and — most importantly — shading objects. 
Most shading is accomplished using blends of two or more colors, usually referred to 
as gradients or blends. 

Blends add depth (sometimes called dimensionality) to otherwise flat artwork. 
Blends come in several different types. The two most common types of gradient are 
linear blends and radial blends. 

Apply a Standard Gradient to Selected Objects

Flash includes several gradients (both linear and radial) in the Swatches panel. You can 
apply those gradients to an object by choosing them in the Fill Color Swatches panel 
when an object is selected.

You can also apply a gradient fill by selecting the Paint Bucket tool in the Tools panel, 
choosing a gradient swatch as the fill color, and then clicking the objects that you 
want to fill with the gradient. Finally, you can select an object on the Stage and choose 
Linear or Radial from the Type menu of the Color panel; the object will be filled with 
a gradient of the last-used colors.

You can’t choose a 
gradient swatch when 
changing the overall 
background color of a 
movie; only solid colors 
are available. 

Note:

The terms “gradient” 
and “blend” are used 
interchangeably. Flash 
documentation uses both 
gradient and blend; both 
terms mean a smooth 
transition from one color 
to another.

Note:
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	 1.	 Open rocket_working.fla from the WIP>Rocket folder.

Make sure you open the correct file; you don’t want to modify the flat-art version that 
you saved in the previous exercise.

	 2.	 Unlock all the layers except the Deep Space layer.

	 3.	 Select the Tail Fins layer.

	 4.	 Select the Paint Bucket tool from the Tools panel. Click the Fill button and 
then choose the black-to-white linear gradient swatch in the pop-up Color 
Swatches panel.

When you select a layer (as you did in Step 3), the objects on that layer are automatically 
selected — which means that when you choose a new fill color, the selected objects 
automatically reflect the color change.

	 5.	 Repeat the process with the bottom fins: select the Bottom Fins layer, and 
then select the black-to-white swatch in the Fill Color Swatch panel. 

	 6.	 Use the same method to apply gradients to the top fin, nose cone, and body 
of the ship.

Leave the side fin alone for now. You will use a different kind of gradient to add 
dimensionality to that shape.

	 7.	 Save the file and continue to the next exercise.
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Change the Direction of a Gradient

In your drawing, all the shapes containing gradients follow the same flow of colors: 
from light (white) to dark (black). However, real shadows follow real light sources. This 
fact requires you to exercise some degree of control over the direction of the gradients 
in your drawings. 

You can accomplish this task using the Gradient Transform tool. When you select 
the tool and click a gradient, a bounding box appears. You can use the handles on the 
bounding box to enlarge, reduce, rotate, or otherwise transform a Flash object. 

You can edit the colors in a gradient using the gradient ramp in the Color panel (Window>Color). This allows you to create 
custom gradients that blend across multiple colors (up to 15) at different locations along the ramp.

When you use the Paint Bucket tool to apply a gradient, the bottom of the Tools panel offers an option to lock the fill to 
the Stage. When this option is toggled on, the gradient will be applied relative to the overall stage; when you fill individual 
objects with the Lock Fill modifier, those objects show the associated portion of the underlying gradient. 
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	 1.	 With rocket_working.fla open, select the Gradient Transform tool from the 
Tools panel (nested under the Free Transform tool).

	 2.	 Hide the Deep Space layer.

	 3.	 Click the top rear fin with the Gradient Transform tool to show the gradient 
handles.

	 4.	 Click the gradient rotation handle and drag left until the white part of the 
gradient roughly aligns to the point where the fin meets the body.

The Gradient Transform tool (nested under the Free Transform tool) lets you adjust the size, direction, and center point of a 
gradient fill. When you click an object filled with a gradient, a special bounding box shows the gradient-editing handles.
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	 5.	 Use the round icon to rotate the gradient so its brightest spot is near the 
junction of the front of the fin and the body.

	 6.	 Click the gradient center point and drag left until the center point appears 
just left of the body edge.

	 7.	 Click the gradient size handle and drag left to make the gradient narrower, 
so that most of the top rear fin is black.

	 8.	 Using the same techniques, transform the gradients that fill the other 
components of the ship. Try to create the effect of a consistent light source.

When you get to the main body, rotate the gradient so the black part is on 
the left, meeting the black portion of the gradient that fills the nose cone.

	 9.	 Save the file and continue to the next exercise.

You can use the rotation 
handle to reverse a 
gradient. Simply drag all 
the way around (180°) 
until the gradient colors 
are reversed.

Note:
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Use Radial and Custom Gradients

So far you’ve used linear gradients that move from one end of a shape to the other, 
changing color along the way. You can also use radial gradients, which start in the 
center of a shape and radiate outward toward the edges. Radial gradients are very well 
suited for making round objects appear three dimensional. Fortunately, you have 
several perfect candidates in your drawing for radial gradients: the round portholes at 
the lower rear of the ship. 

	 1.	 With rocket_working.fla open, select the bottom windows of the rocket ship 
using the Selection tool.

	 2.	 Select the Paint Bucket tool and display the Color panel (Window>Color).

	 3.	 In the Color panel, choose Radial from the Type menu.

A number of choices are available in the Type menu: None, which represents no fill; 
Solid (or flat) colors; Linear; Radial; and Bitmap, which affects imported bitmap images, 
allowing you to adjust color tones.

Since the three windows are already selected, they automatically reflect the new radial-
gradient fill.

	 4.	 Select the top windows and change the Type to Linear. 

Because the windows are already selected, they are automatically filled with the black-
to-white linear gradient. (Black-to-white is the last gradient setting you used, so it is 
maintained in the gradient ramp until you choose or create a new gradient.)

	 5.	 In the Color panel, drag the left gradient stop to the midpoint of the 
gradient ramp.
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	 6.	 Click under the left end of the ramp to add another gradient stop.

	 7.	 While the new gradient stop is selected, change the RGB color values to  
R:0, G:0, B:0 (the equivalent of black).

	 8.	 Select the Paint Bucket tool and turn off the Lock Fill modifier at the 
bottom of the Tools panel. Click near the top of the long window and drag 
down past the window edge to define the direction of the gradient fill.

When you release the mouse button, the gradient fill is redirected based on the length of 
the line you drew with the Paint Bucket tool. We dragged past the window edge about 
the same distance as the window’s height; the center point of the gradient is just near the 
bottom edge of the middle of the window.

	 9.	 Use the same method to change the gradients in the other three top 
windows. Try to make the gradients in all four windows consistent, using 
the Gradient Transform tool if necessary.

	10.	 Using any method you prefer, add a gradient to the side fin and adjust it 
until you are satisfied with the overall result.

	11.	 Show the Deep Space layer.

	12.	 Save the file as “rocket_depth.fla” in the WIP>Rocket folder and close it.
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Summary
Although Flash is known as an animation program, you can see from this project that Flash offers a 
considerable array of drawing and painting tools. You learned how to import a sketch, control the 
size of the Flash Stage, and align objects to the Stage. These skills set the groundwork for any type 
of assignment. You also developed an understanding of layers and how they affect the construction 
of complex drawings and artwork. You now know how to create, rename, lock, and hide layers. You 
know that artwork contained on one layer resides either above or below other layers in the document, 
and that the order in which layers are piled on top of one another is called the stacking order.

You learned about the difference between the two drawing modes, which will be vital as you 
complete virtually any project in Flash. You created shapes using several different methods, including 
the primitive drawing tools, the Line tool, and the Pen and Pencil tools for more complex curves. You 
also learned how to control shape attributes such as the fill and stoke colors, as well as how to apply 
stroke styles and gradients to create unique artistic effects.
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Portfolio Builder Project 1
Your client is happy with the rocket 
ship artwork, and wants you to create 
a second set of illustrations that will 
be required for the new Web site.

To complete this project, you should:

o	 Search the Internet or any other 
source for graphic ideas relating to 
the client’s five icons. If necessary, 
use images as templates when you 
draw the icons.

o	 Create the five icons, each in its 
own Flash file.

o	 Carefully consider the best 
approach for each icon and use 
whichever tool (or tools) would 
be most appropriate to create the 
icon artwork.

“�We need a series of icons that we can use on our Web site. These icons 
will eventually be turned into buttons that will link to different areas  
of the site: basic shipping information, cargo and freight shipping 
information, packing services, tracking services, and customer service.

“�We really like the ‘retro’ look of the rocket ship that you drew. If possible, 
can you continue that style into the icons? 

“�Use any colors you want except brown/yellow and blue/orange. Those 
schemes are already taken by our main competitors, and we don’t want 
to be accused of infringing on any trademarks.

“�We don’t have the images for these icons. Can you find something on  
the Internet to use as a guide? We are talking about icons, which need to 
be easily recognizable in any language. Each illustration should very 
clearly convey what each one is for.

“Can you have the project finished within the next two weeks?”




