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Moxie Digital Portfolio
Your client David Monroe is the 
owner of Moxie Photographic 
Studios. He already has a basic Web 
site for his business, but he hired you 
to organize and implement a new set 
of digital portfolio pages. 

Th is project incorporates the following skills:

o Creating, exporting, and removing site defi nitions in 
Dreamweaver

o Moving fi les around in a site root folder

o Creating relative links between pages in a site

o Defi ning absolute links to external sites and email addresses

o Creating image links and image maps

o Improving searchability with fi le names and titles

o Hiding site fi les from a Web server



cl
ie

nt
 c

o
m

m
en

ts

ar
t 

d
ire

ct
o

r 
co

m
m

en
ts

p
ro

je
ct

 o
b

je
ct

iv
es

Project Meeting
My basic Web site used to be enough of a 
digital presence, but lately I’ve been getting a 
lot of phone calls from potential clients, asking 
what types of photography I do and ordering 
samples of my work. Even though I think the 
physical prints have a stronger visual impact, 
it’s getting expensive to send hard-copy samples 
in the mail — and a number of potential 
clients have specifi cally asked for a digital 
portfolio instead of prints.

I already created the Web pages for my new 
digital portfolio, but I don’t know what links 
to use, and I’m not sure how to create them. 
I’ve also heard that there are certain things you 
should do to improve a site’s search engine 
rating — which is obviously important for a 
small business like mine.

Th is project underscores the importance of 
a well-organized Web site. Th e more pages 
you add to a site, the more complex it 
becomes, until it’s almost impossible to 
make sense of what you have and where it 
is located. Web sites — even those with only 
a few pages — should be designed with a 
good organizational plan, making it easier to 
modify pages later. 

Once you have a handle on the organization, 
make sure the pages link to each other 
properly. Visitors get frustrated very quickly 
when they’re forced to return to the home page 
every time they want to jump to a diff erent set 
of pages. You need to build a number of links 
on the diff erent portfolio pages.

Th e last thing you should do is add page 
titles and change fi le names to give a better 
indication of what’s on each page. Doing so 
will make the site more accessible to people 
with screen-reader software, and it will also 
improve the site’s ratings on search engines.

To complete this project, you will:

o Create a Dreamweaver site defi nition 

o Create new folders within the site 
root folder

o Use various methods to move fi les from 
one place to another within the site

o Create links between pages using several 
techniques available in Dreamweaver

o Diff erentiate between relative and 
absolute links

o Copy and paste uniform links from one 
page to another

o Create image map hotspots and links

o Improve searchability and usability using 
page names and titles

o Cloak site fi les to hide them from the 
Web server
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Stage 1	 Exploring Site Structure
When you start a new project that involves updating an existing site, your first task is to assess the file 
and folder structure. Doing so gives you a good idea of what the site contains. 

A small site with only a few pages requires very little organization; in fact, you can place all of 
the files — Web pages and image files — in one folder (although even a small site benefits from a 
dedicated folder for images). Larger sites, however, require careful organization of file names, pages, 
and image files. A good site design with excellent organization speeds development now, and makes it 
much easier to update the site later. 

Create a New Site Definition

Web sites are designed so all of the Web pages, image files, style sheets, and other 
resources are stored on your local drive in a base folder called the root folder. Other 
folders can be placed inside (below) the root folder to make it easier to manage and 
organize files.  

	 1.	 Download DW5_RF_Project1.zip from the Student Files Web page.

	 2.	 Expand the ZIP archive in your WIP folder (Macintosh) or copy the archive 
contents into your WIP folder (Windows).

This results in a folder named Moxie, which contains all the files you need to complete 
this project. 

If necessary, refer to Page 9 of the Interface chapter for specific instructions on 
expanding or accessing the required resource files.

	 3.	 In Dreamweaver, choose Designer in the Workspace switcher to revert to 
the default interface settings. 

	 4.	� Choose Reset ‘Designer’ to restore the default interface options as defined 
by the software.

Resetting the application to the built-in Designer workspace allows you to start at the 
same point you see in our screen shots.

	 5.	 In the Files panel, click the Manage Sites link or open the Directory menu 
and choose Manage Sites from the bottom of the list.

If available, clicking 
Manage Sites opens 
the Manage Sites 
dialog box.

This option performs the 
same function as clicking 

the blue Manage Sites 
link to the right of the 

Directory menu.

	 6.	 Click the New button in the Manage Sites dialog box.

	 7.	 In the Site Setup dialog box, make sure Site is selected in the category list. 

	 8.	 Type Moxie New in the Site Name field.

The site name can be anything that will allow you to easily recognize the project; it is 
only for identification within Dreamweaver. For example, you could use “Eve’s site” as 
the site name within Dreamweaver to describe the Web site (www.evelynsmith.biz) that 
you are creating for your friend. 

When a site is defined 
in Dreamweaver, the 
Manage Sites link at the 
top of the Files panel is 
replaced by a menu that 
defaults to Local view. 

Note:

Remember from the 
Interface discussion that 
ellipses in a menu or 
button name indicate 
that clicking will open 
a dialog box. We do not 
include the ellipses in our 
instructions.

Note:
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	 9.	 Click the button to the right of the Local Site Folder field. Navigate to the 
WIP>Moxie folder and click Choose/Select to return to the Site Setup dialog box.

Part of the process of defining a site within Dreamweaver is to specify a particular folder 
as the site root folder of the Web site. Clicking the Local Site Folder button opens a 
navigation dialog box where you can find the folder you want to use.

	10.	 Click Save to close the Site Setup dialog box.

	11.	 In the Manage Sites dialog box, make sure the Moxie New site appears in 
the list of sites, and then click Done.

	12.	 Continue to the next exercise.

Examine the Site Files 
There are many files in the messy and disorganized Moxie New folder. The first step 
in organizing the new portfolio files is to examine the Web page files and understand 
what they contain.

	 1.	 With the Moxie New site showing in the Directory menu of the Files panel, 
expand the site folder (if necessary) and examine the files in the site.

Click and drag the header 
edge to make the column 
wider or narrower.Click this button to 

expand the folder.

Directory menu

Click here and drag 
left to make the 

panel wider.

This is the root folder 
of the current site.

If more than one site is 
defined, you can switch 
between sites using the 
Directory menu of the 
Files panel.

Note:
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	 2.	 Double-click index.html in the Files panel to open the file in Dreamweaver.

If you see code in addition to the page design, click the Design button in the 
Document toolbar (above the document window).

These image map links 
should appear on every 
page of the site.

In regular Design view, 
you see only the first 
frame of the animation.

These email and external 
URL links should appear 
on every page of the site.

	 3.	 Close index.html, then open portfolio.html.
This page is the gateway page for the various photographic portfolios that your client 
wants to promote: commercial jewelry, fashion catalogs, food, and music industry. The 
words in the middle of the page will be links to the portfolio pages for each category.

This image needs to 
be converted to an 
image map.

Each of these words 
should link to the 
appropriate portfolio page.

“David Monroe” should 
be an email link to your 
client’s email address.

“Pro Techniques” should 
link to the Web site of the 
original site designer.

	 4.	 Close portfolio.html, and then open portfolio1.html.
This page shows four jewelry images that your client wants to feature; these will become 
links to larger versions of the images. The four lines of text on the left side of the page 
will be links to the other portfolio category pages.

Each of these images 
will be a link to a page 
with a larger version of 
the associated photo.

Each of these words 
should link to the home 
page for that category 
of the portfolio.

The files portfolio2.html, 
portfolio3.html, and 
portfolio4.html are 
similar gateway pages to 
the fashion, food, and 
music portfolios 
(respectively). 

Note:
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	 5.	 Close portfolio1.html, then open and examine portfolio1a.html.
These pages display larger photographs that make up the jewelry section of the portfolio.

Each of these images 
should link to the page 
for the associated photo.

	 6.	 Close portfolio1a.html, and then continue to the next exercise.

Plan Folder Organization 
When all files are dumped into the main site folder, it can be challenging to manage 
your work. A well-organized site is an easy-to-manage site. Ideally, organization occurs 
before the site is constructed, but Dreamweaver makes it easy to reorganize files and 
folders at any point in the process. 

There are no absolute rules to follow for organizing files and folders — other than 
the general principle of keeping related components together so you know where to 
find certain files when you need them.

	 1.	 With your Moxie New site open in the Files panel, scroll to the top of the 
Files panel and click to select the site name at the top of the list.

The basic pages (home, about us, contact us, etc.) form the root of the site, and they 
should therefore appear within the root folder of the site. Everything else is better kept 
in a folder that is named based on what it contains.

	 2.	 Control/right-click the site name and choose New Folder from the pop-up menu.

	 3.	 Type resources and press Return/Enter to apply the new folder name.

If after pressing Return/
Enter, the folder name 
remains untitled, 
Control/right-click the 
untitled folder, choose 
Edit>Rename (or press 
F2), and correct the 
name.

Note:
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	 4.	 In the Files panel, click the Refresh button.

When folders and files are created, they appear at the bottom of their containing 
folders (as you saw in Step 3). After refreshing the file list, folders on Macintosh are 
alphabetized along with all other files and folders; on Windows, folders are moved to 
and alphabetized at the top of the list, above individual files. 

On Macintosh, folders 
are alphabetized 

along with all other 
files in the site.

Refresh button

On Windows, folders 
are alphabetized at the 
top of the site list, 
above individual files.

	 5.	 Click to again select the site folder at the top of the Files panel. 
Control/right-click the site folder and choose New Folder.

If you don’t first select the site folder, the new folder would be created inside of the 
resources folder that you just created. You want another folder at the same level as the 
resources folder — in main level of the site root folder — so you first have to select the 
site folder as the target location for the second new folder.

	 6.	 Type portfolio and press Return/Enter to apply the new folder name.

Because there are many portfolio pages with images of individual photos, the portfolio 
group of files is best placed within its own folder.

	 7.	 With the new portfolio folder selected, Control/right-click the portfolio 
folder and choose New Folder. Type images and press Return/Enter.

The new folder is created inside of (“under”) the selected portfolio folder.  
All portfolio images will be moved into this folder for easier organization. 

	 8.	 Add four more folders inside the portfolio folder — jewelry, fashion, 
food, and music — and then refresh the Files panel list.

By placing the pages of each portfolio category in separate folders, you are making it 
easier to find exactly what you need.

	 9.	 Continue to the next exercise.

Press F5 to refresh the file 
list in the Files panel.

Note:
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Sort and Move Image Files 
When you define a site in Dreamweaver, the application reads all of the pages in the 
site (a process that can take a few minutes in a large site), notes the links between 
pages, and identifies which images are used in which pages. These associations between 
files are stored in a cache that Dreamweaver creates when a new site is defined. 

When pages are renamed or moved within the site, Dreamweaver recognizes that 
other pages and image files are related to the moved or renamed files, and prompts you 
to update the links in all of the affected files. If you move files using Macintosh Finder 
or Windows Explorer, the links between pages and to image files will not update to 
recognize the new paths. 

	 1.	 With your Moxie New site open in the Files panel, click and drag 
banner_port.gif into the main images folder (not the portfolio/images folder).

Make sure you drag the file directly over the name of the folder or folder icon; if you 
drag the file too far to the left or right, Dreamweaver will not move the file.

If you can’t see the images folder in the Files panel list, drag the selected file to the top or 
bottom of the Files panel; the file list will scroll until the images folder becomes visible.

By default, the Files panel displays the files on 
your local computer. You can also view the files 
on the remote or testing servers by choosing the 
appropriate option from the View menu.

The top of the Files panel also includes buttons that 
allow you to manage the files in your site:

•	 Connect to Remote Host establishes a connection 
with the remote server (if you defined one). Otherwise, 
clicking this button opens the Site Definition dialog box.

•	 Refresh refreshes the file list that displays in the panel.

•	 Get Files copies the selected files from a remote server 
to the local folder. If the Enable File Check In and Check 
Out option is active, the copied files are available on 
the local site in read-only mode, which means you can’t 
modify them. You must click the Check Out Files button 
to edit the files.

•	 Put Files copies the selected files from the local folder 
to the remote server. If a new file is added to the server, 
and if the Enable File Check In and Check Out option is 
active, the file’s status is Checked Out.

•	 Check Out Files copies the selected files from the 
remote server to the local folder and locks the files so 
only the user who checked out those files can edit them.

•	 Check In Files copies the selected files from the local 
folder to the remote server and makes the copied files 
read-only in the local folder. To edit these files, you need 
to select them and click the Check Out Files button. 

•	 Synchronize synchronizes the files between the local 
folder and the remote server so the same version of the 
files appears in both places.

•	 Expand shows both local files and the remote site 
(if one has been defined). The expanded Files panel has 
two panes; one displays the files on the remote or test 
server and one displays the local site files.
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The Files Panel in Depth

Expand to Show Local 
and Remote Sites

Directory menu

Refresh

Get Files

Put Files

Connect to 
Remote Host

View menu

Synchronize

Check In Files

Check Out Files
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	 2.	 When prompted, click Update to update the affected pages with the new 
location for the banner_port.gif image file.

If you choose Don’t Update, the image will not appear in the pages that call for that 
file. If you had moved the image file using Windows Explorer or the Macintosh Finder, 
Dreamweaver would not have been aware of the movement, and you would not have 
had the opportunity to adjust the path to the image file in pages that link to that image.

The banner_port.gif file is now stored in the main images folder, along with the other 
images that are used on the site’s first-level pages. When you move files into a folder, that 
folder automatically expands in the Files panel. 

   

	 3.	 Click the down-facing arrow (Macintosh) or the “–” symbol (Windows) 
to the left of the images folder name to collapse the folder.

	 4.	 Click CJ_LG_39003.jpg to select that file. Press Shift and then click 
CJ_SM_cuff.jpg to select that and all files in between.

You can move multiple files into a folder at the same time. To select files that are 
grouped together (contiguous), simply click the first one and then Shift-click the last 
one; all files, including the first and last, are selected. 

	 5.	 Click any of the selected files and drag them into the portfolio/images folder.

	 6.	 Click Update to update all of the files that use the moved image files.

   

When a browser down-
loads a Web page, it reads 
the page code, requests 
the image files from the 
defined locations, and 
displays the images with-
in the page. You should 
understand that images 
in Web pages are not  
embedded into Web 
pages; they are merged 
into the page by the 
browser.

Note:

Press Shift to select 
multiple contiguous files 
in the panel.

Press Command/Control 
to select multiple non-
contiguous files.

Note:
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	 7.	 Click fashioncat.gif, and then Shift-click food.gif to select the contiguous 
image files. Command/Control-click commjewelry.gif to add that file to 
the active selection.

Pressing Command/Control enables you to select non-contiguous files.

	 8.	 Drag the selected image files to the portfolio/images folder, and then click 
Update to update all of the pages that reference the moved files.

	 9.	 Expand the Files panel by dragging the left edge of the panel dock until you 
can see the Type column.

	10.	 Click the Type column header to arrange the site files by type.

Click here and drag 
left until you can see 
the Type column.

Click a column 
heading to sort files 
based on that option.

	11.	 Select the remaining GIF file and 16 JPEG files in the site root folder 
and drag them into the portfolio/images folder. Update the links when 
prompted, and then collapse the portfolio/images folder.

	12.	 Click the Local Files column header in the Files panel to sort the files by name.

	13.	 Select and move the files portfolio images.psd and portfolio notes.doc 
into the resources folder. 

These files contain preliminary information that helped the designer build the portfolio 
Web pages, but they are not part of the actual Web site. It’s a good idea to keep these 
files in the site folder in case you need to make changes later. Later in this project, you 
will learn how to prevent these files from being uploaded as part of the site. 

You can change the 
columns that appear 
in the Files panel — 
and the order of those 
columns — in the File 
View Columns pane of 
the Site Setup dialog box.

Note:

You can also Command/
Control-click to deselect a 
selected file. For example, 
if you select a file by 
accident, you can deselect 
it by Command/Control-
clicking the file name 
again. 

Note:
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	14.	 Collapse the resources folder.

	15.	 Move the remaining files into the correct locations as follows:

into portfolio folder: 	 portfolio.html	

into portfolio/jewelry folder:	 �portfolio1.html	
portfolio1a.html

	 portfolio1b.html	
	 portfolio1c.html	
	 portfolio1d.html

into portfolio/fashion folder:	 �portfolio2.html	
portfolio2a.html

	 portfolio2b.html	
	 portfolio2c.html	
	 portfolio2d.html

into portfolio/food folder:	 �portfolio3.html	
portfolio3a.html

	 portfolio3b.html	
	 portfolio3c.html	
	 portfolio3d.html

into portfolio/music folder:	 �portfolio4.html	 	
portfolio4a.html

	 portfolio4b.html	
	 portfolio4c.html	
	 portfolio4d.html

	16.	 Collapse the portfolio subfolders but leave the main portfolio folder expanded.

From the folder structure alone, the Web site appears to be better organized. You now 
know what to expect when you open each folder.

	17.	 Continue to the next stage of the project.

You can also copy and 
paste files into a folder 
using the Edit options 
in the contextual menus, 
or using the standard 
keyboard shortcuts:

Cut: 
Command/Control-X

Copy: 
Command/Control-C

Paste: 
Command/Control-V

Note:

If the number of portfolio 
images grows to a much 
larger number, it might 
be beneficial to create an 
images folder for each 
portfolio category (such 
as portfolio/jewelry/
images/). That way, the 
specific images for the 
pages in each category 
would be located nearby, 
making it easier to find 
and change the images 
if necessary. The folder 
structure in this example 
would look like this:

Note:
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Stage 2	 Organizing the Site Navigation
Hyperlinks (the official term for links) can be created to link pages on a site to other pages within the 
same site, or to pages on other sites. A well-designed site includes links that make it easy to get to any 
part of a site from any other part of a site. You should carefully plan the flow of links and connections 
between pages — always keeping the reader’s usability in mind. 

Organizing links is a simple application of a science called information 
architecture, which is the organization of a Web site to support both usability and 
“findability.” As you organize site links, remember that your goal is to enable visitors 
to see a pattern in your links, which will assist them in navigating through your site. 
Keep the following points in mind when you plan a site’s link structure:

•	 You can’t know how visitors will enter your site. The primary site pages 
(home, about us, etc.) should be accessible from every page on the site; these 
links are commonly created in a banner on the top or left side of the page.  

•	 When linking secondary pages such as individual categories of portfolios, 
don’t make users constantly click the browser’s Back button. Links should 
allow users to navigate the secondary structure as easily as navigating the 
primary structure.

•	 When creating a site with multiple subsidiary pages (such as the four 
“jewelry” portfolio pages), users should be able to explore all child pages in 
the category without first returning to the parent page.

Using the terms “parent,” “child,” and “sibling” is simply a way of describing 
relationships between pages. A large Web site cannot provide links to all of the pages 
from its home page. By grouping pages, grouping groups of pages, and so on, you create relationships 
of equality between pages that are grouped together, as well between groups that are grouped together. 

A flowchart of the Moxie site link structure looks like this:
Moxie Photographic Studio

Home What Is Services Portfolio Clients Contact

Jewelry Fashion Food Music

southwest costume watches bracelet

In this stage of the project, you will learn various techniques to create the necessary links on the 
Moxie Portfolio pages.

Creating flowcharts is 
a great tool for novice 
designers and experts 
alike. Flowcharts are 
often used to map 
complex software 
programming and Web 
site development. In 
fact, a language called 
UML (unified modeling 
language, a standardized 
graphical notation that 
can be used to create 
models of systems) has 
been developed by 
professionals specifically 
for this purpose.

Note:
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Create Links Using the Hyperlink Button

The first step to completing the site navigation is to create links from the main 
portfolio page to each of the portfolio category pages. In this exercise, you learn to 
create links between pages using the Hyperlink dialog box, which is accessed in the 
Common Insert panel.

	 1.	 With the Moxie New site open in the Files panel, open portfolio/portfolio.html.

	 2.	 Drag to select the word “Jewelry” in the middle of the page.

	 3.	 Expand the Insert panel, and then choose Common from the Insert panel menu.

	 4.	 Click the Hyperlink button in the Common Insert panel.

The Common Insert panel contains many of the common functions you use to create 
Web pages. If a different Insert panel is showing, you can return to the Common Insert 
panel by choosing Common in the panel menu.

Hyperlink 
button 

	 5.	 In the Hyperlink dialog box, click the Browse button to the right of the 
Link field.

Browse button

Text selected in the 
document is automatically 
entered in the Text field.
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•	 The Hyperlink button opens a dialog box where you 
can create text or image links to another file, either in 
the same Web site or in an external Web site.

•	 The Email Link button opens a dialog box where 
you can create links to email addresses. When a user 
clicks an email link, it opens the user’s default email 
application with the email address in the To line.

•	 The Named Anchor button marks locations within 
a page. Links can be provided to these locations from 
within the same page or from other pages of the same 
Web site or other Web sites.

•	 The Horizontal Rule button inserts a solid line across 
the width of the page. This can be useful for visually 
separating sections of text.

•	 The Table button inserts a table into the page.

•	 The Insert Div Tag button inserts new sections 
(divisions) in a page. Each division in a page is marked 
by a dotted line in Dreamweaver; these dotted lines 
do not appear when the page is viewed in a browser. 
Divisions are useful for inserting blocks of content you 
want to format independently from other blocks.

•	 The Images button inserts various types of graphics. If 
you click the arrow on the button icon, a menu shows 
the available types of objects (basic images, rollover 
images, etc.) You can also insert an image placeholder, 
which reserves a portion of the page for inserting an 
object later.

•	 The Media button inserts audio-visual files. These files 
could be in any format, but Dreamweaver also has 
functionality specific to inserting Flash, QuickTime, and 
Shockwave files; Java applets; and ActiveX controls.

•	 The Widget is used to insert Spry widgets. Dream
weaver ships with a number of built-in Spry widgets, 
which you will use in Projects 6 and 7. You can down-
load other widgets through the online Widget Browser, 
which is a separate free download. To access this func-
tionality, you can open the Extend Dreamweaver menu 
in the Application/Menu bar and choose Widget Brows-
er. (If the Widget Browser extension is not yet installed 
on your system, you will be prompted to download and 
install the application.)

•	 The Date button inserts 
the date and time. An 
option is provided for 
updating the date and time 
whenever the file is saved.

•	 The Server-Side Include 
button inserts a file within 
a page. In this case, instead 
of providing a link to the 
file, the actual contents of 
the file are included in the 
page itself.

•	 The Comment button inserts comments in the code 
that describe something about its use. These comments 
display in Code view only; they do not appear in Design 
view or in the browser. 

•	 The Head button adds information about the page that 
will be used by browsers. This information is included in 
the properties of the page. Click the arrow to select the 
type of information you want to add.

•	 The Script button enables you to add code that will 
be used by the browser to perform an action when 
the page is accessed. Click the arrow and click Script 
from the menu to add the code. Some older versions of 
browsers might have the script-reading feature disabled; 
to display alternate content when browsers fail to read 
the script, click No Script from the menu. You need 
to know programming languages to use this feature 
properly.

•	 The Templates button creates a template based on the 
current document, which is useful when you need to 
create multiple documents from the same layout. 

•	 The Tag Chooser button inserts tags in the code. Tags 
are elements in the code that determine the kind of 
content that can be included in them. Tags are included 
automatically when you edit pages in Design view. 
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The Common Insert Panel in Depth
The Common Insert panel contains buttons for frequently used items. For example, to insert 
a hyperlink, simply click the corresponding button. (Some of the terms and functions in the 
following descriptions will make more sense as you use those tools to complete later projects.)
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	 6.	 Navigate to the portfolio/jewelry folder, select portfolio1.html, and click 
Choose/OK.

	 7.	 Open the Target menu and choose _self.

This option determines where the linked file will open: 

•	 _blank opens every linked file in a new, unnamed browser window. 
•	 _�new creates a new browser window with the name “_new”. Every link assigned 

the _new target will open in that same _new browser window.
•	 _�parent is relevant if a page includes nested frames; this option opens the link in 

the frame or window that contains the frame with the link.  
•	 _self opens the link in the same frame or browser window as the link.
•	 _top opens the link in the same browser window, regardless of frames.

	 8.	 Click OK in the Hyperlink dialog box to create the link.

	 9.	 Examine the link in the Design view.

Text links default to blue with an underline, but cascading style sheets (CSS) make 
it possible to change the appearance of links. The text you just converted to a link is 
now underlined, which is the defined appearance for hyperlinks on this page. (You will 
begin working with CSS styles to format different elements in Project 2, and use them 
extensively throughout the rest of this book.)

The link destination 
now appears in the 
Link field of the 
Properties panel.

The linked text is 
underlined, which is 
defined by the 
original site’s CSS file.

	10.	 Save your work (File>Save) and continue to the next exercise.

If you don’t choose a 
specific target, the linked 
file opens in the same 
browser window as the 
one in which the link 
appears. 

Note:

The Title field defines 
text that appears when 
the cursor is placed over 
the link text.

You can use the Access 
Key field to define a 
keyboard shortcut for the 
link, and use the Tab 
Index field to specify the 
number of times a user 
needs to press the Tab key 
to select the link.

Note:
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Create a Link Using the Browse for File Function

The Browse for File function in the Properties panel is similar to the Hyperlink button 
in the Common Insert panel. As with most applications, Dreamweaver often includes 
several different ways to achieve the same result. You should use the method that is 
most efficient at the time. For example, if you are using a different mode of the Insert 
panel, you can use the Properties panel to create a link without switching modes in the 
Insert panel. 

	 1.	 With the Moxie New site open in the Files panel, make sure portfolio/
portfolio.html is open. 

	 2.	 Select the word “Fashion” below the Jewelry link from the previous exercise.

	 3.	 Click the Browse for File button to the right of the Link field in the 
Properties panel.

If you don’t see the Properties panel, choose Window>Properties. The Properties panel’s 
primary purpose is to review and change the properties of the selected HTML element 
(such as a heading, paragraph, or table cell). 

Browse for 
File button

	 4.	 In the resulting dialog box, navigate to the portfolio/fashion folder, select 
portfolio2.html, and then click Choose/OK.

The link destination 
now appears in the 
Link field of the 
Properties panel.

The linked text is 
underlined, which is 
the style defined by 
the site’s CSS file.

	 5.	 Save the file and continue to the next exercise.

You can change the 
destination of a link 
by selecting the linked 
text or object in the 
document and choosing 
Modify>Change Link. 
This menu command 
opens the same dialog 
box as the Browse for File 
button, where you can 
navigate to and select the 
new link destination.

Note:
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Create a Link Using the Point to File Function

Using the Point to File function, you can create a link by simply clicking in the 
Properties panel and dragging to a file in the Files panel. (To use this function, the 
target file must be visible in the Files panel.)  

	 1.	 With portfolio.html (from the Moxie New site) open, select the word 
“Food” below the Fashion link you created in the previous exercise.

	 2.	 Expand the portfolio/food folder in the Files panel.

	 3.	 Click the Point to File button in the Properties panel and drag to 
portfolio/food/portfolio3.html in the Files panel.

Point to File 
button

	 4.	 Save the file and continue to the next exercise.

Shift-Drag to Create a Link

A fourth way to create a link between pages in a site requires no buttons, toolbars, or 
panels. You can create a link directly from the document window by pressing Shift and 
dragging to the destination page in the Files panel.

	 1.	 With portfolio.html (from the Moxie New site) open, select the word “Music”.

	 2.	 Expand the portfolio/music folder in the Files panel.

	 3.	 Press the Shift key, then click the selected text and drag to portfolio/
music/portfolio4.html in the Files panel.

You have to press the Shift key, and then click and drag to the link destination. 
If you try to click and drag before pressing the Shift key, this technique will fail.

	 4.	 Save the file and close it, and then continue to the next exercise.

Expand and collapse 
Files panel folders as 
necessary, depending on 
your available screen 
space. We will not repeat 
instructions to collapse or 
expand folders unless it 
is necessary to perform a 
specific function. 

Note:
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Adjust Relative Link Paths

A path is the route taken through the folder structure to link one page to another. By 
default, Dreamweaver uses relative paths when creating links (the application refers to 
this as “relative to the document”). The alternative is to create absolute paths (“relative 
to the site”); but unless your site is running on a Web server, you can’t test links that 
use absolute paths.

As an example, consider creating a link from portfolio1.html to  
portfolio1a.html, both of which reside in the jewelry folder (as shown in the 
figure to the right). In this case, the source and destination pages are in the same 
folder; the relative-path link simply states the file name of the destination page:

<a href="portfolio1.html">Link Text</a>

When you drill down into nested levels of folders, the source folder is not 
identified in the path; the link automatically works starting from the location of 
the link. To link from portfolio.html to portfolio1.html, for example, you have to 
include the nested jewelry folder but not the starting portfolio folder in the path: 

<a href="jewelry/portfolio1.html">Link Text</a>

To link from index.html to portfolio1.html, the entire path needs to include both 
nested folders:

<a href="portfolio/jewelry/portfolio1.html">Link Text</a>

When the link is in an upward direction, the ../ notation says “go up one folder.” 
To link from portfolio1.html to portfolio.html in the portfolio folder means that the 
link needs to take the visitor up one folder level: 

<a href="../portfolio.html">Link Text</a>

To link from portfolio1.html in the portfolio/jewelry folder to /index.html in the 
root folder, the link must take the visitor up two folder levels:

<a href="../../index.html">Link Text</a>

In this exercise, you are going to create a set of links that will appear on every 
portfolio category page. For the links to work properly on all pages, you will make the 
necessary adjustments so the links will work properly when they are copied into the 
other three category pages.

	 1.	 With the Moxie New site open in the Files panel, open portfolio/jewelry/
portfolio1.html. 

	 2.	 Using any method you prefer, create text links for the words on the left side 
of the page:

“Jewelry” links to portfolio/jewelry/portfolio1.html 

“Fashion” links to portfolio/fashion/portfolio2.html 

“Food” links to portfolio/food/portfolio3.html 

“Music” links to portfolio/music/portfolio4.html 

portfolio1.html
JEWELRY

portfolio1a.html
portfolio2d.html

FASHION
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	 3.	 Select the word “Jewelry” and review the link in the Properties panel.

There is no folder path because portfolio1.html is the current file and is obviously in the 
same folder as the file containing the link. (The same concept would be true if you were 
linking to any of the other files in the portfolio/jewelry folder.)

Link path

	 4.	 Select the word “Fashion” and review the link in the Properties panel.

The path from portfolio/jewelry/portfolio1.html to portfolio/fashion/portfolio2.html 
requires you to go up one folder to the portfolio folder, then down to the fashion folder 
to get to portfolio2.html.

	 5.	 One by one, select the Food and Music links in the document and review 
the paths in the Properties panel.

In each case, the link goes up to the portfolio folder, and then moves down to the 
specific folder for the page that is linked.

	 6.	 Select the “Jewelry” text.

All of the links that you have created on the Jewelry portfolio page need to be present 
on all of the other portfolio category pages as well. If you copied this block of links 
to the other portfolio category pages, the “Jewelry” link would always look for the file 
portfolio1.html in the folder containing the active page. Before you copy and paste the 
block of links to the other category pages, you need to adjust the portfolio1.html link so 
that it will work for all pages.

	 7.	 Click the Link field in the Properties panel and move the insertion point to the 
left of the existing path.

When a link to another 
page in the site is selected 
in the document, you 
can open the related 
page in Dreamweaver by 
choosing Modify>Open 
Linked Page.

Note:
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	 8.	 Type ../jewelry/ to the left of portfolio1.html.

This modification to the link takes the browser up to the portfolio folder, and then back 
to the portfolio/jewelry folder. This might seem like an unnecessary step, but it enables 
this link to work from any of the four portfolio category pages.

	 9.	 Save the changes to the page and then continue to the next exercise.

Copy and Paste Links

Now that the links have been configured to work from every portfolio category page, 
it’s time to copy and paste the entire list of links to the other category pages.

	 1.	 With portfolio1.html open, click in any of the text links to place the 
insertion point, and then click the <ul#leftnav> tag in the Tag Selector.

The Tag Selector, located in the status bar of the document window, shows the path of 
tags to the tag of the current selection or the current location of the insertion point. 

Clicking a tag in the Tag Selector selects all of the content contained within that tag.  
In the document window, the associated content is highlighted.

Selected list

Selected tag

Tag Selector
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	 2.	 Copy the selected content to the Clipboard by choosing Edit>Copy or 
pressing Command/Control-C.

	 3.	 Close portfolio1.html and open fashion/portfolio2.html.

	 4.	 Click to place the insertion point anywhere in the list of links on the left 
side of the page, and then click the <ul#leftnav> tag in the Tag Selector to 
select the entire unlinked list.

The selected 
list does not yet 
include links.

	 5.	 Paste the content from the Clipboard by choosing Edit>Paste or pressing 
Command/Control-V.

The pasted 
content includes 
the links.

	 6.	 Save the changes to portfolio2.html and close the file.

	 7.	 Repeat Steps 3 through 6 to paste the copied content (the links) into pages 
portfolio/food/portfolio3.html and portfolio/music/portfolio4.html.
If you hadn’t adjusted the link path to portfolio1.html in the previous exercise, you would 
have to adjust the path each time you paste to a page that wasn’t in the portfolio/jewelry/ 
folder. Because you adjusted the path before copying the links, all you had to do was 
paste the same paragraph of links to each of the pages in all four category folders.

	 8.	 Save and close all files, and then continue to the next exercise.
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Create Email and External URL Links

Most Web sites include one or more external links (including email links), which 
require the appropriate protocol to tell the browser what type of link is present. 

An email link requires the “mailto:” protocol, followed by the appropriate email 
address. This instructs the browser to open a new mail message with the defined 
address already in the To line.

An external URL link must begin with the “http://” protocol, followed by the 
domain name and, if relevant, the folder path and file name of the page to which you 
are linking. 

The bottom of each page in the Moxie site should include an email link to your 
client and a link to the Web site of the original site designer (a common practice). 
Most of the portfolio pages were created from a template that already defined these 
links. However, they were inadvertently omitted from the primary portfolio page.

	 1.	 With the Moxie New site open in the Files panel, open portfolio.html 
from the portfolio folder.

	 2.	 Select the words “David Monroe” near the bottom of the page. 

	 3.	 In the Common Insert panel, click the Email Link button.

Selected 
text

	 4.	 In the Email Link dialog box, type info@moxiestudios.com in the 
Email field.

If you select text before clicking the Email Link icon, the Text field is completed for you. 

	 5.	 Click OK to create the email link.

Review the link field in the Properties panel; an email link must begin with “mailto:” 
followed by the address; when you use the Email Link dialog box, Dreamweaver 
automatically inserts the mailto: protocol.

You can access the  
same Email Link 
dialog box by choosing 
Insert>Email Link.

Note:

Dreamweaver remembers 
the last email address you 
entered into the Email 
field; you might not need 
to complete that field if 
you insert the same email 
address multiple times.

Note:
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	 6.	 Select the words “Pro Techniques” at the bottom of the page.

	 7.	 In the Link field of the Properties panel, type http://www.
protechniques.com and press Return/Enter.

Dreamweaver can’t help you create an external URL link because it’s outside the site 
definition. You have to simply type or paste the address into the Link field.

	 8.	 Save the file and close it, then continue to the next stage of the project.

Stage 3	 Creating Image Links 
Many Web sites use navigation bars with images of text as the links to other pages. Other sites include 
photo galleries, in which small thumbnail images open larger versions of the image or (as in this site) a 
separate Web page with more details about the clicked image. 

You can use any of the methods you already learned to create image links, with one exception — 
you can’t Shift-drag from an image in the document window. You can, however, click the Hyperlink 
button in the Common Insert panel, type a URL in the Link field, click the Browse for File button, or 
click the Point to File button in the Properties panel. 

Create Image Links

In this exercise, you create links from the portfolio category pages to the photo pages 
that contain larger versions of the photos. 

	 1.	 With the Moxie New site open, open portfolio/jewelry/portfolio1.html.

	 2.	 Click the top-left portfolio image to select it. Using any method you prefer, 
link the selected image to portfolio/jewelry/portfolio1a.html.

You can remove a link 
by selecting the linked 
text or object in the 
document and choosing 
Modify>Remove Link, 
or by simply deleting the 
text from the Link field 
in the Properties panel.

Note:
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	 3.	 Using any method you prefer, link the top-right image to portfolio1b.html, 
link the lower-left image to portfolio1c.html, and link the lower-right image 
to portfolio1d.html.

	 4.	 Save the file and close it, and then open portfolio/fashion/portfolio2.html.

	 5.	 Link the images to the four remaining pages in the portfolio/fashion folder 
as shown below. Save and close portfolio2.html when finished.

Link this image to 
portfolio2a.html.

Link this image to 
portfolio2b.html.

Link this image to 
portfolio2c.html.

Link this image to 
portfolio2d.html.

	 6.	 Repeat Step 5 for portfolio/food/portfolio3.html. 

Link this image to 
portfolio3a.html.

Link this image to 
portfolio3b.html.

Link this image to 
portfolio3c.html.

Link this image to 
portfolio3d.html.

	 7.	 Repeat Step 5 for portfolio/music/portfolio4.html.

Link this image to 
portfolio4a.html.

Link this image to 
portfolio4b.html.

Link this image to 
portfolio4c.html.

Link this image to 
portfolio4d.html.

	 8.	 Continue to the next exercise.
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Copy and Paste Image Links

When a visitor clicks a link to jump to a specific portfolio image, the user should be 
able to explore other photos in the same category without being forced to first return to 
the main category page. Adding four thumbnail images on the left side of the page will 
provide this navigational structure. Once you have created links from the thumbnails in 
one page, you can copy and paste that group to the other pages in the same category — 
which reduces some of the effort. 

	 1.	 With the Moxie New site open in the Files panel, open portfolio/jewelry/
portfolio1a.html.

	 2.	 Using the techniques you have already learned, create links from the four 
small images on the left side of the page:

Link this image to portfolio1b.html.

Link this image to portfolio1a.html.

Link this image to portfolio1c.html.

Link this image to portfolio1d.html.

	 3.	 With any of the four thumbnail images selected, click the rightmost 
(second) <table> tag in the Tag Selector to select the small table that encloses 
the four thumbnail image links.

When you click the <table> tag, the selection switches to the entire table that contains 
the originally selected image. 

When this image 
is selected… 

...the Tag Selector 
shows the full path 

of tags leading to 
the selected image.

Click the second 
<table> tag in the 

Tag Selector to select 
that entire object in 

the layout.

	 4.	 Choose Edit>Copy (or press Command/Control-C) to copy the selected 
table to the Clipboard.

	 5.	 Save the changes to portfolio1a.html and close the file.

	 6.	 Open portfolio1b.html and click one of the thumbnail images.
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	 7.	 Click the rightmost <table> tag in the Tag Selector and paste the copied table 
(with the defined links) in place of the selected table (which has no links).

	 8.	 Save the changes to portfolio1b.html and close it.

	 9.	 Repeat Steps 6 through 8 to paste the same linked table into 
portfolio1c.html and portfolio1d.html.

	10.	 Repeat this process for each category of photo pages:

•	 Create the thumbnail links in one of the category pages.

•	 Use the Tag Selector to select the table containing the thumbnail links.

•	 Copy the linked thumbnail table.

•	 Paste the linked thumbnail table, replacing the unlinked thumbnail, 
table in the other pages of the same category.

By adding these links, site visitors can explore the other photos within the same category 
from any of the photo pages in that category.

Link to portfolio2a.html.

Link to portfolio2b.html.

Link to portfolio2c.html.

Link to portfolio2d.html.

   

Link to portfolio3a.html.

Link to portfolio3b.html.

Link to portfolio3c.html.

Link to portfolio3d.html.

Link to portfolio4a.html.

Link to portfolio4b.html.

Link to portfolio4c.html.

Link to portfolio4d.html.

	11.	 Save and close any open files, and then continue to the next exercise.
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Create Image Map Links

In addition to creating a link from a whole image, you can also create a link from a 
portion of an image. For example, an image of a map of the United States could have a 
link from each state to the government Web site for that state; or a group photograph 
could have a link from each person to a personal Web page. This type of image is 
known as an image map.

Image maps contain hotspots, which are specific areas of the image configured as 
links. Each hotspot on an image can have its own URL, which means a single image 
can have multiple URLs. Dreamweaver applies a semi-transparent colored shape to 
represent the location, shape, and size of each hotspot area.

The top banner image on each page will be an image map that includes links to 
the primary pages of the site. The necessary hotspots were created by a template on 
most of the portfolio pages, but were accidentally left out of the main portfolio page. 
In this exercise, you will create the missing image map. 

	 1.	 With the Moxie New site open in the Files panel, open portfolio/portfolio.html.

	 2.	 Click once on the banner image to select it. 

Rectangle Hotspot tool

Pointer tool

Circle Hotspot tool

Polygon Hotspot tool

Map ID field

	 3.	 In the Properties panel, type primary in the Map ID field (not the Image 
ID field).

	 4.	 Click the Rectangle Hotspot tool to activate it.

	 5.	 Click and drag to draw a rectangle around the word “home” in the banner 
image at the top of the document window.

Click and drag to 
create an area around 
the word “home”.
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	 6.	 Click OK to dismiss the message dialog box.

After drawing a hotspot, you see a message reminding you to define alt text for the 
image map. Alt text (alternative text) aids usability for disabled users who use screen-
reader software. This is an extremely important issue, which you will examine in depth 
in Project 3.

	 7.	 From the Properties panel, use either the Point to File or Browse for File 
method to create a link to index.html in the root folder of the site.

Because the active file (portfolio.html) is one folder below index.html in the root folder, 
Dreamweaver inserts the required ../ to direct the browser up one folder to index.html.

Hotspot

	 8.	 Using the Rectangle Hotspot tool, draw rectangles around each phrase in 
the banner image. Link each hotspot to the appropriate page.

Most of these pages are in the root folder; the word “portfolio”, however, links to 
portfolio.html in the portfolio folder (which is also the page you are editing).

	 9.	 Save the page, close it, and then continue to the next stage of the project.
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Stage 4	 Naming and Titling Documents
SEO (search engine optimization) is the process of improving the ranking of a Web site and its 
pages within SERPs (search engine results pages, or the pages that list the results of a search). 
Search engines certainly use the content of a page for ranking purposes, but the names of folders  
and files also affect search engine rankings. Descriptive folder and file names also improve usability; 
you can use /p/j/3.html for the path to the costume jewelry page, for example, but /portfolio/jewelry/
costume.html is much easier for human visitors to understand — and will also improve your search 
engine ranking.

Rename Default Pages

When a Web server (special computers that store and deliver Web pages) receives a 
request for a folder but not a specific page, the Web server delivers the default page for 
that folder — usually named index.html or index.htm. (There is no practical difference 
between the two extensions; most, if not all, browsers correctly interpret the content of 
a file with either.) When creating links to the default page for a particular folder, you 
do not need to include the file name. Both www.moxiestudios.com/portfolio/ and 
www.moxiestudios.com/portfolio/index.html refer to the same page.  

In this exercise, you rename the default pages for each portfolio folder. As with 
moving files, the application recognizes when a file name has been changed and knows 
that links to the page must be adjusted.

	 1.	 With the Moxie New site open in the Files panel, Control/right-click 
portfolio/portfolio.html and choose Edit>Rename.

	 2.	 Type index.html, press Return/Enter, and then click Update to update all 
pages that link to this page.

As with moving files, Dreamweaver recognizes that all links to the renamed page need to 
point to the new file name.
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	 3.	 Open contact.html from the root folder of the site, click the hotspot for 
portfolio, and examine the URL in the Properties panel.

The destination page changed from portfolio.html to index.html.

Selected hotspot

The selected hotspot 
correctly links to the 
renamed file. 

	 4.	 Close contact.html.

	 5.	 In the Files panel, rename the following files as index.html. Click Update 
each time you are prompted.

portfolio/jewelry/portfolio1.html

portfolio/fashion/portfolio2.html

portfolio/food/portfolio3.html 

portfolio/music/portfolio4.html 

These are the default pages for each of the portfolio category folders.

	 6.	 Continue to the next exercise.

The file name  
“index.html” is the 
naming convention for 
the home page of the  
Web site or the default 
page of a specific folder. 

Note:
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Rename Portfolio Pages for Improved Usability

The rest of the file names for the pages in the portfolio folders are essentially nonsense; 
numbers mean nothing and do not represent the content of the pages. The file names 
of these pages should be changed so the content or purpose of each page is clear. 

Because different servers run on different operating systems, the safest way to 
name pages is to use only characters that are guaranteed to work perfectly: 

•	 a through z (use only lowercase letters)

•	 0 through 9

•	 Hyphen (great-site.html) 

•	 Underscore (great_site.html)

Consider everything else to be “illegal,” including:

•	 Spaces 

•	 Brackets of all kinds, including ( ), [ ], { }, and < >

•	 Symbols, including #, @, %, ~, |, *, and &

•	 Quotation marks, both double (“ ”) and single (‘ ’)

•	 Slashes, both back slashes (\) and forward slashes (/)

•	 Commas, periods, question marks, and exclamation points

•	 Uppercase characters

Some designers use camelcase — uppercase letters at the beginning of each word 
within a file name, such as UniversalStudios.html — file names instead of using 
hyphen or underscore characters to separate words. The problem with mixing the 
lettercase is that some Web server software is case-sensitive and some is not. Most 
Windows-based Web server software is not case-sensitive; but UNIX- and Linux-
based Web server software is case-sensitive. Considering that many Web servers run on 
UNIX- or Linux-based computers, it’s best to use only lowercase file and folder names.

	 1.	 With the Moxie New site open in the Files panel, open the Preferences dialog 
box (Dreamweaver>Preferences on Macintosh or Edit>Preferences on Windows).

	 2.	 In the General pane of the Preferences dialog box, choose Always in the 
Update Links when Moving Files menu.
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	 3.	 Click OK to close the Preferences dialog box.

Because you are about to rename a large number of files, the default behavior would 
require you to manually click Update after changing each file name. By changing the 
Update Links preference, the update process will happen automatically as soon as 
you change the file names. This might seem like a minor difference, but it can be a 
significant time-saver when changing large numbers of file names.

	 4.	 In the Files panel, change the following file names in the portfolio/
jewelry folder:

portfolio1a.html 	 becomes	 southwestern.html

portfolio1b.html 	 becomes	 costume.html

portfolio1c.html 	 becomes	 watches.html

portfolio1d.html 	 becomes	 gold-bracelet.html

	 5.	 In the portfolio/fashion folder, change the following file names:

portfolio2a.html 	 becomes	 fall.html

portfolio2b.html 	 becomes	 leisure.html

portfolio2c.html 	 becomes	 business.html

portfolio2d.html 	 becomes	 sports.html

	 6.	 In the portfolio/food folder, change the following file names:

portfolio3a.html 	 becomes	 breakfast.html

portfolio3b.html 	 becomes	 restaurant.html

portfolio3c.html 	 becomes	 fruits-vegetables.html 

portfolio3d.html 	 becomes	 seafood.html

	 7.	 In the portfolio/music folder, change the following file names:

portfolio4a.html 	 becomes	 orbital-funk.html

portfolio4b.html 	 becomes	 jaden.html

portfolio4c.html 	 becomes	 saturn-5.html 

portfolio4d.html 	 becomes	 trumaine.html

	 8.	 Open the Preferences dialog box again.

	 9.	 In the General pane, choose Prompt in the Update Links menu and then 
click OK.

Now that you’re done with the renaming process, it’s a good idea to restore the default 
behavior so you will again be informed in advance before changes are made.

	10.	 Continue to the next exercise.

You can click the file in 
the Files panel to select it, 
wait a second, then click 
the selected file name to 
highlight it. You can then 
simply type a new file 
name.

Note:
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Create Document Titles for the Portfolio Pages

Appropriate document titles are an important concern for both search engines and 
site visitors. While the document title does not appear within the body of a Web page, 
it does appear in the title bar of the browser, as the default name of the page in the 
Bookmarks or Favorites list, and as the page name in search-engine results pages. 

The generally recommended format for a document title is to list the categories in 
which the page is found, similar to the folder path, ending with the Web site name. 
You should separate the components of the title with the colon (:) or pipe (|) character. 

If you list the Web site name first, the specific details of the page could be cut 
off. Also, in a SERP, it’s easier to see if your search has provided suitable results if the 
specific information about the page is listed first. The 
image to the right shows results from two Google searches. 
The blue underlined links (top lines) are the document 
titles — suggesting that the document titles are important 
to visitors looking for information using search engines.

In this exercise, you add document titles to the new 
pages to increase the pages’ search engine rankings and 
improve usability for visitors who find the pages in search engines and bookmarks. You 
also learn to use the Find and Replace function, which can greatly reduce the amount 
of effort required to create all of the document titles.

	 1.	 With the Moxie New site open in the Files panel, open portfolio/index.html.

	 2.	 Make sure the Document toolbar is showing (View>Toolbars>Document) 
and examine the Document Title field above the document window.

When you create a new page in Dreamweaver, the default title is “Untitled Document”.

Document title

	 3.	 Close index.html.

	 4.	 With Dreamweaver active but no documents open, choose Edit>Find 
and Replace.

Don’t worry if your settings are different than what you see in our screen shot.  
You configure them in the next step.

	 5.	 Change the Find In menu to Folder, click the Browse button, and select 
the portfolio folder.

All files within and below the portfolio/ folder will be searched.

Click this button 
to browse to the 
proper folder. 
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	 6.	 Choose Source Code in the Search menu.

The document title does not appear in the body of the page, so when you use Find and 
Replace, you must apply the change to the source code rather than the document text.

	 7.	 In the Find field, type Untitled Document.

	 8.	 In the Replace field, type Portfolio : Moxie Photographic Studios.

All pages in the portfolio folder will include this block of text at the end of the 
document title. As more detail about the pages becomes available, it will be added to  
the left of the document title.

	 9.	 Click Replace All. When prompted to confirm whether you want to proceed 
with this function, click Yes.

Like most applications, Dreamweaver has an Undo function that allows you to undo the 
most recently completed actions; however, this function only works if the document is 
open. Since you are using the Find and Replace function on the entire folder and not an 
open page, you are making changes in closed documents — which means you cannot 
use the Undo command.

After completing the Find and Replace function, Dreamweaver displays the results in 
the Search panel.

	10.	 Open portfolio/index.html and examine the Document Title field again. 

As a result of the Find and Replace function, the document title has been changed.  
(The same change has been made in all of the portfolio pages.)

	11.	 Close index.html.

Unlike file names, 
document titles can use 
mixed lettercase and 
include spaces and other 
characters. However, you 
should avoid both single 
and double quotation 
marks.

Note:
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	12.	 Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/jewelry folder:

•	 Set the Find In menu to Folder and target the portfolio/jewelry folder.

•	 Set the Search menu to Source Code. 

•	 Change the Find field to Portfolio :

•	 Change the Replace field to Jewelry : Portfolio :

•	 Click Replace All. When prompted to confirm your action, click Yes.

   

	13.	 Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/fashion folder:

•	 Set the Find In menu to Folder and target the portfolio/fashion folder.

•	 Set the Search menu to Source Code. 

•	 Change the Find field to Portfolio : 

•	 Change the Replace field to Fashion : Portfolio :

•	 Click Replace All. When prompted to confirm your action, click Yes.

   

	14.	 Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/food folder:

•	 Set the Find In menu to Folder and target the portfolio/food folder.

•	 Set the Search menu to Source Code. 

•	 Change the Find field to Portfolio :

•	 Change the Replace field to Food : Portfolio :  

•	 Click Replace All. When prompted to confirm your action, click Yes.

   



56 Project 1: Moxie Digital Portfolio

	15.	 Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/music folder:

•	 Set the Find In menu to Folder and target the portfolio/music folder.

•	 Set the Search menu to Source Code. 

•	 Change the Find field to Portfolio :

•	 Change the Replace field to Music : Portfolio :

•	 Click Replace All. When prompted to confirm your action, click Yes.

   

	16.	 Control/right-click the Search panel tab and choose Close Tab Group from 
the contextual menu.

	17.	 Continue to the next exercise.

Add Specific Page Information in the Document Title

The current document titles contain generic information that represents the specific 
portfolio categories. In this exercise, you add specific information in the document 
title for each page.

	 1.	 With the Moxie New site open in the Files panel, open portfolio/
jewelry/southwestern.html.

	 2.	 In the Document Title field, click to place the insertion point left of the 
word “Jewelry” and type Southwestern : .
If you don’t see the Document Title field, choose View>Toolbars>Document.

	 3.	 Save the changes to southwestern.html and close the file.

	 4.	 One by one, open the rest of the pages in the portfolio category folders and 
add the same text you used in the file name to the beginning (left) of the 
document title (“Saturn 5” and “Fruits and Vegetables”, for example). Save 
and close each file after changing the document title.

Unlike file names, document titles can have spaces, so you can replace hyphens or 
underscores with spaces between words.

	 5.	 Continue to the next exercise. 
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Hide Files from the Web Server

As you saw when you created the folders for the new site, not all of the new files are 
meant to be uploaded to the Web server — specifically, the Word document and Photo-
shop file in the resources folder. (You should, however, store them locally as source files 
or documentation for the work you completed.) 

Dreamweaver provides a very useful function — called cloaking — that allows 
you to prevent certain files from uploading. There are two methods for cloaking 
files: by file extension and by folder. If you cloak by file extension, such as PSD (a 
Photoshop file), any PSD files in the site’s folder will be cloaked. The disadvantage of 
cloaking by file extension is that it’s an all-or-nothing proposition — you can’t uncloak 
some PSD files to upload while leaving other PSD files cloaked. If you create a folder 
for all files that you don’t want uploaded, however, you can cloak the entire folder, no 
matter what type of files exist within that folder (including HTML files).

Cloaking a folder allows you to keep preliminary, source, draft, and other 
documents and files within the site, but prevent them from uploading to the Web 
server. By default, Dreamweaver has the cloaking function enabled; all you need to do 
is identify the folder you want to cloak.

	 1.	 With the Moxie New site open in the Files panel, open the Directory menu 
in the Files panel and choose Manage Sites.

	 2.	 In the Manage Sites dialog box, make sure Moxie New is selected and click Edit.

	 3.	 In the Site Setup dialog box, expand the Advanced Settings menu on the left 
side and click Cloaking to show the related options.

	 4.	 Make sure the Enable Cloaking check box is active, and then click Save to 
return to the Manage Sites dialog box.

When Enable Cloaking is checked, you can hide selected files and folders from a Web 
server. You can also use the Cloak Files Ending With option to hide all files with the 
extensions that are listed in the field.
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	 5.	 Click Done to close the Manage Sites dialog box.

	 6.	 In the Files panel, collapse all open folders and expand only the resources folder.

	 7.	 Control/right-click the resources folder and choose Cloaking>Cloak.

Notice the red slash through the resources folder icon and the icons for the two files 
in the resources folder. The red slash refers to the cloaking function only; it does not 
prevent you from working with the files, adding more files, or deleting any of the 
existing files.

	 8.	 Continue to the next exercise.
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Export and Remove the Site Definition

To reduce the potential for confusion, it’s a good idea to remove the defined sites of 
completed projects, leaving only the defined sites of current projects. 

As stated in the Interface chapter, removing a site from Dreamweaver does not 
delete the actual files and folders from your computer; it simply removes them from 
Dreamweaver. Rather than removing a site, however, you can export a site definition 
file — which you can later import to restore the same settings and options you already 
defined (as you did in the Interface chapter when you imported the ATC New site). 

As you work through the projects in this book, you will export and remove site 
definitions for completed projects so your site list remains manageable. You should get 
into this habit so you can quickly reinstate site definitions if necessary.

	 1.	 With the Moxie New site open in the Files panel, choose Manage Sites at 
the bottom of the Directory menu.

	 2.	 In the Manage Sites dialog box, choose the Moxie New site name, and then 
click the Export button.

This function creates a “.ste” file that stores the Dreamweaver site definition settings. 

	 3.	 Navigate to WIP>Moxie and click Save.

The Export Site dialog box defaults to the current site’s root folder. You can restore the 
site settings by importing the site definition file from this location.

	 4.	 In the Manage Sites dialog box, make sure Moxie New is selected and click 
Remove.

	 5.	 Click Yes to the warning to confirm the removal of the Moxie New site definition.

Remember, you are not deleting the files from the site; you are simply removing the site 
definition from Dreamweaver.

	 6.	 At the bottom of the Manage Sites dialog box, click Done.

As you work through the 
projects in this book, you 
export and remove site 
definitions for completed 
projects so your site list 
remains manageable. 
You should get into the 
habit of exporting site 
definitions before you 
remove them so you can 
quickly reinstate the site 
definitions if necessary.

Note:
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Project ReviewProject ReviewProject ReviewProject Review

 1. Briefl y explain why it is important to defi ne a Dreamweaver site fi le. 

 2. Briefl y explain the importance of creating a site fl owchart.

 3. Explain three different methods for creating a link to a page in the current site.

 1. The _______________ extension identifi es a 
Dreamweaver site defi nition fi le.

 2. The _______________ is the primary folder that 
contains all fi les and subfolders of a Web site.

 3. The _______________ is used to view 
and manage fi les that make up a site in 
Dreamweaver.

 4. _______________ is the process of improving a 
page’s ranking in search engine results pages.

 5. A(n) _______________ is the path from one 
image to another, beginning from the current 
location and moving up or down through 
folder paths to the target image.

 6. The notation _______________ tells 
Dreamweaver to move up one folder from the 
current location.

 7. The _______________ shows the ”path of 
tags” to the currently selected object.

 8. A(n) _______________ is an image in which 
different areas link to different destinations.

 9. The _______________ protocol is used to defi ne 
an email link.

 10. _______________ is the process of hiding 
certain fi les in the site so they are not uploaded 
to the Web server.
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Use what you learned in this project to complete the following freeform exercise. 
Carefully read the art director and client comments, then create your own design to meet the needs of the project.
Use the space below to sketch ideas; when fi nished, write a brief explanation of your reasoning behind your fi nal design.

Portfolio Builder ProjectPortfolio Builder ProjectPortfolio Builder ProjectPortfolio Builder ProjectPortfolio Builder Project

When I started working with our site fi les I noticed 
that none of the links exist anymore. I might have 
worked from an earlier version of the site fi les, but 
I’m not sure. Can you fi x this for me? Other than 
the navigation in the middle of the pages, there are 
a number of other places where links are necessary:

• On index.html, the words ‘take a photo tour’ 
should link to the tour.html page.

• On the individual tour pages, the ‘Back to View 
Homes’ image should link back to tour.html.

• On tour.html, the thumbnail images should 
each link to the appropriate tour page (those are 
numbered 01–10.html).

• At the bottom of tour.html, the words ‘Click 
here to print information fl yer’ should link to 
the PDF fi le in the site folder.

• On contact.html and amenities.html, the words 
‘click here’ (near the bottom of the page) should 
be an email link to pattic@romanaplace.biz.

Romana Place Town Homes is adding a 
photo tour to its Web site. Th e owner is fairly 
competent at building Web pages, but is 
having trouble fi nalizing the new site. Your job 
is to fi nish what he started in a professional, 
organized manner.

To complete this project, you should:

o Import the site fi les into Dreamweaver 
(from the DW5_PB_Project1.zip archive 
on the Student Files Web page).

o Analyze the content of the diff erent pages. 
Create a fl owchart to map the direction of 
links from one page to another in the site.

o Organize the site folder into a clear, 
understandable structure.

o Create the links from one page to another 
throughout the entire site.
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Th is project focused on two of the foundational elements of Web site design — organizing fi les and 
creating links. A well-organized site structure includes links that make it easy for users to navigate 
throughout the entire site. Dreamweaver makes it easy to manage the fi les in a site — renaming and 
moving them while maintaining the links between pages within the site. You also learned a number 
of ways to create links, for both text and images. Th e skills you used in this project will be required to 
complete virtually any site you create in Dreamweaver.

Create an image map 
to link to different 
areas of the site

Define accurate 
document titles 

Create a link to an 
external URL

Create an email link

Create navigation links to 
portfolio category pages

Copy and paste a list of 
text links

Create image links to 
product detail pages

Copy and paste 
tables of image links
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Digital Book Chapter
Against Th e Clock Inc. (ATC)
publishes textbooks for the graphic 
communications education market. 
In addition to application-specifi c 
books, the company also has a series 
of “companion” titles that discuss the 
concepts underlying the use of digital 
software — basic design principles, 
type, color, and so on. You were hired 
to build an “excerpt” booklet of the 
companion titles, which ATC will 
use on its corporate Web site. Visitors 
will be able to download and read the 
booklet free of charge. ATC believes 
this off ering will increase sales of the 
full line of ATC titles. Your task is to 
structure the content appropriately 
using HTML code.

Th is project incorporates the following skills:

o Incorporating text from external sources

o Working in both Design view and Code view to add 
appropriate HTML tags

o Organizing content with appropriate heading tags

o Properly formatting block quotes and citations

o Adding special characters that work in HTML code

o Creating lists and tables within text-based content

o Attaching a CSS fi le to new pages




