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Moxie Digital Portfolio
Your client, David Monroe, is the 
owner of Moxie Photographic 
Studios. He already has a basic Web 
site for his business, but he has hired 
you to organize and implement a new 
set of digital portfolio pages. 

Th is project incorporates the following skills:

o Examining the existing and new site contents

o Creating, exporting, and removing site defi nitions in 
Dreamweaver

o Creating a fl owchart to plan the new site organization 

o Moving fi les around in a site root folder

o Creating relative links between pages in a site

o Defi ning absolute links to external sites and email addresses

o Creating image links and image maps

o Improving searchability with fi le names and titles

o Hiding site fi les from a Web server
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The Project Meeting
My basic Web site used to be enough of a 
digital presence, but lately I’ve been getting a 
lot of phone calls from potential clients, asking 
what types of photography I do and ordering 
samples of my work. Even though I think the 
physical prints have a stronger visual impact, 
it’s getting expensive to send hard-copy samples 
in the mail — and a number of potential 
clients have specifically asked for a digital 
portfolio instead of prints.

I already created the Web pages for my new 
digital portfolio, but I don’t know what links 
to use, and I’m not sure how to create them. 
I’ve also heard that there are certain things you 
should do to improve a site’s search engine 
rating — which is obviously important for a 
small business like mine.

This project underscores the importance of a 
well-organized Web site. Moxie’s existing site 
is simple, so you can drop everything into the 
root folder. But the more pages you add to a 
site, the more complex it becomes — until it’s 
almost impossible to make sense of what you 
have where. All Web sites — even those with 
only a few pages — should be designed with 
a good organizational plan, making it much 
easier to add or modify pages later. 

Once you have a handle on the organization, 
make sure the pages link to each other 
properly. Visitors get frustrated very quickly 
when they’re forced to return to the home page 
every time they want to jump to a different 
set of pages. You need to build links between 
the different pages in the site, as well as add an 
external link and email link so that users can 
easily contact our client.

The last thing you should do is add page 
titles and change file names to give a better 
indication of what’s on each page. That will 
make the site more accessible to people with 
screen-reader software, and it will also improve 
the site’s ratings on search engines.

To complete this project, you will:

o Create a Dreamweaver site definition  
and export old site definitions

o Plan site organization using a flowchart

o Create new folders within the site root 
folder

o Use various methods to move files from  
one place to another within the site

o Create links between pages using several 
techniques available in Dreamweaver

o Differentiate between relative and  
absolute links

o Copy and paste uniform links from  
one page to another within the site

o Create image map hotspots and links

o Improve searchability and usability using 
page names and titles

o Cloak site files to hide them from the  
Web server



11Project 1: Moxie Digital Portfolio

Stage 1 Exploring Existing Site Structure
When you start a new project that involves updating an existing site, your first task is to assess the file 
and folder structure. Doing so gives you a good idea of what the site contains. 

A small site with only a few pages requires very little organization; in fact, you can usually place all 
of the files (Web pages and image files) in one folder. Larger sites, however, require careful organization 
of file names, Web pages, and image files. A good site design with excellent organization speeds 
development now, and also makes it much easier to update the site later. 

create a site Definition

Web sites are designed so that all of the Web pages, image files, style sheets, and other 
resources are found under a common (root) folder. The root folder of a Web site is its base 
folder. For example, if you open your browser and go to CSSZenGarden.com, the page 
you see in your browser is found in the root folder of the Web site. Other folders can also 
be placed inside (below) the root folder of the Web site, such as an images folder. 

 1. Copy the Moxie folder from the WIP folder on your resource CD to your 
WIP folder where you will save files.

 2. Copy the contents of the RF_Dreamweaver>Moxie folder into your 
WIP>Moxie folder.

The files for this project need to be in a location where you can save changes, which is 
not possible when working directly from the resource CD. When you work through the 
exercises in this project, you should only access the files from your WIP>Moxie folder 
and not from the RF_Dreamweaver>Moxie folder.

 3. Launch Dreamweaver. If your screen does not look like the image shown 
below, choose Window>Workspace Layout>Default (Macintosh) or 
Window/Workspace Layout>Designer (Windows) to revert the interface to 
the default settings.

Menu bar 

Insert bar 

Welcome Screen 

Panel groups 

Properties Inspector

If the Welcome Screen 
is not visible, you can 
choose Dreamweaver> 
Preferences (Macintosh) 
or Edit>Preferences 
(Windows), choose the 
General category, check 
the Show Welcome Screen 
option, and click OK. 
After you quit and then 
relaunch the application, 
the Welcome Screen will 
be visible.

Note:
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 4. In the Files panel, click Manage Sites or open the Directory menu and 
choose Manage Sites.

If available, clicking 
Manage Sites opens the 
Manage Sites dialog box. 

This option performs the 
same function as clicking the 
blue Manage Sites link to 
the right of the Directory list.

 5. In the Manage Sites dialog box, click the New button and choose Site from 
the pop-up list.

 6. If the Site Definition dialog box appears in its basic form (as shown below), 
click the Advanced tab at the top of the dialog box.

Dreamweaver offers two ways to create a site definition. The basic form offers only the 
basic functionalities, while the advanced form offers additional options. You will use the 
advanced form in this book.

The basic version of the Site Definition 
dialog box uses a wizard-like method to 
help you define a new site. Although 
the basic version might be a little easier 
to configure for the first time, it does 
not offer any of the advanced options; 
once you have defined a site or two, it’s 
faster to use the advanced version of 
the Site Definition dialog box. 

 7. In the Site Name field, type “Moxie Old”.

The site name in Dreamweaver does not need to be the Web site’s URL (uniform 
resource location, which is the Internet address of a Web site, Web page, image, style 
sheet, or any other Web resource file). The site name can be any name that will allow 
you to easily recognize the Web project. 

This site name is only for the site identification within Dreamweaver. For example, you 
could use “Jimmy’s Web site” as the site name within Dreamweaver to describe the Web 
site (bbq-tips.com) you are creating for your friend (Jimmy). 

In the Directory menu, 
sites that have already 
been defined appear 
below the drives on 
your computer and/or 
network. Simply choose 
from this list to switch to 
another site.

Note:
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 8. Click the folder icon to the right of the Local Root Folder field.

Click here to define the 
root folder location.

Part of the process of defining a site within Dreamweaver is to specify a particular 
folder as the root folder of the Web site. Clicking the Local Root Folder button opens a 
navigation dialog box where you can find the folder you want to use.

 9. Navigate to the WIP>Moxie>old folder and click Choose/Select.

There is no default images folder defined in this exercise, so that portion of the Site  
Definition dialog box does not need to be set. You aren’t required to insert the URL  
of the Web site either.

 10. Click OK to close the Site Definition dialog box.
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 11. In the Manage Sites dialog box, make sure the Moxie Old site appears in the 
list of sites, and then click Done.

The Manage Sites dialog box can be used for more than just creating new site 
definitions. The most common uses are editing an existing site definition (to correct 
spelling or add new properties to the site definition) and removing a site definition once 
you’ve finished the site. 

 12. Continue to the next exercise.

The Remote Info category allows you to specify the Web 
server on which the final version of the pages you create 
will be loaded. You enter the method of transfer such as 
FTP (File Transfer Protocol), as well as the password and 
username for uploading your site to the remote server.

The Testing Server category is used to specify the pro-
gramming language used on a local server. In a corporate 
environment, your local computer is typically used for 
development purposes (a development server), and the 
remote server is the production server. In this environment, 
you use the Testing Server category to specify the location of 
the development server and its features.

The Cloaking category allows you to enable or disable 
cloaking and set cloaking file types. Cloaking is a feature 
of Dreamweaver that allows you to prevent certain files or 
folders from being uploaded to your Web server, such as files 
that contain preliminary information that you don’t want 
site visitors to see.

The Design Notes category allows you to specify whether 
you want to keep and share design notes. Design notes 
contain information about a site, such as what changes are 
unfinished or how a particular price was set. These notes 
are meant to be shared with other designers; they do not 
upload to the Web site.

The Site Map Layout category allows you to manage the 
layout of the site map, which is an alternative to the Files 
panel; it displays the pages in your site and allows you to 
see links between the pages. When you view the files on 
your site using the expanded view, in addition to file names, 
you can also see other properties of the files such as file size 
and modified date. The File View Columns category allows 
you to enable and disable these and other columns, as well 
as change the column order.

Contribute is an Adobe application designed for 
organizations where many people contribute content to a 
Web site, but they are not responsible for its design. The 
Webmaster controls the permissions and the design of the 
site. The Contribute category enables compatibility of the 
site with the Contribute application.

The Templates category allows you to prevent 
Dreamweaver from changing the relative paths to files 
located in the Templates folder. This little-used feature has 
been added to the application in response to Dreamweaver 
users who encountered problems with their designs.

The Spry category allows you to define the default Spry 
assets folder location.
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Advanced Site Definition Categories
In addition to the local information (the site name, root folder location, etc.), you can define a large number of advanced 
options in the other categories of the Advanced Site Definition dialog box.



15Project 1: Moxie Digital Portfolio

examine the olD site

One aspect of defining a Web site in Dreamweaver is that the application reads all of 
the pages in the site (a process that can take a few minutes in a large site) and notes the 
links between pages and which images are in which pages. These associations between 
files are stored in a cache that Dreamweaver creates when a new site is defined. 
When pages are either renamed or moved from one folder to another, Dreamweaver 
recognizes that other pages and image files are related to the moved or renamed files, 
and the program prompts you to update the links in all of the affected files.

 1. With Moxie Old showing in the Directory menu of the Files panel, examine 
the files in the Moxie Old site folder. 

If you can’t see the list of files or the list does not match the one shown here, 
click the down arrow/+ to expand the site folder and show the file list.

There are only 15 files in the root folder: 5 HTML documents, 9 GIF files (GIF is an 
acronym for Graphic Interchange Format, one of the Web-ready image file formats),  
and 1 CSS file (CSS is an abbreviation for Cascading Style Sheets, a file that sets the 
style and design properties of the Web site). 

Click and drag the header 
edge to make the column 
wider or narrower. 

This is the root folder 
of the current site.

Click this button to 
expand the folder.

Click here and drag left 
to make the panel wider.

 2. Double-click index.html to open the file in Dreamweaver.

When a browser 
downloads a Web page, 
it reads the code of the 
page, requests the image 
files from the defined 
locations, and displays 
them within the page 
for the visitor. In Project 
3, you learn more about 
image files and how 
they are referenced in 
Web pages. For now, 
you should know that 
images in Web pages are 
not embedded into Web 
pages; they are merged 
into the Web page by the 
browser.

Note:

When a site is defined 
in Dreamweaver, the 
Manage Sites link at the 
top of the Files panel is 
replaced by a menu that 
defaults to Local view. 
A series of buttons also 
appears below the two 
menus.

Note:
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 3. Choose File>Preview in Browser and select your preferred browser to 
preview the page.

 4. Click the links in the top banner image to explore the old site.

By default, the Files panel displays the 
files on your local computer. You can also 
choose to view the files on the remote 
or testing servers by selecting those 
options from the View menu, or you 
can select Map view to see a graphic 
representation of your site structure.

The top of the Files panel also includes 
buttons that allow you to manage the files in your site. 

•	 The	Connect to Remote Host button establishes a 
connection with the remote server (if you have defined 
it). Otherwise, clicking this button opens the Site 
Definition dialog box.

•	 The	Refresh button refreshes the file list that is 
displayed in the panel.

•	 The	Get Files button copies the selected files from 
the remote server to the local folder. If the Enable File 
Check In and Check Out option is active, the copied files 
are available on the local site in read-only mode, which 
means you can’t modify them. You must click the Check 
Out Files button to edit the files.

•	 The	Put Files button copies the selected files from the 
local folder to the remote server. If a new file is added 
to the server, and if the Enable File Check In and Check 
Out option is active, the file’s status is Checked Out.

•	 The	Check Out Files button copies the selected files 
from the remote server to the local folder and locks the 
files so only the user who checked out those files can 
edit them.

•	 The	Check In Files button copies the selected files 
from the local folder to the remote server and makes the 
copied files read-only in the local folder. To edit these 
files, you need to select them and click the Check Out 
Files button. 

•	 The	Synchronize button synchronizes the files between 
the local folder and the remote server so the same 
version of the files appears in both places.

•	 The	Expand button shows both local files and the 
remote site (if one has been defined). The expanded 
Files panel has two panes. The left pane displays the 
files on the remote or test server; the right pane displays 
the site files on the local computer.
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The Files Panel in Depth

Expand to Show Local 
and Remote Sites 

View menu 

Synchronize 

Check In Files 

Check Out Files 

Directory menu 

Connect to Remote Host 

Refresh 

Get Files 

Put Files 

Press Option-F12/F12 to 
preview a page in your 
primary browser. Press 
Command/Control-F12 
to preview the page in 
your secondary browser.

Note:
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 5. Close your browser and return to Dreamweaver.

 6. In Dreamweaver, choose File>Close to close index.html.

You can also close a document in Dreamweaver by clicking the red Close button in the 
top-left corner (Macintosh) or the “X” Close button in the top-right corner (Windows) 
of the document window.

 7. Continue to the next exercise.

exPort anD remove a site Definition

As you gain experience designing and developing Web sites, your site definition list will 
continue to grow — and a longer list becomes increasingly difficult to manage. To keep 
your list under control, you can remove or export old site definitions from the list. 

When you remove a site definition, you are not deleting the actual files and folders 
from your computer; you are simply removing their registration from Dreamweaver’s 
site definition list. This way, when you need to work on a site you created last year, for 
example, all you need to do is reinstate the appropriate site definition settings. 

Rather than simply removing a site definition from Dreamweaver, you can export 
a site definition from the Advanced options in the Site Definition dialog box. When 
you export the site definition, you can later import that definition to restore the same 
settings and options that you already defined. 

 1. With the Moxie Old site showing in the Directory menu of the Files panel, 
choose Manage Sites from the bottom of the panel Directory menu.

To change which browsers are 
available in the Preview menu, use 
the Preview in Browser pane of the 
Preferences dialog box. (Choosing 
Edit Browser List in the File>Preview 
in Browser submenu opens this pane 
directly.) You can also define the 
primary and secondary browsers, 
which can then be accessed using the 
associated keyboard shortcuts.
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Browser Preferences

Click here 
to remove a 
browser.

Click here to 
add a browser 
to the list.

Designate 
primary and 
secondary 
browsers.

As you work through 
the projects in this book, 
you remove the site 
definitions for previous 
projects so that your site 
list remains manageable. 
You should also get into 
the habit of exporting 
site definitions before you 
remove them so you can 
quickly reinstate the site 
definitions if necessary.

Note:
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 2. In the Manage Sites dialog box, click the Moxie Old site name, and then 
click the Export button.

 3. Make sure the current folder is WIP>Moxie>old and click Save.

This function creates a “.ste” file that stores the Dreamweaver site definition settings. 

 4. In the Manage Sites dialog box, make sure Moxie Old is selected in the list, 
and then click Remove.

 5. Click Yes to confirm the removal of the Moxie Old site definition.

After exporting the settings, you can easily remove the site definition from the list. 
Remember, you are not deleting the files from the site; you are simply removing the site 
definition from Dreamweaver.

 6. At the bottom of the Manage Sites dialog box, click Done.

When you want to reinstate the site definition, simply click the Import button, navigate 
to the root folder of the site you want to reinstate, and import the .ste file. All of the 
settings will be reinstated — saving you a great deal of time and effort.

 7. Continue to the next exercise.
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create the neW site Definition for moxie

As a Web site designer, you’ll find that sites are in constant flux. The small changes 
you make will require little (if any) reorganization. When you make large changes, 
however, you must check to ensure that everything works properly, with no broken 
links or empty pages. 

In this exercise, you’ll see that the portfolio pages and files were simply dropped 
into the Web site’s root folder — a very poor organizational choice when making such 
a large change to the site. Your job is to correct this organizational error.

 1. Choose Manage Sites from the Directory menu in the Files panel.

 2. Click the New button at the top of the Manage Sites dialog box and choose Site.

 3. Make sure the Advanced tab of the Site Definition dialog box is showing, 
and type “Moxie” in the Site Name field.

If no one has used your workstation since you completed the previous series of exercises, 
and if you haven’t done anything else in Dreamweaver, the Site Definition dialog box 
automatically opens in Advanced mode; Dreamweaver remembers the last-used state of 
the dialog box.

 4. Click the button to the right of the Local Root Folder field. Navigate to the 
WIP>Moxie>new folder and click Choose/Select.

 5. At the bottom of the Site Definition dialog box, click OK.

 6. At the bottom of the Manage Sites dialog box, click Done.

 7. Continue to the next exercise.
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examine the neW site files 
There are many files in the messy and disorganized Moxie New folder. The first step 
in organizing the new portfolio files is to examine the Web page files and understand 
what they contain.

 1. With the new Moxie site showing in the Directory menu of the Files panel, 
expand the site root folder and examine the files in the site.

There are 95 files in the root folder: 26 HTML files, 52 JPEG (an image file format) 
files, 14 GIF files, 1 CSS file, 1 Word document (.doc file), and 1 Photoshop image file 
(identified by the “.psd” extension). Except for the Word and Photoshop files, all of the 
files in the folder are Web-ready.

 2. Open portfolio.html by double-clicking the file name in the Files panel.

This page is identified as the portfolio page by its file name, as well as by the word 
“portfolio” in blue letters at the top of the page. (The designer of this site used blue 
to identify the current page.) This page is also the gateway page for the different 
photographic portfolios that your client wants to promote: commercial jewelry, fashion 
catalogs, food, and music industry. These words will serve as the links to the portfolio 
pages for these categories.

The word “portfolio” is blue, 
indicating that the current page is 
part of the portfolio group of pages.

Each of these lines of text will be a 
link to the respective portfolio page.

“David Monroe” will become an email 
link to your client’s email address.

“Pro Techniques” will be a link to the 
Web site of the original site designer.

The top banner image will be made 
into an image map, with each 
phrase defined as a hotspot link to 
a different page.
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 3. Close portfolio.html and open 01.html by double-clicking the file name in 
the Files panel.

This page is the gateway page to the jewelry photographs that David Monroe wants to 
display. From the appearance of the four images in the middle of the page, there are four 
jewelry photographs available for this portion of the portfolio. Each of the four lines of 
text in the top left of the page will be a link to another portfolio on the site.

Each of these lines of text 
will be a link to the home 
page for that category of 
Monroe’s portfolio.

Each of these images will be 
made into a link to open a 
page with a larger version of 
the associated photo.

 4. Close 01.html. One by one, open 02.html, 03.html, 04.html, and 05.html 
and examine the content of the files.

These four Web pages display larger photographs that make up the jewelry section of the 
portfolio.

Each of these images 
will be made into a 
link to open the 
associated Web page. 

 5. Close any open files from the previous step and, one by one, open 06.html, 
11.html and 16.html.

These pages are the gateway pages to the fashion, food, and music collections of 
portfolio photographs. Similar to the jewelry collection, there are four photographs (and 
pages) for each portfolio collection.

 6. Close any open files, and then continue to the next exercise.
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Plan folDer organization 
Although it is possible to put 95 files in the root folder of a Web site, managing the 
files this way would be very challenging. A well-organized site is an easy-to-manage 
site. Ideally, organization occurs before the site is constructed, but you can certainly 
add organization to sites that already exist.

There are no absolute rules to follow for organizing files and folders — other than 
the general principle of keeping related components together so you know where to 
find certain files when you need for them.

In this exercise, you use a paper and pencil to sketch out a plan for organizing 
the site’s files. As you become more comfortable with this process, you will be able 
to complete this process in your head — but having a sketch allows you to clearly 
communicate your ideas to your client. 

 1. With the Moxie site showing in the Directory menu of the Files panel, double-
click index.html in the panel to open that file in a new document window.

 2. Get a piece of paper and a pen or pencil and write “Moxie Photographic 
Studios” at the top of the paper.

The original pages of this site (home page, about us, contact us, etc.) serve the most 
important functions of the site: telling the reader who we are, what we do, what have 
we done before, and how to contact us. These basic pages form the root of the site, and 
should therefore appear within the root folder of the site.

Many different file types can be found on the Internet. The 
basic document is an HTML file, which can have either 
.htm or .html as the file name extension. The most common 
image file types are GIF and JPEG (Joint Photographic 
Experts Group, with the extension of .jpg or .jpeg). 

In addition to GIF and JPEG, PNG (Portable Network 
Graphics) image files are gaining in popularity. 

The most recent image file type is SVG (Scalable Vector 
Graphics); code in an SVG file tells the browser how to draw 
shapes on screen. This format is supported only by recent 
versions of the Firefox and Opera browsers.

CSS (.css) files contain instructions that tell browsers how to 
display information in associated Web pages.  

JavaScript (.js) files are similar to CSS files in that their 
content is not normally seen; instead, JavaScript content 
is responsible for the behaviors and animation effects that 
appear in a browser.

Many Web pages that appear to be HTML files have 
extensions such as .cfm, .php, .jsp, .asp, or .aspx. These 
extensions are reserved for Web pages generated by 
programming code—otherwise known as dynamic pages. 
For example, if you are a registered member of a particular 
Web site, you might see “Welcome back, Susan!” at the 
top of the page. The programming code in that particular 
page reads your browser’s cookie, retrieves your name from 

the members’ database, and inserts your name into the 
appropriate place on the page. If you viewed the page code, 
it would appear to be standard HTML — and it is, except 
that parts of the page were generated by programming 
code that replaced “Welcome back $personal_name!” with 
“Welcome back, Susan!” 

The extension .cfm is associated with the Cold Fusion 
pro gramming language; .php is associated with the PHP 
(PreHypertext Processor) programming language; .jsp is 
associated with Java Servlet Pages (a lan guage based on 
Java); and .asp and .aspx are associated with Microsoft 
Active Server Pages (ASP) and ASP.Net respectively.

Some file formats require browser plugins (accessory pro-
grams built into your browser). Flash (.fla) is an animation 
format that you can use to create basic animations, as well 
as play videos and interact with databases such as a hotel 
reservation system. Shockwave (.swf) is a relative of Flash, 
used to create Web-based games. 

Various video formats (.wmv, Windows Media Video and .qt, 
Quicktime) and audio formats (.mp3) are also found on the 
Web. Some Web-based video and audio files can only be 
viewed (or heard) while your browser is connected to the 
Internet (known as streaming video or audio); other video 
and audio files must be downloaded before you can see/
hear them. This is not related to the file type, but rather to 
the code that tells the Web page how to handle the files. 
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File Types on the Web
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 3. Write “Root (/) folder –” near the top of the paper. To the right of the 
hyphen, write the following list:

/index.html

/clients.html

/services.html

/contact.html

/whatis.html

 4. Below the last HTML file, write “/styles.css”. 

This CSS (Cascading Style Sheets) file describes the style properties of the pages in the 
site; the style file should also appear in the root folder of the site. While it is common 
practice to put the style file in the root folder of a site, if there are multiple CSS files, 
you typically create a styles folder to hold all of the CSS files for the site. 

 5. In Dreamweaver, examine the graphic images in the index page.

The animated image in the middle left and the large Moxie logo in the middle right are 
used in the index page. 

The bottom banner image appears in every root page. 

The top banner image is slightly modified for each root page. 

Other root pages (whatis.html, clients.html, etc.) include other images that are specific 
to those pages, so those images should be near the root pages. 

Top banner image 

Animated image 

Moxie logo image 

Bottom banner image 

 6. Below the list of Web pages on your paper, write “/images/ folder –”. To the 
right of the hyphen, list the images that appear in the root pages of the site. 

The format /images/ means an images folder will be created in the root folder of the 
site. By coincidence, all of the image files that are common to the root pages are in 
GIF format. (In fact, all GIF files in the site — with the exception of commjewelry.gif, 
fashioncat.gif, food.gif, and music.gif — will go into the root images folder.)

The leading forward 
slash (/) is a standard 
representation for the root 
folder; all of these files 
appear within the root 
folder of the Web site.

Note:

The file name “index.
html” is the file-naming 
convention for the home 
page of the Web site or 
the default page of a 
specific folder. 

Note:

Dreamweaver does not 
allow animations to run, 
so only the first frame of 
the animation (the word 
“energy”) is visible.

Note:
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 7. Below the list of GIF image files on your paper, write “/resources/ folder –”. 
To the right of the hyphen, list the Word file (portfolio notes.doc) and the 
Photoshop file (portfolio images.psd).

The Word and Photoshop files contain preliminary information that helped the designer 
build the portfolio Web pages, but these files are not part of the Web site. While you 
might be tempted to simply delete these files, there are various techniques for keeping 
these background or resource files without including them within the Web site. You’ll 
learn one of these methods later in this project.

 8. On the paper, write “/portfolio/ folder – ”. To the right of the hyphen, write 
“portfolio.html”.

You might wonder why this page doesn’t stay in the root folder. The reasons for keeping 
it in the root folder or moving it into its own folder are equally strong. Because there are 
many other portfolio pages with images of individual photos, the portfolio group of files 
is best placed within its own folder.

 9. Below portfolio.html, write (on separate lines):

/jewelry/ folder

/fashion/ folder

/food/ folder

/music/ folder

/images/ folder

Each portfolio category is assigned its own folder. The page 02.html contains a  
jewelry photograph; when moved to its appropriate folder, the page will be located  
at /portfolio/jewelry/02.html. All of the portfolio images will be moved into the  
/portfolio/images/ folder so that they all remain together. 

This is how our organizational mockup looks:

 10. Close index.html, and then continue to the next exercise.

If the number of portfolio 
images grows to a much 
larger number, it might 
be beneficial to create 
an image folder for each 
portfolio category (such 
as /portfolio/jewelry/
images/). That way, the 
specific images for the 
pages in the /portfolio/
jewelry/ folder would be 
located nearby, making it 
easier to find and change 
the images or pages if 
necessary.

Note:
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create folDers

Once you have mapped a clear plan for organizing your site, you can begin to 
implement that plan by creating new folders in Dreamweaver. 

 1. With your Moxie site open in the Files panel, scroll to the top of the Files 
panel and click to select the site name at the top of the list.

 2. Control/right-click the site name and choose New Folder from the pop-up menu.

 3. Type “images” and press Return/Enter to apply the new folder name.

SEO (search engine optimization) is the art of improving  
the ranking of a Web site and its pages within SERPs 
(search engine results pages, or the pages that list the 
results of a search). Search engines certainly use the content 
of a page for ranking purposes, but they also use folder and 
file names. Putting portfolio pages within a portfolio folder 
improves the ranking of those pages. 

Many content management systems (CMS) and blogs 
manipulate the URL of a page so that the URL contains  
the title of the article. For example, an article on 
WebStandards.org titled Scared of the Dark? can  
be found at http://www.webstandards.org/2006/05/10/
scared-of-the-dark/. In addition to the article title, you can 
see in the URL that the article was created on May 10, 

2006. Each portion of the URL in this example displays 
searchable content, and the URL provides meaningful 
information for search engines and users alike.

Compare the WebStandards.org URL with http://www.gov.
on.ca/ont/portal/!ut/p/.cmd/cs/.ce/7_0_A/.s/7_0_24P/_s.7
_0_A/7_0_24P/_l/en?docid=EC002001which (believe it or 
not) is the URL of the English homepage of the Government 
of Ontario Web site. To a search engine, this complicated 
URL doesn’t mean anything, and therefore this type of URL 
doesn’t rank highly in SERPs.

When planning the organization of a Web site, carefully 
consider the folder and file names so they are not a 
hindrance to good search engine ranking.
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Search Engine Optimization Considerations

If after pressing  
Return/Enter, the folder 
name remains untitled, 
Control/right-click the 
untitled folder, choose 
Edit>Rename (or press 
F2), and correct the 
name.

Note:
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 4. In the Files panel, click the Refresh button.

When folders and files are created, they appear at the bottom of their containing folders. 

On Macintosh, Dreamweaver alphabetizes folders along with all other files and folders; 
on Windows, Dreamweaver alphabetizes folders at the top of the list (above individual 
files); refreshing the site forces Dreamweaver to sort the files and folders into their 
preferred order.

On Windows, folders 
are alpabetized at the 
top of the site list, 
above individual files.

On Macintosh, folders 
are alphabetized 
along with all other 
files in the site.

Refresh button 

 5. Control/right-click the site folder at the top of the Files panel and choose 
New Folder again.

 6. Type “resources” and press Return/Enter to apply the new folder name.

 7. Add another new folder named “portfolio” to the site. 

 8. Control/right-click the new portfolio folder and choose New Folder.  
Type “images” and press Return/Enter.

By selecting an existing folder before creating a new folder, the new folder is created 
under the selected folder.

Press F5 to refresh the file 
list in the Files panel.

Note:
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 9. Add four more folders to the portfolio folder: “jewelry”, “fashion”, “food”, 
and “music”.

 10. Click the Refresh button at the top of the Files panel.

 Windows Macintosh

     

 11. Continue to the next exercise.

sort anD move image files 
Now that you’ve created the required folder structure, you can begin to sort the various 
files into their appropriate folders. You can drag one image at a time, or you can move 
multiple images at once. In this exercise, you continue to reorganize the existing site by 
moving the images to the folders you created in the previous exercise.

 1. With your Moxie site open in the Files panel, click and drag  
banner_clients.gif into the main images folder in the root folder  
(not the /portfolio/images/ folder).

Make sure you drag the file over the name of the folder or folder icon; if you drag the 
file too far to the left or right, Dreamweaver will not move the file.
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 2. Click Update to update the clients.html page with the new location for the 
banner_clients.gif image file.

By using the Files panel to move the image file to another folder, Dreamweaver is able to 
check its cache, note that clients.html refers to banner_clients.gif, and request that you 
update the HTML file to use the new location of the image file. 

If you chose Don’t Update, the image will not appear in the clients.html page. If 
you had moved the image file using Windows Explorer or the Macintosh Finder, 
Dreamweaver would not be aware of the movement and you would not have the 
opportunity to automatically adjust the path to the image file in clients.html.

List of files affected 
by moving the 
image file 

 3. Examine the images folder in the Files panel.

The banner_clients.gif file is now stored in the images folder.

 4. Double-click clients.html to open the file, and then examine the top banner 
in the page.

The top banner should appear as shown here. Dreamweaver adjusted the necessary code 
so the page can continue to use any of the moved image files.

 5. Close clients.html.

 6. Drag bottom_banner.gif into the main images folder.

 7. Click Update to update all of the files that use the bottom_banner.gif  
image file.

All of the pages in this project use this image file, so all of the pages must be updated 
with the file’s new location. The update process will take a while to complete because 
many files need to be updated. 

The bottom banner image 
appears in every page, so every 
page must be updated with 
the file's new location. 

The same concept applies 
if you rename a file in 
the Files panel; you will 
have the opportunity to 
automatically update  
all references to the 
renamed file.

Note:
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 8. Click banner_contact.gif, and then Shift-click banner_what.gif to select the 
five contiguous image files.

You can move multiple files into a folder at the same time. The trick is to learn how to 
select multiple files at once. To select files that are grouped together (contiguous), simply 
click the first one and then Shift-click the last one; all files between the first and last are 
selected too. 

 9. Drag the selected image files to the images folder, and then click Update to 
update the Web pages affected by the move.

 10. Click homewords.gif, Command/Control-click MoxieLogo.gif, and 
Command/Control-click whatis.gif to select the three files. 

If files are separate (non-contiguous), click the first one, then Command/Control-click 
each additional file you want to select.

 11. Drag one of the selected image files to the main images folder.

If you can’t see the images folder at the top of the Files panel, drag the selected files 
to the top visible file name in the Files panel, and then the file list will scroll until the 
images folder becomes visible.

 12. Click Update when you see the Update Files dialog box.

You can also use 
Command/Control-click 
to deselect a selected 
file. For example, if you 
select a file by accident, 
you can deselect it by 
Command/Control-
clicking the file name. 

Note:
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 13. Open index.html by double-clicking the file name in the Files panel. 
Examine the page in Dreamweaver.

The index.html page contains four of the image files you moved: banner_index.gif, 
homewords.gif on the left (where the word “energy” appears), MoxieLogo.gif to the 
right, and banner_bottom.gif at the bottom. 

banner_index.gif 

homewords.gif 

MoxieLogo.gif 

banner_bottom.gif 

 14. Close index.html.

 15. In the Files panel, click the down-facing arrow (Macintosh) or the “–” symbol 
(Windows) to the left of the images folder name to collapse the folder.

On Macintosh, expanded folders show a down-facing arrow; clicking that arrow 
collapses the folder and changes the arrow to face to the right. You can click a right-
facing arrow to expand a folder and show its contents.

On Windows, expanded folders show a “–” symbol; clicking that symbol collapses the 
folder and changes the “–” to a “+” symbol. You can click a “+” symbol to expand a 
folder and show its contents.

 Windows Macintosh

Collapsed folder 

Expanded folder 

Collapsed folder 

Expanded folder 

 16. Continue to the next exercise.
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cut anD Paste resource files

Just as there are multiple ways to select files, there are many ways to move files into 
or out of folders. In this exercise, you use the Cut and Paste functions to move files to 
new locations.

 1. With the Moxie site open in the Files panel, scroll to the bottom of the files list.

 2. Click once to select portfolio images.psd, and then Shift-click to select 
portfolio notes.doc.

 3. Control/right-click one of the selected files and choose Edit>Cut from the 
contextual menu.

The cut files will still be visible until you paste them in the next step.

 4. Scroll to the top of the Files panel and click the resources folder to select it.

 5. Control/right-click the resources folder and choose Edit>Paste to paste the 
cut files into the selected folder. Update links to the moved files when asked.

 6. Click the Refresh button at the top of the Files panel.

 7. Click the down-facing arrow (Macintosh) or “–” symbol (Windows) to 
collapse the Resources folder.

 8. Continue to the next exercise.

You can cut selected text, 
images, or files using 
Command/Control-X; 
copy using Command/
Control-C; or paste using 
Command/Control-V. 

Note:

Press F5 to refresh the 
file list.

Note:
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organize the Portfolio Pages

Moving files from one folder to another is just as easily done in Dreamweaver’s Files 
panel as it is using the file management software of your operating system. However, if 
you moved files using Finder (Macintosh) or Explorer (Windows), the links between 
pages and to image files would not be updated to accommodate the new paths. 

 1. With the Moxie site open in the Files panel, move portfolio.html into the 
portfolio folder and click Update when prompted.

 2. Move the files 01.html through 05.html into the portfolio/jewelry folder 
and update the links.

When you move files into a folder, that folder is automatically expanded in the Files panel.

 3. Collapse the jewelry folder.

 4. Move 06.html through 10.html to the portfolio/fashion folder, update the 
links, and collapse the fashion folder.

 5. Move 11.html through 15.html to the portfolio/food folder, update the 
links, and collapse the food folder.

 6. Move 16.html through 20.html to the portfolio/music folder, update the 
links, and collapse the music folder.

 7. Move all of the JPG image files beginning with CJ, FC, FO, and MI  
(48 image files in total) to the portfolio/images folder. Update the links.

 8. Move the following files into the portfolio/images folder and update  
the links:

commjewelry.gif fashioncat.gif food.gif music.gif

port_cj.jpg port_fc.jpg  port_fo.jpg  port_mi.jpg
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 9. Collapse the images folder.

From the folder structure alone, the Web site appears to be better organized. You now 
know what to expect when you open each folder.

 10. Continue to the next stage of the project.

Stage 2 Organizing the Site Navigation
Virtually all Web pages have links to other Web pages. Hyperlinks (the official term for links) can be 
created to link pages on a site to other pages within the same site, or to pages in other sites. Although 
it is relatively easy to create links between pages of your site, you shouldn’t go overboard by creating 
more links than necessary. For example, you don’t need to include a link between every page on a 
site; using this method to set up a large site would result in thousands of links on every page. A much 
better plan is to decide which links on any given page will help the user better navigate your site. 
Exploring similar sites can provide some inspiration; but ultimately, you must carefully plan the flow 
of links and connections between pages—always keeping the reader’s usability in mind. 

create a floWchart of links

Creating a flowchart of links between pages is an excellent exercise in planning the 
relationships between pages of a site. Organizing links is a simple application of a 
science called information architecture, which is the organization of a Web site to 
support not only usability, but also “findability.” As you organize site links, remember 
that your goal is to enable visitors to see a pattern in your links, which will assist them 
in navigating through your site.

Not every link in a site can be planned ahead of time because some connections 
are irregular. For example, the history department of a university site provides links 
to the courses offered. Some of those courses have prerequisite courses. It would be 
very useful to link each course to its prerequisites; but because prerequisite courses are 
irregular, it might be difficult to accurately sketch them in a flowchart. Instead, you 
can establish a general principle that all courses with prerequisite courses must provide 
links to those prerequisite courses.

In this exercise, you create a basic flowchart of links between pages in your site. 
While it might seem simplistic to sketch links between pages, in fact, the more 
complicated your Web site becomes, the greater the need to create a flowchart.

Creating flowcharts 
should not be considered 
a tool for novice 
designers. Flowcharts 
are often used to map 
complex software 
programming and Web 
site development. In 
fact, a language called 
UML (unified modeling 
language, a standardized 
graphical notation that 
can be used to create 
models of systems) has 
been developed by 
professionals specifically 
for this purpose.

Note:
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 1. On a sheet of paper, write “Moxie Photographic Studio” at the top.

 2. On a line below, write “Home”, “What Is”, “Services”, “Clients”, 
“Portfolio”, and “Contact”.

These primary pages should be accessible from every page on the site, including the 
individual portfolio pages; the banner image at the top of every page provides these links. 

 3. Draw arrows from “Home” to each of the other five page names.

You can’t know how visitors will enter your site; they might enter from the home page, 
the contact page, or the portfolio page. For that reason, you should provide access to all 
of the primary pages from the other primary pages.

To be technically thorough, you might also create lines from each root page to the other 
root pages. However, as you can see, that can get messy and nearly incomprehensible; 
the first set of arrows is enough if you understand the idea that all pages should link to 
all other pages at the same level.

Moxie Photographic Studio

Home What Is Services Clients Portfolio Contact

 4. From Portfolio, draw four arrows down; at the end of each, write “Jewelry”, 
“Fashion”, “Food”, and “Music”.

These are the four categories of portfolios that the client wants to display; they should all 
be accessible via links from the main portfolio page. 

 5. Draw arrows from Jewelry to the six primary pages (including Portfolio).

A visitor should be able to navigate from each of the portfolio category pages to all of 
the primary pages. Technically, this step should be repeated for each of the portfolio 
category pages; but as long as you understand the principle, you don’t need to draw 
those links.

 6. Draw arrows from Jewelry to the three other portfolio category pages.

A visitor should not be forced to go back to the main portfolio page (one step backward) 
to go to another portfolio category. Consider the portfolio category pages as siblings of 
one another. It is common practice to provide links between sibling pages.

 7. Under Jewelry, write “southwest”, “costume”, “watches”, and “bracelet” to 
represent the four portfolio photographs within the jewelry category. Draw 
arrows from Jewelry to these pages.

Once a visitor has reached the Jewelry category, these links allow the visitor to explore 
the jewelry photographs.

 8. Draw arrows from each specific jewelry photograph to the other jewelry 
photographs.

Again, these pages (photographs) are siblings of one another; links between them allow 
visitors to explore all of the photographs within this category without having to return 
to the Jewelry category home page one level above.

Using the terms parent, 
child, and sibling 
is simply a way of 
describing relationships 
between pages. A large 
Web site cannot provide 
links to all of the pages 
from its home page. 
By grouping pages, 
grouping groups of pages, 
and so on, you create 
relationships of equality 
between pages that are 
grouped together, as well 
between groups that are 
grouped together. 

Note:
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 9. Draw arrows from the southwest page to each of the primary pages in the 
top row, including the Portfolio page.

Every page should be linked to the primary pages. Although this step could be repeated 
for each of the four jewelry pages and the twelve pages in the other three categories, as 
long as you understand the principle, the step is unnecessary.

 10. Draw arrows from the southwest page to the Jewelry, Fashion, Food,  
and Music pages. 

The links to the main pages provide easy access to the other portfolio categories.

Moxie Photographic Studio

Home What Is Services Clients Portfolio Contact

Jewelry Fashion Food Music

southwest costume watches bracelet

 11. Continue to the next exercise.

create links using the hyPerlink Button

The first step to completing the navigation outlined in the previous exercise is to 
create links between the main portfolio pages. In this exercise, you learn to create links 
between pages using the Hyperlink button on the Common Insert bar.

 1. With the Moxie site open in the Files panel, open 01.html from the  
/portfolio/jewelry folder.

 2. Drag to select the word Jewelry in the top-left area of the page.
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 3. Click the Hyperlink button in the Common Insert bar.

The Common Insert bar contains many of the common functions you use to create Web 
pages. If a different Insert bar is showing, you can return to the Common Insert bar by 
simply clicking the Common tab.

Hyperlink button

 4. In the Hyperlink dialog box, click the Browse button to the right of the 
Link field.

Browse button 

 5. Navigate to the /portfolio/jewelry folder, select 01.html, and click  
Choose/OK.

You can also choose 
Hyperlink from the  
Insert menu to access this 
dialog box. 

Note:

In addition to specifying the link, the Hyperlink dialog box 
also allows you to determine how the link appears and how 
the link is accessed.

The text selected for creating a link appears in the Text 
field by default.

In the Link field, you can either select a file within the site 
you are creating, or you can type the URL of a location that 
is outside the Web site you’re building.

You use the Target field to select where the linked file  
will open. By default, the linked file opens in the same 
window or frame as the one in which the link appears  
(this corresponds to the _self option in the menu). If you 
select _blank, the linked file opens in a new browser 

window. If you select _parent, and if the link appears in a 
frame within a frame, the linked file opens in the parent 
frame; if the link appears in a frame that is not within 
another frame, then the linked file opens in the full browser 
window. To open the linked file within the same browser 
window regardless of any existing frames, select _top.

You use the Title field to specify the text that appears 
when the cursor is placed over the link text.

To be able to access the link using the keyboard, you can 
either specify a key that a user can press, or the user can 
press Tab on the page until the link is selected. You can 
specify the key in the Access Key field, and you can use 
the Tab Index field to specify the number of times a user 
needs to press the Tab key to select the link.
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The Hyperlink Dialog Box in Depth



37Project 1: Moxie Digital Portfolio

 6. Click OK in the Hyperlink dialog box to create the link.

 7. Examine the link in the design window.

The text is now underlined. The link text does not change to blue because the style  
rules for this navigation bar state that the link text is to be bold and black.

 8. Save your work (File>Save) and continue to the next exercise.

create a link using the BroWse for file function

The Browse for File function in the Properties Inspector is similar to the Hyperlink 
button in the Insert bar. Like most applications, Dreamweaver often includes several 
different ways to achieve the same result. You should use the method that is most 
efficient at the time. For example, if you are using a different mode of the Insert bar, you 
can use Properties Inspector to create a link without switching modes in the Insert bar. 

 1. With the Moxie site open in the Files panel, make sure 01.html is open in a 
document window. 

 2. Select the word “Fashion” below the Jewelry link you created in the last exercise.

 3. Click the Browse for File button to the right of the Link field in the 
Properties Inspector.

If you don’t see the Properties Inspector, choose Window>Properties. The Properties 
Inspector’s primary purpose is to review and change the properties of the selected 
HTML element (such as a heading, paragraph, or table cell). 

Browse for File button 

You can remove a link 
by selecting the linked 
text or object in the 
document and choosing 
Modify>Remove Link.

Note:

The most common links 
are text links where a 
word or group of words 
forms the link text. 
Commonly, text links are 
blue with an underline; 
but with the advent of 
CSS, many different 
styles are possible. 

Note:
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•	 The	Hyperlink button is used for linking text or 
images in a page to a file, either in the same Web site or 
in an external Web site.

•	 The	Email Link button is used for providing links to 
email addresses. When a user clicks an email link, it 
opens the user’s default email application with the email 
address in the To line.

•	 The	Named Anchor button is used for marking 
locations within a page. Links can be provided to these 
locations from within the same page or from other 
pages of the same Web site or other Web sites.

•	 The	Table button inserts a table within a page.

•	 The	Insert Div Tag button is used for inserting new 
sections in a page. Each division in a page is marked by 
a dotted line in Dreamweaver; these dotted lines do not 
appear when the page is viewed in a browser. Sections 
are useful for inserting blocks of content that you want 
to format independently from other blocks.

•	 The	Images button is used for inserting pictures. Click 
the arrow of this button to insert image-related objects 
such as images exported from the Adobe Fireworks 
application, navigation bars (containing links to other 
pages), rollover images (which change when the cursor 
is placed on them), and hotspots (sections of an image 
that can be linked to different targets). You can also 
insert an image placeholder, which reserves a portion of 
the page for inserting an object later.

•	 The	Media button is used for inserting audio-
visual files. These files could be in any format, but 
Dreamweaver also has functionality specific to inserting 
Flash, QuickTime, and Shockwave files; Java applets; and 
ActiveX controls.

•	 The	Date button is used for inserting the date and 
time. An option is provided for updating the date and 
time whenever the file is saved.

•	 The	Server-Side Include button is used for inserting 
a file within a page. In this case, the contents of the file 
are included in the page itself.

•	 The	Comment button is used for inserting comments 
in the code that describe something about its use. These 
comments display only in Code view; they do not display 
in Design view or in the browser. 

•	 The	Head button is used for adding information about 
the page that will be used by browsers. This information 
is included in the properties of the page. Click the arrow 
to select the information you want to add.

•	 The	Script button is used for adding code that will 
be used by the browsers to perform an action when 
the page is accessed. Click the arrow and choose Script 
from the menu to add the code. Some older versions of 
browsers might have the script-reading feature disabled; 
to display alternate content when browsers fail to read 
the script, choose No Script from the menu. You need 
to know programming languages to use this feature 
properly.

•	 The	Templates button is used for creating a template 
based on the current document. Templates are useful 
when you need to create multiple documents based on 
a single layout. 

•	 The	Tag Chooser button is used for inserting tags in 
the code. Tags are elements in the code that determine 
the kind of content that can be included in them. Tags 
are included automatically when you edit pages in 
Design view. 
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The Common Insert Bar in Depth
The Insert bar appears directly below the main menu bar. The Common Insert bar contains buttons for objects that are 
most frequently used. To insert an object, click the corresponding button. (Some of the terms and functions in the following 
descriptions will make more sense as you use those tools to complete later projects.)

Hyperlink 
button 

Named Anchor 
button 

Insert Div Tag 
button 

Media button 
(and menu) 

Server-Side 
Include button 

Script button 
(and menu) 

Tag Chooser 
button 

Email Link 
button 

Table 
button 

Date 
button 

Comment 
button 

Images button 
(and menu) 

Head button 
(and menu) 

Templates button 
(and menu) 
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 4. Navigate to the /portfolio/fashion folder, select 06.html, and click  
Choose/OK.

 5. Save the file and continue to the next exercise.

create a link using the Point to file function

The Point to File function is an excellent feature of Dreamweaver. To create a 
link, simply drag the Point to File button to a file in the Files panel, and a link is 
automatically created. This function has one minor drawback — the file must be 
visible in the Files panel. If the file is not visible, you must expand the folder first. 

 1. With 01.html (from the Moxie site) open, select the word “Food” below the 
Fashion link you created in the previous exercise.

This text will link to the 11.html page in the /portfolio/food folder, which is currently 
collapsed in the Files panel.

 2. Expand the /portfolio/food/ folder in the Files panel.

 3. Click the Point to File button and drag to 11.html in the /portfolio/food/ 
folder.

Point to File button 

 4. Save the file and continue to the next exercise.

You can change the 
destination of a link 
by selecting the linked 
text or object in the 
document and choosing 
Modify>Change Link. 
This menu command 
opens the same dialog 
box as the Browse for File 
button, where you can 
navigate to and select the 
new link destination.

Note:

When a link to another 
page in the site is selected 
in the document, you 
can open the related 
page in Dreamweaver by 
choosing Modify>Open 
Linked Page.

Note:
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shift-Drag to create a link

One final way to create a link between pages in a site does not require any buttons, 
toolbars, or panels. You can create a link directly from the document window by 
pressing Shift and dragging to the destination page in the Files panel.

 1. With 01.html (from the Moxie site) open, select the word “Music” below 
the Food link you created in the previous exercise.

 2. Expand the music folder in the Files panel.

 3. Press the Shift key, then click the selected text and drag to 16.html in the 
music folder.

You have to press the Shift key, and then click and drag to the link destination. If you 
try to click and drag before pressing the Shift key, this technique will not work.

 4. Save the changes to 01.html and close the file.

 5. Create the same links on 06.html (in the fashion folder), 11.html (in the 
food folder), and 16.html (in the music folder).

Link the word Jewelry to 01.html.

Link the word Fashion to 06.html. 

Link the word Food to 11.html. 

Link the word Music to 16.html.

 6. Save and close any open files.

 7. Continue to the next exercise.

As you work in 
Dreamweaver, expand 
and collapse Files panel 
folders as necessary 
depending on your 
available screen space.  
We will not repeat 
instructions to collapse or 
expand folders unless it 
is necessary to perform a 
specific function. 

Note:
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link Photo Pages to Portfolio category Pages

When you created the linking plan, you drew lines from the photo pages to the 
portfolio category pages, showing that a visitor could jump from a specific photo to 
another category. In this exercise, you create the actual links.

 1. With the Moxie site open in the Files panel, open 02.html from the  
/portfolio/jewelry/ folder.

 2. Select the words “Commercial Jewelry” below the photograph.

By default, Dreamweaver uses relative paths when creating links (in the Hyperlink 
dialog box, Dreamweaver refers to this as “relative to the document”). The 
alternative is to create absolute paths; but unless your site is running on a Web 
server, you cannot test links that use absolute paths (Dreamweaver refers to 
absolute links as “relative to the site”).

A path is the route taken through the folder structure to link one page to another. 
In the figure above, if the source and destination pages are in the same folder 
(01.html and 02.html are both in the jewelry folder), then a link created 
between them simply states the file name of the destination page:

<a href=”01.html”>Jewelry Home Page</a>

However, if the source and destination pages are in different folders, then the 
path to the destination page must be described. When you are drilling down into 
nested levels of folders, the source folder is not identified in the path; the link 
automatically works starting from the location of the link. 

For example, to link from portfolio.html in the /portfolio/ folder to 01.html in the /portfolio/jewelry/ folder, you have 
to include the nested folder in the path, but not the starting /portfolio/ folder: 

<a href=”jewelry/01.html”>Jewelry Home Page</a>

To link from index.html in the root folder to 01.html in the /portfolio/jewelry/ folder, you have to include both folders 
in the path:

<a href=”portfolio/jewelry/01.html”>Jewelry Home Page</a>

When the link is in an upward direction, the ../ notation is used to say “go up one folder”. To link from 01.html in the  
/jewelry/ folder to portfolio.html in the /portfolio/ folder means the link needs to take the visitor up one folder level: 

<a href=”../portfolio.html”>Portfolio</a>

To link from 01.html in the /portfolio/jewelry folder to /index.html in the root folder, the link must take the visitor up 
two folder levels:

<a href=”../../index.html”>Moxie Photography Home Page</a>

It’s possible to combine the two methods. For example, to link from /portfolio/jewelry/01.html to /portfolio/
fashion/10.html, the link must take the visitor up one folder level and then down to a different folder:

<a href=”../fashion/10.html”>Sportswear</a>
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 3. Using either the Point to File or Browse to File method, create a link from 
the selected text (“Commercial Jewelry”) to 01.html in the Jewelry folder.

Remember, you need to expand folders in the Files panel if you plan to use the Point  
to File method. 

 4. Select the words “Fashion Catalogs” and create a link to 06.html in the  
/portfolio/fashion/ folder.

 5. Select “Food” and create a link to 11.html in the /portfolio/food/ folder. 

 6. Select “Music Industry” and create a link to 16.html in the  
/portfolio/music/ folder.

 7. With the Music Industry link selected, examine the link path in the Link 
field of the Properties Inspector.

The path from /portfolio/jewelry/02.html to /portfolio/music/16.html requires you  
to go up one folder to the /portfolio/ folder, and then down to the /music/ folder to  
get to 16.html.

Link path 

 8. One by one, click the Food and Fashion links in the document and review 
the paths in the Properties Inspector.

In each case, the link goes up to the /portfolio/ folder, then moves down to the specific 
folder for the page that is linked.

 9. Click the Commercial Jewelry link and note the path.

There is no folder path because both 01.html and 02.html are in the same folder.

 10. Save the file and continue to the next exercise.

The Shift-Drag method 
will not work in this 
instance because each 
text link is only part of a 
single paragraph. 

Note:
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aDjust the music link

These links are present in all sixteen of the photo pages of the portfolio. If you copied 
this block of links to the other pages in the /portfolio/jewelry/ folder, they would all 
work. However, if you copied them to the pages in the /portfolio/music/ folder, the 
first link (to 01.html) would be broken because the path (or lack of one) would make 
the browser look for 01.html in the /portfolio/music/ folder. Rather than adjust these 
links for each of the new folders, in this exercise you change the link to 01.html so it 
will work in any of the portfolio photo pages.

 1. With the Commercial Jewelry link selected in 02.html (of the Moxie site), 
click the Link field and move the insertion point to the left of the existing 
path (“01.html”).

 2. Type “../jewelry/” to the left of 01.html.

This modification to the link takes the browser up to the /portfolio/ folder, and then 
back to the /portfolio/jewelry/ folder. This might seem like unnecessary effort, but it 
means that this link will work from any of the sixteen photo pages.

 3. Save the changes to the page.

 4. Preview the page in your primary browser (File>Preview in Browser).  
Test the links by clicking them one at a time to ensure that the intended 
page opens from the link.

You must click the Back button in your browser to return to this page to check each 
link; the other pages don’t yet have links to return you to this page.

 5. Close your browser, return to Dreamweaver, and continue to the next 
exercise.

coPy anD Paste links

Now that the bottom set of links has been configured to work from every photo page 
of the portfolio, it’s time to copy and paste that paragraph to the rest of the photo 
pages in the portfolio.

 1. With 02.html (from the Moxie site) open, click within the paragraph of 
links, and then click the <p#bottom-nav> tag in the Tag Selector.

The Tag Selector, located in the status bar of the document window, shows the path of 
tags to the tag of the current selection or the current location of the insertion point. 

Clicking a tag in the Tag Selector selects all of the content contained within that tag. In 
the document window, the associated content is highlighted.

Tag selector 

Selected paragraph 

Selected tag 

Dreamweaver is very 
good at creating the 
correct HTML code 
according to your 
instructions, but it’s 
entirely possible for you to 
create a link to the wrong 
page, such as linking 
the text “Contact Us” to 
clients.html instead of 
contact.html. Although 
the code might be 
correct, the destination is 
incorrect. The best way to 
catch errors such as these 
is to preview the pages 
in your browser and test 
the links shortly after 
creating them.

Note:
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 2. Copy the selected content to the clipboard by choosing Edit>Copy or 
pressing Command/Control-C.

 3. Close 02.html and open 03.html.

 4. Click within the paragraph near the bottom of the page and click the 
<p#bottom-nav> tag in the Tag Selector to select the paragraph.

The selected content 
does not include links.

 5. Paste the content from the clipboard by choosing Edit>Paste or pressing 
Command/Control-V.

The pasted content 
includes the links. 

 6. Save the changes to 03.html and close the file.

 7. Repeat Steps 3 through 6 to paste the copied content (the links) into pages 
04.html and 05.html in the /portfolio/jewelry/ folder.

 8. Repeat Steps 3 through 6 to paste the same links into the following pages:

07.html to 10.html in the /portfolio/fashion/ folder

12.html to 15.html in the /portfolio/food/ folder 

17.html to 20.html in the /portfolio/music/ folder.

If you hadn’t adjusted the link path to 01.html in the previous exercise, you would have 
to adjust the path each time you pasted to a page that was not in the /portfolio/jewelry/ 
folder. By adjusting the path so it would work each time, all you had to do was paste the 
same paragraph of links into each of the pages in all four category folders.

 9. Save and close all files, and then continue to the next stage of the project.
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Stage 3 Creating Image Links and Maps
Many Web sites use navigation bars in which the links are not live text but images of text; text graphics 
are often used because the appearance of the text can be modified to a much greater extent in graphics 
applications than is possible using CSS alone. And of course there are photo galleries, in which you 
click a thumbnail image to open a larger version of the photo.

You can use any of the methods you already learned to create image links, with one exception — 
you can’t Shift-point to another file from an image in the document window. You can, however, use 
the Hyperlink button in the Common Insert bar, type a URL in the Link field, use the Browse for File 
button, or use the Point to File button in the Properties Inspector. 

create image links

In this exercise, you create links from the portfolio category pages to the photo pages 
with larger versions of the photos. 

 1. With the Moxie site open in the Files panel, open 01.html from the  
/portfolio/jewelry/ folder.

 2. Click the top-left portfolio image.

 3. Examine the Properties Inspector, noting the position of the Link field,  
the Browse for File button, and the Point to File button.

Selected image 

Link field 

Browse for File button 

Point to File button 

 4. Using the Browse for File method, link the selected image to 02.html in the 
/portfolio/jewelry/ folder.

 5. Click the image in the top-right corner and use the Point to File method to 
link the selected image to 03.html.

 6. Using any method you prefer, link the lower-left image to 04.html and link 
the lower-right image to 05.html.

 7. Preview the page in your primary browser (click Yes to save the file if 
prompted) and check the links.
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 8. Close your browser and return to Dreamweaver.

 9. Close 01.html and open 06.html from the /portfolio/fashion/ folder.

 10. Working from left to right, top to bottom, link the four images to the four 
remaining pages in the /portfolio/fashion/ folder in numerical order, using 
whatever method you prefer. Save and close 06.html when finished.

Link this image to 07.html.

Link this image to 08.html.

Link this image to 09.html.

Link this image to 10.html.

 11. Repeat Step 10 for 11.html in the /portfolio/food/ folder. 

Link this image to 12.html.

Link this image to 13.html.

Link this image to 14.html.

Link this image to 15.html.

 12. Repeat Step 10 for 16.html in the /portfolio/music/ folder.

Link this image to 17.html.

Link this image to 18.html.

Link this image to 19.html.

Link this image to 20.html.

 13. Continue to the next exercise.
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coPy anD Paste image links

When a visitor clicks a link to jump to a specific portfolio image, the user should be 
able to explore other photos in the same category without being forced to first return to 
the main category page. Four thumbnail images in the left side of the page will provide 
this navigational structure. Once you’ve created links from the thumbnails in one page, 
you can copy and paste that group to the other pages in the same category — which 
reduces some of the effort. 

 1. With the Moxie site open in the Files panel, open 02.html from the  
/portfolio/jewelry/ folder.

 2. Click to select the top-left image in the top-left region of the page.

Selected image 

 3. Link this image to 02.html.

This image creates a link to the current page. Some designers counsel against this 
practice; but when this block of links is copied to the other four pages in this folder, this 
image will link from other pages to this one.

 4. Working from left to right, top to bottom, link the remaining images to the 
last three pages in the /portfolio/jewelry/ folder in numerical order.

Link this image to 03.html.

Link this image to 04.html.

Link this image to 05.html.

 5. With any of the four thumbnail images selected, click the right-most 
(second) <table> tag in the Tag Selector to select the small table that encloses 
the four thumbnail image links.

The Tag Selector shows the “path of tags”, leading to the selected <img> tag. 

When you click the <table> tag, the selection switches to the entire table that contains 
the originally selected image. The path of tags now ends at the selected <table> tag. 

The entire table is 
selected in the document.

Select the <table> tag 
in the Tag selector.
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 6. Choose Edit>Copy (or press Command/Control-C) to copy the selected 
table to the clipboard.

 7. Save the changes to 02.html and close the file.

 8. Open 03.html and click one of the thumbnail images.

 9. Click the right-most <table> tag in the Tag Selector and paste the copied table 
(with the defined links) in place of the selected table (which has no links).

 10. Save the changes to 03.html and close it.

 11. Repeat Steps 8 through 10 on 04.html and 05.html.

 12. Repeat this process for each category of photo pages:

•	 Create	the	thumbnail	links	in	one	of	the	category	pages.

•	 Use	the	Tag	Selector	to	select	the	table	containing	the	thumbnail	links.

•	 Copy	the	linked	thumbnail	table.

•	 Paste	the	linked	thumbnail	table,	replacing	the	unlinked	thumbnail	
table in the other pages of the same category.

By adding these links, a visitor can explore the other photos within the same category 
from each of the photo pages in that category.

Link this image to 07.html.

Link this image to 08.html.

Link this image to 09.html.

Link this image to 10.html.

     

Link this image to 12.html.

Link this image to 13.html.

Link this image to 14.html.

Link this image to 15.html.

Link this image to 17.html.

Link this image to 18.html.

Link this image to 19.html.

Link this image to 20.html.

 13. Save and close any open files, and then continue to the next exercise.
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create image maP links

In addition to creating a link from a whole image, you can also create a link from a 
portion of an image. For example, an image of a map of the United States could have a 
link from each state to the government Web site for that state; or a group photograph 
could have a link from each person to a personal Web page. This type of image is 
known as an image map.

Image maps contain hotspots, which are specific areas of the image configured as 
links. Each hotspot on an image can have its own URL, which means a single image 
can have multiple URLs. Dreamweaver applies a semi-transparent, aqua-colored shape 
to represent the location, shape, and size of each hotspot area.

There are three basic shapes of hotspots: rectangular (including square), circular, 
and polygonal (any multi-pointed shape that isn’t a rectangle). You can create any of 
these types of hotspots in Dreamweaver, although you create only rectangular hotspots 
in this project. 

The top banner image of each page will be an image map that includes links to 
the primary pages of the site. The image map hotspots were already created in the old 
primary pages (index.html and the others), but not in any of the portfolio pages. 

 1. With the Moxie site open in the Files panel, open 01.html from the  
/portfolio/jewelry/ folder and examine the top banner image.

The words in the banner image, with the exception of Moxie, will be links to the 
primary pages.

 2. Click once on the banner image and examine the bottom-left region of the 
Properties Inspector.

The field to the right of the word Map is for the image map name. The three aqua 
shapes below the field allow you to select the shape of the hotspot before drawing it on 
the image.

Map Name field 

Rectangular Hotspot tool 

Pointer tool 

Oval Hotspot tool 

Polygon Hotspot tool 

 3. Type “primary” in the Map Name field.

 4. Click the Rectangular Hotspot tool.

 5. Drag to draw a rectangle around the word “home” in the banner image at 
the top of the document.

It’s best to start from the top left and drag to the bottom right.
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 6. Click OK to dismiss the message dialog box.

After drawing a hotspot, you will see a message reminding you to define alt text for the 
image map. Alt text aids usability for disabled users who use screen-reader software. This 
is an extremely important issue, which you will learn about extensively in Project 3.

 7. From the Properties Inspector, use either the Point to File or Browse for File 
method to create a link to index.html in the root folder of the site.

Because 01.html is two folders below index.html in the root folder, Dreamweaver inserts 
the required ../../ to direct the browser up two folders to index.html.

Hot spot 

 8. Using the Rectangular Hotspot tool, draw rectangles around each phrase in 
the image. Link each hotspot to the appropriate pages.

Most of these pages are in the root folder; the word “portfolio”, however, links to 
portfolio.html in the /portfolio/ folder.

 9. Save your changes to the page.
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 10. Click once outside the banner image to disable the Rectangular Hotspot 
tool, and then click the banner image again to select the entire image.

This image map is the same for all pages within the portfolio group of pages. You can 
copy and paste the banner image to replace the banner images in the other pages; the 
image map links will be copied to those pages as well.

Each hotspot links 
to the appropriate 
page. 

The entire image — 
including all 6 linked 
hotspots — is selected. 

 11. Copy the image to the clipboard (Command/Control-C or File>Copy).

 12. Close 01.html and open 02.html from the /portfolio/jewelry/ folder.

 13. Click once on the banner image at the top of the page to select it, and then 
paste the copied image (including the image map links). 

 14. Click OK to dismiss the Image Description dialog box.

 15. Close 02.html after saving the changes.

 16. Repeat Steps 12 through 15 for the remaining 18 portfolio pages.

 17. Continue to the next stage of the project.
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Stage 4 Creating Other Types of Links
There are two other common types of links — external links and email links. An external link is a 
link to another Web site or a page on another Web site. An email link opens the site user’s email 
application so the user can send an email to the address in the link. Both types of links can be text 
links, image links, or image map links. 

Regardless of the type of link, the URL must begin with the appropriate protocol for that link. An 
external Web site link must begin with http://, followed by the site’s domain name and, if necessary, 
the folder path and file name of the Web page to which you are linking. For example, the faculty 
page on the UCLA Web site is found at http://www.ucla.edu/audience/faculty.html. Dreamweaver 
cannot help you create an external link because it’s outside the site definition; you must either type it 
manually or copy it from the original page and paste it into the Link field in Dreamweaver.

An email link must begin with mailto: followed by the address (e.g., mailto:info@sony.com). 
Similar to an external Web site link, Dreamweaver cannot provide much help with constructing an 
email link; you must manually type it or copy and paste it (although there is an email dialog box that 
you can use to create an email link).

create a link to an external WeB site

The original Moxie Photographic Studios Web site was created for David Monroe by 
a company called Pro Techniques. For the purposes of marketing their products and 
services, Web design businesses often insert a link to their own Web sites on the pages 
of their clients’ sites.

 1. With the Moxie site open in the Files panel, open portfolio.html  
and examine the bottom of the page, where you find the reference  
to Pro Techniques.

 2. Drag to select the words “Pro Techniques.”

 3. In the Link field of the Properties Inspector, type  
“http://www.protechniques.com” and press Return/Enter.

 4. Save and continue to the next exercise.
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create an email link

It’s a good idea to include an email link to the owner or designer of the Web site on 
every page. This link makes it easy for a visitor to contact the owner/designer in case 
the visitor sees something of interest. (This doesn’t eliminate the value of a contact 
page, which should contain the mailing address and other contact information.)

 1. In the open portfolio.html file, select the words “David Monroe” above the 
Pro Techniques link.

 2. In the Common Insert bar, click the Email Link button.

Email Link button 

Selected text 

 3. In the Email Link dialog box, type “Info@moxiestudios.com” in the E-Mail field.

By default, if you select text before clicking the Email Link icon, the Text field is 
completed for you from the selected text. Also, Dreamweaver remembers the last email 
address you entered into the E-Mail field; you might not need to complete that field if 
you insert the same email address multiple times.

 4. Click OK to create an email link from the text David Monroe.

 5. Examine the Link field in the Properties Inspector. 

Dreamweaver automatically inserts the mailto: protocol.

 6. Save the changes to portfolio.html.

The rest of the portfolio pages do not yet contain these links. You have to copy this 
entire block of text to the rest of the pages in the portfolio section of the Web site.

You can access the same 
Email Link dialog box 
by choosing Insert>Email 
Link.

Note:
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 7. With the insertion point in the block of text containing the two links, click 
the <div#footer> tag in the Tag Selector.

This tag identifies the section (or division) of the page named “footer”, which is the area 
that contains the external page link and the email link.

Selected area 
corresponding to the 
selected tag 

Selected tag 

 8. Copy the selected content to the clipboard.

 9. Close portfolio.html and open 01.html from the /portfolio/jewelry/ folder.

 10. Click within the same block of text at the bottom of the page, and then click 
the <div#footer> tag in the Tag Selector.

 11. With the footer section selected, paste the copied content (with the links) 
from the clipboard, replacing the original (unlinked) selection.

 12. Save the changes and close the 01.html file.

 13. Repeat Steps 9 through 12 on the remaining 19 pages in the portfolio 
section of the Web site.

 14. Continue to the next stage of the project.

A named anchor is used to mark a specific location on 
a page so it can be linked to from other locations within 
the same page or from other pages. Instead of forcing the 
reader to search for the information by scrolling or other 
means, you can create a hyperlink that points to the exact 
location of the information.

Named anchors can be especially useful on long Web pages. 
For example, on a page that contains many sections, you 
can include a table of contents at the top with links to each 
section. To help the reader return to the table of contents 
from any section of the page, it is considered good practice 
to include a link to the top of the page at the end of each 
section (such as “Back to Top”).

To insert a named anchor, simply click the Named Anchor 
button on the Common Insert bar. When linking to the 
named anchor, type the number sign (#) followed by the 
name of the anchor in the Link field of the dialog box or 
Properties Inspector. If you are linking to the anchor from 
another page, type the name of the file containing the 
anchor, followed by the number sign and the name of the 
anchor.
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Stage 5 Naming Pages and Titling Documents
The names of folders and files have an impact on search engine optimization (SEO). Creating 
appropriate folder and file names also improves usability; even though you can use /p/j/3.html for 
the path to the costume jewelry page, for example, /portfolio/jewelry/costume.html is much easier to 
understand for human visitors — and will also improve your SERP ranking.

Web servers (specially designed computers used to store and deliver Web pages over the Internet) 
are configured to deliver a default page if a specific page has not been requested. For example, if you 
browse to www.nytimes.com, you still see content — the home page — even though you haven’t 
requested a specific page. When a Web server receives a request for a folder but not a 
specific page, the Web server delivers the default page for that folder; the default page 
is identified by its file name, which is most often index.html or index.htm. 

When creating a link to the default Web page for a particular folder, you can 
choose not to include the file name, such as http://moxiephotographic.com/portfolio/ 
versus http://moxiephotographic.com/portfolio/index.html. Both URLs refer to the 
same page. Remember, however, that you can’t test a link to a folder path on your local 
computer because your computer won’t know what page to deliver. If you are running 
Web server software on your local computer, however, you can complete the test. 

rename Default Pages

In this exercise, you rename the default pages for each folder. Dreamweaver recognizes 
when a file name has been changed and knows that links to the page must be adjusted.

 1. With the Moxie site open in the Files panel, Control/right-click  
/portfolio/portfolio.html and choose Edit>Rename.

 2. Type “index.html”, press Return/Enter, and then click Update to update all 
pages that link to this page.

Some pages employ 
server-side programming 
languages such as PHP 
or ASP; their default 
names are index.php and 
default.asp, respectively.

Note:
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 3. Open clients.html from the root folder of the site, click the hotspot for 
portfolio, and examine the URL in the Properties Inspector.

The destination page changed from portfolio.html to index.html.

The selected hotspot 
correctly links to the 
renamed file. 

Selected hotspot 

 4. Close clients.html.

 5. In the Files panel, rename the following files as “index.html”. Click Update 
each time you are prompted.

/portfolio/jewelry/01.html

/portfolio/fashion/06.html

/portfolio/food/11.html 

/portfolio/music/16.html 

These are the default pages for each of the portfolio category folders.

 6. Continue to the next exercise.

•	 a	through	z	(use	only	lowercase	letters)

•	 0	through	9

•	 Hyphen	(-)	character

•	 Underscore	(as	in	great_site.com)

Consider everything else to be “illegal,” including:

•	 Spaces	—	no	Web	site	name	can	use	a	space

•	 Brackets	of	all	kinds,	including	(	),	[	],	{	},	and	<	>

•	 Symbols,	including	#,	@,	%,	~,	|,	*,	and	&

•	 Quotation	marks,	both	double	(“	“)	and	single	(‘	‘)

•	 Slashes,	both	back	slashes	(\)	and	forward	slashes	(/)

•	 Punctuation	marks,	including	commas,	question	marks,	
and exclamation marks

•	 Uppercase	characters
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Legal Characters in File Names
We could talk for hours about what characters are suitable (or “legal”) for naming your Web pages. Suffice it to say that the 
safest way to name your pages is to limit the use of the available characters on your keyboard to just a few that are sure to 
work perfectly. Basically, you should limit the characters you use to:

In short, limiting the characters you use to lowercase alphanumeric characters plus the underscore and hyphen will save you 
a great deal of time, effort, and frustration later.
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rename Portfolio Pages for imProveD usaBility

The rest of the file names for the pages in the portfolio folders are essentially nonsense; 
numbers mean nothing and do not represent the content of the pages. The file names 
of these pages should be changed so the content or purpose of the page is clear. 

When you want to use two or more words in a file name, you should know that 
the space character is illegal in UNIX and Linux file and folder names. Instead, you 
can use either the hyphen or underscore character to represent a space. 

In some cases, people use camelcase (uppercase letters at the beginning of words 
within a file name, such as redHotChiliPeppers.html) file names instead of using 
hyphen or underscore characters to separate words. The problem with mixing the 
lettercase is that some Web server software is case-sensitive and some is not. Most 
Windows-based Web server software is not case-sensitive; but UNIX- and Linux-based 
Web server software is case-sensitive. 

 1. With the Moxie site open in the Files panel, change the following file names 
in the /portfolio/jewelry/ folder. Click Update when prompted.

Current name New name
02.html  southwestern.html
03.html  costume.html
04.html  watches.html
05.html  gold-bracelet.html

 2. In the /portfolio/fashion/ folder, change the following file names  
(click Update when prompted).

Current name New name
07.html  fall.html
08.html  leisure.html
09.html  business.html 
10.html  sports.html

 3. In the /portfolio/food/ folder, change the following file names  
(click Update when prompted).

Current name New name
12.html  breakfast.html
13.html  restaurant.html
14.html  fruits-vegetables.html 
15.html  seafood.html

 4. In the /portfolio/music/ folder, change the following file names  
(click Update when prompted).

Current name New name
17.html  the-black-honkies.html
18.html  jaden.html
19.html  saturn-5.html 
20.html  trumaine.html

 5. Continue to the next exercise.
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create Document titles for the Portfolio Pages

When creating new pages for a site, applying appropriate document titles is another 
critical concern. The document title is important for both SEO and site visitors. While 
the document title does not appear within the Web page, it does appear in the title bar 
of the browser, as the name of the page in the Bookmarks or Favorites list, and as the 
page name in search-engine results pages. 

The generally recommended format for a document title is to list the categories in 
which the page is found, similar to the folder path in which the page is located, ending 
with the Web site name. You should separate the components of the title with a colon (:) 
or pipe (|) character. For example, for the Jaden page of the /portfolio/music/ folder, the 
title could be Jaden : Music : Portfolio : Moxie Photographic Studios.

It might be tempting to list the Web site name first; but if a page title is long, the 
specific details of the page (such as Jaden in the example above) could be cut off. Also, 
in a SERP, it’s easier to see if your search has provided suitable results if the specific 
information about the page is listed first. The following images show results from 
two Google searches. The blue underlined links (top lines) are the document titles — 
suggesting that the document titles are important to visitors looking for information 
using search engines.

In this exercise, you add document titles to all of the new pages. Doing so will 
increase the pages’ rankings in search engines and improve usability for visitors who 
find the pages in search engines and in bookmarks. You also learn to use the Find and 
Replace function, which can greatly reduce the amount of effort required to create all 
of the document titles.

 1. With the Moxie site open in the Files panel, open index.html from the  
/portfolio/ folder 

 2. Make sure the Document toolbar is showing (View>Toolbars>Document) 
and examine the Document Title field above the design window.

When you create a new page in Dreamweaver, the default title is “Untitled Document”.

Document title

 3. Close index.html.

 4. With no documents open, choose Edit>Find and Replace.

Don’t worry if your settings are different than what you see in our screen shot.  
You configure them in the next step.

Unlike file names, 
document titles can use 
mixed lettercase and 
include spaces and other 
characters. 

Note:
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 5. Change the Find In field to Folder, click the Browse button, and select the  
/portfolio/ folder.

All files within and below the /portfolio/ folder will be searched.

 6. Change the Search field to Source Code (from the pop-up menu).

The document title does not appear within the body of the page; so when you use Find 
and Replace, you must apply the change to the source code rather than the document text.

 7. In the Find field, type “Untitled Document”.

 8. In the Replace field, type “Portfolio : Moxie Photographic Studios”.

All pages in the portfolio folder will include this block of text at the end of the 
document title. As more detail about the pages becomes available, it will be added to the 
left of the document title.

 9. Click Replace All.

 10. When prompted to confirm whether you want to proceed with this 
function, click Yes.

Like most applications, Dreamweaver has an Undo function that allows you to undo the 
most recently completed actions; however, this function only works if the document is 
open. Since you are using the Find and Replace function on the entire folder and not an 
open page, you are making changes in closed documents — which means you cannot 
use the Undo command.

After completing the Find and Replace function, Dreamweaver displays the results in 
the Results panel.



60 Project 1: Moxie Digital Portfolio

 11. Open index.html from the /portfolio/ folder and examine the Document 
Title field again. 

As a result of the Find and Replace function, the document title has been changed.  
(The same change has been made in all of the portfolio pages.)

 12. Close index.html.

 13. Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/jewelry/ folder:

•	 Set	the	Find	In	field	to	Folder	and	choose	the	portfolio/jewelry/	folder	
as the target.

•	 Set	the	Search	field	to	Source	Code.	

•	 Change	the	Find	field	to	“Portfolio	:”	

•	 Change	the	Replace	field	to	“Jewelry	:	Portfolio	:”.		

•	 Click	Replace	All.	When	prompted	to	confirm	your	action,	click	Yes.

 14. Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/fashion/ folder:

•	 Set	the	Find	In	field	to	Folder	and	choose	the	portfolio/fashion/	folder	
as the target.

•	 Set	the	Search	field	to	Source	Code.	

•	 Change	the	Find	field	to	“Portfolio	:”	

•	 Change	the	Replace	field	to	“Fashion	:	Portfolio	:”.		

•	 Click	Replace	All.	When	prompted	to	confirm	your	action,	click	Yes.
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 15. Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/food/ folder:

•	 Set	the	Find	In	field	to	Folder	and	choose	the	portfolio/food/	folder	as	
the target.

•	 Set	the	Search	field	to	Source	Code.	

•	 Change	the	Find	field	to	“Portfolio	:”	

•	 Change	the	Replace	field	to	“Food	:	Portfolio	:”.		

•	 Click	Replace	All.	When	prompted	to	confirm	your	action,	click	Yes.

 16. Open the Find and Replace dialog box again. Repeat this process to change 
the document title of all files in the portfolio/music/ folder:

•	 Set	the	Find	In	field	to	Folder	and	choose	the	portfolio/music/	folder	
as the target.

•	 Set	the	Search	field	to	Source	Code.	

•	 Change	the	Find	field	to	“Portfolio	:”	

•	 Change	the	Replace	field	to	“Music	:	Portfolio	:”.		

•	 Click	Replace	All.	When	prompted	to	confirm	your	action,	click	Yes.

 17. Choose Window>Results to close the Results panel.

 18. Continue to the next exercise.
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aDD sPecific Page information in the Document title

The current document titles contain only generic information that represents the 
broad portfolio categories. In this exercise, you add the most specific information in 
the document title for each page.

 1. With the Moxie site open in the Files panel, open southwestern.html from 
the /portfolio/jewelry/ folder.

 2. In the Document Title field, click to place the insertion point to the left of 
the word Jewelry and type “Southwestern : ”.

 3. Save the changes to southwestern.html and close the file.

 4. One by one, open the rest of the pages in the portfolio category folders and 
add the same text you used in the file name to the beginning (left) of the 
document title (“Saturn 5” and “Fruits and Vegetables”, for example). Save 
and close each file after changing the document title.

Unlike file names, document titles can have spaces, so you can replace hyphens or 
underscores with spaces between words.

 5. Continue to the next exercise. 

hiDe files from the WeB server

For all intents and purposes, the new portfolio pages are ready to upload to the Web 
server. Because there are more new files than there were old files, it makes the most sense 
to reload the complete site rather than select only the new files to upload to the Web 
server. However, not all of the new files are meant to be uploaded to the Web server — 
specifically, the Word document and Photoshop file in the /resources/ folder. (You  
should store them locally as source files or documentation for the work you completed.) 

Dreamweaver provides a very useful function — called cloaking — that allows 
you to prevent certain files from uploading. There are two methods for cloaking 
files: by file extension and by folder. If you cloak by file extension, such as .psd (a 
Photoshop file), any .psd files in the site’s folder will be cloaked. The disadvantage of 
cloaking by file extension is that if you want to upload some .psd files but not others, 
you can’t uncloak some files while leaving other files cloaked. However, if you create a 
folder for files that you don’t want uploaded, you can cloak the entire folder, no matter 
what type of files exist within that folder (including HTML files).

Cloaking a folder allows you to keep preliminary, source, draft, and other 
documents and files within the site, but prevent them from uploading to the Web 
server. By default, Dreamweaver has the cloaking function enabled; all you need to do 
is identify the folder you want to cloak.
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 1. With the Moxie site open in the Files panel, collapse all open folders and 
expand only the resources folder.

 2. Control/right-click the resources folder and choose Cloaking>Cloak.

Notice the red slash through the resources folder icon and the icons for the two files 
in the resources folder. The red slash refers to the cloaking function only; it does not 
prevent you from working with the files, adding more files, or deleting any of the 
existing files.
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Summary
In this project, you learned that creating a Web site requires a lot of detailed, upfront planning. You 
found that without proper planning, adding or renaming a file can cause serious problems that ripple 
throughout a site. You also learned the value of structuring your folders and applying appropriate  
file names and document titles. You discovered how to apply links within your pages, as well as to 
external pages and sites. You also learned about image maps and hotspots, and how they can be used  
as navigational aides within your Web sites. 

Create an image map 
to link to different 
areas of the site

Define accurate 
document titles for better 
search engine placement

Create image links to 
larger detail pages

Create navigation links to 
portfolio category pages

Create navigation links to 
portfolio category pages

Create an email link

Create a link to 
an external URL



65Project 1: Moxie Digital Portfolio

Portfolio Builder Project 1
Romana Place Town Homes is 
adding a photo tour to its Web site. 
The owner is fairly competent at 
building Web pages, but is having 
trouble finalizing the new site. Your 
job is to finish what he started in a 
professional, organized manner.

To complete this project, you should:

o Import the site files (from the 
RF_Builders>Rentals folder) into 
Dreamweaver.

o Analyze the content of the 
different pages. Create a flowchart 
to map the direction of links from 
one page to another in the site.

o Organize the site folder into a 
clear, understandable structure.

o Create the links from one page to 
another throughout the entire site.

“ I’m not really sure what happened, but when I started working with the 
files I noticed that none of the links exist anymore. I might have worked 
from an earlier version of the site files, but I’m not sure. Can you fix this 
for me? Other than the navigation links in the middle of the pages, there 
are a number of other places where links are necessary:

“ On the index.html page, the words ‘take a photo tour’ should link to  
the tour.html page.

“ On the individual tour pages, the ‘Back to View Homes’ image should 
link back to the main tour.html page.

“ On the tour.html page, the thumbnail images should each link to the 
appropriate tour page (those are numbered 01-10.html).

“ At the bottom of the tour.html page, the words ‘Click here to print 
information flyer’ should link to the PDF file in the site folder.

“ On the contact.html and amenities.html pages, the words ‘click  
here’ (near the bottom of the page) should be an email link to  
pattic@pc-rentals.com.”

 “ At the bottom of every page, the ‘Website design by...’ address should be a 
link to that address, which should open in a new browser window.”




