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Walk-Through

Project Goals
Each project begins with a clear description 
of the overall concepts that are explained 
in the project; these goals closely match the 
different “stages” of the project workflow.

The Project Meeting
Each project includes the client’s initial 
comments, which provide valuable 
information about the job. The Project 
Art Director, a vital part of any design 
workflow, also provides fundamental 
advice and production requirements. 

Project Objectives
Each Project Meeting includes a 
summary of the specific skills required  
to complete the project.

Step-By-Step Exercises
Every stage of the workflow is 
broken into multiple hands-on, 
step-by-step exercises.

Visual Explanations
Wherever possible, screen shots 
are annotated so that you 
can quickly identify important 
information.

Real-World Workflow 
Projects are broken into logical lessons or 
“stages” of the workflow. Brief introductions at 
the beginning of each stage provide vital foun-
dational material required to complete the task.
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Dreamweaver Foundations
Additional functionality, related tools,  
and underlying graphic design concepts  
are included throughout the book.

Advice and Warnings
Where appropriate, sidebars  
provide shortcuts, warnings, or 
tips about the topic at hand.

Visual Summary
Using an annotated version of the 

finished project, you can quickly  
identify the skills used to complete 

different aspects of the job.

Project Review
After completing each project, you  
can complete these fill-in-the-blank and 
short-answer questions to test your under-
standing of the concepts in the project.

Portfolio Builder Projects
Each step-by-step project is accompanied 
by a freeform project, allowing you to 
practice skills and creativity, resulting in an 
extensive and diverse portfolio of work.



Projects at a Glance

Photographer’s Web Site

o	 Placing Static Foreground Images

o	 Extracting Photoshop Assets
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 2 Digital Book Chapter

o	 Preparing the Workspace

o	 Working with Semantic Markup 

o	 Working with Special Characters

o	 Creating Lists

o	 Attaching an 
External CSS File

p
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 1 Bistro Site Organization

o	 Exploring Site 
Structure

o	 Organizing the Site 
Navigation

o	 Naming 
and Titling 
Documents

The Against The Clock Portfolio Series teaches graphic 
design software tools and techniques entirely within 
the framework of real-world projects; we introduce and 
explain skills where they would naturally fall into a real 
project workflow. For example, rather than including 
an entire chapter about site management, we teach site 
management where you naturally need to do so — when 
you begin building a new site in each project.

The project-based approach in the Portfolio Series 
allows you to get in depth with the software beginning 
in Project 1 — you don’t have to read several chapters 
of introductory material before you can start creating 
finished artwork. 

The Portfolio Series project-based approach also 
prevents “topic tedium” — in other words, we don’t 
require you to read pages and pages of information about 
marking up text (for example); instead, we explain text-
related mark-up as part of a larger project (in this case, as 
part of a digital book chapter). 

Clear, easy-to-read, step-by-step instructions walk 
you through every phase of each job, from creating a new 
file to saving the finished piece. Wherever logical, we also 
offer practical advice and tips about underlying concepts 
and graphic design practices that will be important as you 
enter the job market.

The projects in this book reflect a range of different 
types of Dreamweaver jobs, from organizing a client’s 
site and links to developing a functional site template 
to building a dynamic site. When you finish the eight 
projects in this book (and the accompanying Portfolio 
Builder exercises), you will have a substantial body of 
work that should impress any potential employer.

The eight Dreamweaver projects are described briefly 
here; more detail is provided in the full table of contents 
(beginning on Page viii).
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 8 Bootstrap Responsive Page

o	 Working with Bootstrap

o	 Creating CSS3 Transitions
p
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 7 Vintage Car JavaScript Site

o	 Using JavaScript Behaviors

o	 Adding jQuery UI Elements

p
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 6 Kayaking CSS3 Site

o	 Working with CSS3 Selectors

o	 Working with Web Fonts

o	 Adding Video in HTML5

o	 Creating a CSS3 Image Gallery

p
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je
ct

 5 Cupcake Bakery CSS Site

o	 Working with Classes

o	 Creating Online Forms

p
ro
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ct

 4 Museum CSS Layout

o	 Creating Layouts with Style Sheets

o	 Working with a Template

o	 Using CSS 
to Control 
Content

Our goal in this book is to familiarize you with the 
Dreamweaver tool set, so you can be more productive and 
more marketable in your career as a graphic designer.

It is important to keep in mind that Dreamweaver is 
an extremely versatile and powerful application. The sheer 
volume of available panels, options, and features can seem 
intimidating when you first look at the software interface. 
Most of these tools, however, are fairly simple to use with a 
bit of background information and a little practice. 

Wherever necessary, we explain the underlying concepts 
and terms that are required for understanding the software. 
We’re confident that these projects provide the practice you 
need to be able to create sophisticated artwork by the end of 
the very first project.
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Getting Started
Prerequisites

The Professional Portfolio Series is based on the assumption 
that you have a basic understanding of how to use your 
computer. You should know how to use your mouse to 
point and click, as well as how to drag items around the 
screen. You should be able to resize and arrange win-
dows on your desktop to maximize your available space. 
You should know how to access drop-down menus, and 
understand how check boxes and radio buttons work. It 
also doesn’t hurt to have a good understanding of how 
your operating system organizes files and folders, and how 
to navigate your way around them. If you’re familiar with 
these fundamental skills, then you know all that’s necessary 
to use the Portfolio Series. 

Resource Files

All of the files you need to complete the projects in 
this book — except, of course, the Dreamweaver 
application files — are on the Student Files Web page at 
againsttheclock.com. See the inside back cover of this book 
for access information.

Each archive (ZIP) file is named according to the related 
project (e.g., Cars_DWCC17_RF.zip). At the begin-
ning of each project, you must download the archive file 
for that project and expand that archive to access the 
resource files that you need to complete the exercises. 
Detailed instructions for this process are included in the 
Interface chapter.

Files required for the related Portfolio Builder exercises at 
the end of each project are also available on the Student 
Files page; these archives are also named by project (e.g., 
Flowers_DWCC17_PB.zip).

Software Versions

This book was written and tested using the 2017 release of 
Adobe Dreamweaver CC software (Build 9315). You can 
find the version and build number in the Splash Screen 
that appears while your application is launching, or by 
choosing About Dreamweaver in the Dreamweaver CC/
Help menu. 

Because Adobe has announced periodic upgrades rather 
than releasing new full versions, some features and func-
tionality might have changed since publication. Please 
check the Errata section of the Against The Clock Web site 
for any significant issues that might have arisen from these 
periodic upgrades.

System Requirements

The Professional Portfolio Series was designed to work on 
both Macintosh or Windows computers; where differences 
exist from one platform to another, we include specific 
instructions relative to each platform. One issue that 
remains different from Macintosh to Windows is the use of 
different modifier keys (Control, Shift, etc.) to accomplish 
a task. When we present key commands, we always follow 
the same Macintosh/Windows format — Macintosh keys 
are listed first, then a slash, followed by the Windows keys. 

xi
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Typical Dreamweaver work ranges from static HTML pages with hyperlinks to complex, dynamic, 
database-driven sites, where pages are generated on-the-fly based on individual user requests. 
Mastering the tools and techniques of the application can significantly improve your potential career 
options. Our goal in this book is to teach you how to use the available tools to create different types 
of work that you might encounter in your professional career. 

The basic exercises in this introduction are designed to let you explore the Dreamweaver 
user interface. Whether you are new to the application or upgrading from a previous version, we 
recommend you follow these steps to click around and become familiar with the basic workspace. 

Launching the Dreamweaver Application

The first time you launch Dreamweaver, you see a series of setup screens that 
determine what is included in the initial user interface (UI). In this exercise, we walk 
you step-by-step through the initial setup process.

	 1.	 Macintosh users: 

		�  While holding down the Command-Option-Shift keys, launch 
Dreamweaver. 

		�  Windows users: 

– �� Locate the Dreamweaver application folder on your system (probably 
C:/Program Files/Adobe/Adobe Dreamweaver [version]).

– � �Press and hold the Control-Shift-Windows keys and double-click 
Dreamweaver.exe. 

	 2.	 Click Yes when asked if you want to reset preferences and settings.

Steps 1–2 reset the application to its original 
“out-of-the-box” state, resulting in Dreamweaver 
launching as if for the first time. 

	 3.	 When you see the setup screen asking if you have used Dreamweaver 
previously, click the Yes, I Have button.

This book is designed to teach you how to use the software; clicking the “Yes” button 
allows you to more quickly move on to the exercises in this book.

The Dreamweaver CC User Interface

Note:

If you click the No, I’m 
New button, you will see 
a series of introductory 
videos before you can use 
the software. 
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	 4.	 In the second setup screen, choose the color theme you prefer.

The color theme defines the basic appearance of your overall workspace, including the 
darkness or lightness of various panels and panes throughout the application. The screen 
captures throughout this book use the lightest option because they reproduce better on a 
printed page. Feel free to use whichever theme you prefer.

	 5.	 In the third setup screen, choose the Standard Workspace option.

These options define what you see when you first begin using the application. Regardless 
of what option you choose here, the workspace is highly customizable; you will learn 
how to personalize your individual workspace in the next exercise.

Note:

You can change the 
color theme of your 
workspace at any time in 
the Interface pane of the 
Preferences dialog box.
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	 6.	 Click the Close button in the final setup screen to dismiss the setup screen.

You can use the arrow buttons to navigate through the featured new options, or simply 
close the screen to begin working in Dreamweaver.

	 7.	 If you see a message about syncing settings, click the Advanced button. 

As part of your individual-user Adobe 
Creative Cloud membership, you can use 
the Sync Settings options to share certain 
custom assets between different computers. 
This means that you can access those same 
assets on any computer where you are logged in to your Creative Cloud account.

Clicking the Advanced button in the warning dialog box opens Sync Settings pane of 
the Preferences dialog box, where you can customize which settings are synced.

If you check the Enable Automatic Sync option, changes to the settings in your desktop 
application automatically upload to your Creative Cloud account, and changes to your 
Creative Cloud account are automatically applied whenever you use the application. 

	 8.	 Click Close to dismiss the Preferences dialog box.

	 9.	 Continue to the next exercise.

Note:

If you do not enable 
automatic syncing, 
you can click the Sync 
Settings button in the 
top-right corner of the 
user interface to initiate 
the sync process at any 
time. 

Note:

You must be logged into 
your Creative Cloud 
account and connected to 
the Internet for the sync 
process to work. You can 
open the Help menu to 
verify that you are signed 
in to your Creative Cloud 
account.
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Exploring the Dreamweaver Workspace

After making your initial choices in the setup screens, you will see the default 
workspace settings defined by Adobe. When you relaunch the application after you 
or another user has quit, the workspace defaults to the last-used settings — including 
specific open panels and the position of those panels on your screen.

As you gain experience and familiarity with the software, you will develop 
personal working styles and preferences. You will also find that different types of jobs 
often require different but specific sets of tools. In recognition of this wide range of 
needs, Dreamweaver includes many options for customizing the arrangement of the 
application’s many panels. We designed the following exercise so you can explore 
various ways of controlling Dreamweaver’s panels. 

	 1.	 Macintosh users: Open the Window menu and make sure the Application 
Frame option is checked (toggled on). 

Many menu commands and options in Dreamweaver are toggles, 
which means they are either on or off; when an option is already 
checked, that option is toggled on (visible or active). You can toggle 
an active option off by choosing the checked menu command, or toggle an inactive 
option on by choosing the unchecked menu command.

	 2.	 Review the various elements of the workspace.

Because you chose the Standard workspace in the previous exercise, the default UI 
includes the Common Toolbar on the left and a set of docked expanded panels on the 
right side of the workspace. 

Docked, expanded 
panel groups

Each panel in an 
expanded group is 
represented by a tab.

Common 
Toolbar

Menu bar

Application bar

Workspace switcher

Close

The Windows Menu bar includes 
the same options that are available 

in the Macintosh Application bar.

MaximizeMinimize

Close MaximizeMinimize

This option should 
be checked.
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The general Macintosh and Windows workspaces are virtually identical, with a few 
primary exceptions:

•	 On Macintosh, the application’s title bar appears below the Menu bar; the Close, 
Minimize, and Restore buttons appear on the left side of the Application bar,  
and the Menu bar is not part of the Application frame. 

	 On Windows, the Close, Minimize, and Restore buttons appear at the right end 
of the Menu bar, which is part of the overall Application frame.

•	 Macintosh users have two extra menus (consistent with the Macintosh operating 
system structure). The Apple menu provides access to system-specific commands. 
The Dreamweaver menu follows the Macintosh system-standard format for all 
applications; this menu controls basic application operations such as About, 
Hide, Preferences, and Quit.

•	 On Windows, each application is contained within its own frame; all elements of 
the application — including the Menu bar, panels, and open documents — are 
contained within the Application frame; you can’t turn off the Application frame 
on the Windows OS. On Macintosh, you can toggle the Application frame off in 
the Window menu; when the Application frame is not active on Macintosh, you 
can also toggle the Application bar on and off in the Window menu.

The Common Toolbar, which you can toggle on or off in the 
View>Toolbars submenu, appears by default on the left side 
of the UI when you use the Standard workspace. It provides 
easy access a number of useful options. (These options will 
make more sense as you complete the projects in this book, 
in which these are explained more clearly in context.)

The Open Documents menu ( ) lists all open files. 
Choosing a file in this list makes that file active in the 
document window.

The File Management menu ( ) includes options for 
managing files that are uploaded on a remote server. You 
can Get files from or put files onto the server; and check 
files in or out to view or make changes to files that are 
being managed in a team setting.

The Live View Options menu ( ) includes a number 
of options for managing what you see in the document 
window when the Live view is active.

The Toggle Visual Media Queries Bar button ( ) can 
be used to show or hide that element, which appears by 
default at the top of the document window whenever the 
Live view is active. 

The Expand All button ( ) can be used to expand any 
code blocks that have been collapsed in the Code pane.

The Format Source Code menu ( ) includes a number of 
options for formatting code in the Code pane.

The Apply Comment menu ( ) includes several options for 
adding comments to code in the Code pane.

The Remove Comment button ( ) removes commenting 
identifiers from the selected code in the Code view.

The Customize Toolbar button ( ) opens a dialog box that 
you can use add or remove various options from the toolbar. 
If you make changes, you can always reopen the dialog box 
and click the Restore Defaults button to reset the toolbar to 
its original state.D
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	 3.	 On the right side of the workspace, click the Files tab in the top docked 
panel group and drag left, away from the dock.

The area where the default panels are stored is called the panel dock. You can move 
any docked panel (or panel group) away from the dock, so it appears as a separate panel 
(called a floating panel).

Click the panel tab 
and drag to move a 

specific panel.

Drag from this area (called 
the panel drop zone) to 

move an entire panel group.

When you release the mouse 
button, the dragged panel “floats” 

separate from the panel dock.

	 4.	 Click the Files panel tab again and drag back to the dock until a blue line 
appears to the right of the existing dock column.

You can move panels by dragging their tabs to another position in the dock. To move an 
entire panel group (including all panels in the group), you can click and drag the panel 
group’s drop zone.

The blue line indicates where the panel or group will appear if you release the mouse 
button. To add a panel to an existing panel group, drag until the target group’s drop 
zone turns blue.

When you release the mouse button, 
the dragged panel appears to the 
right of the existing dock column.

Drag the Files panel tab until 
you see a blue line to the right 

of the existing dock column.

	 5.	 Double-click the dock title bar above the left dock column panel.

Panels, whether docked or floating, can be collapsed to icons (called iconic or iconized 
panels) to save space in the document window. By default, iconized panels appear with 
the panel name to the right of the icon.

Double-click the title bar 
over a dock column to 

toggle between expanded 
and iconized modes.

Note:

Each dock column is 
technically considered a 
separate dock; it can be 
expanded or iconized 
independently of other 
columns.

Note:

When we provide an 
instruction to “click and 
drag” you should hold 
down the mouse button 
while you drag.

Note:

You don’t need to move 
a panel out of the dock 
before placing it in a 
different position within 
the dock. We included 
Step 3 to show you how 
to float panels and panel 
groups. 
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	 6.	 Click the left edge of the iconized panels and drag right. 

When panels are iconized, you can reduce the panel buttons to the icons only. This can 
be particularly useful once you are more familiar with the application and the icons used 
to symbolize the various panels.

Click the left edge and 
drag right to reduce 

the iconized panel 
buttons to icons only.

Iconized panel 
groups are separated 

by heavy lines.

If docked panels are not iconized, you can drag the left edge of the dock column to 
make it wider or narrower. All panel groups in that column are affected. 

You can also drag the line between two panel groups in the same dock column to make 
panels shorter or higher. When you drag the bottom edge of a docked group, other 
panels in the same column expand or contract to fit the available space. Some panels, 
such as the CSS Designer panel, have a smallest-possible size; depending on your 
monitor size, you might not be able to fully expand another panel in the same dock 
column if another panel would be smaller than its required minimum height.

	 7.	 Control/right-click the title bar above the iconized dock column. If the 
Auto-Collapse Iconic Panels option is not checked, choose that item to 
toggle on that option. 

As we explained in the Getting Started 
section, when commands are different for 
the Macintosh and Windows operating 
systems, we include the different commands 
in the Macintosh/Windows format. In this case, Macintosh users who do not have right-
click mouse capability can press the Control key and click to access the contextual menu. 
You do not have to press Control and right-click to access the menus. 

(If you’re using a Macintosh and don’t have a mouse with right-click capability, we highly 
recommend that you purchase one. They’re inexpensive, they’re available at almost any 
retail store, and they save significant amounts of time accessing contextual options.)

Control/right-clicking a dock title bar opens the dock contextual menu, where you 
can change the default panel behavior. When the Auto-Collapse Iconic Panels option 
is toggled on, panels collapse as soon as you click away from them. If you uncheck this 
option, panels will remain open until you intentionally collapse them. 

	 8.	 In the left column of docked panels, click the third button in the bottom 
panel group (Snippets).

When panels are grouped, the button you click is the active panel in the expanded group.

Hovering your mouse 
over an iconized panel 
button shows the 
name of the panel.

Clicking a docked panel 
button opens the panel to 
the left of the panel dock.

Click here to manually 
collapse an expanded 

panel group.

Click here to 
open the panel 
Options menu.

This option should 
be checked (active).

Note:

Floating panel groups 
can be iconized just like 
columns in the panel 
dock. Simply double-
click the title bar of the 
floating panel group to 
toggle between expanded 
and iconized modes.
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	 9.	 Control/right-click the Snippets panel tab and choose Close Tab Group in 
the contextual menu.

Choosing Close in the menu 
closes only the active panel. Close 
Tab Group closes all panels that 
are docked together. When panels 
are docked, the contextual menu 
options are the only way to close a 
panel or panel group. 

	10.	 Choose Window>CSS Designer. 

All panels can be accessed in the Window menu. 

•	 If you choose a panel that’s open but iconized, the panel expands to the left of its icon. 
•	 If you choose a panel that’s part of an expanded group, that panel comes to the front 

of the group. 
•	 If you choose a panel in a minimized group, the panel group expands and the 

selected panel comes to the front of the group.
•	 If you choose a panel that isn’t open, it appears in the same position as when it was 

last closed.

   

	11.	 Click the CSS Designer panel tab and drag until a blue line appears below 
the Files panel.

The blue line shows 
where the panel will be 
placed when you release 
the mouse button. 

Control/right-click a panel tab 
to open the contextual menu.

Note:

Closing one panel from 
a panel group does not 
affect the other panels in 
the same group.

Note:

You can also close 
individual panels by 
dragging them away from 
the dock or group, and 
then clicking the Close 
button on the floating 
panel (group).
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	12.	 In the right column of the panel dock, click the line between the two panel 
groups and drag up until the CSS Designer panel occupies about two-thirds 
of the vertical space.

Drag the line between 
panel groups to resize 
the panels vertically.

	13.	 Double-click the CSS Designer panel tab to minimize that panel group.

You can minimize an expanded panel group by double-clicking the active panel tab. 
When minimized, only the group’s panel tabs are visible. 

If a docked panel is already minimized, clicking a panel tab once expands that group.

Double-click a panel 
tab to minimize that 

group in the dock.

	14.	 Click the Insert panel button to expand that panel group. Click the Insert 
panel tab and then drag up and left until a blue line appears immediately 
below the Application/Menu bar.

The Insert panel contains buttons for adding a number of common elements to a Web 
page. Various commands are categorized into groups, which can be accessed using the 
menu at the top of the panel when it is docked in the default position.

The Insert panel can be displayed as a tabbed row at the top or bottom of the workspace, 
which can be especially useful if you have a small monitor. When the Insert panel 
appears in the tabbed format, you can click the tabs in the top row to access the different 
categories of options.

Dock the Insert panel at the top of the 
workspace to display it as a series of tabs.

Note:

Drag a panel into a 
group’s drop zone to add 
a panel to an existing 
panel group.

Note:

Even if a panel is not 
grouped with others (no 
other panel tabs appear 
at the top of the panel), 
that panel is still referred 
to as a panel group.

Note:

Because workspace 
preferences are largely a 
matter of personal taste, 
the projects in this book 
direct you to use specific 
panels, but you can 
choose where to place 
those elements within the 
interface. 



10 The Dreamweaver CC User Interface

	15.	 Choose Window>Properties to open the Properties panel. Drag the 
Properties panel until you see a blue line at the bottom of the workspace, 
then release the mouse button to dock the Properties panel.

Dock the Properties 
panel at the bottom 
of the user interface.

	16.	 Continue to the next exercise.

Create a Saved Workspace

Over time you will develop personal preferences — the Files panel always appears 
at the top, etc. — based on your work habits and project needs. Rather than re-
establishing every workspace element each time you return to Dreamweaver, you can 
save your custom workspace settings so they can be recalled with a single click.

	 1.	 Click the Workspace switcher in the Application/Menu bar and choose  
New Workspace.

Again, keep in mind that we list differing commands in the Macintosh/Windows 
format. On Macintosh, the Workspace switcher is in the Application bar; on Windows, 
it’s in the Menu bar. 

Saved workspaces (accessed in the Window>Workspace Layout menu, or in the 
Workspace switcher) provide one-click access to a defined group of panels. 

	 2.	 In the Save Workspace dialog box, type Portfolio and click OK.

The Workspace 
switcher shows 
the name of the 
active workspace.

Note:

User-defined workspaces 
are listed at the top of the 
menu. 
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	 3.	 Control/right-click the Files panel tab and choose Close in the menu.

	 4.	 Open the Workspace switcher and choose Developer.

   

	 5.	 Open the Workspace switcher again and choose Portfolio to restore your 
custom workspace.

Calling a saved workspace restores the last-used state of the workspace. Because you 
closed the Files panel after saving the workspace, Dreamweaver reverts to the last-used 
version of the custom workspace — without the Files panel.

Note:

The Manage Workspaces 
option in the Workspace 
switcher opens a dialog 
box where you can choose 
a specific user-defined 
workspace to rename or 
delete. 
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