
Your client has opened a new 
restaurant in a fast-growing 
community in Southern California. 
He has already designed the pages for 
his site, but has hired you to make 
sure everything works properly and 
then make the site available to the 
browsing public. 

This project incorporates the following skills:

o	 Creating, exporting, and removing site definitions in 
Dreamweaver

o	 Moving files around in a site root folder

o	 Creating relative links between pages in a site

o	 Defining absolute links to external sites and email addresses

o	 Improving search engine optimization (SEO) with file names  
and titles

o	 Cloaking site files from a Web server

o	 Uploading files to a Web server

Bistro Site Organization
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Project Meeting
I already created the pages for our site, but I 
don’t know what links to use, and I’m not sure 
how to create them. I’ve also heard that there 
are certain things you should do to improve a 
site’s search engine rating — which is obviously 
important for a small business like mine.

The more pages you add to a site, the more 
complex it becomes, until it’s almost impossible 
to make sense of what you have and where it  
is located. Web sites — even those with only  
a few pages — should be designed with a  
good organizational plan, making it easier to 
modify pages later. 

Once you have a handle on the organization, 
make sure the pages link to each other 
properly. Visitors get frustrated very quickly 
when they’re forced to return to the home page 
every time they want to jump to a different set 
of pages. 

The last thing you should do is add page 
titles and change file names to give a better 
indication of what’s on each page. Doing so 
will make the site more accessible to people 
with screen-reader software, and it will also 
improve the site’s ratings on search engines.

To complete this project, you will:

o	 Create a Dreamweaver site definition 

o	 Create new folders within the site  
root folder

o	 Use various methods to move files from  
one place to another within the site

o	 Create links between pages using several 
techniques available in Dreamweaver

o	 Differentiate between relative and  
absolute links

o	 Copy and paste links from one page to 
another

o	 Improve searchability and usability using 
page names and titles

o	 Cloak site files to hide them from the  
Web server

o	 Upload the site files to a server so they can 
be viewed online
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Stage 1	 Exploring Site Structure
When you start a new project that involves updating an existing site, your first task is to assess the file 
and folder structure. Doing so gives you a good idea of what the site contains. 

A small site with only a few pages requires very little organization; in fact, you can place all of 
the files — Web pages and image files — in one folder (although even a small site benefits from a 
dedicated folder for images). Larger sites, however, require careful organization of file names, pages, 
and image files. A good site design with excellent organization speeds development now, and makes it 
much easier to update the site later. 

Create a New Site Definition

Web sites are designed so all of the Web pages, image files, style sheets, and other 
resources are stored on your local drive in a base folder called the root folder. Other 
folders can be placed inside (below) the root folder to make it easier to manage and 
organize files.  

	 1.	 Download Kinetic_DWCC16_RF.zip from the Student Files Web page.

	 2.	 Expand the ZIP archive in your WIP folder (Macintosh) or copy the archive 
contents into your WIP folder (Windows).

This results in a folder named Kinetic, which contains all the files you need to 
complete this project. 

If necessary, refer to Page 10 of the Interface chapter for specific instructions on 
expanding or accessing the required resource files.

	 3.	 In Dreamweaver, set up your workspace so the Files, Insert, and Properties 
panels are visible. 

It doesn’t matter which saved workspace you start with. The primary tools you need for 
this project are the Files, Insert, and Properties panels. We have closed all other panels to 
maximize the available space in our screen shots.

	 4.	 In the Files panel, click the Manage Sites link or open the Directory menu 
and choose Manage Sites from the bottom of the list.

If available, clicking 
Manage Sites opens 
the Manage Sites 
dialog box.This option performs the 

same function as clicking 
the blue Manage Sites link.

	 5.	 Click the New Site button in the Manage Sites dialog box.

When a site is defined 
in Dreamweaver, the 
Manage Sites link at the 
top of the Files panel is 
replaced by a menu that 
defaults to Local view. 

Note:

Ellipses in a menu or 
button name indicate 
that clicking will open 
a dialog box. We do not 
include the ellipses in our 
instructions.

Note:
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	 6.	 In the Site Setup dialog box, make sure Site is selected in the category list. 

	 7.	 Type Kinetic in the Site Name field.

The site name can be anything that will allow you to easily recognize the project; it is 
only for identification within Dreamweaver. For example, you could use “Eve’s site” as 
the site name within Dreamweaver to describe the Web site (www.evelynsmith.biz) that 
you are creating for your friend. 

	 8.	 Click the Browse for Folder button to the right of the Local Site Folder field. 
Navigate to the WIP>Kinetic folder and click Choose/Select Folder to return to 
the Site Setup dialog box.

Part of the process of defining a site within Dreamweaver is to specify a particular folder 
as the site root folder of the Web site. Clicking the Local Site Folder button opens a 
navigation dialog box where you can find the folder you want to use.

Browse for 
Folder button

	 9.	 Click Save to close the Site Setup dialog box.

	10.	 In the Manage Sites dialog box, make sure the Kinetic site appears in the list 
of sites, and then click Done.

	11.	 Continue to the next exercise.

You will learn about 
other options in the Site 
Setup dialog box later in 
this book.

Note:
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Examine the Site Files 
There are many files in the Kinetic site folder. The first step in organizing the files is to 
examine the Web page files and understand what they contain.

	 1.	 With Kinetic showing in the Directory menu of the Files panel, expand the 
site folder (if necessary) and examine the files in the site.

Click and drag the header 
edge to make the column 
wider or narrower.Click this button to 

expand the folder.

Directory menu

Click here and drag 
left to make the 

panel wider.

This is the root folder 
of the current site.

	 2.	 Double-click index.html in the Files panel to open the file in Dreamweaver.

Using the options on the left side of the Document toolbar, close the Code 
pane (if necessary) and make the regular Design view active; the Live view 
should be turned off. 

All of the pages in this site use the same basic design. The links at the top of each page 
need to navigate between the pages. The copyright information at the bottom (in the 
footer area) needs to navigate to the copyright owner’s Web site, which is external to 
your client’s site.

These words will be 
links, which will appear 
on every page in the site.

Choose Design in this 
menu to show the 

regular Design view.

Click this button 
to show only the 

Design view.

This should be a link 
to the copyright 
holder’s Web site.

If more than one site is 
defined, you can switch 
between sites using the 
Directory menu of the 
Files panel.

Note:
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	 3.	 Close index.html, then open contact.html.
As you can see, this page uses the same basic design as the index page. The specific page 
content also includes an email link, which you need to define so that users can click the 
link to send your client an email message.

These links should be 
the same on every 
page in the site.

This should be an 
email link to your 
client’s email address.

	 4.	 Close contact.html, then open menu1.html.
Again, the page uses the same basic layout as the other pages in the site. The top area of 
this page’s primary content indicates that there are actually two menus — Dinner and 
Lunch. As you can see in the Files panel, two separate menu files exist. You will use the 
two headings at the top of the page to create links to each menu.

These words should 
link to the relevant 
menu page.

	 5.	 Close menu1.html, then continue to the next exercise.

The layout for this site 
is based on the free 
“Creation” template from 
www.templatemo.com. 
Photos are by Charlie 
Essers.

Note:
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Plan Folder Organization 
When all files are dumped into the main site folder, it can be challenging to manage 
your work. A well-organized site is an easy-to-manage site. Ideally, organization occurs 
before the site is constructed, but Dreamweaver makes it easy to reorganize files and 
folders at any point in the process. 

There are no absolute rules to follow for organizing files and folders — other than 
the general principle of keeping related components together, so you know where to 
find certain files when you need them.

	 1.	 With the Kinetic site open in the Files panel, scroll to the top of the Files 
panel (if necessary). Control/right-click the  
site name and choose New Folder from the  
contextual menu.

The basic pages (home, about, contact, etc.) form 
the root of the site, and they should therefore appear 
within the root folder of the site. Other pages are 
better kept in folders that are named based on what 
they contain.

	 2.	 Type resources and press Return/Enter to apply the new folder name.

If the folder name remains untitled after pressing Return/Enter, Control/right-click the 
untitled folder, choose Edit>Rename in the contextual menu (or press the F2 key), and 
retype the new folder name.

By default, the Files panel displays the site files on your local 
computer. The top of the Files panel also includes buttons 
that allow you to manage the files in your site:

A	 The Directory menu includes a list of available drives, 
sites that have been defined in Dreamweaver, and a link 
to the Manage Sites dialog box.

B	 Connect to Remote Server establishes a connection 
with the remote server (if you defined one). Otherwise, 
clicking this button opens the Site Definition dialog box.

C	 Refresh refreshes the file list that displays in the panel.

D	 Get Files from Remote Server copies the selected 
files from a remote server to the local folder. If the 
Enable Check In and Check Out Files option is active, 
the copied files are available on the local site in read-
only mode, which means you can’t modify them. You 
must click the Check Out Files button to edit the files.

E	 Put Files to Remote Server copies the selected 
files from the local folder to the remote server. If a new 
file is added to the server, and if the Enable Check In 
and Check Out File option is active, the file’s status is 
Checked Out.

F	 Use the View menu to view the files on the remote or 
testing servers by choosing the appropriate option from 
the View menu. 

G	 Expand shows both local files and the remote site  
(if one has been defined). The expanded Files panel has 
two panes; one displays the files on the remote or test 
server and one displays the local site files.

H	 Synchronize with Remote Server synchronizes files 
between the local folder and remote server so the same 
version appears in both places.

I	 Check In copies the selected files from the local folder 
to the remote server and makes the copied files read-
only in the local folder. To edit these files, you need to 
select them and click the Check Out Files button. 

J	 Check Out Files copies the selected files from the 
remote server to the local folder and locks the files, so 
only the user who checked out those files can edit them.

A

B

C

D

E

G

F

H

I

J

D
R

EA
M

W
EA

V
ER

 F
O

U
N

D
A

TI
O

N
S

The Files Panel in Depth



32 Project 1: Bistro Site Organization

	 3.	 Click the Refresh button in the Files panel.

When the Files panel is sorted by name, folders on Macintosh are alphabetized along 
with all other files and folders after refreshing the file list; on Windows, folders are 
moved to and alphabetized at the top of the list, above individual files. 

On Macintosh, folders 
are alphabetized 

along with all other 
files in the site.

Refresh button

On Windows, folders 
are alphabetized at the 
top of the site list, 
above individual files.

	 4.	 Control/right-click the main site folder again and choose New Folder from 
the contextual menu.

You want another folder at the same level as the resources folder — in the main level of 
the site root — so you first have to use the contextual menu for the site root folder. 

	 5.	 Type images and press Return/Enter to apply the new folder name.

Web design convention dictates image files be placed in a folder named “images” for 
easier organization. If you have many photos in various categories, you might want to 
create additional nested folders inside the main images folder.

	 6.	 Repeat Steps 4–5 to create another new folder named menus in the site root 
folder.

	 7.	 Refresh the list in the Files panel.

	 8.	 Continue to the next exercise.

You can create a new 
folder inside an existing 
folder (called nesting) by 
Control/right-clicking the 
existing folder — instead 
of the root folder — and 
choosing New Folder 
from the contextual 
menu.

Note:

Press F5 to refresh the file 
list in the Files panel.

Note:



33Project 1: Bistro Site Organization

Sort and Move Image Files 
When you define a site in Dreamweaver, the application reads all of the pages in the 
site (a process that can take a few minutes in a large site), notes the links between 
pages, and identifies which images are used in which pages. These associations between 
files are stored in a cache that Dreamweaver creates when a new site is defined. 

When files are moved or renamed within the site, Dreamweaver recognizes that 
other files are related to the moved or renamed files and prompts you to update the 
links in all of the affected files. 

	 1.	 With the Kinetic site open in the Files panel, click and drag burger.jpg 
into the images folder.

Make sure you drag the file directly over the name of the folder or folder icon; if you 
drag the file too far to the left or right, Dreamweaver will not move the file.

	 2.	 When prompted, click Update to update the affected pages with the new 
location for the burger.jpg image file.   
When a browser downloads a Web page, it reads 
the page code, requests the image files from the 
defined locations, and displays the images within 
the page. You should understand that images in 
Web pages are not embedded into Web pages; 
they are merged into the page by the browser.

Files being updated do not need to be open for Dreamweaver to change the required 
link information. If pages are open, links in those pages are updated, but the changes are 
not automatically saved; you have to manually save each open file to make the updates 
permanent.

If you choose Don’t Update in the Update Links dialog box, the image will not appear 
in the page that calls for that file. If you had moved the image file using Windows 
Explorer or the Macintosh Finder, Dreamweaver would not have been aware of the 
movement, and you would not have had the opportunity to adjust the path to the image 
file in pages that link to that image.

The burger.jpg file is now stored in the main images folder. When you move files into a 
folder, that folder automatically expands in the Files panel. 

To avoid potential 
problems if you 
accidentally close a file 
without saving, you 
might want to close open 
files before moving or 
renaming files in the 
Files panel.

Note:
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	 3.	 In the Files panel, click the Type column heading to sort the site files by type.

By default, site files are sorted by name. You can sort by another criteria by clicking the 
column headings in the Files panel. Sorting by type allows you to easily find all of the 
images that are used in this site.

	 4.	 Click the first JPG file in the list (onion-rings.jpg) to select that file. Press 
Shift and click kinetic.png to select all consecutive files between the first and 
the last ones you selected.

Press Shift to select multiple consecutive files in the panel. Press Command/Control and 
click to select multiple, nonconsecutive files.

You can also Command/Control-click to deselect a selected file. For example, if you 
select a file by accident, you can deselect it by Command/Control-clicking the file name. 

Click a column 
heading to sort files 
based on that option.

Shift-click the first 
and last files to select 
multiple consecutive 
files in the list.

	 5.	 Click the icon of any of the selected files and drag the selected files into the 
images folder. When asked, click Update to update all links to all of the 
moved files.

	 6.	 Click the down-facing arrow (Macintosh) or the “–” symbol (Windows)  
to the left of the images folder name to collapse the folder.

	 7.	 Click the Local Files column header to re-sort the files by name.

You can change the 
columns that appear 
in the Files panel — 
and the order of those 
columns — in the File 
View Columns pane of 
the Site Setup dialog box.

Note:

Images in Web sites 
typically have a GIF, 
JPG, or PNG extension.

Note:
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	 8.	 Select menu1.html and menu2.html, and move them into the menus folder. 
Update the links when asked.

This is a relatively small site, so nesting files into subfolders isn’t strictly necessary. 
However, when you work with larger files, clearly organized subfolders can be extremely 
helpful in maintaining a site that is easy to update as often as necessary.

	 9.	 Collapse the menus folder.

	10.	 Select and move the file tables.psd into the resources folder. 

In this case, you are not asked to update links. This is a layered Photoshop file that was 
used to create the background image behind the page content. It is not part of the actual 
Web site, but it’s a good idea to keep this type of file in the site folder in case you need 
to make changes later. Later in this project, you will learn how to prevent this file from 
being uploaded as part of the site. 

	11.	 Collapse the resources folder.

From the folder structure alone, the Web site appears to be better organized. You now 
know what to expect when you open each folder.

	12.	 Continue to the next stage of the project.

You can also copy and 
paste files into a folder 
using the Edit options 
in the contextual menus, 
or using the standard 
keyboard shortcuts:

Cut: 
Command/Control-X

Copy: 
Command/Control-C

Paste: 
Command/Control-V

Note:

As you have seen, Dreamweaver automatically asks you to 
update links when you move a file in the Files panel. You 
can change this behavior in the General pane of the 
Preferences dialog box.

If you choose Always in the Update Links... menu, the 
affected links are automatically updated without user 
intervention. In other words, you do not see the Update Files 
dialog box during the process.

If you choose Never, links are not automatically updated 
when you move files in the Files panel. If you do not 
manually correct links, they will result in an error when 
clicked by a user.D
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Stage 2	 Organizing the Site Navigation
Hyperlinks (the official term for links) can be created to link pages on a site to other pages within the 
same site, or to pages on other sites. A well-designed site includes links that make it easy to get to any 
part of a site from any other part of a site. You should carefully plan the flow of links and connections 
between pages — always keeping the reader’s usability in mind. 

Organizing links is a simple application of a science called information architecture, which is 
the organization of a Web site to support both usability and “findability.” As you organize site links, 
remember that your goal is to enable visitors to see a pattern in your links, which will assist them in 
navigating through your site. Keep the following points in mind when you plan a site’s link structure:

•	 You can’t know how visitors will enter your site. The primary site pages (home, about us, etc.) 
should be accessible from every page on the site.  

•	 When linking secondary pages such as different menus for different mealtimes, don’t make 
users constantly click the browser’s Back button. Links should allow users to navigate all 
sibling pages (at the same level) as easily as navigating the primary structure. For example, 
users should be able to access the dinner menu or lunch menu in the restaurant’s site without 
first going back to a main “Menu” page.

Using the terms “parent,” “child,” and “sibling” is simply a way of describing relationships between 
pages. A large Web site cannot provide links to all of the pages from its home page. By grouping 
pages, grouping groups of pages, and so on, you create relationships of equality between pages that are 
grouped together, as well as between groups that are grouped together. 

When you plan a new site, you should create this type of flowchart to make sure you create all the 
necessary links that make the site as user-friendly as possible. A flowchart of the required Kinetic site 
link structure is shown below. 

Kinetic Bistro Site Navigation

Home About Menus Events Contact

Dinner Lunch

In this stage of the project, you will learn various techniques to create the necessary links on the 
Kinetic site pages.
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Create Hyperlinks within the Site

Dreamweaver offers a number of options for creating the necessary links for any Web 
site structure.

•	 Hyperlink Button in the HTML Insert Panel. Clicking the Hyperlink 
button in the HTML Insert panel opens the Hyperlink dialog box, where you 
define the specific parameters of the link. 

•	 Insert>Hyperlink menu. This menu command opens the same dialog box 
that you see when you click the Hyperlink button in the Insert panel.

•	 Properties Panel Fields. You can also simply define the specifics of a hyperlink 
in the Properties panel. This method offers the same options as those in the 
Hyperlink dialog box but does not require the dialog box interface. 

•	 Point to File button in the Properties panel. To create a link using this 
method, simply click the Point to File button, hold down the mouse button, 
and drag to a file in the Files panel; Dreamweaver automatically creates a link. 

•	 Browse for File button in the Properties panel. The Browse for File button 
opens a navigation dialog box where you can select the file that will open when 
a user clicks on the link. 

•	 Shift-Drag Method. You can create a link directly from the document window 
by pressing Shift and then clicking and dragging from the link source to the 
destination page in the Files panel. (This method only works for text; you can’t 
Shift-drag to create a link for an image.) 

•	 Quick Property Inspector in Live View. When the Live view is active, you 
can use the Link button in the Quick Property Inspector, which appears 
attached to the selected item in the document window, to create a hyperlink.

	 1.	 With the Kinetic site open in the Files panel, open index.html. Make sure the Live 
view is not active.

	 2.	 At the top of the page, double-click the word “HOME” to select it. 

	 3.	 If your Insert panel is docked above the document window, click the HTML tab at 
the top of the panel.

		�  If your Insert panel is docked on the right side of the screen, or if it is floating as a 
separate panel, choose HTML in the menu at the top of the panel.

If docked in standard mode, 
use the menu at the top of 

the panel to access different 
categories of options.

If docked in tabbed mode, 
use the tabs at the top of 

the panel to access different 
categories of options.

Dreamweaver often 
includes several different 
ways to achieve the same 
result. You should use 
the method that is most 
efficient at the time. 

Note:
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	 4.	 Click the Hyperlink button in the HTML Insert panel.

The HTML Insert panel contains many of the common functions you use to create 
Web pages. If a different Insert panel is showing, you can return to the HTML Insert 
panel by choosing HTML in the panel menu.

If docked in standard 
mode, buttons in the 

panel are identified by 
icon and name.

If docked in tabbed mode, 
hover your mouse over a 
button to find its name.

This word 
is selected.

	 5.	 In the Hyperlink dialog box, click the Browse button to the right of the 
Link field.

The text selected in the document appears in the Text field by default. (If an image is 
selected, this field defaults to be blank.)

Browse button

Text selected in 
the document is 

automatically entered 
in the Text field.

	 6.	 Navigate to your WIP>Kinetic folder, select index.html, and click  
Open/OK to return to the Hyperlink dialog box.

In the Link field, you can either type the URL of a location outside the site you’re 
building, or you can click the Browse button to select a file within the current site.

From this point on, we 
will leave our Insert 
panel docked on the right 
side of the workspace, 
immediately below the 
Files panel. Feel free to 
organize your workspace 
however you prefer.

Note:

Remember, when 
commands are different 
for different operating 
systems, we list them as 
Macintosh/Windows. 

Note:
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The HTML Insert panel contains buttons for frequently used items. For example, to insert a hyperlink, simply click the 
corresponding button. (Some of the terms and functions in the following descriptions will make more sense as you use those 
tools to complete later projects.)

•	 Div inserts sections (divisions) in a page, which are 
useful for inserting blocks of content that you want to 
format independently from other blocks. You will work 
extensively with div tags in later projects.

•	 Image opens a dialog box where you can define the 
source for the image you want to insert.

•	 Paragraph surrounds each selected paragraph with 
<p></p> tags, which is the proper HTML structure for a 
paragraph of text.

•	 Heading is used to assign predefined HTML heading 
levels (h1 through h6) to selected text.

•	 Table inserts an HTML table into the page.

•	 Figure inserts a properly structured HTML figure, 
including the appropriate tags for the figure and the 
figure caption.

•	 Unordered List creates a bulleted list from the 
selected paragraphs; each selected paragraph is 
automatically tagged as a list item.

•	 Ordered List creates a numbered list from the selected 
paragraphs; each selected paragraph is automatically 
tagged as a list item.

•	 List Item creates a new list item at the location of the 
insertion point. No ordered or unordered list is created 
to surround the list item.

•	 Hyperlink opens a dialog box where you can create 
text or image links to another file, either in the same 
Web site or in an external Web site.

•	 Header, Navigation, Main, Aside, Article, Section, 
and Footer add the related HTML5 tags to the page. 
You have the option to determine exactly how the 
tags are applied in relation to selected text, as well as 
defining an ID or class attribute for the resulting tag.

•	 Meta opens a dialog box where you can define a 
variety of page head information. When you type specific 
values in the name and content fields, the appropriate 
information is added to the page head using the 
following structure:

	       <meta name=”test” content=”123”>

•	 Keywords opens a dialog box where you can define 
keywords in the page head. The keywords are added 
using the following structure:

	       <meta name=”keywords” content=”words”>

•	 Description opens a dialog box where you can 
define a text-based description to the page head. The 
description is added using the following structure:

	       <meta name=”description” content=”Text”>

•	 Viewport offers a way to better control the appearance 
of a page on mobile devices. It sets the width of the 
visible area of a web page on a user’s device to match 
the width of the device screen.

•	 The Script button can be used to add code from an 
external file, which will be used by the browser to 
perform an action when the page is accessed. 

•	 The Email Link button opens a dialog box where you 
can create links to email addresses. 

•	 HTML5 Video inserts a video element, which allows 
a video file to be played directly in an HTML5 page 
without the need for external browser plugins.

•	 Canvas inserts a canvas element, which is a container 
for graphics that are created directly in the page using 
scripts. 

•	 Edge Animate Composition places a defined Edge 
Animate composition (OAM file) into the HTML page at 
the location of the cursor. 

•	 HTML5 Audio inserts a audio element, which allows 
an audio file to be played directly in an HTML5 page 
without the need for external browser plugins.

•	 Flash SWF allows you to place a SWF file (created from 
a Flash animation). Keep in mind that SWF files require 
the Flash Player browser plugin to function properly.

•	 Flash Video allows you to place an FLV file, which is 
a video format created from Flash professional. Again, 
this format requires the Flash Player browser plugin to 
function properly.

•	 Plugin embeds a specific user-defined plugin file into 
the page.

•	 Rollover Image opens a dialog box where you can 
define the default image, as well as a different image 
that will appear when a user’s mouse cursor enters into 
the image area.

•	 iFrame inserts an iFrame element, which allows you to 
embed one document into another. 

•	 Horizontal Rule inserts a solid line across the width 
of the page. This can be useful for visually separating 
sections of text.

•	 The Date button inserts the current date and time. 
In the resulting dialog box, you can choose the date 
format, as well as an option to update the date and 
time whenever the file is saved.

•	 Non-Breaking Space adds a special character that 
prevents a line break from appearing between specific 
words in a paragraph.

•	 Character is used to insert special characters, such as 
copyright symbols and foreign currency characters.
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	 7.	 Open the Target menu and choose _self.

This option determines where the linked file will open: 

•	 _blank opens every linked file in a new, unnamed browser window. 
•	 �new creates a new browser window with the name “_new”. Every link assigned 

the _new target will open in that same _new browser window.
•	 _�parent is relevant if a page includes nested frames; this option opens the link in 

the frame or window that contains the frame with the link.  
•	 _self opens the link in the same frame or browser window as the link. This is the 

default behavior if you do not choose an option in the Target menu.
•	 _top opens the link in the same browser window, regardless of frames.

	 8.	 In the Title field, type Kinetic Bistro home page.

The Title field defines text that appears when the cursor is placed over the link text. 
Defining a descriptive title for links can help a page achieve better search engine results.

	 9.	 Click OK in the Hyperlink dialog box to create the link.

	10.	 Click the Split button in the Document toolbar to review both the design 
and code views at one time.

A Web page is basically a page full of code. A browser reads the code to determine how 
to treat various elements of the page. HTML code largely revolves around tags, which 
tell a browser how to interpret specific objects on the page.

A hyperlink is identified by the a element, which starts with the opening <a> tag;  
the link destination and target are defined as attributes of that tag (href="index.html" 
target="self"). After the link text, the closing tag (</a>) identifies the end of the link.

The link destination now 
appears in the Link field 
of the Properties panel.

The selected text 
is now a link.

In the code view, the link text 
is surrounded by opening 
and closing <a> tags, which 
identify the text as a link.

You can use the Access 
Key field to define a 
keyboard shortcut for 
the link and use the Tab 
Index field to specify the 
number of times a user 
needs to press the Tab key 
to select the link.

Note:
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	11.	 Select the word “ABOUT” at the top of the page.

	12.	 Click the Browse for File button to the right of the Link field in the 
Properties panel.

If you don’t see the Properties panel, choose Window>Properties. The Properties panel’s 
primary purpose is to review and change the properties of the selected HTML element 
(such as a heading, paragraph, or table cell). 

Browse for 
File button

The word ABOUT 
is selected.

	13.	 In the resulting dialog box, select about.html, and then click Open/OK.

The link destination now 
appears in the Link field of 

the Properties panel.

	14.	 Select the word “MENUS” at the top of the page. 

	15.	 Expand the menus folder in the Files panel.

You should expand and collapse Files panel folders as necessary, depending on your 
available screen space. We will not repeat instructions to collapse or expand folders 
unless it is necessary to perform a specific function. 

	16.	 Click the Point to File button in the Properties panel, hold down the mouse 
button, and drag to menus/menu1.html in the Files panel.

The word MENUS 
is selected.

Point to File 
button
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	17.	 Select the word “EVENTS” at the top of the page.

	18.	 Press the Shift key, then click the selected text and drag to events.html in 
the Files panel.

You have to press the Shift key, and then click and drag to the link destination.  
If you try to click and drag before pressing the Shift key, this technique will fail.

	19.	 Use any method you just learned to create a link from the word 
“CONTACT” to the contact.html file.

	20.	 In the Document toolbar, click the arrow to the right turn of the Design 
button and choose Live from the menu to turn on the Live view.

Choose Live in 
the menu to turn 
the Live view on.

Click the arrow 
to open the 

button menu.

Choose Design in 
the menu to turn 
the Live view off.

In the Live view, you can accurately see how the CSS will be rendered by Web browsers.

In the Live view, CSS 
is properly rendered 
and the link appears 
correctly on one line.

The button text shows 
whether (regular) Design 
or the Live view is active.

You can remove a link 
by selecting the linked 
text or object in the 
document and choosing 
Modify>Remove Link, 
or by simply deleting the 
text from the Link field 
in the Properties panel.

Note:

When a link to another 
page in the site is selected 
in the document, you 
can open the related 
page in Dreamweaver by 
choosing Modify>Open 
Linked Page.

Note:



The strong and em 
tags are explained in 
Project 2: Digital Book 
Chapter.

Note:
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	21.	 In the Design window with the Live view active, click once to select the 
footer paragraph at the bottom of the page.

When the Live view is active, clicking an object in the document window shows the 
Element Display, which shows the active HTML element. (If an element has a defined 
ID or class attribute, those also appear in the Element Display. You will learn about IDs 
and classes in later projects.) In this case, you can see that the selected element is a p 
element — in other words, it is a paragraph.

The Element Display 
appears when you 

click an object in the 
Live view.

The entire active 
element is surrounded 

by a blue border.

The element is 
identified in the 
widget header.

	22.	 Double-click the text in the selected paragraph to place the insertion point.

You can now place the insertion point and edit text directly in the Live view. (You might 
have to look closely to see the insertion point in this case.)

Double-clicking places 
the insertion point inside 

the active element.

The orange border identifies 
the element where the 

insertion point is placed.

	23.	 Double-click and drag to select the words “Against The Clock, Inc.” within 
the active paragraph.

In the Live view, the Quick Property Inspector shows options related to the selected text. 
You can use the B and I buttons to apply the <strong> and <em> tags (respectively). 
You can also click the Hyperlink button to define a link destination for the selected text.

Add <strong> 
tag

Add <em> 
tag

Hyperlink

Quick Property Inspector



You will work more 
extensively with tags 
beginning in Project 2: 
Digital Book Chapter.

Note:
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	24.	 In the Quick Property Inspector, click the Hyperlink button. In the 
resulting Link field, type http://www.againsttheclock.com as the link 
destination.

Dreamweaver can’t help you create an external URL link because it’s outside the site 
definition. You have to simply type or paste the address into the Link field.

An external URL link must begin with the “http://” protocol, followed by the domain 
name and, if relevant, the folder path and file name of the page to which you are linking. 

Clicking the Hyperlink 
button opens the Link field 

for the selected text.

You can click the Browse 
for File button to define an 

existing file as the link.

	25.	 Click anywhere else in the workspace to finalize the hyperlink you defined 
in Step 24.

	26.	 In the Document toolbar, click the arrow to the right turn of the Live 
button and choose Design from the menu to turn off the Live view.

You should become familiar with the process of turning the Live view on or off. We will 
not continue to repeat these specific instructions as you move throughout the projects in 
this book.

	27.	 Choose File>Save to save your changes, then continue to the next exercise.

Copy and Paste Links

Rather than manually creating the same links on every page, you can now simply copy 
and paste them from one page to another.

	 1.	 With index.html open (from the Kinetic site), click in any of the text links 
to place the insertion point.

The insertion point is the location where text will appear if you type.

	 2.	 Review the Tag Selector below the document window.

The Tag Selector, located in the status bar of the document window, shows the nesting 
order of HTML tags (the “path of tags”) based on the current selection or the current 
location of the insertion point. 

Insertion point

Active tag

Tag Selector

To minimize the 
repetitive work required, 
we already defined this 
link for you on the other 
pages in the site. In a 
professional environment, 
you would need to add 
this link to every page in 
the site.

Note:



45Project 1: Bistro Site Organization

	 3.	 Click the <ul> tag in the Tag Selector.

The <ul> tag identifies an unordered list, which is how this navigation structure was 
created; each link is a separate list item (using the <li> tag).

Clicking a tag in the Tag Selector selects that HTML element and all of its content.  
In the document window, the associated content is highlighted.

The entire 
unordered list (all of 
the links) is selected.

Selected tag

	 4.	 Choose Edit>Copy (or press Command/Control-C) to copy the selected 
content to the Clipboard.

	 5.	 Close index.html and open about.html.

	 6.	 Click to place the insertion point anywhere in the list of links at the top of 
the page, and then click the <ul> tag in the Tag Selector to select the entire 
unlinked list.

The selected 
list does not yet 
include links.

	 7.	 Choose Edit>Paste (or press Command/Control-V) to paste the copied 
content from the Clipboard.

	 8.	 Place the insertion point in any of the links and review the Tag Selector.

The Tag Selector now shows the <a> tag for the current insertion point (in our example, 
the EVENTS link). The Properties panel also shows the destination of the active link.

The pasted 
content includes 
the links.

	 9.	 Save the changes to about.html and close the file.

	10.	 Repeat Steps 6–9 to paste the copied content (the links) into all HTML pages in 
the site root level, as well as the two HTML pages in the menus folder. 

	11.	 Save and close any open file, and then continue to the next exercise.
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Adjust Relative Link Paths

A path is the route taken through the folder structure to link one page to another. By 
default, Dreamweaver uses relative paths when creating links (the application refers to 
this as “relative to the document”). The alternative is to create absolute paths (“relative 
to the site”); but unless your site is running on a Web server, you can’t test links that 
use absolute paths.

As an example, consider creating a link from index.html 
to about.html, both of which reside in the root folder (as 
shown in the figure to the right). In this case, the source and 
destination pages are in the same folder; the relative-path link 
simply states the file name of the destination page:

<a href="menu2.html">Link Text</a>

When you drill down into nested levels of folders, the source folder is not 
identified in the path; the link automatically works starting from the location of the 
link. To link from index.html to menu1.html, for example, you have to include the 
nested menus folder in the path: 

<a href="menus/menu1.html">Link Text</a>

When the link is in an upward direction, the ../ notation says “go up one folder.” 
To link from menu1.html to index.html in the site root folder means that the link 
needs to take the visitor up one folder level: 

<a href="../index.html">Link Text</a>

Each step up in the folder structure requires another command to “go one step 
up” in the folder structure. If you had another level of nesting inside the menus folder, 
for example, a link would have to take the visitor up two folder levels to return to the 
main index page:

<a href="../../index.html">Link Text</a>

	 1.	 With the Kinetic site open in the Files panel, open menu1.html. 
In this exercise, you are going to adjust the various links so they work properly on all 
pages in the site. 

	 2.	 Double-click the word HOME at the top of the page to select that element.

	 3.	 In the Link field of the Properties panel, type ../ before the existing link. 
Press Return/Enter to finalize the change.

Type  . ./ before the 
existing link.

ROOT
index.html         about.html         events.html         contact.html

MENUS
menu1.html         menu2.html
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The files for this project were created using  
divs (using the opening and closing <div> 
tags), which are simply a way to identify and 
format parts or sections of a page.

(You will work with divs in Project 4: Museum 
CSS Layout.) Although you don’t need to 
worry about the underlying page structure for 
now, you might see some unusual behavior 
when you try to select content in the main 
section the menu pages when the Live view is 
not active.

The area that holds the actual menu content 
has a fixed height, but both menus have more 
content than will fit into the defined size. 
When the page is viewed in a browser, the 
area includes a scroll bar for users to access 
the content that doesn’t fit.

In Dreamweaver’s regular Design view, 
however, this scrollbar doesn’t appear. 
Instead, the first time you click, the entire div 
is selected and all of the contained text is 
highlighted. 

Double-clicking inside the area again causes 
the page to jump down, showing the overflow 
content.

If you click a third time, you can place the 
insertion point inside the actual text, scroll up 
as necessary, and then select the link text at 
the top of the area.

Clicking once selects the entire div that contains the menu content...

...then double-clicking jumps the page down to show the overflow content.

You can then click again to place the insertion point and select specific text.
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	 4.	 Repeat Steps 2–3 for the ABOUT, EVENTS, and CONTACT links.

	 5.	 Select the word MENUS at the top of the page.

In this case, the link is still a problem because it directs the browser to look for a folder 
named “menus” inside the same folder as the active page. You need to remove the folder 
part of the path to prevent an error if a user clicks this link from the menu1.html page.

The active file is in 
the menus folder.

This link would cause a browser 
to look for a menus folder at the 

same level as the active file.

	 6.	 In the Link field of the Properties Inspector, delete menus/ (including the 
forward slash) from the existing link.

Delete the folder path 
from the existing link.

	 7.	 Using any method you have learned, link “Lunch Menu” (in the main 
content area) to menu2.html and link “Dinner Menu” to menu1.html.
See “Accessing Page Content in the Menu Pages” (Page 47) for specific information 
about selecting the text in the main content area.

Link this to menu2.html. Link this to menu1.html.

	 8.	 Repeat the process from Steps 1–7 to adjust the top links and add the 
necessary secondary links in the menu2.html file.

	 9.	 Save and close any open files, then continue to the next exercise.

You can save each file individually, or choose File>Save All to save all open files at once.
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Create an Email Link

Most Web sites include one or more external links (including email links), which 
require the appropriate protocol to tell the browser what type of link is present. 

An email link requires the “mailto:” protocol, followed by the appropriate email 
address. This instructs the browser to open a new mail message with the defined 
address already in the To line.

	 1.	 With the Kinetic site open in the Files panel, open contact.html. 
Make sure the Live view is not active.

	 2.	 Select the words “info@kineticbistro.atc” in the main content area. 

	 3.	 In the HTML Insert panel, click the Email Link button.

Selected text

	 4.	 Review the resulting dialog box.

If you select text before clicking the Email Link icon, 
the Text field is completed for you. Dreamweaver 
also recognizes that the selected text is an email 
address, so the Email field is filled in for you.

If the selected text is not recognized as an email address, the Email field defaults to the 
last address that was defined in the field.

	 5.	 Click OK to create the email link.

	 6.	 Review the link field in the Properties panel.

An email link must begin with “mailto:” followed by the address. When you use the 
Email Link dialog box, Dreamweaver automatically inserts the mailto: protocol.

In many cases throughout this book, we use “[company].atc” as the domain of a 
site. Although at the time of writing, none of the domain names we use are real, 
new domains are registered every day. We use the fictitious “.atc” domain to avoid 
inadvertently using the domain name of a real company. 

When you upload files to a server, you should use the accurate domain (.com, .gov, 
.edu, etc.) for the site you are building.

	 7.	 Save the file and close it, then continue to the next stage of the project.

You can access the  
same Email Link 
dialog box by choosing 
Insert>Email Link.

Note:
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Stage 3	 Naming and Titling Documents
When a Web server (a computer that stores and delivers Web pages) receives a request for a folder but not 
a specific page, the Web server delivers the default page for that folder — usually named index.html or 
index.htm. There is no practical difference between the two extensions; most Web servers can serve files 
with either extension. (If you do not have an index file in that folder, the link will result in an error.)

To create links to the default page in a specific folder, you do not need to include the file name if 
you use the index naming convention. Both www.kineticbistro.com/ and www.kineticbistro.com/
index.html refer to the same page.  

Rename Pages for Search Engine Optimization

Search engine optimization (SEO) is the process of improving the ranking of a Web 
page on search engine results pages (SERPs). Search engines certainly use the content 
of a page for ranking purposes, but the names of folders and files also affect rankings. 

Descriptive folder and file names improve usability; you can use m/menu1.html 
for the path to the dinner menu page, for example, but /menus/dinner-menu.html is 
much easier for visitors to understand — and will improve your search engine ranking. 

In this exercise, you rename the menu pages to more accurately describe what 
is contained in the files. As with moving files, the application recognizes when a file 
name has been changed and knows that links to the page must be adjusted.

	 1.	 With the Kinetic site open, click menus/menu1.html in the Files panel to 
select that file.

	 2.	 Click the selected filename again to highlight it.

This highlights the existing filename, excluding the extension. 

	 3.	 Type dinner-menu, then press Return/Enter. In the resulting dialog box, 
click Update to update all pages that link to this page.

Typing when the filename is highlighted replaces the previous file name. Pressing 
Return/Enter finalizes the change.

As with moving files, Dreamweaver recognizes that all links to the renamed page need to 
point to the new file name.

You can also Control/
right-click a file in the 
Files panel and choose 
Edit>Rename to rename 
a specific file.

Note:
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	 4.	 Repeat Steps 1–3 to rename menu2.html as lunch-menu.html.

	 5.	 Continue to the next exercise.

Create Document Titles for Individual Pages

Appropriate document titles are an important concern for both search engines and 
site visitors. While the document title does not appear within the body of a Web page, 
it does appear in the title bar of the browser, as the default name of the page in the 
Bookmarks or Favorites list, and as the page name in search-engine results pages. 

Page titles should be relatively short, around 70 characters or so to avoid their 
being truncated in various locations (such as a user’s Bookmarks/Favorites list). You 
should separate the components of the title with some type of divider, such as a 
colon (:) or pipe (|) character. 

In this exercise, you add document titles to the new pages to increase the pages’ 
search engine rankings and improve usability for visitors who find the pages in search 
engines and bookmarks. You also learn to use the Find and Replace function, which 
can greatly reduce the amount of effort required to create all of the document titles.

	 1.	 With the Kinetic site open in the Files panel, open index.html.

	 2. 	Click the Split button in the Document toolbar to show both the Code and 
Design views at one time.

Because different servers run on different operating systems, 
the safest way to name pages is to use only characters that 
are guaranteed to work perfectly: 

•	 a through z (use only lowercase letters)

•	 0 through 9

•	 Hyphen (great-site.html) 

•	 Underscore (great_site.html)

Consider everything else to be “illegal,” including:

•	 Spaces 

•	 Brackets of all kinds, including ( ), [ ], { }, and < >

•	 Symbols, including #, @, %, ~, |, *, and &

•	 Quotation marks, both double (“ ”) and single (‘ ’)

•	 Slashes, both back slashes (\) and forward slashes (/)

•	 Commas, periods, question marks, and exclamation 
points

•	 Uppercase characters

Some designers use CamelCase — uppercase letters at the beginning of each word within a file name, such as 
UniversalStudios.html. The problem with mixing the lettercase is that some Web server software is case-sensitive and some 
is not. Most Windows-based Web server software is not case-sensitive, but UNIX- and Linux-based Web server software is 
case-sensitive. Considering that many Web servers run on UNIX- or Linux-based computers, it’s best to use only lowercase 
file and folder names.
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	 3.	 Examine the Document Title field in the Properties panel.

When you create a new page in Dreamweaver, the default title is “Untitled Document”. 
That text appears in the Document Title field by default, and in the title element in the 
Code pane (wrapped in the opening and closing <title> tags).

Document title

	 4.	 Choose Edit>Find and Replace.

	 5.	 Open the Find In menu and choose Entire Current Local Site. 

This option allows you to affect all files in the active site. You can also search only 
selected text; the current (active) document; all open documents; a specific folder; or 
only selected files in the active site.

	 6.	 Choose Source Code in the Search menu.

The document title does not appear in the body of the page, so when you use Find and 
Replace, you must apply the change to the source code rather than the document text.

	 7.	 In the Find field, type Untitled Document.

	 8.	 In the Replace field, type Kinetic Bistro | Lancaster, California | . 
(Include a space after the final pipe character.) 

All pages in the site will include this block of text at the beginning of the document title. 
Further detail about individual pages will be added to the right of this information.

Unlike file names, document titles can use mixed lettercase and include spaces and other 
characters. However, you should avoid both single and double quotation marks.

When you use the Split 
view, feel free to arrange 
the pane however you 
prefer. We arrange them 
as necessary to best suit 
what we are trying 
to show in our screen 
captures.

Note:

Some experts disagree 
whether the company 
name should come before 
or after the specific page 
information in a title. 
However, putting the 
company name at the 
beginning of the page 
title can help with search 
engine results because 
the company name is an 
important keyword. 

Note:
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	 9.	 Click Replace All. When prompted to confirm whether you want to proceed 
with this function, click Yes.

Like most applications, Dreamweaver has an 
Undo function that allows you to undo the 
most recently completed actions; however, this 
function only works if the document is open. 
Since you are using the Find and Replace function on the entire folder and not only on 
an open page, you are making changes in closed documents — which means you cannot 
use the Undo command.

After completing the Find and Replace function, Dreamweaver displays the results in 
the Search panel.

	10.	 Examine the title in the Properties panel and the Code pane again for the 
open file (index.html). 

As a result of the Find and Replace function, the document title has been changed.  
The same change has been made in all pages in the site. (Because the title tag of the 
open page is active in the Code pane, the Properties panel now shows only options for 
that active element.)

	11.	 Control/right-click the Search panel tab and choose Close Tab Group.

	12.	 Click in the Code pane to make it active.

Making a specific pane active is called “bringing it into focus”.

	13.	 Click at the end of the existing page title to place the insertion point immediately 
before the closing </title> tag, then type Gourmet Casual Dining.

You can edit the page title in the Document toolbar or in the Code pane. Changes in 
either place are automatically applied to the other.

Type the new information immediately 
before the closing </title> tag.

In the Code pane, 
highlighting identifies the 

entire line where the 
insertion point is placed.

	14.	 Save index.html and close it.
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	15.	 Open about.html. Using either the Code pane or the Document Title field in the 
Properties panel, add Hours of Operation to the end of the existing page title.

	16.	 Save about.html and close it.

	17.	 Repeat this process (Steps 12–16) to change the page titles of the remaining 
pages as follows:

File	 Title

contact.html	 Address and Contact Information

events.html	 Special Event Facilities

menus/dinner-menu.html	 Dinner Menu

menus/lunch-menu.html	 Lunch Menu

	18.	 Continue to the final stage of the project.

Stage 4	 Making Files Public
To complete the final stage of this project — making your files accessible to the browsing public — 
you need to have access to some type of server. 

On the inside back cover of this book, you have a 
code that you need to gain access to the required resource 
files. The same code also provides access to a six-month, 
free trial Web hosting account at Pair Networks (www.
pair.com). 

If you don’t already have access to an online server, 
go to www.pair.com/atc/ to sign up for your hosting 
account before you complete the final stage of this 
project. You must enter your contact information and the 
code from the inside back cover of your book. You should 
then define a user name in the last field; this will become 
part of the server name for your hosting account.

After you click Continue, you will receive an 
acknowledgement that your request is being processed. 
(The message warns that the setup process can take up to 
one business day — although it is usually about an hour. 
You should complete this step as early as possible.)

You will receive a confirmation email, sent to the email you defined in the Signup Form, with 
your username and password information. Once you receive the confirmation email, you are ready to 
complete the final stage of this project. 

Important note: Pair Networks provides a free six-month trial account for Against The Clock 
users. If you do not cancel the account before the six months end, you will be billed a small monthly 
fee for the hosting account. 
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Hide Files from the Web Server

As you saw when you created the folders for the new site, not all of the new files are 
meant to be uploaded to the Web server — specifically, the Photoshop file in the resourc-
es folder. (You should, however, store such files locally as source files or documentation 
for the work you completed.) Dreamweaver provides a very useful function — called 
cloaking — that allows you to prevent certain files from uploading. You can cloak an 
individual file; cloak all files with the same extension (for example, all native Photoshop 
files with the PSD extension); or cloak a folder, which also cloaks all files in that folder. 

	 1.	 With the Kinetic site open in the Files panel, open the Directory menu and 
click the Kinetic site name in the menu.

This opens the Site Setup dialog box for the selected site. You do not need to go through 
the Manage Sites dialog box to edit the settings for the active site.

Click the site name in the 
Directory menu to open 
the Site Setup dialog box 
for the selected site.

	 2.	 In the Site Setup dialog box, expand the Advanced Settings menu on the left 
side and click Cloaking to show the related options.

	 3.	 Make sure the Enable Cloaking check box is active.

When Enable Cloaking is checked, you can hide selected files and folders from a Web 
server. You can also use the Cloak Files Ending With option to hide all files with the 
extensions that are listed in the field.

	 4.	 Click Save to close the Site Setup dialog box.

	 5.	 In the Files panel, collapse all open folders and expand only the resources folder.
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	 6.	 Control/right-click the resources folder and choose Cloaking>Cloak.

Notice the red slash through the resources folder icon and the icon for the file in the 
resources folder. The red slash refers to the cloaking function only; it does not prevent 
you from working with the files, adding more files, or deleting any of the existing files.

	 7.	 Continue to the next exercise.

Define Remote Connection Info for the Site

For Dreamweaver to manage file uploading, you first have to define the hosting server 
connection settings as part of the site setup information. 

	 1.	 With the Kinetic site open in the Dreamweaver Files panel, re-open the Site 
Setup dialog box for the site. 

	 2.	 In the Site Setup dialog box, click Servers in the list of categories, then click 
the + button near the bottom of the dialog box to define a new server.

You can also cloak 
a specific file by 
Control/right clicking 
that file in the Files 
panel and choosing 
Cloaking>Cloak.

Note:
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	 3.	 In the Basic options, type a name for the server you are using.

This name is simply for you to identify it in Dreamweaver.

	 4.	 Assuming you are working with a remote server, choose FTP in the  
Connect Using menu.

If you are using a local server, consult your network administrator for the settings to use.

	 5.	 In the FTP Address field, type the hostname for your server. 

Using our example hosting account at Pair Networks, the FTP host is the same as the 
server name. (If you signed up for this service, your server name was in the confirmation 
email that you received after signing up.) Check your hosting account documentation 
for your FTP hostname and account information.

	 6.	 Type your FTP login (username) and password in the related fields. 

These are the username and password for your hosting account. Again, this information 
was probably sent to you via email when you first set up the hosting account; consult 
your server documentation for the correct information to use.

	 7.	 In the Root Directory field, type the location of the folder where you want 
the files to be placed.  

Some hosting providers require you to place public files inside a specific folder, such as 
public_html or www. When users navigate to your URL, they see the index page located 
in the designated folder. 

Using a hosting account at Pair Networks, as in our example, public files must be placed 
in the /usr/home/USERNAME/public_html/USERNAME.pairserver.com/ folder (the 
word “USERNAME” would replaced by your personal username),

	 8.	 In the Web URL field, type the URL at which users will access the site.

Dreamweaver automatically defines this URL based on your other choices in this dialog 
box; the default value will be “http://” plus the FTP Address plus the Root Directory.  
In our example, the default was http://atctest.pairserver.com/usr/home/public_html/
atctest.pairserver.com/.

You need to change the URL to the path a user would type in a browser to access your 
site. In our example, the address is http://atctest.pairserver.com/. 

Note that we removed the root-directory folder path from the URL; it is only required 
when you upload files for viewing over the Internet. 

Make sure you enter the correct information for your domain name.

Step 3

Step 4

Step 5

Step 6

Step 7

Step 8
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	 9.	 Make sure the Save check box (next to the Password field) is checked, and 
then click Test.

You must receive a message stating that Dreamweaver 
successfully connected to the Web server. If a 
connection with the Web server cannot be established, 
check your entries to make sure your Internet connection is active, and then try again.

(If you are working on a shared computer, you might want to uncheck the Save option. 
However, you will have to retype your username and password every time you upload 
files to your hosting account.)

	10.	 Click Save to return to the Site Setup dialog box.

	11.	 Click Save to close the Site Setup dialog box, then continue to the next 
exercise.

Upload Files to a Remote Site

Dreamweaver’s FTP functionality makes it easy to put files into the remote site folder 
(defined in the Site Setup dialog box). You can even synchronize all files on the remote 
and local sites — which is useful when you are ready to publish the site for public 
Internet access.

	 1.	 With the Kinetic site open in the Files panel, click the Expand button in the 
Files panel to show both the local and remote sites.

Click this button to 
synchronize the remote 
and local site folders.

Click this button to toggle 
the panel between expanded 
and regular modes.

Click here to connect 
to the remote site.
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	 2.	 Above the Remote Server pane, click the Connection button to link to and 
show the remote site.

After the connection has been made, the remote site appears in the left pane of the Files 
panel. (Your host account might include a number of default files.)

	 3.	 Click the Synchronize button at the top of the expanded Files panel.

	 4.	 In the Synchronize with Remote Server dialog box, choose Entire ‘Kinetic’ 
Site in the Synchronize menu, and choose Put Newer Files to Remote in the 
Direction menu.

This utility enables you to synchronize an entire site 
or only selected files. You can also determine which 
version (local or remote) to synchronize from. For 
example, if you accidentally delete files from your local site folder, you can choose to 
synchronize files from the remote site to the local site to restore the missing files.

	 5.	 Click the Preview button.

After a few seconds, the Synchronize 
dialog box shows a list of all files that will 
be affected by the process. In this case, 
this is the first time you are uploading to 
the remote site, so all site files need to be 
put onto the remote site.

	 6.	 Click OK to put the files onto the remote site.

	 7.	 In the Background File Activity dialog box, click the arrow button to the 
left of the word “Details.” 

When you upload files to the remote server, Dreamweaver keeps a log of affected files. 
The Background File Activity dialog box shows a list of each file, including any potential 
problems encountered during the transfer process. Clicking the Details button expands 
the dialog box and shows the progression of the synchronization. 

Click here to 
show or hide 

syncing details.

After the synchronization is 
complete, the uncloaked files 

appear in the remote site.
All files should show 

“Put Operation successful.”

Note:

You can use the buttons 
at the bottom of the 
Synchronize dialog box 
to change the options for 
selected files in the list.
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	 8.	 Open a browser window. In the navigation bar, type the URL of the Kinetic 
home page at your domain name. 

Type the same Web URL you defined in the Servers section of the Site Setup dialog box  
(see Page 57, Step 8). In our example, the complete URL is http://atctest.pairserver.com/.

 

	 9.	 Test the various links in the site.

   

	10.	 Close the browser and return to Dreamweaver, then continue to the next 
exercise.
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Export and Remove the Site Definition

To reduce the potential for confusion, it’s a good idea to remove the defined sites of 
completed projects, leaving only the defined sites of current projects. 

As stated in the Interface chapter, removing a site from Dreamweaver does not 
delete the actual files and folders from your computer; it simply removes them from 
Dreamweaver. Rather than removing a site, however, you can export a site definition 
file — which you can later import to restore the same settings and options you already 
defined (as you did in the Interface chapter when you imported the sf-arts site). 

As you work through the projects in this book, you will export and remove site 
definitions for completed projects, so your site list remains manageable. You should get 
into this habit so you can quickly reinstate site definitions if necessary.

	 1.	 With the Kinetic site open in the Files panel, click the Collapse button in 
the Files panel.

The Files panel retains the last-used position and mode; it can be a good idea to collapse 
it whenever you are not interacting with files on a server.

Click here to collapse 
the panel back to the 
standard mode.

	 2.	 Choose Manage Sites at the bottom of the Directory menu.

You can access this menu even when the Files panel is in expanded mode.

	 3.	 In the Manage Sites dialog box, choose the Kinetic site name, and then click 
the Export button.

This function creates a “.ste” file that stores the Dreamweaver site definition settings. 
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	 4.	 Read the resulting warning. Choose the option you prefer, then click OK.

If you are sharing site files with other users, you might want to exclude login and 
password information in the site setup. Each user should have his or her own password 
and login information.

	 5.	 Navigate to WIP>Kinetic and click Save.

The Export Site dialog box defaults to the current site’s root folder. You can restore the 
site settings by importing the site definition file from this location.

	 6.	 In the Manage Sites dialog box, make sure Kinetic site is selected and click the “–” 
button to remove the site from the list.

	 7.	 Click Yes to the warning to confirm the removal of the Kinetic site definition.

Remember, you are not deleting the files from the site; you are simply removing the site 
definition from Dreamweaver.

	 8.	 At the bottom of the Manage Sites dialog box, click Done.
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Project 1: Bistro Site Organization

Project Review

	 1.	Briefly explain why it is important to define a Dreamweaver site file. 

	 2.	Briefly explain the importance of creating a site flowchart.

	 3.	Explain three different methods for creating a link to a page in the current site.

	 1.	The _______________ extension identifies a 
Dreamweaver site definition file.

	 2.	The _______________ is the primary folder that 
contains all files and subfolders of a Web site.

	 3.	The _______________ is used to view 
and manage files that make up a site in 
Dreamweaver.

	 4.	_______________ is the process of improving a 
page’s ranking in search engine results pages.

	 5.	A(n) _______________ is a path from one file 
to another, beginning from the current location 
and moving up or down through folder paths 
to the target image.

	 6.	The notation _______________ tells 
Dreamweaver to move up one folder from the 
current location.

	 7.	The _______________ shows the nested order 
of HTML tags to the currently selected object.

	 8.	The _______________ protocol is used to define 
an email link.

	 9.	_______________ is the process of hiding 
certain files in the site so they are not uploaded 
to the Web server.

	10.	The _______________ pane of the Site Setup 
dialog box defines the settings you need to 
upload site files through Dreamweaver’s Files 
panel.
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Use what you learned in this project to complete the following freeform exercise.  
Carefully read the art director and client comments, then create your own design to meet the needs of the project. 
Use the space below to sketch ideas; when finished, write a brief explanation of your reasoning behind your final design.

Portfolio Builder Project

When I started working with our site files I noticed 
that none of the links exist anymore. I might have 
worked from an earlier version of the site files, but 
I’m not sure. Can you fix this for me? Other than 
the navigation in the middle of the pages, there are 
a number of other places where links are necessary:

•	 Users should be able to navigate between the 
different property pages without going back to 
the main Properties page.

•	 There should be a link to our main information 
email address (info@romanaplace.atc) on every 
page.

•	 The original design company’s name in the 
footer should link to its Web site.

Romana Place Town Homes is adding a 
photo tour to its Web site. The owner is fairly 
competent at building Web pages, but is 
having trouble finalizing the new site. Your job 
is to finish what he started in a professional, 
organized manner.

To complete this project, you should:

o	 Import the site files into Dreamweaver 
(from the Rentals_DWCC16_PB.zip 
archive on the Student Files Web page).

o	 Analyze the content of the different pages. 
Create a flowchart to map the direction of 
links from one page to another in the site.

o	 Organize the site folder into a clear, 
understandable structure.

o	 Create the links from one page to another 
throughout the entire site.
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This project focused on two of the foundational elements of Web site design — organizing files and 
creating links. A well-organized site structure includes links that make it easy for users to navigate 
throughout the entire site. Dreamweaver makes it easy to manage the files in a site — renaming 
and moving them while maintaining the links between pages within the site. You also learned a 
number of ways to create links, whether to other pages in the site, to an external URL, or to an email 
address. The skills you used in this project will be required to complete virtually any site you create in 
Dreamweaver.

Create a link to 
an external URL

Define descriptive 
document titles 

Create navigation 
links to site pages

Organize site files 
in Dreamweaver

Copy and paste a 
list of links

Create an email link

Adjust relative link 
paths to work on 
nested pages
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