Bistro Site Organization
Your client has opened a new
restaurant in a fast-growing
community in Southern California.
He has already designed the pages for
his site, but has hired you to make
sure everything works properly and
then make the site available to the
browsing public.

This project incorporates the following skills:

o Creating, exporting, and removing site definitions in
Dreamweaver

o Moving files around in a site root folder
o Creating relative links between pages in a site
o Defining absolute links to external sites and email addresses
o Improving search engine optimization (SEO) with file names
and titles

o Cloaking site files from a Web server
o Uploading files to a Web server

art director comments

I already created the pages for our site, but I
don’t know what links to use, and I’m not sure
how to create them. I’ve also heard that there
are certain things you should do to improve a
site’s search engine rating — which is obviously
important for a small business like mine.

The more pages you add to a site, the more
complex it becomes, until it’s almost impossible
to make sense of what you have and where it
is located. Web sites — even those with only
a few pages — should be designed with a
good organizational plan, making it easier to
modify pages later.
Once you have a handle on the organization,
make sure the pages link to each other
properly. Visitors get frustrated very quickly
when they’re forced to return to the home page
every time they want to jump to a different set
of pages.
The last thing you should do is add page
titles and change file names to give a better
indication of what’s on each page. Doing so
will make the site more accessible to people
with screen-reader software, and it will also
improve the site’s ratings on search engines.

project objectives

client comments

Project Meeting

To complete this project, you will:

o Create a Dreamweaver site definition
o Create new folders within the site
root folder

o Use various methods to move files from
one place to another within the site

o Create links between pages using several
techniques available in Dreamweaver

o Differentiate between relative and
absolute links

o Copy and paste links from one page to
another

o Improve searchability and usability using
page names and titles

o Cloak site files to hide them from the
Web server

o Upload the site files to a server so they can
be viewed online

Stage

1

Exploring Site Structure

When you start a new project that involves updating an existing site, your first task is to assess the file
and folder structure. Doing so gives you a good idea of what the site contains.
A small site with only a few pages requires very little organization; in fact, you can place all of
the files — Web pages and image files — in one folder (although even a small site benefits from a
dedicated folder for images). Larger sites, however, require careful organization of file names, pages,
and image files. A good site design with excellent organization speeds development now, and makes it
much easier to update the site later.

Create a New Site Definition
Web sites are designed so all of the Web pages, image files, style sheets, and other
resources are stored on your local drive in a base folder called the root folder. Other
folders can be placed inside (below) the root folder to make it easier to manage and
organize files.

1. Download Kinetic_DWCC14_RF.zip from the Student Files Web page.
2. Expand the ZIP archive in your WIP folder (Macintosh) or copy the archive
contents into your WIP folder (Windows).

This results in a folder named Kinetic, which contains all the files you need to
complete this project.
If necessary, refer to Page 11 of the Interface chapter for specific instructions on
expanding or accessing the required resource files.

3. In Dreamweaver, set up your workspace so the Files, Insert, and Properties
panels are visible.

It doesn’t matter which saved workspace you start with. The primary tools you need for
this project are the Files, Insert, and Properties panels. We have closed all other panels to
maximize the available space in our screen shots.

4. In the Files panel, click the Manage Sites link or open the Directory menu
and choose Manage Sites from the bottom of the list.
This option performs the
same function as clicking
the blue Manage Sites
link to the right of the
Directory menu.

If available, clicking
Manage Sites opens
the Manage Sites
dialog box.

5. Click the New Site button in the Manage Sites dialog box.

Note:
When a site is defined
in Dreamweaver, the
Manage Sites link at the
top of the Files panel is
replaced by a menu that
defaults to Local view.
Note:

Click here to
create a new site
in Dreamweaver.

Ellipses in a menu or
button name indicate
that clicking will open
a dialog box. We do not
include the ellipses in our
instructions.
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6. In the Site Setup dialog box, make sure Site is selected in the category list.
7. Type Kinetic in the Site Name field.
The site name can be anything that will allow you to easily recognize the project; it is
only for identification within Dreamweaver. For example, you could use “Eve’s site” as
the site name within Dreamweaver to describe the Web site (www.evelynsmith.biz) that
you are creating for your friend.

8. Click the Browse for Folder button to the right of the Local Site Folder field.

Navigate to the WIP>Kinetic folder and click Choose/Select Folder to return to
the Site Setup dialog box.
Part of the process of defining a site within Dreamweaver is to specify a particular folder
as the site root folder of the Web site. Clicking the Local Site Folder button opens a
navigation dialog box where you can find the folder you want to use.
Note:
Browse for
Folder button

9. Click Save to close the Site Setup dialog box.
10. In the Manage Sites dialog box, make sure the Kinetic site appears in the list
of sites, and then click Done.

11. Continue to the next exercise.

28 Project 1: Bistro Site Organization

You will learn about
other options in the Site
Setup dialog box later in
this book.

Examine the Site Files
There are many files in the Kinetic site folder. The first step in organizing the files is to
examine the Web page files and understand what they contain.

1. With Kinetic showing in the Directory menu of the Files panel, expand the
site folder (if necessary) and examine the files in the site.
Directory menu
Click this button to
expand the folder.
Click here and drag
left to make the
panel wider.

Click and drag the header
edge to make the column
wider or narrower.

Note:
If more than one site is
defined, you can switch
between sites using the
Directory menu of the
Files panel.

This is the root folder
of the current site.

2. Double-click index.html in the Files panel to open the file in Dreamweaver.
If you see code in addition to the page design, click the Design button in the
Document toolbar (above the document window).
All of the pages in this site use the same basic design. The links at the top of each page
need to navigate between the pages. The copyright information at the bottom (in the
footer area) needs to navigate to the copyright owner’s Web site, which is external to
your client’s site.

These words will be
links, which will appear
on every page in the site.

This should be a link
to the copyright
holder’s Web site.
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3. Close index.html, then open contact.html.
As you can see, this page uses the same basic design as the index page. The specific page
content also includes an email link, which you need to define so that users can click the
link to send your client an email message.

These links should be
the same on every
page in the site.

This should be an
email link to your
client’s email address.

Note:

4. Close contact.html, then open menu1.html.
Again, the page uses the same basic layout as the other pages in the site. The top area of
this page’s primary content indicates that there are actually two menus — Dinner and
Lunch. As you can see in the Files panel, two separate menu files exist. You will use the
two headings at the top of the page to create links to each menu.

The layout for this site
is based on the free
“Creation” template from
www.templatemo.com.
Photos are by Charlie
Essers.

Each of these words
should link to the
relevant menu page.

5. Close menu1.html, then continue to the next exercise.
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Plan Folder Organization
When all files are dumped into the main site folder, it can be challenging to manage
your work. A well-organized site is an easy-to-manage site. Ideally, organization occurs
before the site is constructed, but Dreamweaver makes it easy to reorganize files and
folders at any point in the process.
There are no absolute rules to follow for organizing files and folders — other than
the general principle of keeping related components together, so you know where to
find certain files when you need them.

1. With the Kinetic site open in the Files panel, scroll to the top of the Files
panel (if necessary). Control/right-click the site name and choose New
Folder from the contextual menu.

The basic pages (home, about, contact, etc.)
form the root of the site, and they should
therefore appear within the root folder
of the site. Other pages are better kept in
folders that are named based on what they
contain.

2. Type resources and press Return/Enter to apply the new folder name.
When folders are first created, they appear at the bottom of their containing folders.
Note:
If after pressing Return/
Enter, the folder name
remains untitled,
Control/right-click the
untitled folder, choose
Edit>Rename (or press
F2), and correct the
name.

3. In the Files panel, click the Refresh button.

Note:

When the Files panel is sorted by name, folders on Macintosh are alphabetized along
with all other files and folders after refreshing the file list; on Windows, folders are
moved to and alphabetized at the top of the list, above individual files.

Press F5 to refresh the file
list in the Files panel.

Refresh button

On Macintosh, folders
are alphabetized
along with all other
files in the site.

On Windows, folders
are alphabetized at the
top of the site list,
above individual files.
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4. Control/right-click the main site folder again and choose New Folder from
the contextual menu.

You want another folder at the same level as the resources folder — in the main level of
the site root — so you first have to use the contextual menu for the site root folder.

5. Type images and press Return/Enter to apply the new folder name.
Web design convention dictates image files be placed in a folder named “images” for
easier organization. If you have many photos in various categories, you might want to
create additional nested folders inside the main images folder.

6. Repeat Steps 4–5 to create another new folder named menus in the site root
folder.

7. Refresh the list in the Files panel.

Note:
You can create a new
folder inside an existing
folder (called nesting) by
Control/right-clicking the
existing folder — instead
of the root folder — and
choosing New Folder
from the contextual
menu.

8. Continue to the next exercise.

DREAMWEAVER FOUNDATIONS

The Files Panel in Depth
By default, the Files panel displays the files on
your local computer. You can also view the files
on the remote or testing servers by choosing the
appropriate option from the View menu.

Directory menu

The top of the Files panel also includes buttons
that allow you to manage the files in your site:
• Connect to Remote Host establishes a
connection with the remote server (if you defined
one). Otherwise, clicking this button opens the Site
Definition dialog box.

Connect to
Remote Host
Refresh

Expand to Show Local
and Remote Sites
Synchronize

Get Files

Check In Files

Put Files

Check Out Files

• Refresh refreshes the file list that displays in the panel.
• Get Files copies the selected files from a remote server
to the local folder. If the Enable File Check In and Check
Out option is active, the copied files are available on
the local site in read-only mode, which means you can’t
modify them. You must click the Check Out Files button
to edit the files.
• Put Files copies the selected files from the local folder
to the remote server. If a new file is added to the server,
and if the Enable File Check In and Check Out option is
active, the file’s status is Checked Out.
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View menu

• Check Out Files copies the selected files from the
remote server to the local folder and locks the files, so
only the user who checked out those files can edit them.
• Check In Files copies the selected files from the local
folder to the remote server and makes the copied files
read-only in the local folder. To edit these files, you need
to select them and click the Check Out Files button.
• Synchronize synchronizes files between the local folder
and remote server so the same version appears in both
places.
• Expand shows both local files and the remote site
(if one has been defined). The expanded Files panel has
two panes; one displays the files on the remote or test
server and one displays the local site files.

Sort and Move Image Files
When you define a site in Dreamweaver, the application reads all of the pages in the
site (a process that can take a few minutes in a large site), notes the links between
pages, and identifies which images are used in which pages. These associations between
files are stored in a cache that Dreamweaver creates when a new site is defined.
When files are moved or renamed within the site, Dreamweaver recognizes that
other files are related to the moved or renamed files and prompts you to update the
links in all of the affected files.

1. With the Kinetic site open in the Files panel, click and drag burger.jpg
into the images folder.

Make sure you drag the file directly over the name of the folder or folder icon; if you
drag the file too far to the left or right, Dreamweaver will not move the file.

2. When prompted, click Update to update the affected pages with the new
location for the burger.jpg image file.

When a browser downloads a Web page, it reads the page code, requests the image
files from the defined locations, and displays the images within the page. You should
understand that images in Web pages are not embedded into Web pages; they are
merged into the page by the browser.
Files being updated do not need to be open for Dreamweaver to change the required
link information. If pages are open, links in those pages are updated, but the changes are
not automatically saved; you have to manually save each open file to make the updates
permanent.
If you choose Don’t Update in the Update Links dialog box, the image will not appear
in the page that calls for that file. If you had moved the image file using Windows
Explorer or the Macintosh Finder, Dreamweaver would not have been aware of the
movement, and you would not have had the opportunity to adjust the path to the image
file in pages that link to that image.

Note:
To avoid potential
problems if you
accidentally close a file
without saving, you
might want to close open
files before moving or
renaming files in the
Files panel.

The burger.jpg file is now stored in the main images folder.
When you move files into a folder, that folder automatically expands in the Files panel.
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3. In the Files panel, click the Type column heading to sort the site files by type.
By default, site files are sorted by name. You can sort by another criteria by clicking the
column headings in the Files panel. Sorting by type allows you to easily find all of the
images that are used in this site.

4. Click the first JPG file in the list (onion-rings.jpg) to select that file. Press

Shift and click kinetic.png to select all consecutive files between the first and
the last ones you selected.

Click a column
heading to sort files
based on that option.
Shift-click the first
and last files to select
multiple consecutive
files in the list.

5. Click the icon of any of the selected files and drag the selected files into the
images folder. When asked, click Update to update all links to all of the
moved files.

Note:
You can change the
columns that appear
in the Files panel —
and the order of those
columns — in the File
View Columns pane of
the Site Setup dialog box.

Note:
Press Shift to select
multiple consecutive files
in the panel.
Press Command/Control
and click to select multiple,
nonconsecutive files.
You can also Command/
Control-click to deselect a selected file. For
example, if you select a
file by accident, you can
deselect it by Command/
Control-clicking the file
name again.

Note:

6. Click the down-facing arrow (Macintosh) or the “–” symbol (Windows)
to the left of the images folder name to collapse the folder.

7. Click the Local Files column header to re-sort the files by name.
8. Select menu1.html and menu2.html, and move them into the menus folder.
Update the links when asked.

This is a relatively small site, so nesting files into subfolders isn’t strictly necessary.
However, when you work with larger files, clearly organized subfolders can be extremely
helpful in maintaining a site that is easy to update as often as necessary.
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Images in Web sites
typically have a GIF,
JPG, or PNG extension.

9. Collapse the menus folder.
10. Select and move the file tables.psd into the resources folder.
In this case, you are not asked to update links. This is a layered Photoshop file that was
used to create the background image behind the page content. It is not part of the actual
Web site, but it’s a good idea to keep this type of file in the site folder in case you need
to make changes later. Later in this project, you will learn how to prevent this file from
being uploaded as part of the site.

Note:
You can also copy and
paste files into a folder
using the Edit options
in the contextual menus,
or using the standard
keyboard shortcuts:
Cut:
Command/Control-X
Copy:
Command/Control-C

11. Collapse the resources folder.
From the folder structure alone, the Web site appears to be better organized. You now
know what to expect when you open each folder.

Paste:
Command/Control-V

12. Continue to the next stage of the project.

DREAMWEAVER FOUNDATIONS

Changing the Update Preferences
As you have seen, Dreamweaver automatically asks
you to update links when you move a file in the
Files panel. You can change this behavior in the
General pane of the Preferences dialog box.
If you choose Always in the Update Links... menu,
the affected links are automatically updated
without user intervention. In other words, you do
not see the Update Files dialog box during the
process.
If you choose Never, links are not automatically
updated when you move files in the Files panel. If
you do not manually correct links, they will result in
an error when clicked by a user.
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Stage

2

Organizing the Site Navigation

Hyperlinks (the official term for links) can be created to link pages on a site to other pages within the
same site, or to pages on other sites. A well-designed site includes links that make it easy to get to any
part of a site from any other part of a site. You should carefully plan the flow of links and connections
between pages — always keeping the reader’s usability in mind.
Organizing links is a simple application of a science called information architecture, which is
the organization of a Web site to support both usability and “findability.” As you organize site links,
remember that your goal is to enable visitors to see a pattern in your links, which will assist them in
navigating through your site. Keep the following points in mind when you plan a site’s link structure:
• You can’t know how visitors will enter your site. The primary site pages (home, about us, etc.)
should be accessible from every page on the site.
• When linking secondary pages such as different menus for different mealtimes, don’t make
users constantly click the browser’s Back button. Links should allow users to navigate all
sibling pages (at the same level) as easily as navigating the primary structure. For example,
users should be able to access the dinner menu or lunch menu in the restaurant’s site without
first going back to a main “Menu” page.
Using the terms “parent,” “child,” and “sibling” is simply a way of describing relationships between
pages. A large Web site cannot provide links to all of the pages from its home page. By grouping
pages, grouping groups of pages, and so on, you create relationships of equality between pages that are
grouped together, as well as between groups that are grouped together.
When you plan a new site, you should create this type of flowchart to make sure you create all the
necessary links that make the site as user-friendly as possible. A flowchart of the required Kinetic site
link structure is shown below.

Kinetic Bistro Site Navigation

Home

About

Menus

Events

Dinner

Contact

Lunch

In this stage of the project, you will learn various techniques to create the necessary links on the
Kinetic site pages.
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Create Hyperlinks within the Site
Dreamweaver offers a number of options for creating the necessary links for any Web
site structure.
• Hyperlink Button in the Common Insert Panel. Clicking the Hyperlink
button in the Common Insert panel opens the Hyperlink dialog box, where
you define the specific parameters of the link.
• Insert>Hyperlink menu. This menu command opens the same dialog box
that you see when you click the Hyperlink button in the Insert panel.
• Properties Panel Fields. You can also simply define the specifics of a hyperlink
in the Properties panel. This method offers the same options as those in the
Hyperlink dialog box but does not require the dialog box interface.

Note:
Dreamweaver often
includes several different
ways to achieve the same
result. You should use
the method that is most
efficient at the time.

• Point to File button in the Properties panel. To create a link using this
method, simply click the Point to File button, hold down the mouse button,
and drag to a file in the Files panel; Dreamweaver automatically creates a link.
• Browse for File button in the Properties panel. The Browse for File button
opens a navigation dialog box where you can select the file that will open when
a user clicks on the link.
• Shift-Drag Method. You can create a link directly from the document window
by pressing Shift and then clicking and dragging from the link source to the
destination page in the Files panel. (This method only works for text; you can’t
Shift-drag to create a link for an image.)
• Quick Property Inspector in Live View. When the Live view is active, you
can use the Link button in the Quick Property Inspector, which appears
attached to the selected item in the document window, to create a hyperlink.

1. With the Kinetic site open in the Files panel, open index.html.
2. At the top of the page, double-click the word “HOME” to select it.
3. If your Insert panel is docked above the document window, click the Common tab
at the top of the panel.

If your Insert panel is docked on the right side of the screen, or if it is floating as a
		
separate panel, choose Common in the menu at the top of the panel.
If docked in standard mode,
use the menu at the top of
the panel to access different
categories of options.

If docked in tabbed mode,
use the tabs at the top of
the panel to access different
categories of options.
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4. Click the Hyperlink button in the Common Insert panel.
The Common Insert panel contains many of the common functions you use to create
Web pages. If a different Insert panel is showing, you can return to the Common Insert
panel by choosing Common in the panel menu.

If docked in standard mode,
buttons in the panel are
identified by icon and name.

Note:
From this point on, we
will leave our Insert
panel docked on the right
side of the workspace,
immediately below the
Files panel. Feel free to
organize your workspace
however you prefer.

If docked in tabbed mode,
hover your mouse over a
button to find its name.

This word is selected.

DREAMWEAVER FOUNDATIONS

The Common Insert Panel in Depth
The Common Insert panel contains buttons for frequently used items. For example, to insert
a hyperlink, simply click the corresponding button. (Some of the terms and functions in the
following descriptions will make more sense as you use those tools to complete later projects.)
• The Div button inserts sections (divisions) in a page,
which are useful for inserting blocks of content that you
want to format independently from other blocks. You
will work extensively with div tags in later projects.
• The HTML5 Video button opens a dialog box where
you can define the various options related to placing
video directly in an HTML5 page.
• The Canvas button inserts a canvas element into the
page. The canvas element is a container for graphics that
are created directly in the page using scripts.
• The Image button inserts various types of graphics. If
you click the arrow on the button icon, a menu shows
the available types of objects (basic images, rollover
images, Fireworks HTML).
• The Table button inserts a table into the page.
• The Head button includes a menu for adding metadata,
keywords, descriptions, and viewport information to the
<head> section of the page. This content will be used
by browsers and search engines.
• The Script button can be used to add code from an
external file, which will be used by the browser to
perform an action when the page is accessed.
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• The Hyperlink button opens
a dialog box where you can
create text or image links
to another file, either in
the same Web site or in an
external Web site.
• The Email Link button
opens a dialog box where
you can create links to email
addresses. When a user
clicks an email link, it opens the user’s default email
application with the email address in the To line.
• The Horizontal Rule button inserts a solid line across
the width of the page. This can be useful for visually
separating sections of text.
• The Date button inserts the current date and time.
In the resulting dialog box, you can choose the date
format, as well as an option to update the date and time
whenever the file is saved.
• The iFrame button inserts an iFrame element, which
allows you to embed one document into another.
• The Character button/menu is used to insert special
characters, such as copyright symbols and foreign
currency characters.

5. In the Hyperlink dialog box, click the Browse button to the right of the
Link field.

The text selected in the document appears in the Text field by default. (If an image is
selected, this field defaults to be blank.)
Text selected in the
document is automatically
entered in the Text field.
Browse button

6. Navigate to your WIP>Kinetic folder, select index.html, and click
Open/OK to return to the Hyperlink dialog box.

In the Link field, you can either type the URL of a location outside the site you’re
building, or you can click the Browse button to select a file within the current site.
Note:
Remember, when
commands are different
for different operating
systems, we list them as
Macintosh/Windows.

7. Open the Target menu and choose _self.
This option determines where the linked file will open:
•

_blank opens every linked file in a new, unnamed browser window.

•

new creates a new browser window with the name “_new”. Every link assigned
the _new target will open in that same _new browser window.

•

_parent is relevant if a page includes nested frames; this option opens the link in
the frame or window that contains the frame with the link.

•

_self opens the link in the same frame or browser window as the link. This is the
default behavior if you do not choose an option in the Target menu.

•

_top opens the link in the same browser window, regardless of frames.

8. In the Title field, type Kinetic Bistro home page.
The Title field defines text that appears when the cursor is placed over the link text.
Defining a descriptive title for links can help a page achieve better search engine results.

Note:
You can use the Access
Key field to define a
keyboard shortcut for
the link and use the Tab
Index field to specify the
number of times a user
needs to press the Tab key
to select the link.
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9. Click OK in the Hyperlink dialog box to create the link.
10. Click the Split button in the Document toolbar to review both the design
and code views at one time.

A Web page is basically a page full of code. A browser reads the code to determine how
to treat various elements of the page. HTML code largely revolves around tags, which
tell a browser how to interpret specific objects on the page.
A hyperlink is identified by the a element, which starts with the opening <a> tag;
the link destination and target are defined as attributes of that tag (href="index.html"
target="self"). After the actual link text, the closing tag (</a>) identifies the end of
the link.
The selected text is
now a link.

In the code view, the link
text is surrounded by
opening and closing <a>
tags, which identify the
text as a link.
The link destination
now appears in the
Link field of the
Properties panel.

You might notice that the pipe character (|) after the link text now appears on a second
line. Although the Design view does a good job of displaying various page elements,
it does not always perfectly render the cascading style sheet (CSS) rules that define the
appearance of various page elements.

11. In the Document toolbar, click the Live button to turn on the Live view.
In the Live view, you can accurately see how the CSS will be rendered by Web browsers.

In the Live view, CSS
is properly rendered
and the line of links
appears correctly.

12. Click the Live View button again to turn off the Live view, then click the
Design button in the Document toolbar to close the Code pane.
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13. Select the word “ABOUT” at the top of the page.
14. Click the Browse for File button to the right of the Link field in the

Note:

Properties panel.

If you don’t see the Properties panel, choose Window>Properties. The Properties panel’s
primary purpose is to review and change the properties of the selected HTML element
(such as a heading, paragraph, or table cell).

The word
ABOUT is
selected.
Browse for
File button

You can change the
destination of a link
by selecting the linked
text or object in the
document and choosing
Modify>Change Link.
This menu command
opens the same dialog
box as the Browse for
File button, so you can
navigate to and select the
new link destination.

15. In the resulting dialog box, select about.html, and then click Open/OK.

The link destination now
appears in the Link field of
the Properties panel.

Note:

16. Select the word “MENUS” at the top of the page.
17. Expand the menus folder in the Files panel.
You should expand and collapse Files panel folders as necessary, depending on your
available screen space. We will not repeat instructions to collapse or expand folders
unless it is necessary to perform a specific function.

18. Click the Point to File button in the Properties panel, hold down the mouse
button, and drag to menus/menu1.html in the Files panel.

The word MENUS
is selected.

When a link to another
page in the site is selected
in the document, you
can open the related
page in Dreamweaver by
choosing Modify>Open
Linked Page.

Point to File
button
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19. Select the word “EVENTS” at the top of the page.
20. Press the Shift key, then click the selected text and drag to events.html in
the Files panel.

You have to press the Shift key, and then click and drag to the link destination.
If you try to click and drag before pressing the Shift key, this technique will fail.

21. Use any method you just learned to create a link from the word
“CONTACT” to the contact.html file.

22. Select the words “Against The Clock, Inc.” at the bottom of the page.
23. In the Link field of the Properties panel, type http://www.
againsttheclock.com and press Return/Enter.

Dreamweaver can’t help you create an external URL link because it’s outside the site
definition. You have to simply type or paste the address into the Link field.
An external URL link must begin with the “http://” protocol, followed by the domain
name and, if relevant, the folder path and file name of the page to which you are linking.

Type or paste in the field to
define an external URL link.

To minimize the repetitive work required, we already defined this link for you on the
other pages in the site. In a professional environment, you would need to add this link
to every page in the site.

24. Choose File>Save to save your changes in the file, then continue to the next
exercise.
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Note:
You can remove a link
by selecting the linked
text or object in the
document and choosing
Modify>Remove Link,
or by simply deleting the
text from the Link field
in the Properties panel.

Copy and Paste Links
Rather than manually creating the same links on every page, you can now simply copy
and paste them from one page to another.

1. With index.html open (from the Kinetic site), click in any of the text links
to place the insertion point.

The insertion point is the location where text will appear if you type.

2. Review the Tag Selector below the document window.
The Tag Selector, located in the status bar of the document window, shows the nesting
order of HTML tags (the “path of tags”) based on the current selection or the current
location of the insertion point.

Insertion point
Active tag
Tag Selector

3. Click the <ul> tag in the Tag Selector.
The <ul> tag identifies an unordered list, which is how this navigation structure was
created; each link is a separate list item (using the <li> tag).
Clicking a tag in the Tag Selector selects that HTML element and all of its content.
In the document window, the associated content is highlighted.

Selected tag

Note:
You will work more
extensively with tags
beginning in Project 2:
Digital Book Chapter.

The entire unordered list
(all of the links) is selected.

4. Choose Edit>Copy (or press Command/Control-C) to copy the selected
content to the Clipboard.

5. Close index.html and open about.html.
6. Click to place the insertion point anywhere in the list of links at the top of
the page, and then click the <ul> tag in the Tag Selector to select the entire
unlinked list.

The selected
list does not yet
include links.
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7. Choose Edit>Paste (or press Command/Control-V) to paste the copied
content from the Clipboard.

8. Place the insertion point in any of the links and review the Tag Selector.
The Tag Selector now shows the <a> tag for the current insertion point (in our example,
the EVENTS link). The Properties panel also shows the destination of the active link.
The pasted
content includes
the links.

9. Save the changes to about.html and close the file.
10. Repeat Steps 6–9 to paste the copied content (the links) into all HTML pages in
the site root level, as well as the two HTML pages in the menus folder.

11. Choose File>Save All to save all open files. Close all files, and then continue
to the next exercise.

Adjust Relative Link Paths
A path is the route taken through the folder structure to link one page to another. By
default, Dreamweaver uses relative paths when creating links (the application refers to
this as “relative to the document”). The alternative is to create absolute paths (“relative
to the site”); but unless your site is running on a Web server, you can’t test links that
use absolute paths.
As an example, consider creating a link from index.html
ROOT
to about.html, both of which reside in the root folder (as
index.html
about.html
events.html
shown in the figure to the right). In this case, the source and
destination pages are in the same folder; the relative-path link
MENUS
simply states the file name of the destination page:
<a href="menu2.html">Link Text</a>

menu1.html

When you drill down into nested levels of folders, the source folder is not
identified in the path; the link automatically works starting from the location of the
link. To link from index.html to menu1.html, for example, you have to include the
nested menus folder in the path:
<a href="menus/menu1.html">Link Text</a>
When the link is in an upward direction, the ../ notation says “go up one folder.”
To link from menu1.html to index.html in the site root folder means that the link
needs to take the visitor up one folder level:
<a href="../index.html">Link Text</a>
Each step up in the folder structure requires another command to “go one step
up” in the folder structure. If you had another level of nesting inside the menus folder,
for example, a link would have to take the visitor up two folder levels to return to the
main index page:
<a href="../../index.html">Link Text</a>
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menu2.html

contact.html

1. With the Kinetic site open in the Files panel, open menu1.html.
In this exercise, you are going to adjust the various links so they work properly on all
pages in the site.

2. In the Document toolbar, click the Live button to display the page in the
Live view.

In the 2014 release of Dreamweaver CC, you now have a certain number of editing
options directly in the document window even when the Live view is active.

3. Click the word HOME at the top of the page to select that element.
When the Live view is active, clicking a object in the document window shows the
Element Display, which shows the active HTML element. (If an element has a defined
ID or class attribute, those also appear in the Element Display. You will learn about IDs
and classes in later projects.) In this case, you can see that the selected element is an a
element — in other words, it is a link.
The Element Display
appears when you
click an object in the
Live view.

The element is identified The entire active element is
in the widget header.
surrounded by a blue border.

4. Double-click the word HOME to place the insertion point.
You can now place the insertion point and edit text directly in the Live view.

Double-clicking places the insertion
point inside the active element.

5. Double-click the word HOME again to select the text of the entire word.
When the Live view is active, the Quick Property Inspector shows options related to
the selected text. You can use the B and I buttons to apply the <strong> and <em> tags
(respectively). If no link is applied to the selected text, you can click the Link button to
show the Link field and define a link for the selected text.

Note:
The strong and em
tags are explained in
Project 2: Digital Book
Chapter.

The Quick Property
Inspector appears
with options for the
selected text.
Add <strong> tag

Add <em> tag

Hyperlink

Browse for File
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6. In the Quick Property Inspector, type ../ before the existing link.

Type ../ before the existing
link to move up one folder
from the active file.

8. Repeat Steps 3–6 for the ABOUT, EVENTS, and CONTACT links.
9. Select the word MENUS at the top of the page.
In this case, the link is still a problem because it directs the browser to look for a folder
named “menus” inside the same folder as the active page. You need to remove the folder
part of the path to prevent an error if a user clicks this link from the menu1.html page.

The active file is in
the menus folder.

This link would cause a browser to look
for a menus folder at the same level as
the active file — i.e., another menus
folder inside the existing menus folder.

10. In the Quick Properties Inspector, delete menus/ (including the forward
slash) from the existing link.

Delete the folder path
from the existing link.
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11. With the Live view still active, highlight the words “Lunch Menu” at the top
of the yellow section.

Because this text does not yet have a link, the Quick Property Inspector does not yet
have a link field or a Browse for File button.

12. Click the Hyperlink button in the Quick Property Inspector.

13. Select the file menu2.html in the site menus folder, then click Open/OK.

14. Repeat Steps 11–13 to link the words “Dinner Menu” to the menu1.html file.

15. Repeat the process from Steps 1–14 to adjust the top links and add the
necessary secondary links in the menu2.html file.

16. Save and close any open files, then continue to the next exercise.
You can save each file individually, or choose File>Save All to save all open files at once.
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Create an Email Link
Most Web sites include one or more external links (including email links), which
require the appropriate protocol to tell the browser what type of link is present.
An email link requires the “mailto:” protocol, followed by the appropriate email
address. This instructs the browser to open a new mail message with the defined
address already in the To line.

1. With the Kinetic site open in the Files panel, open contact.html.
2. Select the words “info@kineticbistro.atc” in the main content area.
3. In the Common Insert panel, click the Email Link button.

Selected text

4. Review the resulting dialog box.
If you select text before clicking the Email Link icon, the Text field is completed for you.
Dreamweaver also recognizes that the selected text is an email address, so the Email field
is filled in for you.
If the selected text is not recognized as an email address, the Email field defaults to the
last address that was defined in the field.

Note:
You can access the
same Email Link
dialog box by choosing
Insert>Email Link.
Note:
In many cases throughout
this book, we use
“[company].atc” as the
domain of a site.

5. Click OK to create the email link.
6. Review the link field in the Properties panel.
An email link must begin with “mailto:” followed by the address. When you use the
Email Link dialog box, Dreamweaver automatically inserts the mailto: protocol.

7. Save the file and close it, then continue to the next stage of the project.
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Although at the time
of writing, none of the
domain names we use
are real, new domains
are registered every day.
We use the fictitious
“.atc” domain to avoid
inadvertently using the
domain name of a real
company.
When you upload files
to a server, you should
use the accurate domain
(.com, .gov, .edu, etc.) for
the site you are building.

Stage

3

Naming and Titling Documents

When a Web server (a computer that stores and delivers Web pages) receives a request
for a folder but not a specific page, the Web server delivers the default page for that
folder — usually named index.html or index.htm. There is no practical difference
between the two extensions; most Web servers can serve files with either extension.
To create links to the default page in a specific folder, you do not need to include
the file name if you use the index naming convention. Both www.kineticbistro.com/
and www.kineticbistro.com/index.html refer to the same page.

Rename Pages for Search Engine Optimization
SEO (search engine optimization) is the process of improving the ranking of a
Web site and its pages within SERPs (search engine results pages, or the pages that
list the results of a search). Search engines certainly use the content of a page for
ranking purposes, but the names of folders and files also affect search engine rankings.
Descriptive folder and file names also improve usability; you can use m/menu1.html
for the path to the dinner menu page, for example, but /menus/dinner-menu.html
is much easier for visitors to understand — and will also improve your search engine
ranking.
In this exercise, you rename the menu pages to more accurately describe what
is contained in the files. As with moving files, the application recognizes when a file
name has been changed and knows that links to the page must be adjusted.

Note:
If a link does not specify
a specific file in a nested
folder, the Web server
will look for a file named
index.html or index.htm
inside the defined folder.
If you do not have an
index file in that folder,
the link will result in an
error.

1. With the Kinetic site open, click menus/menu1.html in the Files panel to
select that file.

2. Click the selected filename again to highlight it.
This highlights the existing filename, excluding the extension.

Note:
You can also Control/
right-click a file in the
Files panel and choose
Edit>Rename to rename
a specific file.

3. Type dinner-menu, then press Return/Enter. In the resulting dialog box,
click Update to update all pages that link to this page.

Typing when the filename is highlighted replaces the previous file name. Pressing
Return/Enter finalizes the change.
As with moving files, Dreamweaver recognizes that all links to the renamed page need to
point to the new file name.
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4. Repeat Steps 1–3 to rename menu2.html as lunch-menu.html.

5. Continue to the next exercise.

DREAMWEAVER FOUNDATIONS

Understanding Web File Naming Conventions
The file names of pages should make the content or purpose of each page clear.
Because different servers run on different operating systems,
the safest way to name pages is to use only characters that
are guaranteed to work perfectly:
• a through z (use only lowercase letters)
• 0 through 9
• Hyphen (great-site.html)
• Underscore (great_site.html)

Consider everything else to be “illegal,” including:
• Spaces
• Brackets of all kinds, including ( ), [ ], { }, and < >
• Symbols, including #, @, %, ~, |, *, and &
• Quotation marks, both double (“ ”) and single (‘ ’)
• Slashes, both back slashes (\) and forward slashes (/)
• Commas, periods, question marks, and exclamation
points
• Uppercase characters

Some designers use CamelCase — uppercase letters at the beginning of each word within a file name, such as
UniversalStudios.html. The problem with mixing the lettercase is that some Web server software is case-sensitive and some
is not. Most Windows-based Web server software is not case-sensitive, but UNIX- and Linux-based Web server software is
case-sensitive. Considering that many Web servers run on UNIX- or Linux-based computers, it’s best to use only lowercase
file and folder names.

Create Document Titles for Individual Pages
Appropriate document titles are an important concern for both search engines and
site visitors. While the document title does not appear within the body of a Web page,
it does appear in the title bar of the browser, as the default name of the page in the
Bookmarks or Favorites list, and as the page name in search-engine results pages.
Page titles should be relatively short, around 70 characters or so to avoid their
being truncated in various locations (such as a user’s Bookmarks/Favorites list). You
should separate the components of the title with some type of divider, such as a colon
(:) or pipe (|) character.
In this exercise, you add document titles to the new pages to increase the pages’
search engine rankings and improve usability for visitors who find the pages in search
engines and bookmarks. You also learn to use the Find and Replace function, which
can greatly reduce the amount of effort required to create all of the document titles.

1. With the Kinetic site open in the Files panel, open index.html.
2. Make sure the Document toolbar is showing (View>Toolbars>Document).
3. Click the Split button in the Document toolbar to show both the Code and
Design views at one time.
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4. Examine the Title field above the document window.
When you create a new page in Dreamweaver, the default title is “Untitled Document”.
That text appears in the Title field of the Document toolbar, and in the title element in
the Code pane (wrapped in the opening and closing <title> tags).

Document title

5. Choose Edit>Find and Replace.

Note:
When you use the Split
view, feel free to arrange
the pane however you
prefer. We arrange them
as necessary to best suit
what we are trying
to show in our screen
captures.

6. Open the Find In menu and choose Entire Current Local Site.
This option allows you to affect all files in the active site. You can also search only
selected text; the current (active) document; all open documents; a specific folder; or
only selected files in the active site.

7. Choose Source Code in the Search menu.
The document title does not appear in the body of the page, so when you use Find and
Replace, you must apply the change to the source code rather than the document text.

8. In the Find field, type Untitled Document.
9. In the Replace field, type Kinetic Bistro | Lancaster, California | .
(Include a space after the final pipe character.)
All pages in the site will include this
block of text at the beginning of the
document title. Further detail about
individual pages will be added to
the right of this information.

10. Click Replace All. When prompted to confirm whether you want to proceed
with this function, click Yes.

Like most applications, Dreamweaver has an
Undo function that allows you to undo the
most recently completed actions; however, this
function only works if the document is open.
Since you are using the Find and Replace function on the entire folder and not only on
an open page, you are making changes in closed documents — which means you cannot
use the Undo command.

Note:
Some experts disagree
whether the company
name should come before
or after the specific page
information in a title.
However, putting the
company name at the
beginning of the page
title can help with search
engine results because
the company name is an
important keyword.

After completing the Find and Replace function, Dreamweaver displays the results in
the Search panel.
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11. Examine the title in the Document toolbar and the Code pane again for the open
file (index.html).

As a result of the Find and Replace function, the document title has been changed.
The same change has been made in all pages in the site.

12. Contol/right-click the Search panel tab and choose Close Tab Group.
13. Click in the Code pane to make it active.

Note:

14. Click at the end of the existing page title to place the insertion point

Making a specific pane
active is called “bringing
it into focus”.

immediately before the closing </title> tag, then type Gourmet Casual
Dining.
You can edit the page title in the Document toolbar or in the Code pane. Changes in
either place are automatically applied to the other.
In the Code pane, blue
highlighting identifies the
entire line where the
insertion point is placed.

Type the new information immediately
before the closing </title> tag.

15. Save index.html and close it.
16. Open about.html. Using either the Title field in the Document toolbar or the
Code pane, add Hours of Operation to the end of the existing page title.

17. Save about.html and close it.
18. Repeat this process (Steps 13–17) to change the page titles of the remaining
pages as follows:
File

Title

contact.html

Address and Contact Information

events.html

Special Event Facilities

menus/dinner-menu.html

Dinner Menu

menus/lunch-menu.html

Lunch Menu

19. Continue to the final stage of the project.
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Note:
Unlike file names,
document titles can use
mixed lettercase and
include spaces and other
characters. However, you
should avoid both single
and double quotation
marks.

Stage

4

Making Files Public

To complete the final stage of this project — making your files accessible to the browsing public —
you need to have access to some type of server.
On the inside back cover of this book, you have a code that you need to gain access to the
required resource files. The same code also provides access to a six-month, free trial Web hosting
account at Pair Networks (www.pair.com).
If you don’t already have access to an online server, go to www.pair.com/atc/ to sign up for your
hosting account before you complete the final stage of this project. You must enter your contact
information and the code from the inside back cover of your book. You should then define a user
name in the last field; this will become part of the server name for your hosting account.

Note:

Enter the code from
the inside back cover
of your book here.
Create a unique
username here.

After clicking Continue
in this screen, the
resulting message warns
that the setup process can
take up to one business
day (although it is
usually about an hour).
You should complete this
step as early as possible.

After you click Continue, you will receive an acknowledgement that your request is being
processed. You will receive a confirmation email (sent to the email you defined in the Signup Form)
with your username and password information. Once you receive the confirmation email, you are
ready to complete the final stage of this project.

Hide Files from the Web Server
As you saw when you created the folders for the new site, not all of the new files are
meant to be uploaded to the Web server — specifically, the Photoshop file in the resources folder. (You should, however, store such files locally as source files or documentation
for the work you completed.) Dreamweaver provides a very useful function — called
cloaking — that allows you to prevent certain files from uploading. You can cloak an
individual file; cloak all files with the same extension (for example, all native Photoshop
files with the PSD extension); or cloak a folder, which also cloaks all files in that folder.

1. With the Kinetic site open in the Files panel, double-click the site name at
the top of the Directory menu.

This opens the Site Setup dialog box for the selected site. You do not need to go through
the Manage Sites dialog box to edit the settings for the active site.
Double-click the site
name in the Directory
menu to open the
Site Setup dialog box.
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2. In the Site Setup dialog box, expand the Advanced Settings menu on the left
side and click Cloaking to show the related options.

3. Make sure the Enable Cloaking check box is active.
When Enable Cloaking is checked, you can hide selected files and folders from a Web
server. You can also use the Cloak Files Ending With option to hide all files with the
extensions that are listed in the field.

4. Click Save to close the Site Setup dialog box.
5. In the Files panel, collapse all open folders and expand only the resources folder.
6. Control/right-click the resources folder and choose Cloaking>Cloak.
Note:
You can also cloak
a specific file by
Control/right clicking
that file in the Files
panel and choosing
Cloaking>Cloak.

Notice the red slash through the resources folder icon and the icon for the file in the
resources folder. The red slash refers to the cloaking function only; it does not prevent
you from working with the files, adding more files, or deleting any of the existing files.

7. Continue to the next exercise.
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Define Remote Connection Info for the Site
For Dreamweaver to manage file uploading, you first have to define the hosting server
connection settings as part of the site setup information.

1. With the Kinetic site open in the Dreamweaver Files panel, re-open the Site
Setup dialog box for the site.

2. In the Site Setup dialog box, click Servers in the list of categories, then click
the + button near the bottom of the dialog box to define a new server.

Click here to define
a new server.

3. In the Basic options, type a name for the server you are using.
This name is simply for you to identify it in Dreamweaver.

4. Assuming you are working with a remote server, choose FTP in the
Connect Using menu.

If you are using a local server, consult your network administrator for the settings to use.

5. In the FTP Address field, type the hostname for your server.
Using our example hosting account at Pair Networks, the FTP host is the same as the
server name. (If you signed up for this service, your server name was in the confirmation
email that you received after signing up.) Check your hosting account documentation
for your FTP hostname and account information.

6. Type your FTP login (username) and password in the related fields.
These are the username and password for your hosting account. Again, this information
was probably sent to you via email when you first set up the hosting account; consult
your server documentation for the correct information to use.

7. In the Root Directory field, type the location of the folder where you want
the files to be placed.

Some hosting providers require you to place public files inside a specific folder, such as
public_html or www. When users navigate to your URL, they see the index page located
in the designated folder.
Using a hosting account at Pair Networks, as in our example, public files must be placed
in the /usr/home/USERNAME/public_html/USERNAME.pairserver.com/ folder (the
word “USERNAME” would replaced by your personal username),
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8. In the Web URL field, type the URL at which users will access the site.
Dreamweaver automatically defines this URL based on your other choices in this dialog
box; the default value will be “http://” plus the FTP Address plus the Root Directory.
In our example, the default was http://atctest.pairserver.com/usr/home/public_html/
atctest.pairserver.com/.
You need to change the URL to the path a user would type in a browser to access your
site. In our example, the address is http://atctest.pairserver.com/.
Note that we removed the root-directory folder path from the URL; it is only required
when you upload files for viewing over the Internet.
Make sure you enter the correct information for your domain name.
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8

9. Make sure the Save check box (next to the Password field) is checked, and
then click Test.

You must receive a message stating that Dreamweaver
successfully connected to the Web server. If a
connection with the Web server cannot be established,
check your entries to make sure your Internet connection is active, and then try again.
(If you are working on a shared computer, you might want to uncheck the Save option.
However, you will have to retype your username and password every time you upload
files to your hosting account.)

10. Click Save to return to the Site Setup dialog box.

11. Click Save to close the Site Setup dialog box, then continue to the next
exercise.
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Upload Files to a Remote Site
Dreamweaver’s FTP functionality makes it easy to put files into the remote site folder
(defined in the Site Setup dialog box). You can even synchronize all files on the remote
and local sites — which is useful when you are ready to publish the site for public
Internet access.

1. With the Kinetic site open in the Files panel, click the Expand button in the
Files panel to show both the local and remote sites.

Click this button to toggle
the panel between expanded
and regular modes.
Click here to connect
to the remote site.

Click this button to
synchronize the remote
and local site folders.

2. Above the Remote Server pane, click the Connection button to link to and
show the remote site.
After the connection
has been made, the
remote site appears in
the left pane.
Your host account
might include a
number of default files.

3. Click the Synchronize button at the top of the expanded Files panel.
4. In the Synchronize with Remote Server dialog box, choose Entire ‘Kinetic’

Site in the Synchronize menu, and choose Put Newer Files to Remote in the
Direction menu.
This utility enables you to synchronize an entire site
or only selected files. You can also determine which
version (local or remote) to synchronize from. For
example, if you accidentally delete files from your local site folder, you can choose to
synchronize files from the remote site to the local site to restore the missing files.

5. Click the Preview button.
After a few seconds, the Synchronize dialog box shows a list of all files that will be
affected by the process. In this case, this is the first time you are uploading to the remote
site, so all site files need to be put onto the remote site.

Click these buttons to
change the options for
selected files in the list.
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6. Click OK to put the files onto the remote site.
7. In the Background File Activity dialog box, click the arrow button to the
left of the word “Details.”

When you upload files to the remote server, Dreamweaver keeps a log of affected files.
The Background File Activity dialog box shows a list of each file, including any potential
problems encountered during the transfer process. Clicking the Details button expands
the dialog box and shows the progression of the synchronization.

Click here to
show or hide
syncing details.

All files should show
“Put Operation successful.”

After the synchronization is
complete, the uncloaked files
appear in the remote site.

8. Open a browser window. In the navigation bar, type the URL of the Kinetic
home page at your domain name.

Type the same Web URL you defined in the Servers section of the Site Setup dialog box
(see Page 55, Step 8). In our example, the complete URL is http://atctest.pairserver.com/.

9. Test the various links in the site.

10. Close the browser and return to Dreamweaver, then continue to the next
exercise.
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Export and Remove the Site Definition
To reduce the potential for confusion, it’s a good idea to remove the defined sites of
completed projects, leaving only the defined sites of current projects.
As stated in the Interface chapter, removing a site from Dreamweaver does not
delete the actual files and folders from your computer; it simply removes them from
Dreamweaver. Rather than removing a site, however, you can export a site definition
file — which you can later import to restore the same settings and options you already
defined (as you did in the Interface chapter when you imported the sf-arts site).
As you work through the projects in this book, you will export and remove site
definitions for completed projects, so your site list remains manageable. You should get
into this habit so you can quickly reinstate site definitions if necessary.

1. With the Kinetic site open in the Files panel, choose Manage Sites at the
bottom of the Directory menu.

You can access this menu even when the Files panel is in expanded mode.

2. In the Manage Sites dialog box, choose the Kinetic site name, and then click
the Export button.

This function creates a “.ste” file that stores the Dreamweaver site definition settings.

3. Read the resulting warning. Choose the option you prefer, then click OK.
If you are sharing site files with other users, you might want to exclude login and
password information in the site setup. Each user should have his or her own password
and login information.
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4. Navigate to WIP>Kinetic and click Save.
The Export Site dialog box defaults to the current site’s root folder. You can restore the
site settings by importing the site definition file from this location.

5. In the Manage Sites dialog box, make sure Kinetic site is selected and click the “–”
button to remove the site from the list.

6. Click Yes to the warning to confirm the removal of the Kinetic site definition.

Remember, you are not deleting the files from the site; you are simply removing the site
definition from Dreamweaver.

7. At the bottom of the Manage Sites dialog box, click Done.
8. Click the Collapse button in the Files panel.
The Files panel retains the last-used position and mode; it can be a good idea to collapse
it whenever you are not interacting with files on a server.
Click here to collapse
the panel back to the
standard mode.
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fill in the blank

Project Review
1. The _______________ extension identifies a
Dreamweaver site definition file.
2. The _______________ is the primary folder that
contains all files and subfolders of a Web site.
3. The _______________ is used to view
and manage files that make up a site in
Dreamweaver.
4. _______________ is the process of improving a
page’s ranking in search engine results pages.

short answer

5. A(n) _______________ is a path from one file
to another, beginning from the current location
and moving up or down through folder paths
to the target image.

6. The notation _______________ tells
Dreamweaver to move up one folder from the
current location.
7. The _______________ shows the nested order
of HTML tags to the currently selected object.
8. The _______________ protocol is used to define
an email link.
9. _______________ is the process of hiding
certain files in the site so they are not uploaded
to the Web server.
10. The _______________ pane of the Site Setup
dialog box defines the settings you need to
upload site files through Dreamweaver’s Files
panel.

1. Briefly explain why it is important to define a Dreamweaver site file.

2. Briefly explain the importance of creating a site flowchart.

3. Explain three different methods for creating a link to a page in the current site.
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Portfolio Builder Project
Romana Place Town Homes is adding a
photo tour to its Web site. The owner is fairly
competent at building Web pages, but is
having trouble finalizing the new site. Your job
is to finish what he started in a professional,
organized manner.
To complete this project, you should:

o Import the site files into Dreamweaver

(from the Rentals_DWCC14_PB.zip
archive on the Student Files Web page).

client comments

art director comments

Use what you learned in this project to complete the following freeform exercise.
Carefully read the art director and client comments, then create your own design to meet the needs of the project.
Use the space below to sketch ideas; when finished, write a brief explanation of your reasoning behind your final design.

• Users should be able to navigate between the
different property pages without going back to
the main Properties page.
• There should be a link to our main information
email address (info@romanaplace.atc) on every
page.

o Analyze the content of the different pages.
Create a flowchart to map the direction of
links from one page to another in the site.

• The original design company’s name in the
footer should link to its Web site.

o Organize the site folder into a clear,
understandable structure.

o Create the links from one page to another

project justification

throughout the entire site.
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When I started working with our site files I noticed
that none of the links exist anymore. I might have
worked from an earlier version of the site files, but
I’m not sure. Can you fix this for me? Other than
the navigation in the middle of the pages, there are
a number of other places where links are necessary:

Project Summary
This project focused on two of the foundational elements of Web site design — organizing files and
creating links. A well-organized site structure includes links that make it easy for users to navigate
throughout the entire site. Dreamweaver makes it easy to manage the files in a site — renaming
and moving them while maintaining the links between pages within the site. You also learned a
number of ways to create links, whether to other pages in the site, to an external URL, or to an email
address. The skills you used in this project will be required to complete virtually any site you create in
Dreamweaver.
Define descriptive
document titles
Create navigation
links to site pages
Organize site files
in Dreamweaver

Create a link to
an external URL

Copy and paste a
list of links
Create an email link

Adjust relative link
paths to work on
nested pages
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