
Your client is the main sponsor and 
event promoter of the annual Car 
Cruise and Music Festival at the Santa 
Monica Pier. You have been hired to 
create digital artwork for a number 
of elements that will be added to the 
event’s Web site, including a game 
that he is going to develop with 
Animate programming functionality. 
The first step is to build a basic 
illustration that can later be used for 
the client’s various purposes.

This project incorporates the following skills:

o	 Defining a movie file with appropriate settings for the job  
you’re building

o	 Importing a scanned image provided by the creative director

o	 Using various drawing tools to develop a digital version of a  
rough sketch

o	 Understanding the different drawing modes that are available

o	 Changing fill and stroke colors using a variety of methods

o	 Adding depth using various shading techniques

Corvette Artwork
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Project Meeting
I’m planning a number of different projects 
to promote this year’s event. The American 
sportscar area is always a big draw at the event, 
so I’d like to feature Corvettes on all of the 
event collateral. 

Most of the print work is going to use photos, 
but I’m planning some other projects where  
I want to use artwork instead of a picture —  
animations, Web banners, and I’m even think-
ing about an interactive game.

I’m an Animate programmer, but not an 
artist. If you can create the artwork directly in 
Animate, that would save me some time when 
I implement my other plans.

One final thing — I don’t want it to look like 
a cartoon. Obviously, I don’t want it to be a 
photo, but I do want it to be realistic looking.

I sketched out a Corvette, and scanned the 
sketch for you. I want you to use that sketch 
as the basis for your finished piece. Start by 
tracing that drawing using a bright color that 
you can see against the gray lines in the sketch. 

Once you’ve finished the basic artwork, try 
to make it seem more realistic than just a flat 
color conveys. Add some dimension and depth 
so it doesn’t look too much like a cartoon.

Also, make sure you build the artwork using 
logical layers. That way, if we need to make 
changes later, or if the client decides to animate 
it, the document will be structured properly.

Since Animate produces vector artwork, we 
can use the artwork for just about anything 
once it’s done. The important thing for now, 
however, is to create a static file that we can 
post on our Web site for the client’s approval.

To complete this project, you will:

o	 Set up the workspace to match the 
requirements of the project

o	 Import the scan of the sketched Corvette

o	 Create a set of logical layers to hold the 
various components that you will create

o	 Understand the difference between object-
drawing and merge-drawing modes

o	 Use the basic shape and line tools to 
develop the components of the drawing

o	 Draw precise Bézier curves with the  
Pen tool

o	 Use the Pencil tool to draw freehand shapes

o	 Apply color with the Paint Bucket, Ink 
Bottle, and Brush tools

o	 Use object groups to combine and protect 
drawing objects

o	 Apply and edit color gradients

o	 Export a static image for online review



21Project 1: Corvette Artwork

Stage 1	 Setting up the Workspace
Create a New Document

	 1.	 Download Vette_ANCC17_RF.zip from the Student Files Web page.

	 2.	 Expand the ZIP archive in your WIP folder (Macintosh) or copy the archive 
contents into your WIP folder (Windows).

This results in a folder named Vette, which contains all of the files you need for this 
project. You should also use this folder to save the files you create in this project.

If necessary, refer to Page 1 of the Interface chapter for specific information on 
expanding or accessing the required resource files.

	 3.	 In Animate, choose File>New. 

When you create a new file, you can define a number of options for the file. 

In the General tab, you can use the Type window to determine what kind of file you are 
creating. ActionScript 3.0, the default option, exports a SWF file that requires a special 
Player plug-in to view the file. You can also create an HTML5 canvas file, which can 
play natively in a browser without a plug in, or a WebGL (Web Graphics Library) file 
that uses JavaScript code and does not require a browser plug-in to display. The AIR for 
Desktop, AIR for Android, and AIR for iOS options create files that can be distributed 
as standalone “apps” for (respectively) desktop use, Android tablets/phones, and Apple 
iPads/iPhones. 

On the right side of the dialog box, the Width and Height options define the Stage 
size, or the area that will be included in the final exported movie. In this project, you are 
using the Animate Stage as a drawing board (literally). You will adjust the Stage size in 
the next exercise to meet the needs of the drawing you will create.

The Ruler Units menu defaults to Pixels, which is appropriate for files that will be 
distributed digitally.

The Frame Rate defines the number of frames that exist in a second (frames per second, 
or fps). You will learn more about frame rate beginning in Project 2: Talking Kiosk 
Interface, when you start creating animations.

The Background Color option defines the color of the Stage; this color appears behind 
all elements that you create or place in the file.

Although there are slight 
differences in appearance 
between the Macintosh 
(shown here) and 
Windows dialog boxes, 
the options are the same.

Note:

Press Command/
Control-N to open the 
New Document dialog 
box.

Note:

You can click the 
Templates tab to access 
pre-defined templates in 
many different styles.

Note:
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	 4.	 In the General tab, choose ActionScript 3.0 in the Type list. Leave all other 
options at the default settings, and then click OK.

When you create a new file, the Stage is automatically centered in the document 
window. The Stage is essentially the workspace, or the digital “page” area; anything 
outside the Stage area will not be visible in the exported movie (although it will increase 
the file size, which affects its download time).

	 5.	 Choose File>Save.

Because this is a new file that has not yet been saved, choosing File>Save automatically 
opens the Save dialog box, where you define the file name, save location, and format. 

If a file has already been saved at some point, the Save command simply overwrites the 
previously saved version of the file. If you want to save the new version and maintain the 
original, you have to use the File>Save As command to define a new name and create a 
copy of the file.

	 6.	 In the resulting dialog box, navigate to your WIP>Vette folder. 

	 7.	 Change the file name to corvette.fla. Make sure Animate Document is 
selected in the File Format/Save As Type menu and click Save.

Native Animate files use the FLA extension. By default, the extension is included in the 
Save As/File Name field. You don’t need to type it again if you don’t delete the default 
extension from the field. (If you don’t see the extension, uncheck the Hide Extension 
option at the bottom of the dialog box.)

	 8.	 Continue to the next exercise.

We have arranged our 
workspace to make the 
best possible use of space 
in our screen shots; 
feel free to arrange the 
panels however you 
prefer. For this project, 
you will be using the 
Tools, Properties, Align, 
Timeline, and Color 
panels.

Note:

Press Command/
Control-S to save the 
active file.

Press Command/Control-
Shift-S to use the Save As 
option.

Note:
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There are two kinds of computer images. The first, known as 
a raster image or bitmap, is composed of simple pixels. 
Each pixel has a specific value, and that value determines 
the color, intensity, and brightness of that pixel. The number 
of pixels that make up a raster image is fixed at the time of 
the scan or photograph. If you blow up (enlarge) a raster 
image, it becomes grainy and loses 
quality; in fact, you can see the individual 
pixels in an enlarged raster image. 

Animate is a vector-based program. 
Vector art is not based on pixels; 
instead, it is based on mathematical 
values. Vector art is essentially a tiny 
program that tells the printer or monitor 
to “draw a line from Point A to Point B, 
bending X degrees coming out of Point 
A and entering Point B from an angle of 
Z.” Although this might sound confusing, 
you don’t have to write any complicated 
code to make vectors work properly; you 
can simply draw with the Animate tools 
and the vectors are created for you.

Although vector graphics often improve 
the quality of images in a movie, they 
can also degrade playback performance 
because they require greater processing 
power to perform the necessary 
mathematical calculations. 

An example of the difference between a raster image and 
vector art is shown below. At 100% size, both the raster 
image and the type (composed of vector objects) are crisp.  
If you zoom in closely enough, however, the individual pixels 
in the photograph start to show, and the image breaks 
down — but the type remains perfectly crisp and clear. 

A
N

IM
A

TE
 F

O
U

N
D

A
TI

O
N

S

Raster Images vs. Vector Art

At actual size, both the type 
in this image and the 
photograph appear 
perfectly crisp and clear.

The type object, which is a 
vector object, remains clear 
even when enlarged.

The detail on the tree 
breaks down if you look 
closely enough.

Import a Raster Image

As we discussed during the production meeting for this assignment, you will base your 
work on a scanned sketch. Animate can import a range of file formats, including JPG, 
GIF, PNG, TIF, EPS, and native Illustrator and Photoshop files.

	 1.	 With corvette.fla open, choose File>Import>Import to Stage.

Four options are available when you choose the Import command: 

•	 Import to Stage simply brings an external image onto the current Stage.  
Imported bitmap images are also added to the file Library panel; if you import a 
vector graphic that uses no symbols or embedded bitmaps, nothing is added to 
the Library.

•	 Import to Library automatically places graphics into the Animate Library panel.
•	 Open External Library is commonly used to incorporate graphics from one 

project into another project.
•	 Import Video allows you to bring digital video into an Animate file. 

Press Command/
Control-R to import an 
object to the Stage. 

Note:
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	 2.	 Navigate to your WIP>Vette folder, select corvette.jpg, and click Open/Import.

The imported file is placed on the Stage, aligned to the left edge and centered vertically 
to the Stage area. As you can see, the placed image does not fit in the default Stage area.

	 3.	 Note the placed image’s width and height in the Properties panel. 

Because the imported image is still selected, the Properties panel shows information 
about the image — most importantly for this exercise, the image’s physical dimensions.

The Properties panel 
shows that the selected 
object is a bitmap file.

The object’s position 
and size are clearly 
listed in the panel.

The placed file is aligned to 
the left edge and centered 
vertically on the Stage.

The placed file is wider than 
the current Stage area.

	 4.	 Save the file and continue to the next exercise.

Change Document Properties 
The imported artwork is larger than the defined Stage size. Because you’re going to 
trace the imported sketch, you need to make the Stage area large enough to hold the 
entire sketch (and ultimately, the finished artwork). 

	 1.	 With corvette.fla open, choose the Selection tool at the top of the Tools panel.

	 2.	 Click in the gray area outside the Stage to make sure nothing is selected.

When nothing is selected in the file, you can use the Properties panel to access a number 
of options that affect the entire document — including the file’s physical dimensions.

When nothing is selected, 
the Properties panel 
shows options related to 
the overall file.
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	 3.	 In the Properties panel, place the cursor over the left number in the Size setting. 

When the cursor is over an existing value, you can click and drag left or right to 
dynamically change the value (called a “scrubby slider”).

	 4.	 Click the existing value to highlight the existing field value, then type 850.

Clicking an existing value in a panel accesses the actual field; you can type to change the 
value in the field.

	 5.	 Press Tab to highlight the Height field, then type 450, to change the 
Stage height. 

	 6.	 Press Return/Enter to finalize the change.

	 7.	 If the entire Stage does not fit into your document window, choose Fit In 
Window in the View Percentage menu.

The placed file’s position 
relative to the Stage is not 
affected. The top-left corner 
is in the same spot as before 
you changed the Stage size.

If necessary, use this 
menu to fit the entire 
Stage area in the 
document window.

If you click the Advanced Settings button in the Properties panel (or choose Modify> 
Document), you can access the same document properties that are available in the 
Properties panel when nothing is selected in the file.

The Dimensions, Frame Rate, and Background Color options are the same as those 
available in the Properties panel.

By default, changing the Stage size does not affect objects that are already placed on 
the Stage. You can check the Scale Content option to resize placed objects when the 
Stage size changes.

You can also use the Match Contents option to automatically change the Stage  
size to match existing Contents (objects placed on the Stage) or Printer settings. 
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Using the Document Settings Dialog Box

You can also simply click 
away from a field to 
finalize the new value.

Note:

Whenever we say “click 
and drag”, you should 
hold down the mouse 
button as you drag. 
We will not repeat the 
instruction to hold down 
the mouse button unless 
it differs in some way 
from the normal click-
and-drag procedure.

Note:
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	 8.	 At the bottom of the Align panel (Window>Align), check the Align To  
Stage box.

When this option is active, you can use the Align panel to precisely position one or 
more objects relative to the defined Stage area in your file. (The Align panel remembers 
the last-used state of the Align To Stage option, so it might already be checked.)

Align options move 
selected objects based on 
the defined edge or center.

Distribute options average the 
spacing between the selected 
edge or center of objects.

Match Size options can be 
used to force objects to the 
same height, width, or both.

Space options can be used 
to create uniform space 
between selected objects.

Button icons indicate 
which edge will be 

aligned or distributed.

Check this option

	 9.	 Click the sketch with the Selection tool to select it, and then click the Align 
Horizontal Center and Align Vertical Center buttons in the Align panel.

Align Horizontal Center

Align Vertical Center

	10.	 In the Align panel, turn off the Align to Stage option.

If you later try to align multiple objects to one another and the Align to Stage option is 
still checked, the results will not be what you want. Although you can undo the Align 
process (Edit>Undo Align), it is a good idea to get into the habit of turning off the Align 
to Stage option as soon as you are finished using it.

	11.	 Save the file and continue to the next exercise.

Remember: all Animate 
panels can be accessed in 
the Window menu. 

Note:

Press Command/
Control-K to show or 
hide the Align panel.

Note:
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Create Layers for Organizing Artwork

The Timeline panel allows you to easily create, arrange, and manage multiple layers in 
order to better organize your work. Layers can help you organize complex drawings 
and animations into a logical, easy-to-understand structure, while keeping all the 
components separate. You will use the timeline layers extensively as you complete the 
projects in this book.

	 1.	 With corvette.fla open, review the Timeline panel.

Layers are listed on the left side of the timeline; the order in which the layers are stacked 
(from top to bottom) is referred to as the layer stacking order. Objects on higher layers 
in the stack will obscure objects on layers that are lower in the stack. You can easily 
change the stacking order by dragging a layer to a new position in the stack.

Every file includes a default layer, named Layer 1. The icons to the right of the layer 
name provide a number of options, as well as some useful information. 

•	 The Pencil icon identifies the active layer, where new objects will 
be placed when you create them. 

•	 Click the column under the Eye icon to hide or show a layer. 
•	 Click the column under the Lock icon to lock or unlock a layer.
•	 Click the column under the hollow rectangle to toggle a layer 

between regular and outline mode. Outline mode shows only the 
wireframes of objects on that layer; fill and stroke attributes are 
not visible. The color of the rectangle under the Outline identifies 
the color of outlines, paths, anchor points, and handles for objects 
on that layer.

	 2.	 Double-click the name of the layer to highlight the name. Type Sketch to 
rename the layer, and then press Return/Enter to apply the change.

Double-click the layer 
name to change it.

	 3.	 Below the list of layers, click the New Layer button to add another layer on 
top of the first layer.

The new layer is automatically added immediately above the previously selected layer. 
New layers (and layer folders) are created in the same nesting level as the currently 
selected layer. In this case there is only one level of layers (there are no layer folders), so 
all new layers will be placed at the primary level.

	 4.	 Using the same technique from Step 2, rename the new layer Window and 
press Return/Enter to apply the change.

New Layer

New Folder

Delete
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	 5.	 Repeat Steps 3–4 to create four more layers: Body, Wheels, Door, and Accents.

	 6.	 If you can’t see all six layer names, click the bar above the docked Timeline 
panel and drag up to expand the panel.

Drag this bar up or down 
to change the height of 
the Timeline panel.

	 7.	 If you can’t see the full layer names, click the bar to the right of the Outline 
icons and drag right.

Drag this bar right to 
widen the area where 
layer names are listed.

	 8.	 Lock the Sketch layer by clicking the small dot below the Lock icon.

Locking the layer prevents you from accidentally deleting or otherwise modifying the 
sketch, which will be the basis for developing the actual drawing.

Click the dot to 
lock the layer.

Click the lock icon 
to unlock the layer.

	 9.	 Save the file and continue to the next stage of the project. 

You can control a number of drawing options using the 
Drawing pane of the Preferences dialog box.

Each time you click with the Pen tool, you add an anchor 
point; successive anchor points are connected by lines. If 
the Show Pen Preview option is checked, a preview line 
follows the cursor to show the line that will be created 
when you add a new anchor point.

When the Show Solid Points check box is active, selecting 
an anchor point with the Subselection tool shows the 
selected point as solid instead of hollow.

The Connect Lines options (Must Be Close, Normal, and 
Can Be Distant) determine how close lines or points must be 
before Animate automatically connects them. 

The Smooth Curves options (Off, Rough, Normal, and 
Smooth) determine how many points will be used to create 
a line when you’re drawing with the Pencil tool with the 
Smooth or Straighten options turned on. The Rough option 
results in more points and a jagged line; the Smooth option 
results in fewer points and a smoother line.

The Recognize Lines options (Off, Strict, Normal, and 
Tolerant) determine how close to straight a line drawn with 
the Pencil tool must be before Animate recognizes it as 
straight.

The Recognize Shapes options (Off, Strict, Normal, and 
Tolerant) determine how close to the shape an oval or 
square drawn with the Pencil tool must be before Animate 
recognizes it as the actual shape and makes the necessary 
adjustment.

The Click Accuracy options (Strict, Normal, and Tolerant) 
determine how close to an object you must place the cursor 
to select the object.
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Drawing Preferences

If your Timeline panel 
is not docked, click 
the bottom edge of the 
floating panel and drag 
down to expand the 
panel.

Note:

If a layer is selected 
but locked, the pencil 
is covered with a slash, 
indicating that you can’t 
change objects on the 
layer or add objects to the 
layer.

Note:
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Stage 2	 Drawing in Animate 
At the bottom of the Tools panel, a number of options affect what will happen when you create new 
drawing objects.

•	 Click the Stroke Color or Fill Color swatch to open 
a pop-up Swatches panel, where you can select a 
new color for the relevant attribute (stroke of fill). 

•	 Clicking the Black and White button resets the 
default colors to a black stroke and white fill.

•	 Clicking the Swap Colors button reverses the active 
stroke and fill colors.

When you draw with the basic shape tools, or with the Pen, Line, Pencil, Paint Brush, or Brush 
tool, a toggle near the bottom of the Tools panel determines what type of drawing you will create.

•	 When the Object Drawing button is not highlighted ( ), shapes are created 
in merge-drawing mode.

•	 When the Object Drawing button is highlighted ( ), shapes are created in 
object-drawing mode.

All shapes drawn in merge-drawing mode exist at the bottom of the stacking order on their layer. 
In other words, they are always behind other objects — groups, drawing objects, symbol instances, 
etc. — in the same layer. You cannot rearrange the stacking order of merge-drawing shapes. 

When you create an object in merge-drawing mode, the fill and stroke are treated as separate 
entities. You can individually select each part with the Selection (solid arrow) tool, and you can move 
or modify each part without affecting the other. 

In the examples shown here, the oval shape was created in merge-drawing mode. It has a defined 
orange fill and blue stroke.

Move or delete only 
the selected pixels.

Drag a selection marquee 
to select part of a shape.

Click and drag to move 
only the selected area.

Click with the Selection tool 
to select the fill or the stroke; 

the cross-hatch pattern 
indicates the selected area.

When you drag one merge-drawing shape onto another on the same layer, the topmost shape 
removes whatever portion of the lower shape(s) it covers. 

In the image to the right, the second column shows that we moved 
the orange circle on top of the blue circle. In the third column, you 
see the result of deselecting the orange circle, and then reselecting 
it and pulling it away from the blue circle. (This type of destructive 
interaction does not occur until you deselect the topmost object, 
which gives you a chance to “finalize” the edit. As long as you still see 
the crosshatch pattern on the object you’re dragging, the underlying 
objects have not yet been changed.) 

Swap colors

Stroke color

Fill color

Object Drawing

Snap to Objects

Black and White

Click the Fill Color or 
Stroke Color swatch 
to open the pop-up 
Swatches panel.
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This type of interaction does not occur with objects created in object-drawing mode or 
when you’re working with grouped objects. If you select something with the Selection tool and 
see a bounding box instead of the crosshatch pattern, underlying objects will not be affected. 

You can prevent this type of destructive editing by grouping the components of the 
shape. Simply drag a selection around the entire object and choose Modify>Group. When a 
standard object is grouped, you see only the group bounding box when you select the object 
on the Stage. (The bounding box marks the outermost boundaries of the shape.)

After grouping the fill and stroke, 
you can’t select the individual 
components. The bounding box 
indicates the boundary of the group.

Bounding box 

Even when merge-drawing shapes are grouped, you can access the individual pixel 
components by double-clicking them on the Stage. This opens a secondary Stage — called 
Edit mode — where you can access and edit the individual components. The Edit bar above 
the Stage shows that you are no longer on the main Stage (Scene 1), but editing a group. 

Double-clicking a group enters 
Edit mode for that group, where 
you can access the individual 
components of the group.

Edit bar

Of course, merge-drawing shapes have drawbacks as well; you could easily move or 
change an object that you don’t want to change — such as dragging a fill away from its 
stroke and not realizing it until 15 steps later when it’s too late to easily undo the error.

To solve this problem, you can draw in object-drawing mode by toggling on the switch 
at the bottom of the Tools panel. When you create a shape or line in object-drawing mode, 
it automatically displays the bounding box as soon as you create it, and you can’t select the 
fill and stroke independently — at least not on the main Stage.

For a shape created in 
merge-drawing mode, you 

can use the Selection tool to 
independently select the 

shape’s fill and stroke.

For a shape created in object- 
drawing mode, you can use the 
Selection tool to reveal the 
shape’s bounding box. You 
can’t independently select the 
object’s fill or stroke.

If you want to access the individual components of an object created in object-drawing 
mode, simply double-click the object. Double-clicking activates Edit mode; the Edit bar 
shows that you are “inside” (editing) a drawing object.

In Edit mode, you can 
access the individual 
drawing shapes that make 
up an object created in 
object-drawing mode.

The color of an object’s 
bounding box is defined 
based on the Highlight 
Color options in the 
General preferences.

Note:
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Draw with the Line Tool

The Line tool creates straight lines, which are simply strokes with no fills. You can 
combine lines with other shapes to develop custom objects. In this exercise, you draw 
several lines to complete the shape of the car’s window.

	 1.	 With corvette.fla open, click the Window layer (in the Timeline panel) to 
make it the active one.

Any objects you draw will be placed on the active layer. It’s important to check which 
layer you’re working on whenever you start to create new artwork. Many professionals 
prefer to lock all but the layer that is being used at a given time, although it isn’t 
necessary if you remember to select the layer you want before you begin drawing.

	 2.	 Select the Line tool in the Tools panel. At the bottom of the Tools panel, 
make sure the object-drawing option is turned off.

	 3.	 Using either the Properties panel or the Tools panel, click the Stroke Color 
swatch to open the pop-up Swatches panel. 

When you select a drawing tool, the Properties panel provides a number of options that 
are relevant to the selected tool. These options remember the last-used settings, so some 
might already reflect the settings we define in the following steps.

The Stroke Color swatch in the Properties panel is the same as the Stroke Color swatch 
in the Tools panel. Changing either swatch reflects the same color in the other one.

When you use the Line tool, the Fill Color swatch in the Properties panel is always set 
to None. By definition, a line has no fill; you can’t change the fill color of a line. The 
Fill Color swatch in the Tools panel, on the other hand, retains the last-used fill option. 
When you switch to a tool that creates filled shapes, the swatch in the Tools panel 
becomes the default fill color.

	 4.	 Make sure the Alpha value is set to 100%, and choose a bright green color as 
the stroke color.

You can use any color you prefer; we are using green so it is easily visible against the gray 
lines in the sketch. Later in this project, you will change the stroke and fill colors of the 
various pieces to create the finished artwork.

Click the swatch 
to open the 
Swatches panel.

The Window 
layer is active.

Object-drawing 
mode is toggled 

off (not active).

Line tool Make sure this value 
is set to 100%.

We are using 
this green color 
for the strokes.

The Line tool does not 
create filled shapes, so the 
fill color is not relevant 
for this exercise.

Note:

You can Control/right-
click a layer in the 
Timeline and choose 
Lock Others to lock all 
but the selected layer.

Note:



The Scale menu defines 
how strokes are affected 
by scaling a symbol in 
which the line exists. 
(This option only affects 
strokes that are part of a 
symbol, which you will 
learn about starting in 
Project 2: Talking Kiosk 
Interface.) 

Note:
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	 5.	 In the Properties panel, set the stroke height (thickness) to 2 and choose 
Solid in the Style menu.

You can type a specific stroke height in the Stroke Height field, or you can drag the 
associated slider for a live preview of the size you drag to (between 0.25 and 200 points). 

Animate includes a number of built-in line styles, including dashed, dotted, ragged, 
stippled, and hatched. You can also edit the selected stroke style by clicking the pencil 
icon to the right of the Style menu.

	 6.	 Open the Cap menu and make sure the Round option is active.

The Cap options define the appearance of a stroke beyond the endpoint of the line.

None end cap style 

Round end cap style 

Square end cap style 

	 7.	 Open the Join menu and make sure the Round option is selected.

The Join options define the appearance of corners where two lines meet. When Miter is 
selected, you can define a miter limit in the Miter field. (This option is not relevant for 
Round or Bevel joins.) A miter limit controls when the corner switches from a pointed 
joint to a beveled joint, as a factor of the stroke height. If you define a miter limit of 2 for 
a 2-point line, the corner is beveled if the pointed corner extends beyond 4 points (2 1 2).

Miter join results 
in pointed corners.

Round join 
applies a circular 
edge to the corners.

Bevel join 
cuts off the points 
of the corners.

	 8.	 Zoom in to the window on the sketch.

As a general rule, we don’t tell you the specific view percentage to use because every 
user’s monitor and personal preferences determine a comfortable working environment. 
We do, however, tell you where to focus your attention.

	 9.	 Choose View>Snapping>Snap to Objects. If this option is already checked 
(toggled on), move the mouse cursor away from the menu and click to 
dismiss the menu.

As you draw different line segments with the Line 
tool, you want the ends of individual segments to 
align with each other. This is much easier when the 
Snap to Objects option is toggled on.

The Hinting check box 
helps when you draw 
straight lines that are 
connected to smooth 
curves. When this option 
is not checked, the 
curves might seem to be 
disconnected from the 
straight lines. 

Note:
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	10.	 Click the top-left corner of the window, hold down the mouse button, 
drag down and right, to the bottom-left corner, and then release the mouse 
button. When you release the mouse button, do not move the mouse cursor.

Click here...

...and drag to here.

	11.	 With the cursor in the same position as when you finished the previous step, 
click and drag down and right to create the lower-left corner of the window 
shape (use the following image as a guide). 

Because the Snap to Objects option is toggled on, when you first click you should see 
a small circle connecting to the end of the line you drew in the previous step. This 
indicates that the new line is connecting to that open endpoint.

A small circle indicates that 
you are connecting to the open 

endpoint of an existing line.

Drag to here to create the 
second line in the shape.

	12.	 With the cursor in the exact position as at the end of Step 11, click and drag 
right to create the bottom edge of the window.

	13.	 With the cursor in the exact position as at the end of Step 12, click and 
drag up and left until you see a small circle over the end of the first line you 
created, then release the mouse button.

Again, the circle icon indicates that you are connecting to the open endpoint of an 
existing line — in this case, you are closing the shape.

The circle indicates that 
you are connecting to the 
open endpoint, effectively 

closing the shape.

	14.	 Save the file and continue to the next exercise.
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Adjust Lines with the Selection Tool

As the name suggests, the Selection tool is used to select objects. It can also be used 
to push or pull drawing objects into different shapes, almost as if you were pushing 
a string with your finger. In this exercise you will use this capability to bend the lines 
you just created into the correct shape for the car’s window.

	 1.	 With corvette.fla open, choose the Selection tool in the Tools panel.

	 2.	 Review the positions of the window corners. If any do not line up with the sketch, 
move the Selection tool cursor near the corner until a small corner shape appears 
in the tool icon. Click and drag to reposition the corner point.

The corner in the cursor 
icon indicates that you can 
click to drag the corner.

	 3.	 Move the cursor near the diagonal line that makes up the top of the window 
shape until you see a curved line in the cursor icon. 

If an object is already selected, you have to first deselect it before you can use the 
Selection tool to bend the lines into different shapes.

The curved line in the 
cursor icon indicates that 
you can click and drag to 
bend the line.

	 4.	 Click and drag up to push the line into a curved shape that matches the sketch. 

One unique aspect of drawing with Animate is using the Selection tool to pull or push a 
line into a different shape. When you release the mouse button, the line is reshaped. 

Click and drag up to 
push the line into a curve 
that matches the sketch.

	 5.	 Repeat this process to slightly bend the diagonal line in the bottom-left 
corner of the window shape.

	 6.	 Save the file and continue to the next exercise.

This type of “bending” 
works for objects created 
in merge-drawing or 
object-drawing mode.

Note:
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Using the Subselection tool. When you  
click a line with the Subselection tool, you can 
see the object’s anchor points. When you click 
a specific anchor point with the Subselection 
tool, you select only that point.

Moving points. To move a specific anchor  
point, select it with the Subselection tool and 
then drag to move it to the desired location. 
You can also nudge (move just a little bit at a 
time) a point by selecting it and then pressing 
the Up/Down/Left/Right Arrow keys on your 
keyboard.

Reshaping a curve using its handles.  
To reshape a curve, first select it with the Subselection tool, and then 
drag the related handles. (Handles will appear from each smooth 
anchor point that is connected to the curve.)

Converting corner points to curves. To change a corner point  
into a smooth curve, first select the point you want to convert with 
the Subselection tool, then press the Option/Alt key and drag the 
point; handles appear, and the corner becomes a curve. You can then 
adjust the shape of the curve by adjusting the handles.

Converting curves to corner points.  
If you need to convert a curve to a corner 
point, place the Pen tool over the curve 
point, press the Option/Alt key, and click  
to change the point to a sharp corner. 
(Alternatively, use the Convert Anchor  
Point tool.)

Adding anchor points. To add an anchor point, first select the path  
with the Subselection tool. Using the Pen tool, place the cursor near 
the path (but not over an existing anchor point) until you see a plus 
sign (+) in the tool cursor. Click the path to add a new point to the 
line. (Alternatively, use the Add Anchor Point tool.)

Deleting anchor points. To delete an anchor point, first select the  
path with the Subselection tool. Using the Pen tool, place the cursor 
near an existing point until you see a minus sign (–) in the tool 
cursor. (Alternatively, use the Delete Anchor Point tool.)

Selected point

Unselected point

Line segment

Subselection tool cursor

Click and drag with 
the Subselection tool 
to move only the 
selected anchor point.

As you drag the handle 
up and out to the right, 
the shape of the curve 
changes accordingly.

Option/Alt-click and drag 
with the Subselection 
tool to convert a corner 
point to a smooth point.

Using the Pen tool, 
Option/Alt-click a point to 
convert it from a smooth 
point to a corner point.

A plus sign (+) in the Pen 
tool cursor indicates that 
clicking will add a point 
to the segment.

A minus sign (–) in the 
Pen tool cursor indicates 
that clicking will remove 
that anchor point.
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Draw with the Pen Tool

The Pen tool draws curved lines, known as Bézier curves, that are shaped based on the 
position of anchor points and their connected direction handles. This type of drawing 
creates very precise shapes, but can be difficult to master. In this exercise, you will draw 
the shape of the car body. While you work through the steps, you should try to get 
a feeling for how clicking and dragging affects the shape you create. The best way to 
master the Pen tool is to practice; as you gain more experience using the Pen tool, you 
will be better able to understand and predict exactly where you should click to create 
the shape you want.

	 1.	 With corvette.fla open, select the Body layer to make it the active layer. 
Zoom out so you can see the entire car shape.

If the Body layer is locked, click the lock icon for the layer to unlock it.

	 2.	 Choose the Pen tool in the Tools panel, and toggle on the Object-Drawing 
mode option.

	 3.	 Click the Fill Color swatch in the Tools panel and choose the None swatch 
in the top-right corner of the pop-up Swatches panel.

Because you want to be able to see the sketch through the shapes you create in this stage 
of the project, you are setting the fill to none. 

Click the Fill Color 
swatch and choose 
the None option.

	 4.	 Using the Properties panel, make sure you are using the same color and size 
stroke that you used to create the window shape.

When you choose a new drawing tool, the object-drawing mode toggle, stroke, and fill 
properties retain the last-used options. If you took a break from this project after the 
previous exercise, make sure your drawing options are correct.

Pen tool

Make sure the stroke 
color, size, and style 
are the same as you 

used earlier.

Object-drawing 
mode is toggled on.

The Body 
layer is active.

Remember, to zoom out 
you can press Option/Alt 
and click with the Zoom 
tool, or press Command/
Control-minus (–).

Note:
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	 5.	 Click once at the top-left corner of the car shape.

Clicking with the Pen tool places an anchor point with no direction handles. (You might 
have to look very closely to see the anchor point.)

Click here without 
dragging to place an 
anchor point with no 

direction handles.

	 6.	 Move to the right until you are above the back edge of the rear wheel. Click and 
drag to the right to place an anchor point with symmetrical direction handles.

When you click and drag with the Pen tool, you create a smooth anchor point with 
symmetrical direction handles (the handles on both sides of the point are the same 
length, exactly opposite one another). The length and angle of the direction handles 
define the shape of the segment that connects the two anchor points.

Click here to place 
the anchor point...

...and drag to create 
the direction handles.

	 7.	 Click and drag right again where the back of the door intersects the top of 
the car.

As you drag, notice how the position of the direction handles affects the shape of the 
connecting line segment. Experiment with dragging up, down, left, and right to see the 
effect on the curve shape.

Pressing Command/
Control while using the 
Pen tool temporarily 
switches to the 
Subselection tool. When 
you release the key, the 
Pen tool is again active.

Note:
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	 8.	 Click and drag again where the top of the car meets the hood.

	 9.	 Place the cursor over the point you just created and click to remove the 
handle from the outside of the open point.

While you are drawing, clicking a symmetrical point again removes the direction handle 
from the outside of the point — converting the point to a corner point. The handle on 
the inside of the point remains because it is required to define the existing curve shape 
between the converted point and the previous one.

The upside-down v in the 
cursor icon indicates that 
clicking will convert this 
point to a corner point.

Clicking removes the 
handle from the outside 
of the point.

The inner handle is required to 
create the shape of the previous 
segment, so it is not removed 
from the new corner point.

You can drag past the 
edge of the document 
window if necessary.

Note:
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	10.	 Click and drag again near the corner of the front bumper.

Do not click the actual corner in the sketch. Because the bumper’s edge is actually 
rounded, it’s better to place anchor points on both sides of the curve rather than in the 
exact center of the curve.

Don’t worry about 
matching the sketched 
hood exactly; you’ll fix this 
in the next exercise.

	11.	 Click on the front side of the bumper, just below the curve, and drag short 
handles along the path of the bumper’s front edge.

As you can see in our example, symmetrical points often result in incorrect paths. You 
will learn how to fix this type of problem in the next exercise. 

The handle from the 
symmetrical point makes 
the connecting curve 
shape incorrect.

	12.	 Click just before the bottom curve of the bumper shape and drag slightly 
along the path of the bumper’s front edge.

The point here is to create a smooth point with handles on both sides, without 
significantly affecting the shape of the connecting curve. Dragging a very small distance 
accomplishes this goal.
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	13.	 Click and drag slightly along on the bottom edge of the car, just past the 
bottom-front corner.

Short direction handles 
can be used to create 
smooth points with very 
tight connecting curves.

	14.	 Continue drawing the rest of the car shape by clicking and dragging to 
place anchor points with handles. For the bottom edge, simply extend the 
bottom-edge line over the wheel shapes. 

	15.	 When you get to the end of the shape, place the cursor over the original 
starting point and click to close the shape.

When you hover the cursor over the original starting point, the cursor shows a hollow 
circle in the icon, indicating that you can click to close the shape.

The circle in the cursor 
icon indicates that 

clicking will connect to 
the open endpoint and 

close the shape.

Extend the lines over the 
wheel areas for now.

	16.	 Save the file and continue to the next exercise.

Adjust Bézier Curve Shapes

From the previous exercise, you might have guessed that many of the lines that you 
draw with the Pen tool will not be perfect when you first create them. Fortunately, the 
Subselection tool makes it easy to edit the position of individual anchor points, as well 
as the length and angle of the direction handles that define connecting line segments.

	 1.	 With corvette.fla open, zoom into the front end of the car.

	 2.	 Choose the Subselection tool in the Tools panel.

The Selection tool selects entire paths, but the Subselection tool selects individual anchor 
points. You use the Subselection tool to select and edit anchor points, or adjust the 
direction handles that define the shapes of curves that connect two anchor points.
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	 3.	 Click the green line on the hood to select the shape, then click the anchor 
point on the front edge of the car hood to select it.

Clicking a line with the Subselection tool reveals the shape’s anchor points.

Click a line to 
reveal the shape’s 
anchor points.

Subselection 
tool

	 4.	 Click to select the anchor point near the top front edge of the car’s hood.

Because you are using the 
Subselection tool, you can select 
individual anchor points. Selecting 
an anchor point reveals the handles 
that are related to that anchor point, 
which allows you to edit those 
handles.

	 5.	 Click the outer direction handle (the one on the bottom) and drag up and 
left to reshape the curve on the top corner of the bumper.

When you drag one direction 
handle, the point remains smooth 
but it is no longer symmetrical; 
changing the length, but not the 
angle, of a direction handle affects 
only the segment on the same side 
of the point as the handle that you 
change. 

Because this is still a smooth point, 
however, dragging one handle to a 
different angle would also affect the 
point’s other handle — affecting the 
shapes of both segments that are connected to the anchor point. 

Direction handles 
for the selected 
point are visible.

Selected points 
are filled.

Unselected points 
are hollow.

Drag the handle along the 
existing line position to 
shorten the handle without 
changing its angle.

If you drag toward or 
away from the anchor 
point without changing 
the angle, you are 
changing the arc of the 
segment that is related to 
the changed handle.

Note:
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	 6.	 Choose the Add Anchor Point tool (nested under the Pen tool), then click 
the existing line midway along the hood to add a new anchor point.

You can also add a point by moving the Pen tool cursor over an existing line segment.

Click this line to add 
an anchor point near 

the middle of the hood.

Add Anchor 
Point tool

Handles are created 
as necessary to keep 

the same curve.

Existing handles are 
adjusted to maintain 

the same curve.

	 7.	 Using the Subselection tool, click the new point and drag until the path 
more closely resembles the line in the sketch.

When you move a point, the length and angle of the related handles are not affected. In 
many cases, you might need to move a point and then adjust the handles to achieve the 
effect you want.

	 8.	 Review the position of each anchor point and line segment in the car shape. 
Make any necessary adjustments until you are satisfied with your drawing.

Keep the following points in mind as you fine-tune your shape:
•	 To move a point, click and drag with the Subselection tool.
•	 To add an anchor point, click an existing segment with the Pen tool (or use the 

Add Anchor Point tool that is nested under the Pen tool).
•	 To remove a point, click an existing point with the Pen tool (or use the Delete 

Anchor Point tool that is nested under the Pen tool).
•	 To convert a smooth point to a corner point, Option/Alt click the point with the 

Pen tool (or use the Convert Anchor Point tool).
•	 To convert a corner point to a smooth point, Option/Alt click the point with the 

Pen tool and drag to create symmetrical direction handles for the point (or use 
the Convert Anchor Point tool).
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	 9.	 In the Timeline panel, click the dot under the Eye icon for the Sketch layer. 
Click the Stage (away from the existing shapes) to deselect everything, then 
review your progress.

Any time you are working from a sketch, it can be helpful to hide the sketch so you can 
better see exactly what you have created. 

Click in this 
column to hide 
the Sketch layer.

	10.	 Click the X for the Sketch layer to show that layer again.

Feel free to repeat this process throughout this project — we won’t include this step again.

	11.	 Save the file and continue to the next exercise.

Use Destructive Editing to Create Shapes

When you work on a merge-drawing shape (in other words, one created without 
object-drawing mode toggled on), you can use the Selection tool to select specific 
pieces of objects:

•	 Clicking a stroke selects the line segment between the nearest two anchor points. 

•	 Clicking a fill selects the entire area of the color you click. 

•	 Double-clicking a merge-drawing shape selects the entire stroke and fill.  

•	 Double-clicking the stroke of a merge-drawing shape selects the entire stroke.

•	 Clicking and dragging a marquee selects only the pixels inside the marquee area. 

This behavior enables a type of destructive editing that is unique to Animate 
drawing tools. You can select and move or delete certain pieces of an object without 
affecting other pieces of the same object.

	 1.	 With corvette.fla open, click the Body layer icon in the Timeline panel to 
select the layer.

When you select a layer, all objects on the layer become selected. In this case, the layer 
only contains one object — the shape of the car’s body. 

Clicking a layer icon in 
the Timeline panel selects 
all objects on that layer.
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	 2.	 Using the Selection tool, double-click any line of the car body shape to enter 
into the drawing object.

Double-clicking an object on the Stage switches into Edit mode for the object (often 
referred to as “entering” the object). While in Edit mode for a particular object, you can 
see but not access other objects on the Stage.

The Edit bar shows the 
path to the object you 

are currently editing.

Other objects are 
visible, but cannot be 

selected or edited.

	 3.	 Choose the Line tool in the Tools panel. Make sure Object-Drawing mode is 
toggled on at the bottom of the Tools panel or in the Properties panel.

	 4.	 Draw a straight line where the back of the door is indicated in the sketch. 
Extend the line above and below the car body shape.

You can use the Properties panel 
to toggle on object-drawing mode.

	 5.	 Choose the Selection tool. Click away from the line to deselect it, and then 
use the Selection tool to bend the line into shape.

	 6.	 Click the line to select it again, and then choose Modify>Break Apart.

This command converts objects in object-drawing mode to merge-drawing mode so you 
can use the destructive editing capabilities of the Selection tool.

After breaking apart, 
the line is a merge- 
drawing shape; you can 
select the object’s pixels 
with the Selection tool.

Before breaking apart, 
selecting the line with 
the Selection tool 
reveals the object’s  
anchor points.

While drawing, press 
Command/Control to 
temporarily access the 
Selection tool; when you 
release the modifier key, 
you return to the last-
selected tool.

The easiest way to deselect 
everything is to press 
Command/Control, and 
then click away from any 
object on the Stage. 

Note:
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	 7.	 Choose the Subselection tool in the Tools panel, and click any of the lines 
that make up the car body shape.

All lines you create in Animate are vectors, which means their position and shape are 
defined mathematically based on the anchor points that make up the shape. Animate 
automatically creates whatever anchor points are necessary to reproduce the line you 
draw — including points wherever two lines overlap, as you can see where the vertical 
curved line intersects the car body shape.

	 8.	 Click away from the lines to deselect everything, then use the Selection tool 
to click the overhanging line above the car.

The selected area displays a small cross-hatch pattern.

	 9.	 Press Shift and click the overhanging line below the car.

Pressing Shift allows you to select multiple objects at once; each item you Shift-click is 
added to the previous selection.

Both overhanging lines 
should be selected.

	10.	 Press Delete/Backspace to remove both elements from the drawing.
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	11.	 Repeat Steps 3–10 to create the line that marks the front of the door.

Later in this project, you need to be able to work with the car body shape as a single piece. 
If you left the door lines on the Body layer, the car shape would be effectively split into 
three pieces by the door-edge lines. To solve this potential problem, you are now going to 
move the door lines onto their own layer so they do not cut the car shape into pieces.

	12.	 Using the Selection tool, click one of the door edges to select it, then Shift-
click to select the other.

	13.	 With both lines selected, choose Edit>Cut.

When you cut an object, it is removed from its original position and temporarily stored 
on the Clipboard — a reserved area of memory that allows you to temporarily hold 
objects until you need to use them again somewhere else. This is not the same as deleting 
(as you did in Step 10); when you delete a selection, it is not stored on the Clipboard.

	14.	 In the Edit bar, click Scene 1 to return to the main Stage.

	15.	 Select the Door layer as the target layer and then choose Edit>Paste in Place.

The Paste in Place command puts the cut objects in the exact position as they were cut 
from, but on the now-selected Door layer instead of the original Body layer.

The lines are 
pasted in the exact 

position...

...but on the now- 
selected Door layer.

You are now back 
on the main Stage.

	16.	 Save the file and continue to the next exercise.
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Draw with the Oval Tool

Many otherwise complex objects are, in fact, simply a collection of primitive shapes. 
In the case of this car, you should recognize that the car’s wheels are actually made up 
of three concentric circles. The basic shape tools — including the Oval tool — make it 
very easy to create this type of object.  

	 1.	 With corvette.fla open, select the Wheels layer (in the Timeline panel) as 
the active layer. Zoom into the rear wheel in the sketch.

	 2.	 Choose View>Rulers to show the Stage rulers at the top and left edges of the 
document window.

	 3.	 Click the horizontal ruler, hold down the mouse button, and drag down to 
place a horizontal guide in the center of the sketched wheel.

Click the top ruler and 
drag down to place a 
horizontal guide.

The Wheels 
layer is active.

Rulers appear at the 
top and left edges of 
the document window.

	 4.	 Click the vertical ruler, hold down the mouse button, and drag right to 
place a vertical guide in the center of the wheel. 

You will perform a number of steps in this and the next exercise that will depend on an 
exact center point — where these two guides intersect.

Click the left 
ruler and drag 
right to place a 
vertical guide.

Because this is a hand-
drawn sketch, the wheels 
aren’t exactly circular. It’s 
okay if your circle doesn’t 
exactly match the sketch.

Note:
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	 5.	 Choose the Oval tool in the Tools panel. Make sure object-drawing mode is 
toggled on.

	 6.	 In the Properties panel, make sure the fill and stroke settings match what you  
used in earlier exercises. In the Oval Options section, set all three sliders to 0.

The Oval tool shares many of the same properties as the Pen tool. You can define the fill 
and stroke color, as well as the stroke style, cap, and join. 

Oval tool

When you draw a basic shape, the Properties panel also includes options for defining the shape that will be created. 

When you use the Oval tool, you can define the Start Angle and End Angle to create a shape with a defined wedge 
removed (such as you might see in a pie chart). You can also use the Inner Radius option to remove a circle from inside the 
circle; the defined value refers to the radius of the inner circle (the part that is removed). The Close Path option, which is 
checked by default, can be unchecked to create an open path rather than a closed shape.

0°

End angle

Start angle

180°

90°

270°

When Close Path is not 
checked, the result is one 
or more open paths.

When you use the Rectangle tool, you can easily  
create a shape with rounded corners. The 
Options area in the Properties panel defines the 
Corner Radius; by default, all four corners are 
linked, but you can click the chain icon to define 
a different radius for each corner. (To understand 
the concept of corner radius, think of an 
imaginary circle at the corner of the shape; the 
radius of that circle is the corner radius, as 
shown in the image to the right.)

Corner radius

A
N

IM
A

TE
 F

O
U

N
D

A
TI

O
N

S

Understanding Basic Shape Options



49Project 1: Corvette Artwork

	 7.	 Click at the intersection of the two guides, hold down the mouse button, 
press Option/Alt-Shift, and drag until the shape approximately matches the 
outer circle of the sketched wheel.

You can create a basic shape by simply 
clicking and dragging; the shape 
is anchored where you first click. 
Holding down the Option/Alt key 
as you drag draws the shape from the 
center out. Holding down the Shift 
key while dragging constrains the 
shape to equal height and width.

	 8.	 Click the new object with the Selection tool to select it, then choose 
Edit>Copy.

Copying stores the selected object in the Clipboard.

	 9.	 Choose Edit>Paste in Place. 

Pasting places a copy of the Clipboard contents onto the selected layer. The Paste in 
Place command puts the copy in the exact position as the original. You can also choose 
Paste in Center to place the copy in the exact center of the document window.

	10.	 Choose the Free Transform tool in the Tools panel.

When you select an object with the Free Transform tool, the object is bounded by eight 
transformation handles, which you can to scale, stretch, skew, or rotate the selection. 
The hollow white circle in the center of the bounding box is the transformation point, 
which identifies the origin point around which the transformation will occur.

Transformation 
handles

Free Transform 
tool

Transformation 
point

	11.	 Press Shift, click the bottom-right bounding box handle, and drag up and 
left to shrink the circle around the center point.

The transformation is applied around the transformation point, which defaults to the 
center of the selected shape. Adding Shift constrains the transformation so the object’s 
height-to-width ratio remains the same as the original.

Shift-drag the corner 
handle to resize the 
circle around the 
transformation point.

Click at the exact 
intersection of the guides, 
press Option/Alt-Shift...

...and drag to create a 
circle from the center out.  

To copy an object, select 
the object and press 
Command/Control-C. 

To cut an object, select 
the object and press 
Command/Control-X. 

To paste an object from 
the Clipboard onto the 
Stage, press Command/
Control-V. 

To paste an object in 
place, press Command/
Control-Shift-V.

Note:
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Free Transform mode allows you to change an object 
(or group) on the Stage by simply dragging. You can enter 
Free Transform mode by selecting an object with the Free 
Transform tool, by pressing Q (the keyboard shortcut for the 
tool), or by choosing Modify>Transform>Free Transform.

In Free Transform mode, the selected object is surrounded 
by a black bounding box with heavy black handles. A hollow 
circle in the center indicates the object’s transformation 
point. Depending on where you place the cursor, you can 
apply different kinds of transformations. The cursor icon 
changes to reflect the change you will make by dragging. 
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Using the Free Transform Tool

Press Command/Control while 
dragging a corner handle to distort 

the object shape.

Press Command/Control while dragging 
a side handle to skew and resize an object 

at the same time.

Click a corner handle and 
drag to resize both height 

and width at once.

Click a side handle and drag to resize the 
object’s height (left) or width (right).

Click and drag between handles on 
any side to skew the object.

Transformations such as rotation and skewing apply 
around the transformation point, 

which defaults to the center of the object.

Moving the transformation point (left) changes the fixed 
point around which the rotation applies (right).

Click outside a corner handle 
and drag to rotate the object.

Press Option/Alt while dragging a handle to apply 
a change around the transformation point. (In this 
example, Option/Alt-dragging the bottom handle 

also moves the top handle.)

Press Shift while dragging a corner 
handle to maintain the original 

height-to-width ratio in the resized 
object (called “constraining”).
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	12.	 Repeat Steps 8–11 to create the third circle in the wheel shape.

	13.	 Using the Selection tool, click away from all objects to deselect them.

	14.	 Save the file and continue to the next exercise.

Draw with the Pencil Tool

The Pencil tool provides another way to develop curved artwork. Drawing with the 
Pencil tool is easy; simply drag a line or shape, and the stroke — in whatever color is 
currently set in the Tools panel — follows the cursor.  

With the proper equipment — notably a pressure-sensitive drawing tablet —  
the Pencil tool might very well be the most important tool Animate offers. This notion 
is particularly true for artists skilled at sketching or drawing with natural media such 
as pen and ink, pencils, and pastel chalks. Other people find the Pencil tool difficult 
to use, preferring the Pen tool, Bézier curves, primitive shapes, freeform shapes, and 
combinations thereof. 

	 1.	 With corvette.fla open, make sure the Wheels layer is active. Hide the 
Body layer so the lines do not interfere with the area where you are working.

	 2.	 Choose the Pencil tool in the Tools panel. Using the Properties panel or 
Tools panel, make sure object-drawing mode is toggled on.

Pencil tool

The Wheels 
layer is selected.
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	 3.	 Click the mode button in the Tools panel and choose the Smooth option.

The Pencil tool offers three possible modes:

•	 Straighten mode favors straight lines and corner points.
•	 Smooth mode favors curves and smooth anchor points in the 

resulting paths. This option allows greater tolerance for slightly jerky movement 
as you drag, which can be very useful if you are using a mouse instead of a 
drawing tablet.

•	 Ink mode closely follows the path that you draw, placing a large number of 
anchor points to capture very small movements of the cursor; this mode often 
results in a very jagged path, especially if you are using a mouse instead of a 
drawing tablet.

	 4.	 Click and drag to create one of the inset shapes on the wheel.  
Make sure you overlap the line ends with the second circle, as shown in  
the following image.

When you release the mouse button, the Smooth mode should result in a fairly rounded 
inset shape.

When you release the 
mouse button, the 
path smoothes out.

Click and drag to 
draw this shape.

	 5.	 Choose the Free Transform tool, then click the new shape to reveal its 
transformation handles.

	 6.	 Click the transformation point and drag to the intersection of the two ruler 
guides.

You are going to copy and rotate this object around the wheel’s center point to create the 
six inset shapes. The ruler guides that you placed mark the center of the wheel, which 
you used when you Option/Alt dragged from the guide intersection to create the circles. 
To rotate the inset shape around the same center, you are now moving the first shape’s 
transformation point to the same center point as the overall wheel shape.

Drag the transformation 
point from the center of 
the shape to the inter- 
section of the guides.

The Free Transform 
tool is selected.

	 7.	 With the object selected, choose Edit>Copy. 
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	 8.	 Immediately choose Edit>Paste in Place.

Because you moved the transformation point before copying and pasting the object, the 
pasted copy also has the same relocated transformation point.

	 9.	 Move the cursor outside one of the object’s corner handles until you see the 
rotation icon in the tool cursor.

	10.	 Click and drag left to rotate the copy, approximating the position of the 
second inset.

As you drag, you should recognize that the object is rotating around the repositioned 
transformation point; in other words, it’s rotating around the wheel center.

Click and drag to 
rotate the object 
around the defined 
transformation point.

Place the cursor 
near a corner point 
until you see the 
rotation icon.

	11.	 Repeat Steps 7–10 four more times to create the six wheel insets.

In this case, don’t worry about perfectly matching the sketch. The important point is to 
have six inset shapes, spaced approximately evenly around the wheel shape.

	12.	 Choose View>Guides>Clear Guides.

You no longer need the wheel’s center-point reference now that all of the necessary 
shapes are in place, so you can delete the ruler guides. 

Note that this menu also includes options for showing or hiding guides, locking guides, 
and numerically editing the position of a guide. These options are all useful at some 
point, depending on the purpose of a particular guide.

	13.	 Choose View>Rulers to toggle off the rulers.

	14.	 Save the file and continue to the next exercise.
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Work with an Object Group

You want to be able to access the individual shapes that make up the wheel, but you 
also want to be able to treat the wheel as a single unit on the main Stage. A group is a 
collection of shapes that is combined so it can be treated as a single object.

	 1.	 With corvette.fla open, hide the Sketch layer to make the wheel shapes 
more prominent.

	 2.	 Choose the Selection tool, then click the Wheels layer icon to select all 
objects on that layer.

Because you created these objects in object-drawing mode, you can see the anchor points 
of each each shape. To prevent moving one of these components independently of the 
others, you can group them into a single unit.

Click the layer icon 
to select all objects 

on the layer.

	 3.	 Choose Modify>Group.

When you group objects, the bounding box displays around the entire group. By 
manipulating the bounding box, you can resize, move, and otherwise modify a group 
as you would a single object. Grouped objects are isolated from other elements on the 
same layer, so you can place grouped objects on top of one another with no worries of 
damaging the underlying objects. 

Grouped objects are 
treated as a single unit, 

and have a single bounding 
box on the main Stage.

You can group objects 
by pressing Command/
Control-G.

To ungroup objects, select 
the group and choose 
Modify>Ungroup or 
press Command/Control-
Shift-G.

Note:

Press Command/
Control-A to select all 
objects (on all layers) that 
are not locked.

Note:
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	 4.	 Double-click the group to enter into it (view the group in Edit mode).

Even though the objects are grouped on the main Stage, you can still access the 
individual components in Edit mode.

Because you drew these shapes in object-drawing mode, you can’t access the pixels of 
the lines. You can’t select and delete parts of the lines with the Selection tool, which you 
need to do.

The Edit bar shows 
that you are working 

inside the group.

In Edit mode, you can 
access the individual 

components of the group.

	 5.	 With all objects in the group selected, choose Modify>Break Apart.

After breaking apart the 
drawing objects, you can use 

the Selection tool to select 
specific pixels, or segments 

between anchor points.

	 6.	 Click away from the lines to deselect everything.

	 7.	 Click to select one of the overhanging lines between the outer and middle 
circles, then press Delete/Backspace.

Remember from the earlier discussion on destructive editing that when you’re editing a 
drawing object, Animate recognizes and separates overlapping elements. 

	 8.	 Repeat Step 7 to remove all of the extraneous line segments.

	 9.	 In the Edit bar, click Scene 1 to return to the main Stage.

Because these objects started as a group, and you made all the edits inside the group, the 
selection on the main Stage is still treated a single unit; the bounding box surrounds the 
outer edge of all the objects in the group.



56 Project 1: Corvette Artwork

	10.	 Show the Body and Sketch layers.

	11.	 Save the file and continue to the next stage of the project.

Stage 3	 Painting and Coloring Objects
You now have all of the primary shapes you need for this project, clearly organized on separate layers. 
(You will create the front wheel later by duplicating the finished back wheel.) You drew all of these 
shapes as unfilled objects so you could see the underlying sketch; now you can apply fill colors to the 
various shapes. You can use a wide variety of methods to paint the car; you will explore these options 
in this stage of the project. 

Apply Fill and Stroke Colors to Selected Shapes

The most basic way to change an object’s color attributes is simply to select the object 
and then define the appropriate colors — which you will do in this exercise.

	 1.	 With corvette.fla open, click the Body layer icon in the Timeline panel.

Remember, clicking a layer icon selects all objects on that layer.

	 2.	 Click the Fill Color swatch in the Tools panel. Make sure the Alpha value is 
set to 100%, and choose a dark red color from the pop-up Swatches panel.

When you change the fill or stroke color when an object is already selected, you affect 
the relevant attributes of the selected object.

Click the swatch to open 
the Swatches panel.

Choosing a new color 
changes the attribute 
of all selected objects.

Make sure this value 
is set to 100%

It’s always a good idea 
to look for ways to avoid 
duplicating work. You 
will create the second 
wheel by duplicating the 
first wheel after you fill it 
with color.

Note:
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	 3.	 With the car shape still selected, click the Stroke Color swatch in the Tools 
panel and choose the None swatch.

This removes the green lines which were only necessary for the original drawing process.

	 4.	 Review the layers in the Timeline panel.

The layer stacking order shows that the window is below the car body. Because the car 
shape now has a solid fill, you can no longer see the window shape. 

	 5.	 Click the Window layer in the Timeline panel and drag up. When a line 
appears above the Body layer, release the mouse button.

Rearranging the layer stacking order is as simple as clicking and dragging. When the 
Window layer is above the Body layer, you can again see the window shape.

    

	 6.	 Save the file and continue to the next exercise.

Fill Artwork with the Paint Bucket Tool

The Paint Bucket tool provides an easy way to change objects’ fill colors without first 
selecting the target objects. In this exercise you will use the Paint Bucket tool to change 
the fill colors of the window and the wheel.

	 1.	 With corvette.fla open, make sure nothing is selected on the Stage.

If you change the Fill or Swatch color when an object is selected, the new color will 
affect the selected object.

	 2.	 Choose the Paint Bucket tool in the Tools panel.

	 3.	 Use the Fill Color swatch in either the Tools panel or the Properties panel to 
change the Fill color to Black.
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	 4.	 Click the Gap Size button at the bottom of the Tools panel and choose  
Close Large Gaps.

The Gap Size menu allows Animate to overlook slight openings 
between line segments, which is a common occurrence when 
you draw with tools such as the Pencil or Line tool. Because you want all of these objects  
to be solid fills, you are using the largest setting to allow the application to fill the areas 
that you have defined.

	 5.	 Click the end of the pointer in the tool cursor on the line that identifies the 
window shape to fill the shape with the defined fill color.

Because the object doesn’t yet have a fill color, you have to click exactly on the existing 
line to fill the closed shape. If you clicked inside the shape, the tool would recognize the 
fill color of the body shape and change its fill to black.

Click exactly on the 
shape’s stroke to fill 
it with the defined 
Paint Bucket fill color.

Paint Bucket 
tool

Use this point to 
determine what will 
be filled with the Paint 
Bucket tool.

	 6.	 Using the Selection tool, double-click the wheel group to enter into the group.

You have to enter into the group to edit the properties of individual group components.

	 7.	 Choose the Paint Bucket tool again, then click between the outer and 
middle circles of the wheel shape to change the fill color to black.

In this case, you are editing only the group. There are no other objects on the group’s 
Stage, so the Paint Bucket tool recognizes the closed area between the two circles and 
adds the black fill color. 

When inside the 
group, you can click 

between the two lines 
to fill the closed area.

The Edit bar 
verifies that you are 

editing the group.

	 8.	 Click inside the center circle, and then click inside each of the inset shapes 
to change all of those fills to black (as shown in the image after Step 10).

If you change the wrong 
object (on a different 
layer), press Command/
Control-Z to undo the 
last step, and click again 
to edit a specific object.

Some users prefer to 
lock all but the layer 
currently being edited, to 
prevent changes to objects 
other than the one you 
targeted. 

Note:
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	 9.	 Change the fill color to medium gray, and then click inside the remaining 
shape (around the wheel insets) to fill that area with gray.

	10.	 Click Scene 1 in the Edit bar to return to the main Stage.

	11.	 Save the file and continue to the next exercise.

Change Stroke Attributes with the Ink Bottle Tool

The Ink Bottle tool allows you to change the color of strokes without first selecting a 
specific object. Any stroke you click will be affected by the defined tool settings. In this 
exercise you will change the bright green strokes that you used during development to 
something that more accurately suits the project artwork.

	 1.	 With corvette.fla open, choose Edit>Deselect All to deselect everything.

When either selection tool is active, you can also simply click an empty area of the Stage 
to deselect everything in the file.

	 2.	 Choose the Ink Bottle tool, change the stroke color to black, and change the 
stroke height to 1 pt.

Once you select the Ink Bottle tool, you can use the Properties panel to predetermine 
the weight, color, stroke style, and other features before you use the tool. The current 
settings in the Properties panel will be applied to any shape you click with the Ink Bottle 
tool, and will remain in effect until you change them.

Ink Bottle 
tool

Use the Properties panel to change 
the stroke settings before clicking 

with the Ink Bottle tool.
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	 3.	 Click inside the Window shape to change the object’s stroke color to black.

The stroke instantly changes to the new color; it doesn’t matter if you select the layer or 
not. Since all objects are on unlocked layers, the Ink Bottle tool “knows” which objects 
it’s touching.

Click with the Ink Bottle tool 
inside a filled shape to change 
the object’s stroke attributes.

	 4.	 With the Ink Bottle tool still selected, click the end of the pointer in the tool 
cursor directly on the lines that mark the front and back of the car door.

When an object has an existing fill, you can click with the Ink Bottle tool anywhere in 
the object’s fill to change the stroke attributes. If an object has no defined fill, you have 
to click on the existing stroke to change its attributes.

To accomplish this step, it might help to zoom into the lines you want to change.

Because these are open 
lines with no fill, you have 
to click directly on the lines 
to change their attributes.

Use this point to 
determine what will 

be filled with the 
Ink Bottle tool.

	 5.	 Zoom in to the top of the rear door line and review the results.

Because you removed the stroke from the body shape, the “door” lines now hang a bit 
past the edge of the body shape. You can fix that by adjusting the end-cap style of the 
door lines.

Zooming in shows 
the overhanging 

end of the line.

	 6.	 Select the door line with the Selection tool. In the Properties panel, choose 
None in the Cap menu.

Choose None 
in this menu. 

Select the line with 
the Selection tool.

You don’t need to select 
the objects before clicking 
with the Ink Bottle tool 
to change the stroke color.

Note:
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	 7.	 Repeat Step 6 for the line that marks the front of the door.

	 8.	 Using the Selection tool, double-click the wheel group to enter into the group.

	 9.	 Choose the Ink Bottle tool again and change the stroke color to medium gray.

	10.	 Click exactly on the edge of the middle circle.

When you used the destructive editing functionality to create the inset shapes, a number 
of anchor points were added to the circle shape to create the inset pieces. You need to click 
the circle edge between and within every inset piece to change the entire stroke to gray.

	11.	 Continue clicking around the circle until the entire middle circle has a 1-pt 
gray stroke.

	12.	 Change the stroke color to black and then click all of the remaining green 
strokes in the wheel to change them to black.

In this case, you have to click the actual strokes. If you clicked the fills, you might 
inadvertently change the gray stroke of the middle circle back to black.
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	13.	 Click Scene 1 in the Edit bar to return to the main Stage.

	14.	 Using the Selection tool, click the wheel group, press Option/Alt, and drag 
right until the duplicate wheel aligns with the front wheel.

Pressing Option/Alt while dragging clones (makes a copy of ) the object you drag.

Option/Alt-dragging an 
object makes an exact 
copy (called cloning).

	15.	 Save the file and continue to the next exercise.

Adjust Alpha Transparency

The Alpha property defines the degree of transparency of an object; in other words, it 
determines how much you can see underlying objects through another object. This can 
be useful for creating special effects, including the appearance of depth. In this exercise 
you will adjust alpha values to create the appearance of reflections on the car’s surface.

	 1.	 With corvette.fla open, click the Outline button for the Body layer so you 
can see the underlying sketch. Select the Accents layer as the active one.

Outline mode allows you to see through filled artwork without changing the objects’ fill 
properties. All objects on outlined layers appear as simple lines that match that layer’s 
defined color swatch; defined fill and stroke attributes are not visible.

Click this button to 
display the layer as 

only outlines.

	 2.	 Use any tool you prefer (with object-drawing mode toggled on) to create  
the two curved shapes that represent reflections on the car’s upper body.

	 3.	 In the Timeline panel, click the Outline button for the Body layer to restore 
the layer to the regular view.

Be careful while making 
copies of any object. Do 
not release the Option/Alt 
key before releasing the 
mouse. Doing so might 
move the original object 
instead of making a copy.

Note:



63Project 1: Corvette Artwork

	 4.	 Select both of the accent shapes and apply a white fill and no stroke.

	 5.	 In the Color panel, click the Fill Color swatch to open the color palette.

Remember, all panels can be accessed in the Window menu.

	 6.	 Place the cursor over the Alpha value (in the top-right corner of the palette) 
until you see a two-headed arrow in the hand icon.

When you see this cursor, you can click 
and drag left or right to change the 

associated value (called “scrubbing”).

	 7.	 Click and drag left to reduce the Alpha value to 50%.

After reducing the Alpha value, 
you can see some of the red color 
through the white-filled shapes.

	 8.	 Save the file and continue to the next exercise.
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Convert Strokes to Softened Fills

The sketch in this project shows three lines that seem to bisect the car, creating an edge 
that catches the reflection of light. In this exercise, you will create these lines and then 
adjust them to add depth and texture to the artwork.

	 1.	 With corvette.fla open, click the Outline icon for the Body layer so you 
can see the underlying sketch. Make sure the Accents layer is the active one.

	 2.	 Choose the Line tool in the Tools panel and activate object-drawing mode. 
Change the stroke color to white with a 50% Alpha value, and set the stroke 
height to 1 pt.

	 3.	 Draw the three lines on the car that seem to bisect the car horizontally.  
Use the Selection tool to position and bend the lines as necessary.

	 4.	 Click the Outline button for the Body layer to restore it to the normal view.

These are the 
lines to draw.

	 5.	 Using the Selection tool, Shift-click to select all three lines.

	 6.	 Choose Modify>Shape>Convert Lines to Fills.

These hard-edged lines appear rather harsh; you are going to modify these lines to 
more smoothly blend into the underlying shape. To do this, you first need to convert 
the strokes to filled shapes. The fill of the new shapes adopts the stroke color that was 
applied to the original line.

	 7.	 With the three lines still selected, choose Modify>Shape>Soften Fill Edges.

	 8.	 In the resulting dialog box, set the Distance field to 2 px and set the 
Number of Steps field to 4. Choose the Expand option.
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	 9.	 Click OK to apply the change.

Each edge of the shape is now extended by 2 pixels, moving in four steps from the 
original alpha value (50%) to 0%, or entirely transparent. 

After softening edgesBefore converting to a fill After converting to a fill

	10.	 Save the file and continue to the next exercise.

Paint with the Brush Tool

The Brush tool, as you might expect, is used to paint areas of color. This tool offers a 
number of modes that allow you to paint in only specific areas, as you will do in this 
exercise to create a shadow underneath the car.

	 1.	 With corvette.fla open, select the Body layer as the active one. 
Click away from the artwork on the Stage to deselect everything.

	 2.	 Choose the Brush tool, change the fill color to a medium gray, and set the 
Alpha value to 100%.

	 3.	 At the bottom of the Tools panel, make sure Object Drawing Mode is 
toggled on.

	 4.	 Click the Brush Mode menu and choose Paint Behind.

The Brush tool has five modes:

•	 Paint Normal is exactly that: it paints on top 
of anything already on the Stage. 

•	 Using the Paint Fills mode, you paint over 
the background and any object fills, but you 
leave object strokes unaffected. 

•	 Paint Behind allows you to paint only the 
background; any area with a fill or stroke 
remains unaffected by the brush stroke. 

•	 Paint Selection applies your brush strokes to 
currently selected fill areas only. 

•	 Paint Inside applies the brush stroke within 
the boundaries of the fill where you first click. 

	 5.	 Click the Brush Size button and choose the largest available solid brush.

	 6.	 Click the Brush Shape button and choose the full round option.

Step 5 Step 6

Brush tool

Brush Mode menu

Lock Fill toggle

Brush Size menu

Brush Shape menu

The tool options 
remember the last-used 
settings, so some of these 
might already be set to 
the options we use in this 
exercise.

Note:
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	 7.	 Using the sketch as a rough guide, click and drag to paint a shadow shape 
underneath the car.

Don’t worry about overlapping the car body shape while you’re painting the shadow; 
although it appears to be on top of (and obscuring) the car shape, the shadow assumes 
its proper place behind the body when you release the mouse button.

While you’re painting, 
the brush strokes appear 
to be on top of the 
existing shape.

The Body layer 
should be active.

Brush tool cursor

Using the Paint Behind 
option, the overlapping 
paint disappears when you 
release the mouse button.

	 8.	 Using the Selection tool, select the shadow shape and then choose Edit>Cut.

	 9.	 In the Timeline panel, click the New Layer button. Name the new layer Shadow.

As we explained previously, new layers are always added immediately above the 
previously selected layer.

	10.	 With the Shadow layer selected, choose Edit>Paste in Place.

Even though you couldn’t see the entire brush stroke after releasing the mouse button, 
the shape exactly matches the area that you painted. When moved to a higher layer in 
the stack, the entire area becomes visible — obscuring some of the car body.

With the Shadow layer 
above the Body layer, 

the entire painted 
shape is visible.

	11.	 Click the Shadow layer in the Timeline panel and drag it below the Body layer.

Rearranging the layer 
stacking order hides 

the shadow edge 
behind the car body.

	12.	 Save the file and continue to the next exercise.
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Apply Linear and Radial Gradients

At this point your artwork is a technically complete piece of artwork; all of the shapes 
are in place, with the necessary solid fills and strokes to clearly portray a digital 
Corvette. To add greater depth and dimension, however, you are going to apply 
gradients to the car’s body and window.

	 1.	 With corvette.fla open, click the window shape with the Selection tool.

	 2.	 Using either the Properties or Tools panel, open the Fill Color palette and 
choose the white-to-black radial gradient swatch.

As soon as you apply the gradient, you see the gradient transformation handles around 
the selected shape. You can ignore those for now.

With the window 
fill selected...

...choose the 
white-to-black radial 

gradient in the Fill 
Color palette.

	 3.	 In the Color panel, click below the gradient ramp near the middle to add a 
new color stop to the gradient.

Clicking below the ramp adds a new stop, which defaults to the color of the location 
where you first click.

Click below the ramp to 
add a stop to the gradient.

	 4.	 Drag the new stop left, to approximately one-fourth of the way across the ramp.

Click the stop and drag 
to move that color to a 
different position along 
the gradient.

The selected shape 
adopts the new 
distribution of color.

The terms “gradient” 
and “blend” are used 
interchangeably. Animate 
documentation uses both 
gradient and blend; both 
terms mean a smooth 
transition from one color 
to another.

Note:

You can define up to 15 
color stops in a single 
gradient.

Note:
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	 5.	 Click the car body shape with the Selection tool. 

	 6.	 In the Color panel, click the Fill Color icon to activate that attribute. 

	 7.	 In the Color Type menu, choose Linear Gradient.

The gradient ramp remembers the last-used gradient, so the adjusted white-to-black 
gradient from the window is applied to the selected shape (the car body).

Choose from this 
menu to apply a 
linear gradient.

The last-used 
gradient is applied 
automatically .

Click here to 
make sure the 
Fill icon is active.

	 8.	 At the bottom of the Color panel, click the color stop in the middle of the 
gradient ramp and drag down away from the ramp.

You can remove any stop from a gradient by simply dragging it away from the ramp.

	 9.	 Double-click the color stop at the left end of the gradient ramp. Choose the 
dark red color swatch from the pop-up palette.

Double-click a gradient 
stop to open the color 

palette for that stop.

	10.	 Double-click the right color stop and choose the same dark red color that 
you applied to the left stop. 

	11.	 With the right stop still selected, drag the Brightness slider in the Color 
panel down until the B option (in the HSB group) shows 10%.

Drag here to 
change the stop’s 
brightness value.

This is the value 
you are affecting by 
dragging the slider.

	12.	 Save the file and continue to the next exercise.
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Transform Gradients

As you saw in the previous exercise, it is fairly easy to apply gradients to any drawing 
object, and to change the colors that are used in those gradients. Of course, the left-to-
right gradient on the car’s body does not create the realistic effect that you want. You 
now need to transform the applied gradients to finish the piece.

	 1.	 With corvette.fla open, choose the Gradient Transform tool (nested under 
the Free Transform tool).

	 2.	 Click the window shape to select it.

The Gradient Transform tool enables you to adjust the size, direction, and center point 
of a gradient fill. When you click an object filled with a gradient, a special bounding box 
shows the gradient-editing handles.

Location of leftmost 
gradient stop color 

Gradient 
Transform tool

Center-point handle

Width handle

Size handle

Rotation handle

	 3.	 Click the center point of the gradient and drag to the top-left corner of the 
window shape.

Dragging the center-point handle moves the center of the gradient to a new location.

	 4.	 Click the gradient-width handle and drag in about halfway to flatten the gradient.

Dragging the width handle of a radial gradient makes the gradient narrower or wider in 
one direction, essentially creating a skewed effect. 
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	 5.	 Click the gradient-rotation handle and drag left to change the angle of the gradient.

Dragging the rotation handle rotates the gradient around its center point.

	 6.	 Click the gradient-size handle and drag out to enlarge the adjusted gradient.

Dragging the size handle makes the overall gradient larger or smaller in both directions 
(without affecting the gradient’s aspect ratio).

	 7.	 Still using the Gradient Transform tool, click the car body shape to select it 
and access the gradient transformation handles.

Center-point handle

Rotation handle

Width handle

	 8.	 Click the gradient-rotation handle and drag down and left to rotate the 
gradient approximately 90°, with the dark part of the gradient toward the 
bottom edge of the car.

Because you did not yet change the gradient width, the rotated gradient transformation 
handles will be well below the Stage edge. If necessary, zoom out so you can see all the 
gradient transformation handles.

The gradient transformation 
handles are below the 
Stage edge because you 
have not yet changed the 
gradient width.

You can use the rotation 
handle to reverse a 
gradient. Simply drag all 
the way around (180°) 
until the gradient colors 
are reversed.

Note:
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	 9.	 Click the gradient-width handle and drag up until the gradient is just 
slightly larger than the height of your artwork.

For a linear gradient, dragging the width handle makes the gradient narrower or wider.

	10.	 Click the center point of the gradient and drag down, about one-third of the 
way closer to the bottom of the car body.

	11.	 Save the file and continue to the next exercise.

You can use a bitmap (raster) image as the fill of an object by choosing 
Bitmap Fill in the Fill Type menu of the Color panel. Available bitmap files 
appear as tiles in the lower half of the panel; if none are available, choosing 
Bitmap Fill opens a dialog box, so you can import the file you want. 

You can use the Paint Bucket tool to fill an existing object with a bitmap, or 
use the Brush tool to paint the bitmap onto the Stage. The Lock Fill modifier 
at the bottom of the Tools panel determines how the fill will be added.

•	 When toggled on, the selected bitmap 
image is tiled inside the shape.

•	 When toggled off, the selected bitmap 
image is basically pasted to the Stage. The 
filled area essentially “reveals” the area of 
the selected bitmap image. (If a bitmap-fill 
image is too small to fill the Stage, the 
image is tiled as necessary)

If you select a bitmap-filled object with the 
Gradient Transform tool, you can edit the size, 
skew, rotation, and position of the fill image. 

Similar Lock Fill options are available when 
you work with gradients. When this option 
is toggled on, the gradient is applied relative 
to the overall Stage; filled areas reveal the 
relevant area of the gradient. If the option 
is turned off, the gradient is applied to each 
object independently.
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Locking Bitmap and Gradient Fills

Without the Lock Fill modifier, 
the gradient is applied 
individually to each square.

With the Lock Fill modifier, 
the same gradient extends 
across all four squares.

Lock Fill modifier Turned on, the bitmap 
image is tiled inside the 

filled shape

Turned off, the shape 
reveals the relevant area 

of the bitmap.

Click Import to add 
bitmaps to the file.

Click any available 
tile to select that 
bitmap as the fill.

Choose Bitmap  
Fill in this menu.
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Organize Finished Artwork Layers

An Animate project can contain dozens of layers representing the various components 
of the animation or movie. To organize all of these layers into logical groups or 
categories, you can use layer folders. 

	 1.	 With corvette.fla open, select the top layer (Accents) in the Timeline panel.

	 2.	 Click the New Folder button at the bottom of the Timeline panel.

New Folder 
button

	 3.	 Double-click the new folder name. Type Car Parts as the new folder name 
and press Return/Enter to finalize the new name.

You change the name of a layer folder the same way you change the name of a layer; 
simply double-click the folder name and type in the new name.

	 4.	 Click the Accents layer to select it, then Shift-click the Shadow layer to add 
it and all contiguous layers to the selection. 

	 5.	 Click any of the selected layers and drag them into the Car Parts folder.

The dragged layers now reside inside the layer folder, which makes it easier to treat the 
entire group of layers as a single object. This will be helpful later when the artwork is 
used in programming and interactive development. 

Shift-click to 
select multiple 
adjacent items.

The indented line shows 
that the selected layers 
will be placed inside the 
Car Parts folder.

	 6.	 Click the Lock column for the Car Parts folder.

By locking the layer folder, you have effectively locked each layer inside the folder 
(although you can unlock individual layers in the folder by clicking that layer’s Lock 
icon). The same concept is true of the Visibility and Outline buttons for the layer folder.

Locking a folder 
locks all layers inside 
that folder.

	 7.	 Click the arrow to the left of the Car Parts folder to collapse it.

Once collapsed, only the layer folder is visible. This makes it easier to navigate through 
the Timeline panel, which can grow very large for complex projects.

	 8.	 Select the Sketch layer and click the panel’s Delete button.

Click here to collapse 
the Car Parts folder. Select the Sketch layer 

and click here to delete it.

	 9.	 Save the file and continue to the final exercise.

Press Shift to select 
contiguous layers — that 
is, layers directly on top 
of or below one another. 
To select layers that aren’t 
next to each other, press 
the Command/Control 
key while clicking 
the individual (non-
contiguous) layers.

Note:

You can rename layer 
folders in the same 
way you rename layers, 
and you can reorder 
layer folders (and their 
contents) by dragging the 
folders into new positions 
in the layer stack.

Note:

When you use layer 
folders, you can lock and 
hide all the contents in 
the folder by locking and 
hiding the entire folder. 

Note:
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Export Artwork as an Image

Instead of sending the Animate file to your client, you are going to export a static 
image that can be easily reviewed by anyone with a Web browser. Animate includes the 
ability to export a number of static image formats, including JPEG, GIF, and PNG.

	 1.	 With corvette.fla open, choose File>Export>Export Image. 

	 2.	 In the bottom left corner of the resulting dialog box, choose Fit On Screen 
in the View Percentage menu.

You can use the Export Image dialog box to determine what type of file you want to 
export, as well as the specific settings for the selected file format.

Hand tool 

Zoom tool

Eyedropper tool

Eyedropper color

File size using the 
active optimization 

settings 

View percentage

Optimization 
settings

	 3.	 In the right side of the dialog box, choose JPEG in the Format menu and 
choose Maximum in the Quality menu.

Reducing the Quality value will result in a smaller file size, but can significantly decrease 
the resulting image quality. For review purposes, the highest possible quality setting is a 
better option.

Choose JPEG in 
this menu.

Choose Maximum 
in this menu.

When JPEG is the 
defined file format, you 
can use the Image Size 
options to change the size 
of the exported image to 
something other than the 
defined Stage size. 

Note:
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	 4.	 Click Save. In the resulting dialog box, navigate to your WIP>Vette folder 
as the target location.

	 5.	 Add -drawing to the end of the existing file name (before the file 
extension). 

On Windows, the file extension might not be visible in the document window. If this is 
the case, simply type after the existing file name.

The extension automatically 
changes to match what you 
select in the File Format/ 
Save As Type menu.

The original file name 
is automatically based 

on the file name of 
your native Flash file.

Add the second half 
of the file name to 
distinguish this file 

from the sketch.

	 6.	 Click Save to export the JPEG file.

	 7.	 Close the corvette.fla file.
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Project 1: Corvette Artwork

Project Review

	 1.	Briefly explain how anchor points and handles control the lines in a vector shape.

	 2.	Briefly explain the difference between the Selection tool and the Subselection tool.

	 3.	Briefly explain what is meant by “destructive editing.”

	 1. The _______________ can be used to change 
the size of the Stage.

	 2.	_______________ in the Timeline panel can be 
used to manage the top-to-bottom order of 
objects on the Stage.

	 3.	When created in _______________, the fill 
and stroke are treated as separate entities; you 
can individually select each part, and move or 
modify each part without affecting the other. 

	 4.	When you create a shape in _______________, 
it automatically displays the bounding box as 
soon as you create it; you can’t select the fill 
and stroke independently on the main Stage.

	 5.	A(n) _______________ allows multiple objects 
to be treated as a single entity on the Stage.

	 6.	The _______________ tool can be used to 
select areas of a standard-drawing object, or to 
bend lines created in either drawing mode.

	 7.	The _______________ tool can be used to 
select individual anchor points and handles that 
make up a shape.

	 8.	The _______________ tool is used to create 
precise Bézier curves.

	 9.	The _______________ tool is used to change 
the fill color of closed shapes.

	10.	The _______________ tool is used to change 
the stroke color of any object.
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Use what you learned in this project to complete the following freeform exercise.  
Carefully read the art director and client comments, then create your own design to meet the needs of the project. 
Use the space below to sketch ideas; when finished, write a brief explanation of your reasoning behind your final design.

Portfolio Builder Project

The cars are a big part of the annual event, but it 
isn’t limited to only cars. Really, the show includes 
categories for just about anything with a motor. 
Aside from the American Heavy Metal sports cars, 
the two most popular parts of the show are Early 
Antiques and Motorcycles. 

I’d like you to create illustrations for both of those 
categories. For the Early Antiques, the Model T 
Ford of the 1910s will be a perfect icon for the 
class. For motorcycles, a 1940s Indian would be 
ideal for the different projects I want to create.

I really like the Corvette artwork, so I want the 
two new illustrations to have a similar style. When 
I look at the three pieces together, I’d like it to be 
clear that all three were created by the same artist.

Your client is happy with the Corvette, and 
asked you to create two more illustrations that 
he can use in different digital projects. 

To complete this project, you should:

o	 Search the Internet for photos that you can 
use as templates for creating the other new 
illustrations. 

o	 Create each illustration in a separate file.

o	 Carefully consider the best approach for 
each icon and use whichever tool (or tools) 
are most appropriate to create the icon 
artwork.
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Although Animate is known as an animation program, you can see from this project that the 
application offers a considerable array of drawing and painting tools. You learned how to import 
a sketch, control the size of the Animate Stage, and align objects to the Stage. These skills set the 
groundwork for any type of assignment. You also developed an understanding of layers and how they 
simplify the construction of complex drawings and artwork. 

Animate includes a range of drawing tools — from the basic shape tools, the Line tool for simple 
lines, and the Pen and Pencil tools for more complex curves. Those tools, combined with the two 
Animate drawing modes and the unique destructive editing capabilities that are part of the Animate 
toolset, make it possible to create complex artwork directly on the Stage. 

Work in both standard- 
and object-drawing modes

Paint shapes 
with different 
brush modes

Use layers to 
control object 

visibility

Convert lines to 
filled shapes

Create and edit 
basic shapes

Use the Pencil 
tool to create 

custom shapes

Use the Pen 
tool to create 
precise curves

Use destructive pixel 
editing to remove 
drawing elements

Control object 
fill and stroke 

attributes

Use alpha 
transparency to 

soften fills

Create the 
appearance of depth 

with gradients
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